Einführung

Einführung >

Einführung

 Return to chapter overview

Diese Online-Hilfe ist eine praktische Anleitung für den Benutzer, der sofort mit WebSite X5 eine persönliche Website, einen Blog oder einen Online-Shop erstellen möchte.

Sie erhalten Schritt für Schritt eine detaillierte Beschreibung der Arbeitsumgebung mit allen Befehlen und Optionen, die Sie in den einzelnen Menüs, Tabs und Dialogfenstern finden.

Dank der Erläuterungen und vertiefenden Informationen, in Kombination mit der leicht verständlichen Vorgehensweise und den zahlreichen, in Echtzeit aktualisierten Vorschauansichten ist die Arbeit mit WebSite X5 äußerst komfortabel und Sie erstellen mühelos ansprechende, interessante und professionell wirkende Webseiten.

Vorliegende Anleitung für WebSite X5 bezieht sich auf die Version Evolution v. 10 kann aber unter Berücksichtigung der jeweils spezifischen Einschränkungen auch für andere Programmversionen genutzt werden.

Die Anleitung ist in folgende Themen gegliedert:

- | Die Arbeitsumgebung Hier werden alle Funktionen der Software erläutert, die bei der Erstellung und Veröffenbtlichung einer Website in den verschiedenen Fenstern zur Verfügung stehen.
- | Tutorials Die Tutorials simulieren Verfahren für ausgewählte Prozesse wie die Erstellung eines Formulars zur Datenerhebung oder die Einrichtung eines passwortgeschützten Bereichs.
- | Vertiefung Dieser Bereich enthält Übersichten mit vertiefenden Informationen zu verschiedenen Aspekten der Webseitengestaltung.

Letzte Aktualisierung: Version 10


Präsentation von WebSite X5

Einführung >

Präsentation von WebSite X5

 Return to chapter overview

Realisieren Sie Websites, Online-Shops und Blogs in nur 5 Schritten

WebSite X5 ist die ideale Software, um Websites zu erstellen, wie Sie sie sich schon immer gewünscht haben. Sie benötigen keinerlei Programmierkenntnisse und arbeiten komplett visuell in einer leicht verständlichen Arbeitsumgebung mit umfassenden Vorschauanzeigen, die in Echtzeit aktualisiert werden.

Auf diese Weise führt Sie WebSite X5 bis zur Veröffentlichung Ihrer Seite und garantiert einfache Bedienung, Flexibilität sowie viel Raum für individuelle Anpassung.

Auf der Grundlage der ausgewählten Optionen und Einstellungen generiert WebSite X5 automatisch die Seiten in HTML5 + CSS 2.1 oder 3. Dies gewährleistet volle Kompatibilität mit allen Browsern und Mobilgeräten sowie eine korrekte Indexierung durch Suchmaschinen.

Professionelle Web-Tools

Trotz seiner außerordentlich einfachen Bedienung stellt Ihnen WebSite X5 diverse professionelle Tools zur Verfügung, unter anderem:

§Online-Shops mit Kreditkartenzahlung

§Blogs mit Podcasts und Videocasts

§Interne Suchmaschine

§E-Mail-Formulare mit Antispam-Filter

§News- und RSS-Feeds

§Zoomfunktionen und Panoramabilder

§Bilder- und Video-Galerien

§Zugangsverwaltung für geschützte Bereiche

§Verwaltung von Werbebannern

§Mehrsprachige Webseiten

Die Komplettlösung

Mit WebSite X5 sparen Sie Zeit und Mühe, da die Software alles enthält, was Sie für die Erstellung einer Website benötigen:

§einen Editor für Templates

§einen Editor für Bilder

§einen Menü-Generator

§einen internen FTP-Client

§1.500 anpassbare Templates

§6.000 lizenzfreie Bilder

§Button-Bibliotheken

§eine Widget-Sammlung

Dieser Mix aus einfacher Bedienung und komplettem Leistungsumfang ist das Erfolgsrezept von WebSite X5: der idealen Software für alle, die eine Website realisieren wollen.


WebSite X5: Was kann dieses Programm

Incomedia WebSite X5: Was kann dieses Programm

Einführung >

Incomedia WebSite X5: Was kann dieses Programm

 Return to chapter overview

Incomedia WebSite X5 ermöglicht die einfache und schnelle Erstellung von Webseiten, Online-Shops, Blogs, digitalen Fotoalben oder interaktiven Präsentationen. Die Projekte können mit einer Netzstruktur entwickelt und über Menüs auf verschiedenen Ebenen strukturiert werden. Auf diese Weise kann eine beliebige Anzahl von Seiten realisiert werden.

Sie haben die Möglichkeit, das Layout jeder einzelnen Seite zu bestimmen und mit den Objekten zu gestalten, die das Programm zur Verfügung stellt, seien es Texte, Bilder, Tabellen, Galerien, Videos, Sounds, E-Mail-Formulare, Soziale Netzwerke, Gästebüche, Karten, Flash™-Animationen, Produktlisten, HTML-Objekte oder Widgets.

WebSite X5 bietet zahlreiche interessante Funktionen für die Bildbearbeitung, so dass keine externen Grafikprogramme mehr benötigt werden. Da Bilder automatisch in einem komprimierten Format gespeichert werden, müssen sie vor dem Einfügen nicht einmal mehr optimiert werden.

Das umfangreiche Archiv mit grafischen Vorlagen, das interne Bearbeitungsprogramm zur Erstellung dreidimensionaler Schaltflächen sowie die weitreichenden Möglichkeiten für die persönliche Gestaltung von Grafik, das Einfügen von Intros, die Einstellung der Sprache, das Einrichten geschützter Bereiche mit Passwortabfrage, die Erstellung und Verwaltung von Blogs, RSS-Feeds und Online-Shops inklusive Modul für Kreditkartenzahlungen bereichern Ihre Seite und lassen sie komplett und professionell wirken.

Außerdem können Sie mit WebSite X5 Ihre Webseite direkt im Netz veröffentlichen, ohne externe FTP-Programme (File Transfer Protocol) zu benötigen.

Die Arbeit mit WebSite X5

WebSite X5 ist wie ein Wizard aufgebaut, der Sie Schritt für Schritt durch die Anwendung leitet und zu einer vollständigen, zweckmäßigen und grafisch ansprechenden Website führt.

So gelangen Sie in nur 5 Schritten von Ihrer Idee zu einer kompletten und veröffentlichten Website:

1. Allgemeine Einstellungen

Nachdem Sie Ihr Projekt definiert und einige allgemeine Informationen wie eine Beschreibung und Keywords für die Indexierung durch die Suchmaschinen eingegeben haben, führt Sie WebSite X5 zur Gestaltung des Layouts. Wählen Sie aus über 1.500 vorprogrammierten Templates oder lassen Sie Ihrer Kreativität freien Lauf und erstellen Sie Ihre eigene Vorlage. Mit dem eigens hierfür vorgesehenen, programminternen Editor können Sie die Header und Fußzeilen der Templates ganz Ihren individuellen Vorstellungen anpassen.

2. Erstellen der Sitemap

Beginnend bei der Homepage können Sie mit WebSite X5 hier die Struktur und die Hierarchien Ihrer Website festlegen. Es können alle Ebenen und Unterebenen eingerichtet werden, die für die Strukturierung einer unbegrenzten Anzahl Seiten benötigt werden. Auf der Grundlage der Sitemap wird dynamisch ein Navigationsmenü generiert. Die Sitemap kann jederzeit geändert werden, sodass Sie die Website umgehend aktualisieren können.

3. Erstellen der Seiten

La Erstellen und gestalten Sie die Seiten einfach per Drag&Drop der verfügbaren Objekte wie Texte, Tabellen, Bilder, Animationen, Videos und Sounds, Galerien, E-Mail-Module, Soziale Netzwerke, Gästebüche, Karten, Produktlistne, HTML-Code und Widgets. Passen Sie die importierten Objekte an Ihre persönlichen Bedürfnisse an und vervollständigen Sie die Inhalte mit Links zu internen oder externen Ressourcen. Dank dem programminternen Grafik-Editor können Sie die Objekte drehen, korrigieren sowie Filter, Masken und Rahmen auf importierte Bilder anwenden, ohne dass externe Software benötigt wird.

4. Erweiterte Einstellungen

Hier können Sie Ihre Website weiter anpassen und den Stil von Elementen wie Navigationsmenüs, Texten, der ShowBox und E-Mail-Nachrichten festlegen. Mit dem internen Editor können Sie dreidimensionale Schaltflächen erstellen und Mouseover-Effekte festlegen (Effekte, die erscheinen, wenn der Mauszeiger über ein Objekt bewegt wird). Außerdem kann die Seite mit Instrumenten ausgestattet werden, wie einer Intro-Seite mit Sound und Sprachauswahl, geschützten Bereichen mit Zugangsverwaltung für Benutzer, Werbebotschaften, RSS-Feeds, einem Blog oder einem Online-Shop.

5. Export

Mit WebSite X5 können Sie die fertige Website auch gleich online stellen: Hierzu werden über eine FTP-Verbindung alle Dateien auf den Server übertragen, die erforderlich sind, um die Website sofort im Internet zu veröffentlichen. WebSite X5 unterstützt sichere Verbindungen und ermöglicht effizientes Arbeiten dank Multiverbindungen und der Option, nur geänderte Dateien zu übertragen.
Neben der Veröffentlichung im Internet können Sie Projekte auch auf einen Datenträger eines Computers übertragen oder Backups erstellen.


Verfügbare Versionen

Einführung >

Verfügbare Versionen

 Return to chapter overview

WebSite X5 ist in verschiedenen Versionen erhältlich. Die wichtigsten sind: Evolution und Compact.

Einen Überblick über die Versionsunterschiede finden Sie auf unserer Website: http://www.websitex5.com/compare


Die Arbeitsumgebung

Die Arbeitsumgebung >

Die Arbeitsumgebung

Return to chapter overview
Versteckten Text zeigen/verstecken

WebSite X5 ist wie ein Wizard aufgebaut, in dessen Dialogfenster Sie schrittweise alle nötigen Informationen eingeben können, um eine vollständige, praktische und grafisch ansprechende Webseite zu erstellen.

Alle Anzeigen des Programms haben eine einheitliche grafische Benutzeroberfläche mit drei Bereichen für Schaltflächen (oben, unten und seitlich), die in allen Ansichten unverändert bleiben, sowie einem zentralen Fenster, das sich je nach Arbeitsphase und den dort jeweils benötigten Funktionen verändert.

Klicken Sie um zu erweitern/minimieren
Die Arbeitsumgebung
Klicken Sie um zu erweitern/minimieren Obere Schaltflächenleiste

Im oberen Bereich befinden sich die je nach Arbeitsphase jeweils am häufigsten benötigten Schaltflächen. Hier können Sie beispielsweise die Online-Hilfe aufrufen, um Informationen über die Funktionsweise des Programms abzurufen, das Projekt zu speichern, Backups zu verwalten sowie eine Vorschau des Projekts im lokalen Browser anzuzeigen.

§Hilfe: Aufruf der Online-Hilfe. Ein Klick auf den Pfeil links von der Schaltfläche Hilfe öffnet ein Kontextmenü mit folgenden Optionen:

-Inhalt...: Aufruf der Online-Hilfe.

-Video Tutorial: Öffnet eine Seite wo Sie eine Reihe von nützlichen Video-Tutorials finden, wie Sie mit WebSite X5zu arbeiten beginnen.

-WebSite X5 Gallery: Öffnet den WebSite X5 Answers Bereich mit eine umfangreiche und vielseitige Galerie mit Websites, die mit WebSite X5 cerstellt wurden , und die von Anwendern selbst eingestellt wurden.

-WebSite X5 Templates: Öffnet den WebSite X5 Answers Bereich wo Sie neue Grafikmodelle finden können. Hier können Sie die neuen Grafikmodelle, die von Incomedia oder von anderen Autoren hergestellt wurden, die angesehen und kostenlos oder kostenpflichtig heruntergeladen werden können.

-Technischer Support: Öffnet WebSite X5 Answers, die Seite wo Sie den technischen Support für WebSite X5 bekommen. Auf WebSite X5 Answers können sie FAQ einsehen oder eine Support-Anfrage versenden.

-www.websitex5.com: Link zur Website von WebSite X5.

-Infos zu WebSite X5: Mit Klick auf diese Option öffnet sich ein Popup-Fenster mit einigen Informationen über die installierte Kopie von WebSite X5.

§Speichern [Strg + S]: Speichert das aktuelle Projekt. Das Projekt wird automatisch im Verzeichnis der Projekte gespeichert, das im Dialogfenster Einstellungen festgelegt wurde. Ein Klick auf den Pfeil links von der Schaltfläche Speichern öffnet ein Kontextmenü mit folgenden Optionen:

-Bei jeder Vorschau speichern: Speichert das Projekt automatisch jedes Mal, wenn der Befehl Vorschau ausgeführt wird, um eine lokale Vorschau der Website anzuzeigen.

-Beim ersten Speichern des projekts eine Sicherungskopie erstellen: Erstellt automatisch eine Backup-Kopie des Projekts (Datei Backup.iwprj) nur nach dem ersten Speichern während der aktuellen Arbeitssitzung

-Bei jedem Hochladen eine Sicherungskopie erstellen: Erstellt automatisch eine Backup-Kopie des Projekts (Datei Uploaded_timestamp.iwprj) vor jeder Online Veröffentlichung der Website.

Die mit den Funktionen Beim ersten Speichern des projekts eine Sicherungskopie erstellen und Bei jedem Hochladen eine Sicherungskopie erstellen generierten Backup-Kopien werden im Unterverzeichnis des Verzeichnis der Projekte er in den Einstellungen Einstellungen angegeben wurde.

Um eine Kopie des Projekts zu speichern, verwenden Sie bitte die Option Speichern als.... Klicken Sie hierzu auf die Schaltfläche Duplizieren im Bereich Projektauswahl.

-Vorschau: Anzeige einer Vorschau des realisierten Projekts im internen Browser.

Wenn Sie im Dialogfenster Einstellungen die Option Seiten während der Projektänderung aktualisieren aktiviert lassen, erhältlich im Fenster Einstellungen, aktualisiert das Programm nach jeder Änderung (z.B. wenn Sie auf OK oder Weiter klicken), alle hiervon betroffenen Elemente. Auf diese Weise ist die lokale Vorschau der Website immer aktuell und kann ohne Wartezeit angezeigt werden.

Zusätzlich kann die Option Bei jeder Vorschau speichern aktiviert werden. Dies bewirkt, dass das Projekt auch bei Klick auf die Schaltfläche Vorschau automatisch gespeichert wird.
Klicken Sie um zu erweitern/minimieren Seitliches Menü

Mit WebSite X5 können Sie in 5 einfachen Schritten eine komplette Website erstellen. Die Schaltflächen des Menüs auf der linken Bildschirmseite sind immer sichtbar und zeigen Ihnen an, in welcher Phase der Site-Erstellung Sie sich befinden. Außerdem können Sie unabhängig von der Standard-Reihenfolge direkt zwischen verschieden Phasen wechseln.

 | Projektauswahl
1. | Allgemeine Einstellungen
2. | Erstellen der Sitemap
3. | Erstellen der Seiten
4. | Erweiterte Einstellungen
5. | Export
Klicken Sie um zu erweitern/minimieren Schaltflächen am unteren Bildschirmrand

Die Schaltflächen im unteren Bereich dienen der Navigation zwischen den einzelnen Programmfenstern:

§Zurück: Über diese Schaltfläche kehren Sie zum vorherigen Fenster zurück, um dort vorgenommene Einstellungen zu ändern.

§Weiter: Übergang zum nächsten Schritt für die Erstellung der Website.


Willkommen bei WebSite X5

Willkommen bei Incomedia WebSite X5

Die Arbeitsumgebung >

Willkommen bei Incomedia WebSite X5

 Return to chapter overview

Nach dem Start von WebSite X5 wird die Introseite angezeigt. Hier finden Sie Links zu online verfügbaren Ressourcen und Materialien, die Sie bei der Arbeit mit der Software unterstützen. Diese Links sind in einem Menü organisiert und bieten folgende Optionen:

Video Tutorial: Öffnet eine Seite wo Sie eine Reihe von nützlichen Video-Tutorials finden, wie Sie mit WebSite X5zu arbeiten beginnen.

WebSite X5 Gallery: Öffnet den WebSite X5 Answers Bereich mit eine umfangreiche und vielseitige Galerie mit Websites, die mit WebSite X5 cerstellt wurden , und die von Anwendern selbst eingestellt wurden.

WebSite X5 Templates: Öffnet den WebSite X5 Answers Bereich wo Sie neue Grafikmodelle finden können. Hier können Sie die neuen Grafikmodelle, die von Incomedia oder von anderen Autoren hergestellt wurden, die angesehen und kostenlos oder kostenpflichtig heruntergeladen werden können.

WebSite X5 Answers: Öffnet WebSite X5 Answers, die Seite wo Sie den technischen Support für WebSite X5 bekommen. Auf WebSite X5 Answers können sie FAQ einsehen oder eine Support-Anfrage versenden.

Neue Updates suchen: Hier können Sie online prüfen, ob Updates für die installierte Version von WebSite X5 verfügbar sind. Wir schlagen vor, dass Sie Ihr Programm auf die neueste verfügbare Version aktualisieren, um stets die aktuellen und vielseitigsten Funktionen genießen können.

Einstellungen: Öffnet das Einstellungen, in dem Sie einige allgemeine Parameter für die Funktionsweise des Programms festlegen können.

Neben diesem Menü finden Sie auf der Introseite Inhalte, die bei aktiver Internetverbindung mit der Zeit aktualisiert werden, wie zum Beispiel: Informationen über die Version des installierten Programms, News, spezielle Inhalte (weiterführende Artikel, WhitePaper, Tips&Tricks), neue Video-Tutorials oder Aktionsangebote.

Ist keine Internetverbindung verfügbar, wird auf der Introseite eine Standardanzeige geladen. Diese Standardanzeige erscheint auch dann, wenn im Einstellungen die Option Bei Programmstart nach Updates suchen deaktiviert wurde.

Und nachdem Sie die Inhalte der Introseite gelesen haben, können Sie mit Klick auf die Schaltfläche Start sofort in Aktion treten und Ihre eigene Website gestalten.


Einstellungen Fenster

Die Arbeitsumgebung >

Einstellungen Fenster

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Dialogfenster, das sich mit Klick auf Einstellungen auf der Startseite von WebSite X5 öffnet, können Sie einige allgemeine Einstellungen für die Programmfunktion vornehmen.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Fenster Einstellungen

Die Optionen die im Fenster Allgemein zur Verfugung stehen sind:

§Verzeichnis der Projekte: In diesem Dialogfenster, das sich mit Klick auf Einstellungen auf der Startseite von WebSite X5 öffnet, können Sie einige allgemeine Einstellungen für die Programmfunktion vornehmen. Wählen Sie hier das Verzeichnis aus, in der die Projektdatei (Project.IWP) gespeichert werden soll, sowohl bei der Erstellung eines neuen Projekts als auch nach dem Import eines bereits bestehenden (siehe Projektauswahl | Importieren...). Wenn Sie während der Arbeit an Ihrer Website auf Speichern klicken, wird das Projekt ohne Abfrage des Zielverzeichnisses hier gespeichert.

§Bei Programmstart nach Updates suchen: Mit dieser Option sucht das Programm bei jedem Start nach eventuell verfügbaren Updates. Hierzu baut es eine Internetverbindung mit dem Server von Incomedia auf.

Es wird empfohlen, diese Option aktiviert zu lassen, damit Sie sicher sein können, dass Sie jederzeit mit der aktuellsten Version von WebSite X5 arbeiten.

Die Optionen die im Fenster Dateierstellung zur Verfugung stehen sind:

§Vorschau automatisch aktualisieren: Mit dieser Option wird die Vorschau der Website parallel zur Arbeit an dem Projekt automatisch aktualisiert. Nach jeder Änderung (und wenn Sie zum Beispiel auf OK oder Weiter klicken) aktualisiert das Programm automatisch die Vorschau im lokalen Browser.

§Seiten während der Projektänderung aktualisieren: Diese Option bewirkt, dass die effektiven Seiten bereits während der Bearbeitung des Projekts erstellt werden. Nach jeder Änderung (und wenn Sie zum Beispiel auf OK oder Weiter) klicken, aktualisiert das Programm alle Elemente, die von der Änderung betroffen sind. uf diese Weise ist die lokale Vorschau der Website immer aktuell und kann ohne Wartezeit angezeigt werden mit der Option Vorschau.

§Maximale Anzahl der gleichzeitigen Prozesse: Stellen Sie hier die Anzahl der vom Programm gestarteten Prozesse (oder Threads) ein, die vom Computer gleichzeitig ausgeführt werden sollen.

Was ist Multithreading?

Die Technik, einen Prozess in mehrere Teilprozesse zu gliedern, die dann gleichzeitig ausgeführt werden, heißt Multithreading und muss vom verwendeten Computer unterstützt werden. Mit anderen Worten, mit einem Multithread werden die Prozessorkapazitäten besser ausgenutzt, da mehrere Threads parallel verarbeitet werden können. Dank dieser Technologie können Sie mit einem Programm wie WebSite X5, das die Aufteilung von Prozessen in mehrere Threads unterstützt, eine erhebliche Leistungssteigerung erzielen.

Um die Vorzüge des Multithreadings effektiv nutzen zu können, muss die Hardwarekonfiguration des verwendeten Computers analysiert werden. Es wird empfohlen, mit 5 Parallelprozessen zu beginnen und den Parameter schrittweise zu erhöhen, um die optimale Anzahl im Verhältnis zu den jeweiligen Anforderungen zu ermitteln.

Die Webserver-Einstellungen für lokale Vorschau sind folgende:

§Port: Dies ist der Port, den der lokale Webserver für die Anzeige der Vorschau überwacht.

§IP-Addresse: Dies ist die IP-Adresse, die der lokale Webserver für die Anzeige der Vorschau überwacht. Standardmäßig ist hier die IP-Adresse 127.0.0.1 eingestellt, die den lokalen Computer identifiziert.

Es wird empfohlen, die Standardeinstellungen für die Port und die IP-Addresse nicht zu ändern, wenn diesbezüglich Unsicherheiten oder Zweifel bestehen.

Praktische Anwendung:

-

Verwaltung von Projekt-Backups


Passo 0 - Projektauswahl

Projektauswahl

Schritt 0 - Projektauswahl >

Projektauswahl

 Return to chapter overview
Versteckten Text zeigen/verstecken

Nach dem Start von WebSite X5, gelangen Sie nach der Startseite zum Fenster Projektauswahl, in dem Sie angeben, an welchem Projekt Sie arbeiten möchten.

Sie können ein neues Projekt erstellen oder ein bereits erstelltes Projekt ändern.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Schaltfächen des Fenster Projektauswahl

§Ein neues Projekt erstellen: Wenn Sie diese Option wählen, beginnen Sie mit der Gestaltung eines neuen Website-Projekts, für das Sie in das Feld direkt darunter einen Namen eingeben müssen. Das so erstellte, neue Projekt können Sie mit der Schaltfläche Speichern sofort sichern.

Beim Zwischenspeichern müssen Sie kein Zielverzeichnis angeben, da die Projekte vom Programm automatisch verwaltet und im Verzeichnis der Projekte gespeichert werden, das Sie im Fenster Einstellungen ausgewählt haben.

§Ein bereits bestehendes Projekt bearbeiten: Bei Auswahl dieser Option können Sie ein bereits erstelltes Projekt öffnen, um es zu ändern oder zu aktualisieren. Alle bereits bestehenden Projekte werden in der Übersicht angezeigt: Für die komfortable Auswahl können Sie zwischen verschiedenen Anzeigemodi wählen:

Große Symbole - Titel - Liste - Details

Definieren die Modalitäten für die Anzeige der Projektvorschau.

Projektgruppen nach dem Datum der letzten Änderung

Die Projekte werden nach dem Datum der letzten Änderung gruppiert und angezeigt.

Die Projekte können mit den folgenden Optionen verwaltet werden:

§Importieren...: Importiert ein zuvor mit WebSite X5 erstelltes und exportiertes Projekt (siehe Projekt exportieren) von einem anderen PC.

§Umbenennen: Das ausgewählte Projekt kann umbenannt werden. Sie können ein markiertes Projekt auch umbenennen, wenn Sie erneut darauf klicken.

§Duplizieren: Von dem ausgewählten Projekt wird eine Kopie erstellt.

§Löschen: Das ausgewählte Projekt wird gelöscht.

Praktische Anwendung:

-

Verwaltung von Projekt-Backups


Allgemeine Einstellungen

Schritt 1 - Allgemeine Einstellungen >

Allgemeine Einstellungen

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Startdialog vor Schritt 1 geben Sie einige grundlegende Parameter für das geplante Projekt ein.

Sie müssen Ihrer Website beispielsweise einen Titel geben, eine URL angeben, die gewünschte Sprache festlegen und die Metatags für die Aktivierung von Zusatzdiensten wie zur Erfassung von Zugriffsstatistiken eingeben. All diese Daten können sofort aber auch zu einem späteren Zeitpunkt definiert werden.

Die verfügbaren Optionen sind in zwei Bereiche gegliedert: Allgemein und Erweitert.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

§Titel der Website: Geben Sie hier einen Titel für Ihre Website ein. Dieser Titel wird in der Titelleiste des Browsers angezeigt und ist ein wichtiger Parameter, damit Benutzer und Suchmaschinen Ihre Website finden.

Standardmäßig wird als Titel der Website der Projektname übernommen (siehe Projektauswahl): Dieser Titel kann jedoch geändert und auf das Thema der Website und die jeweiligen Optimierungsanforderungen abgestimmt werden.

§Autor der Website: Geben Sie in dieses Feld den Namen der Person oder des Unternehmens ein, die/das als Betreiber der Website erscheinen soll. Der Name des Autors wird im HTML-Code der erstellten Seiten als Wert des Metatags <author> wiedergegeben: Auf diese Weise setzen Sie Ihre "Unterschrift" unter Ihre Arbeit.

§URL der Website: Geben Sie in dieses Feld die URL ein, unter der die veröffentlichte Webseite zugänglich ist (zum Beispiel http://www.meinewebsite.de). Diese Information ist für das korrekte Funktionieren eventueller RSS-Feeds, des Warenkorbs für E-Commerce und der Sitemap erforderlich, die vom Programm automatisch erstellt und verlinkt wird.

§Beschreibung der Website: Geben Sie in dieses Feld eine Kurzbeschreibung Ihrer Website ein. Diese Beschreibung sollte prägnant und aussagekräftig für die Website sein, da sie vom HTML-Code als Metatag <description> verwendet und von den Spidern der Suchmaschinen analysiert wird.

§Keywords: Geben Sie hier durch Kommas getrennte Keywords ein, die für die Inhalte Ihrer Website charakteristisch sind, da sie vom HTML-Code als Metatag <keywords> verwendet und von den Spidern der Suchmaschinen analysiert werden.

Die Beschreibung der Website und die Liste der Keywords, die in diese Felder eingegeben wurden, werden automatisch der Homepage der Website zugeordnet.

Für die Optimierung der Website empfiehlt es sich jedoch, allen oder zumindest den wichtigsten Seiten eine Beschreibung und spezifische Keywords zuzuweisen. Öffnen Sie hierzu das Fenster Erstellen der Sitemap, wählen Sie die Seite, die Sie bearbeiten wollen und klicken Sie auf die Schaltfläche Eigenschaften....

§Sprache der Website: In diesem Feld können Sie die Sprache Ihrer Website festlegen. Diese Sprachversion wird dann für die automatisch vom Programm eingefügten Texte wie die Links zu internen Ankern, die Etiketten für das Objekt E-Mail-Formular, die Etiketten der Texte im Warenkorb für E-Commerce und die Texte der Sitemap verwendet.

Um automatisch eingefügte Texte zu ändern oder neue Sprachen hinzuzufügen, klicken Sie auf die Schaltfläche [image] und nutzen Sie die Optionen im Fenster Sprachenzentrum.

§Icon für die Website: In diesem Feld können Sie ein Icon (Datei .ICO, .PNG oder .JPG) für ihre Website auswählen. Dieses Icon wird links neben der URL in der Adressleiste des Browsers angezeigt.

Für das Icon einer Website (oder favicon, aus dem Englischen favorites icon) kann ein Bild im Format .ICO, .PNG, .GIF oder .JPG verwendet werden. Während Dateien im Format .ICO in ihrer urspünglichen Größe genutzt werden, erstellt WebSite X5 von Bildern beliebiger Größe im Format .PNG, .GIF und .JPG automatisch eine Kopie von 16x16 Pixeln im Format .PNG und verwendet diese als Favicon.
Klicken Sie um zu erweitern/minimieren Referenz: Funktionen im Bereich Erweitert

§Benutzerdefinierter Code: Sie können die Position innerhalb des Seitencodes festlegen, in den der individuelle Code eingefügt werden soll: Vor dem <HTML> Tag, Vor dem </HEAD> Tag, Innerhalb des <BODY> Tag (also innerhalb der Anweisung <BODY>, zum Beispiel: <BODY onload="alert('Hello!')">), Vor dem </BODY> Tag, Nach dem </BODY> Tag. nter der Auswahl der Position finden Sie das Feld, in das Sie den gewünschten Code kopieren oder eingeben der automatisch in der Seite eingefügt werden soll.

Dieses Feld kann zum Beispiel genutzt werden, um einen Dienst fü die Erfassung von Zugriffsstatistiken der Website wie Google Analytics™ zu aktivieren.

Für weitere Informationen über Google Analytics™ und um dort ein Konto anzumelden, klicken Sie bitte auf den Button [image], der Sie zur offiziellen Website des Dienstes weiterleitet: http://www.google.de/analytics/.

§Metatag für Google Webmaster-Zentrale: In dieses Feld können Sie den Metatag eingeben, der erforderlich ist, um die Dienste der Google Webmaster-Zentrale™ zu nutzen.

Für weitere Informationen über die Google Webmaster-Zentrale™ und um dort ein Konto anzumelden, klicken Sie bitte auf den Button [image], der Sie zur offiziellen Website des Dienstes weiterleitet: http://www.google.com/webmasters/.

§SiteMap automatisch erstellen: Mit dieser standardmäßig aktivierten Funktion wird die Sitemap der Website automatisch erstellt und verlinkt.

Damit die SiteMap aufgebaut wird und korrekt funktioniert, müssen Sie in das Feld URL der Website in Allgemeine Einstellungen | Allgemein eine gültige URL eingeben.

§HTML-Code schützen: Aktiviert einen Schutz für die Seiten der veröffentlichten Website durch Sperren der rechten Maustaste. Damit wird das normalerweise per Rechtsklick abrufbare Kontextmenü gesperrt, über das sich der Quellcode anzeigen oder die vorhandenen Bilder kopieren lassen.

Praktische Anwendung:

- | Sprachverwaltung für automatisch eingefügten Text
- | Nutzung der Google Webmaster-Zentrale™
- | Aktivierung von Statistikdiensten wie Google Analytics™

-

Erstellen und Verlinken der Sitemap

Weiterführende Informationen:

-

Der Webbrowser und der Browser von WebSite X5


Sprachenzentrum Fenster

Schritt 1 - Allgemeine Einstellungen > Allgemeine Einstellungen >

Sprachenzentrum Fenster

 Return to chapter overview

In diesem Fenster, das sich mit Klick auf die Schaltfläche [image] Sprache der Website im Fenster Allgemeine Einstellungen | Allgemein, öffnet, können Sie die Texte verwalten, die vom Programm automatisch eingefügt werden, wie zum Beispiel die Links zu internen Ankern, die Schaltflächen des Objekt Galerie, die Labels des Objekt E-Mail-Formular, oder des Warenkorb für E-Commerce, oder die Texte der Sitemap.

Das Dialogfenster Sprachenzentrum zeigt links die verfügbaren Sprachen und rechts eine Tabelle mit den Übersetzungen in die verschiedenen Sprachen. Die erste Spalte der Tabelle enthält eine Beschreibung, wo die jeweiligen Inhalte verwendet werden. Die anderen Spalten enthalten jeweils eine der aktiven Sprachen. Eine Sprache ist "aktiv", wenn sie im linken Bereich mit dem entsprechenden Kontrollkästchen ausgewählt wurde. Die Einträge können direkt in dieser Tabelle geändert und hinzugefügt werden.

Außerdem enthält das Dialogfenster Sprachenzentrum folgende Schaltflächen:

Neue Sprache hinzufügen: Öffnet ein Dialogfenster, in das Sie den Namen einer neuen Sprache eingeben können. Diese Eingabe muss folgendes Format haben: "ID - NameSprache", zum Beispiel "EN - English".".

Ausgewählte Sprache entfernen: Löscht eine in der Liste ausgewählte Sprache.

Neue Sprache importieren: Importiert eine neue Sprache, die als XML Datei gerettet wurde, und fügt diese zu den vorhandenen Sprachen zu.

Ausgewählte Sprache exportieren: Exportiert die ausgewählte Sprache in der Liste als XML Datei.

Mit den Befehlen Ausgewählte Sprache exportieren und Neue Sprache importieren können Sie die in eine bestimmte Sprache übersetzten Einträge in einer .XML-Datei speichern und auf einem anderen PC erneut importieren.

Praktische Anwendung:

- | Sprachverwaltung für automatisch eingefügten Text
- | Erstellen einer mehrsprachigen Website


Auswahl der Vorlage

Schritt 1 - Allgemeine Einstellungen >

Auswahl der Vorlage

 Return to chapter overview
Versteckten Text zeigen/verstecken

Ein wichtiger Faktor, der zum Erfolg einer Website beiträgt, ist zweifellos ihr grafisches Layout. Denn die Ästhetik einer Website wirkt auf den Betrachter, noch bevor er zu den Inhalten gelangt, und beeinflusst erheblich sein Urteil. Es liegt daher auf der Hand, dass ein durchdachtes, professionelles Design ein Indiz für eine hochwertige Website ist, deren Inhalte es zu entdecken lohnt.

WebSite X5 bietet Ihnen die Möglichkeit, die Gestaltung der Website mit zwei verschiedenen Methoden vorzunehmen:

1.indem Sie ein Individuelles Template aus den Vorlagen oder von Grund auf selbst gestalten; oder

2.indem Sie ein Vordefiniertes Template aus der Galerie mit über 1.500 gebrauchsfertigen Vorlagen wählen, die mit dem Programm schon automatisch installiert werden.

Sowohl die individuellen als auch die gebrauchsfertigen Templates können anschließend mit den zahlreichen Funktionen des Editors im Fenster Gestaltung des Templates vervollkommnet und bereichert werden.

Alle vordefinierten Templates sind für die Darstellung mit einer Auflösung von 1024 x 768 Pixeln optimiert. Wenn Sie Ihre Website für eine andere Auflösung optimieren möchten, verwenden Sie bitte ein Individuelles Template.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Fenster Auswahl der Vorlage

Der überwiegende Teil des Fensters Auswahl der Vorlage dient der Darstellung der verfügbaren Vorlagen. Um die Auswahl eines Templates zu erleichtern, kann mit den folgenden Optionen festgelegt werden, welche Vorlagen wie angezeigt werden sollen:

Kategorienliste

Diese Liste enthält die Kategorien, in die die verfügbaren Templates gegliedert sind. Die erste Kategorie der individuellen Templates enthält alle selbst erstellten Vorlagen. Sie wird nur angezeigt, wenn mindestens eine selbst erstellte Vorlage gespeichert wurde. Alle anderen Kategorien enthalten hingegen die gebrauchsfertigen Templates.

Menü

In dieser Liste werden die vordefinierten Templates nach ihrer Menüform gefiltert. Zur Auswahl stehen Vorlagen mit horizontalem Menü, vertikalem Menü oder alle Vorlagen.

Kleine Vorschau - Mittelgroße Vorschau - Große Vorschau

Mit diesen Schaltflächen legen Sie fest, wie die Vorschaubilder der Templates angezeigt werden sollen.

Farbton der Vorlage bearbeiten

Mit dieser Schaltfläche hingegen wird das Fenster Farbton der Vorlage geöffnet, in dem Sie den Farbton der Vorlage anpassen können.

Die Templates selbst können mit den folgenden Funktionen bearbeitet werden:

§Neue Vorlage: Startet die Erstellung eines neuen Templates von Grund auf. Hier erstellte Vorlagen werden in der Kategorie der individuellen Templates gespeichert.

§Umbenennen: Ein ausgewähltes Template kann umbenannt werden. Der Befehl ist nur für die individuellen Templates verfügbar. Vordefinierte Templates können nicht umbenannt werden. Sie können ein markiertes individuelles Template auch umbenennen, wenn Sie erneut darauf klicken.

§Duplizieren: Von dem ausgewählten Template wird eine Kopie erstellt.

§Entfernen: Das ausgewählte Template wird gelöscht. Der Befehl ist nur für die individuellen Templates verfügbar. Vordefinierte Templates können nicht gelöscht werden.

§Bearbeiten...: Das ausgewählte Template wird im Fenster Gestaltung des Templates geöffnet, wo es bearbeitet werden kann. Der Befehl ist nur für die individuellen Templates verfügbar. Wenn Sie ein vordefiniertes Template ändern möchten, müssen Sie zuerst mit der Schaltfläche Duplizieren eine Kopie erstellen.

§Importieren...: Ein zuvor mit WebSite X5 erstelltes und mit der entsprechenden Funktion exportiertes Template (Datei mit der Endung .IWTPL) wird importiert.

§Exportieren...: Das ausgewählte Template (Datei mit der Endung .IWTPL) wird in ein anzugebendes Verzeichnis exportiert. Ein auf diese Weise exportiertes Modell kann mit anderen Nutzern geteilt und auf anderen PCs importiert werden.

Hinweise zur Kompatibilität mit Vorgängerversionen:

§Horizontales / vertikales Menü - Während die Auswahl zwischen einem horizontalen und dem vertikalen Menü in den Vorgängerversionen im Dialogfenster "Auswahl des menütyps" (bis Version 8) bzw. mit einer entsprechenden Option (Version 9) vorgenommen wurde, ist es in Version hinreichend, das vordefinierte Template mit der gewünschten Menüausrichtung auszuwählen. Wird hingegen ein individuelles Template erstellt, muss der Menütyp mit der entsprechenden Option festgelegt werden.

§Varianten - In Version 8 standen für jedes vordefinierte Template vier Farbvarianten zur Verfügung. In der Nachfolgerversion 9 wurden diese Farbvarianten durch Stilvarianten ersetzt, die sich von den ersten unterschieden, weil sie nicht nur andere Farbkombinationen hatten, sondern auch im Layout und ihren grafischen Elementen voneinander abwichen. In der aktuellen Version 10 ist die Gliederung in Stilvarianten nicht mehr vorgesehen. Alle Templates zeichnen sich durch eigene Elemente und/oder Einstellungen aus und befinden sich in der Gesamtauflistung.

Praktische Anwendung:

- | Die Arbeit mit Vorlagen
- | Wo finde ich neue Templates für WebSite X5 ?


Farbton der Vorlage Fenster

Auswahl der Vorlage | Farbton der Vorlage

Schritt 1 - Allgemeine Einstellungen > Auswahl der Vorlage >

Auswahl der Vorlage | Farbton der Vorlage

 Return to chapter overview

In diesem Fenster, das sich über die Schaltfläche [image] im Fenster Auswahl der Vorlage öffnet, können die Farben des vordefinierten oder individuellen Templates, an dem Sie gerade arbeiten, nach Wunsch schattiert werden.

Um den Farbton festzulegen, in dem die Farben eines Templates schattiert werden sollen, bewegen Sie einfach den Regler Farbton.

Dank dieser Option ist die Vielfalt der grafischen Gestaltungsmöglichkeiten praktisch unbegrenzt.

Die Schattierung wirkt sich auf alle Elemente des Templates aus, hat aber keine sichtbaren Effekte auf Weiß, Schwarz und Graustufen.

Praktische Anwendung:

- | Die Arbeit mit Vorlagen
- | Wo finde ich neue Templates für WebSite X5 ?


Individuelles Template

Schritt 1 - Allgemeine Einstellungen >

Individuelles Template

 Return to chapter overview
Versteckten Text zeigen/verstecken

WebSite X5 ermöglicht das individuelle Erstellen von Templates. Klicken Sie hierzu auf Neue Vorlage im Fenster Auswahl der Vorlage. Es wird die Vorschau einer neuen Vorlage der Kategorie Individuelle Templates angezeigt. Mit Doppelklick auf diese Vorschau öffnet sich das Fenster Individuelles Template und Sie können mit der Gestaltung Ihrer Vorlage beginnen.

Zur Erleichterung der Arbeit finden Sie im Fenster Individuelles Template eine Vorschau mit einer schematischen Darstellung der Seite. Sie können die Sektion, die Sie bearbeiten wollen, aus der Liste auswählen oder in der Vorschau direkt auf die jeweiligen Bereiche der Seitenstruktur klicken, um sie auszuwählen und mit den verfügbaren Befehlen zu bearbeiten. Das Ergebnis wird jeweils sofort in der Vorschau angezeigt.

Klicken Sie um zu erweitern/minimieren Anleitung: Optionen für die Menükonfiguration

Wenn Sie ein eigenes Template erstellen wollen, müssen Sie zunächst den Menütyp definieren, also festlegen, wo und wie das Navigationsmenü auf den Seiten der Website positioniert werden soll. Folgende Alternativen stehen zur Verfügung:

Horizontal - Menü über dem Header

Horizontal - Menü unter dem Header

Vertikal - linksbündiges Menü

Vertikal - rechtsbündiges Menü
Klicken Sie um zu erweitern/minimieren Anleitung: Optionen zur Auswahl der Seitenbereiche

Nach der Auswahl des Menütyps wählen Sie den Seitenbereich, den Sie bearbeiten möchten. Eine Seite ist folgendermaßen gegliedert:

Seitenhintergrund: Dieser externe Bereich ist sichtbar, wenn das Fenster vom Browser größere Abmessungen hat als die Auflösung der Website selbst erlaubt.

Header-Hintergrund: Bestandteil vom Seitenhintergrund hinter dem Header.

Header: Der Header ist ein vorwiegend grafisch gestalteter Bereich, ideal für Elemente wie Überschriften, Untertitel, ein Firmenlogo, Suchfelder, Service-Menüs mit Links, beispielsweise zur Sitemap oder die Sprachauswahl.

Menü: Dies ist der feste Navigationsbereich mit den Menüpunkten der ersten Ebene, die auf jeder Seite unverändert angezeigt werden müssen. Die Position dieses Bereichs variiert natürlich je nach der gewählten Seitenstruktur.

Seiteninhalt: Dieser Bereich enthält den eigentlichen Inhalt der Seiten und eventuell ein Untermenü für die Navigation.

Fußzeile: Die Fußzeile ist ein ebenfalls vorwiegend grafisch gestalteter Bereich, der visuell die Seite abschließt. Im Allgemeinen enthält dieser Bereich Elemente wie Hinweise, Disclaimer, Informationen zum Urheberrecht, Steuernummer, E-Mail-Adressen usw.

Hintergrund der Fußzeile: Bestandteil vom Seitenhintergrund hinter der Fußzeile.

Wird der Header-Hintergrund oder der Hintergrund der Fußzeile Transparent eingestellt, erscheinen diese Bereiche wie der Seitenhintergrund und sehen identisch aus. Andernfalls erscheinen der Header und/oder der Fußzeile als Streifen, die über die gesamte Breite des Browserfensters verlaufen.
Klicken Sie um zu erweitern/minimieren Anleitung: Optionen für die grafischen Eigenschaften

Für alle Seitenbereiche können die folgenden Grafische Eigenschaften festgelegt werden:

§Farbe: Hier kann die Farbe für den Hintergrund auswählt werden.

§Bilddatei: Wählen Sie hier das Bild für den Hintergrund der Zelle aus. Sie können Dateien in den Formaten JPG, GIF und PNG verwenden. In den Header oder den Fußzeile können auch Flash-Animationen (.SWF) eingefügt werden.

§Anordnung: Hier können Sie festlegen, ob das ausgewählte Hintergrundbild wiederholt werden soll. Das Bild kann nur horizontal, nur vertikal oder in beide Richtungen wiederholt werden, bis es den zur Verfügung stehenden Platz ausfüllt. Nur im Seitenhintergrund kann ein eingefügtes Bild so angepasst werden, dass es den gesamten Hintergrund ausfüllt. In diesem Fall können jedoch möglicherweise die ursprünglichen Proportionen nicht eingehalten werden.

§Ausrichtung: Legen Sie hier fest, wie das Bild zur Seite ausgerichtet werden soll.

Nur für den Seitenhintergrund steht folgende Option zur Verfügung:

§Im Hintergrund fixiert: Bei Aktivierung dieser Option wird das Hintergrundbild fixiert, auch wenn der Seiteninhalt mit der Bildlaufleiste verschoben wird.
Klicken Sie um zu erweitern/minimieren Anleitung: Optionen zum Einstellen der Abmessungen

Für einige Seitenbereiche kann auch die Größe festgelegt werden:

Für das Header und den Menü steht folgende Option zur Verfügung:

§Breite: Breite des Bereichs in der ausgewählten Seite, angegeben in Pixeln. Für vertikale Menüs ist die Breite standardmäßig auf 960 im Bereich Header und 120 Pixel im Bereich Menü eingestellt, kann aber frei geändert werden. Bei horizontalen Menüs hingegen wird die Breite für den Header automatisch auch für das Menü, den Seiteninhalt und die Fußzeile übernommen.

Die voreingestellte Breite wird automatisch berechnet und ist für eine Anzeige mit 1024 x 768 Pixeln optimiert.

Für alle Bereiche außer den Seitenhintergrund und den Seiteninhalt steht folgende Option zur Verfügung:

§Höhe: Höhe des ausgewählten Seitenbereichs in Pixeln.

Nur für den Seiteninhalt ist ferner folgende Option verfügbar:

§Mindesthöhe: Mindesthöhe in Pixeln, die der Bereich auf der Seite, in den die Inhalte eingefügt werden sollen, haben muss, unabhängig von der Höhe der effektiv enthaltenen Inhalte.
Klicken Sie um zu erweitern/minimieren Anleitung: Optionen für die grafischen Eigenschaften der Seiteninhalte

Für einige Seitenbereiche können auch Eigenschaften der Inhalte festgelegt werden:

Für die Bereiche Seitenhintergrund, Menü und Seiteninhalt steht folgende Option zur Verfügung:

§Ränder: Geben Sie die Breite der Ränder in Pixeln ein. Dieser Abstand ist der Freiraum zwischen dem Rand eines Bereichs und seinem Inhalt.

Nur für die Bereiche Seitenhintergrund und Menü ist außerdem folgende Option verfügbar:

§Ausrichtung: Definiert beim Seitenhintergrund, wie er zum Browserfenster ausgerichtet werden soll, und beim Menü, wie die Menüeinträge zur Seite ausgerichtet werden sollen.

Die effektive Breite der Seiten entspricht der Breite des Bereichs Seiteninhalt (abhängig vom Header) abzüglich linkem und rechtem Rand.

Der Header kann mit Texten, Bildern, Flash-Animationen, Slideshows, Suchfeldern und Links vervollständigt werden. Die entsprechenden Funktionen finden Sie im Fenster Gestaltung des Templates, das Sie auch mit der Schaltfläche Weiter öffnen können.

Praktische Anwendung:

- | Die Arbeit mit Vorlagen
- | Wo finde ich neue Templates für WebSite X5 ?


Gestaltung des Templates

Schritt 1 - Allgemeine Einstellungen >

Gestaltung des Templates

 Return to chapter overview
Versteckten Text zeigen/verstecken

Nach Auswahl einer vordefinierten Stilvorlage im Fenster Auswahl der Vorlage bzw. der Gestaltung einer individuellen Vorlage im Fenster Individuelles Template, öffnet sich die Ansicht Gestaltung des Templates. In den Bereichen Header und Fußzeile können Sie jeweils die den Header und/oder die Fußzeile des Templates gestalten und Text, Bilder, Flash-Animationen, Slideshows, HTML-Code, ein Suchfeld oder Links einfügen.

Die verfügbaren Schaltflächen für die Gestaltung des Header und der Fußzeile sind identisch.

In den Bereichen Header oder Fußzeile ist als Hintergrund eine Flash-Animation eingefügt, die unter Gestaltung des Templates nicht verändert werden kann.

Klicken Sie um zu erweitern/minimieren Anleitung: Aufbau des Vorlagen-Editors

Das Fenster Gestaltung des Templates enthält einen Grafik-Editor, in dem unter der Werkzeugleiste automatisch das Hintergrundbild des Headers oder der Fußzeile des ausgewählten Templates (vordefiniert oder individuell) angezeigt wird: Das Bild wird im Maßstab 1:1 angezeigt und die Ansicht kann, sofern erforderlich, mit der horizontalen Bildlaufleiste verschoben werden. In diesem Bild werden alle mit den verfügbaren Funktionen vorgenommenen Änderungen in Echtzeit angezeigt.

Gleich unter dem Bild befindet sich eine Statusleiste mit folgenden Daten:

§Position: X- und Y-Koordinaten der Position der oberen rechten Ecke des ausgewählten Objekts.

§Größe: Breite und Höhe des ausgewählten Objekts in Pixeln.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen in der Werzeugleiste

Mit den Schaltflächen in der Werkzeugleiste können Sie neue Objekte in den Header und die Fußzeile Ihres Templates einfügen und einige Einstellungen vornehmen. Nachdem ein Objekt eingefügt wurde, kann es markiert und mit den Optionen in dem nach dem Objekt benannten Bereich bearbeitet werden.

Ausschneiden [Strg+X] - Kopieren [Strg+C] - Einfügen [Strg+V]

Zum Ausschneiden, Kopieren oder Einfügen des ausgewählten Objekts.

Rückgängig [Strg+Z]

Zum Annullieren der zuletzt durchgeführten Operation.

In den Vordergrund - In den Hintergrund

Mit diesen Funktionen kann das ausgewählte Objekt jeweils in den Vordergrund oder Hintergrund, also über oder unter andere Objekte verschoben werden.

Link zuweisen

Mit dieser Funktion können Sie markierten Text, ein Bild oder ausgewählte Bilder einer Slideshow verlinken. Die Einstellungen für den Hyperlink können Sie im Dialogfenster Link vornehmen.

Position und Größe

In dem sich öffnenden Dialogfenster können Sie die Koordinaten für die Position und die Größe des markierten Objekts festlegen. Die standardmäßig aktivierte Option Größenverhältnis beibehalten bewirkt, dass beim Vergrößern oder Verkleinern die Proportionen des Objekts beibehalten werden.

Text einfügen - Bild einfügen - Flash-Animation einfügen - Slideshow einfügen - HTML-Code einfügen - Suchfeld einfügen

Mit diesen Optionen können Sie die jeweils genannte Funktion ausführen.

Eine Slideshow ist eine Sequenz aus Bildern, die automatisch wiedergegeben wird. Dies eignet sich beispielsweise für die Gestaltung von Werbebannern.

In Form von HTML-Code kann jede Art von Inhalt eingefügt werden. Auf diese Weise haben Sie Möglichkeiten, die über die der Schaltflächen weit hinaus gehen.

Die Suchfunktion nutzt eine interne Suchmaschine, über die der Benutzer in allen Inhalten der Website recherchieren kann.

Flash-Animationen und HTML-Code-Objekte sind nur sichtbar, wenn die Website im Browser geöffnet wird.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Header / Fußzeile

im Tab Header und Fußzeile das Hintergrundbild anklicken, stehen Ihnen in den jeweiligen Bereichen Header / Fußzeile darunter folgende Optionen zur Verfügung:

§Bilddatei im Format JPG speichern: Text- und Bildobjekte, die während der Erstellung der Website als Header/Fußzeile eingefügt werden, vereinen sich mit dem verwendeten Hintergrundbild und das Ergebnis wird automatisch als neue Datei im Format PNG gespeichert. Im Format PNG bleiben eventuell eingestellte Transparenzen erhalten. Bestehen keine besonderen Anforderungen im Hinblick auf Transparenzen, können Sie die Option Bilddatei im Format JPG speichern, um die Dateigröße des Hintergrundbildes zu reduzieren.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Text

Wenn Sie ein Text-Objekt arkieren, das in den Header oder die Fußzeile eingefügt wurde, stehen im Bereich Text folgende Optionen zur Verfügung:

§Inhalt: Geben Sie hier den gewünschten Text ein.

§Schriftart: Hier können Sie die Schriftart, den Schriftschnitt und die Schriftgröße in Punkten festlegen.

§Textfarbe / Hintergrundfarbe: Hier kann die Text- und die Hintergrundfarbe für den eingegebenen Text festgelegt werden.

§Bilddatei im Format PNG speichern: Bei Aktivierung dieser Option wird der eingefügte Text nicht in das Hintergrundbild des Header / der Fußzeile sondern als separate .PNG-Datei mit transparentem Hintergrund gespeichert. In diesem Fall wird der ursprüngliche Text auch automatisch als Alternativtext (ALT text) des .PNG-Datei zugewiesen.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Bild

Wenn Sie ein Bild-Objekt markieren, das in den Header oder die Fußzeile eingefügt wurde, stehen im Bereich Bild folgende Optionen zur Verfügung:

§Bilddatei: Pfad zur Bilddatei, die eingefügt werden soll. Sie können Dateien in den Formaten JPG, GIF, PNG, BMP, PSD, TIF, DIB, PCX, RLE, TGA und WMF verwenden.

§Bild bei Mauskontakt: Hier können Sie eine zweite, von der ersten verschiedene, Bilddatei auswählen, die bei Kontakt des Mauszeigers eingeblendet wird. Diese Option eignet sich besonders für die Erstellung von Buttons mit Aktiv- und Inaktiv-Status (Mouseover Effekt).

§Transparenz aktivieren: Mit dieser Option kann eine bestimmte Farbe im Bild transparent, also unsichtbar gemacht werden.

§Transparente Farbe: Mit Klick auf die Schaltfläche können Sie die Farbe festlegen die im Bild unsichtbar sein soll, wenn die Option Transparenz aktivieren gewählt wurde. In diesem Fall ist die Pipettenfunktion besonders nützlich, da die gewünschte Farbe damit direkt aus dem Bild übernommen werden kann.

§Toleranz: Hier können Sie für die Transparenz einen Toleranzfaktor festlegen. Je höher der Toleranzwert eingestellt wird, desto größer ist der durchsichtige Bereich des Bildes.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Flash-Animation

Wenn Sie eine Flash-Animation markieren, die in den Header oder die Fußzeile eingefügt wurde, stehen im Bereich Flash-Animation folgende Optionen zur Verfügung:

§Animationsdatei: eingefügt wurde, stehen im Bereich Flash-Animation folgende Optionen zur Verfügung:

§Transparenter Hintergrund: Mit dieser Option wird der Hintergrund der Animation unsichtbar.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Slideshow

Wenn Sie ein Slideshow-Objekt markieren, das in den Header oder die Fußzeile eingefügt wurde, stehen im Bereich Slideshow folgende Optionen zur Verfügung:

§Liste der anzuzeigenden Bilder: Liste der Bilder, aus denen sich die Slideshow zusammensetzt. Von jedem Bild werden der Pfad zur entsprechenden Bilddatei und, sofern vorhanden, der angewendete Effekt und der zugewiesene Link angezeigt. Wenn Sie eine Datei aus der Liste auswählen, wird eine Vorschau angezeigt. Für die Mehrfachauswahl halten Sie auf der Tastatur gleichzeitig zum Klick die Taste Strg oder Umschalt gedrückt.

§Hinzufügen... / Entfernen: Mit diesen Schaltflächen können Sie jeweils neue Bilder hinzufügen oder in der Liste für die Slideshow ausgewählte Bilder löschen. Im Dialogfenster Datei auswählen können auch mehrere Bilder gleichzeitig ausgewählt werden.

§Nach oben / Nach unten: Mit diesen Schaltflächen können Sie ein in der Liste der anzuzeigenden Bilder ausgewähltes Bild vor oder hinter ein benachbartes verschieben.

§Effekt...: Mit dieser Schaltfläche öffnen Sie das Dialogfenster Effekteigenschaften der Effekte in dem Sie Einblend-, Bewegungs- und Zoom-Effekte für die Fotos in der Liste der anzuzeigenden Bilder definieren können.

§Automatische Wiedergabe: Bei Aktivierung dieser Option wird die Slideshow automatisch wiedergegeben.

§Zufallsanzeige: Bei Aktivierung dieser Option werden die Bilder der Slideshow nicht wie in der Liste der anzuzeigenden Bilder, sondern in zufälliger Rihenfolge wiedergegeben.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich HTML-Code

Wenn Sie ein HTML-Code -Objekt markieren, das in den Header oder die Fußzeile eingefügt wurde, stehen im Bereich HTML-Code folgende Optionen zur Verfügung:

§HTML-Code: Geben Sie oder fügen Sie in dieses Feld den HTML-Code des zu erstellenden Objekts ein. In der Werkzeugleiste stehe folgende Optionen zur Verfügung:

Ausschneiden [CTRL+X] - Kopieren [CTRL+C] - Einfügen [CTRL+V]

Ausschneiden, Kopieren und Einfügen von ausgewähltem Text.

Rückgängig [Strg+Z] - Wiederherstellen [ALT+UMSCHALT+BACKSPACE]

Zum Annullieren/Wiederherstellen der zuletzt durchgeführten/annullierten Operation.

Widgets einfügen

Fügt den Code des ausgewählten Widgets ein: Klicken Sie auf den Pfeil neben der Schaltfläche, um die Liste aller verfügbaren Widgets aus HTML und Widgets anzuzeigen. Mit einen Klick auf ein Widget wird das Dialogfenster Widget geöffnet, in dem Sie die vorgesehenen Parameter definieren können. Nach der Bestätigung der Eingabe wird der entsprechende HTML-Code erstellt und automatisch in den Editor eingefügt.

§Bildlaufleisten anzeigen: aktiviert die Anzeige der Scrollbars.

Hinweise zur Kompatibilität mit Vorgängerversionen:

In der Vorgängerversion 9 konnte man im Editor für HTML-Code automatisch Snippets (kurze Code-Strings) einfügen. In der aktuellen Version 10 wurden diese Snippets erweitert und in die Liste der Widgets integriert.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Suchfeld

Wenn Sie ein Suchfeld markieren, das in den Header oder die Fußzeile eingefügt wurde, stehen im Bereich Suchfeld folgende Optionen zur Verfügung:

§Button-Beschriftung: Geben Sie hier die gewünschte Beschriftung für den Such-Button ein.

§Schriftart: Legen Sie die Schriftart, den Schriftschnitt und die Schriftgröße in Punkten fest.

§Feldfarben: Legen Sie die Text- und die Hintergrundfarbe für das Suchfeld fest.

§Buttonfarben: Legen Sie die Text- und die Hintergrundfarbe für den Button fest.

§Wenn Sie in den Header / die Fußzeile Ihres Templates ein Suchfeld einfügen, wird automatisch die Spezialseite „Suche“ in die Sitemap eingefügt. Sie können diese Seite auswählen und das Fenster Eigenschaften der Seite öffnen, um die Haupteigenschaften festzulegen.

§Die Ergebnisse der über die Website durchgeführten Suche erscheinen auf Seiten, die automatisch vom Programm erstellt werden. Die grafische Gestaltung dieser Seiten richtet sich nach den Einstellungen für den Textstil (siehe Stile und Modelle im Schritt 4 - Erweiterte Einstellungen).

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Effekte

Wenn Sie ein Objekt vom Typ Text, Bild oder Slideshow auswählen, das in den Header oder die Fußzeile eingefügt wurde, stehen Ihnen im Bereich Effekte folgende Optionen zur Verfügung:

§Effekttyp: Hier können Sie einen oder mehrere Effekte auswählen und aktivieren, die auf das markierte Objekt angewendet werden sollen.

Auf jedes Text-, Bild- oder Slideshow-Objekt können auch mehrere Effekte gleichzeitig angewendet werden und jeder der Effekte ist individuell konfigurierbar:

Effekt

Einstellungen

Schatten

§Diffusion: Hiermit können Sie die Breite des Schattens festlegen.

§Farbe: Im Dialogfenster Farbe können Sie aus der Farbpalette die Farbe des Schattens auswählen.

§Abstand X / Abstand Y: Hier legen Sie fest, wie weit der Schatten horizontal bzw. vertikal zum Objekt verschoben dargestellt werden soll. Bei Eingabe eines positiven Wertes, wird der Schatten nach rechts bzw. unten verschoben, bei Eingabe eines negativen Wertes entsprechend nach links bzw. oben.

Spiegelung

§Diffusion: efinieren Sie hier die Breite der anzuwendenden Spiegelung.

§Abstand: Hier können Sie festlegen, wie weit die Spiegelung vom Objekt entfernt sein soll.

Farbiger Rand

§Breite: Breite des anzuwendenden Rahmen

§Farbe: Im Dialogfenster Farbe können Sie aus der Farbpalette die Farbe des anzuwendenden Rahmens auswählen.

Äußerer Glanz

§Diffusion: Breite des Glanzeffekts.

§Farbe: Im Dialogfenster Farbe können Sie aus der Farbpalette die Farbe des Glanzeffekts auswählen..

Plastischer Rand

§Tiefe: Legen Sie hier fest, wie tief der plastische Effekt sein soll.

§Diffusion: Breite des plastischen Randes

§Winkel: Definieren Sie hier den Winkel des plastischen Randes.

Drehung

§Winkel: Hier können Sie festlegen, um welchen Winkel (im Uhrzeigersinn) das Objekt gedreht werden soll.

Deckkraft

§Deckkraft: Mit einem Wert von 0 bis 255 können Sie die Deckkraft des Bildes verändern. Je näher der Wert an 0 liegt, desto geringer ist die Deckkraft und desto transparenter wird das Bild.

Weichzeichnung

§Diffusion: Intensität der Weichzeichnung.

Welle

§Diffusion: Definieren Sie hier die Breite des Welleneffekts.

§Häufigkeit: Legen Sie hier fest, wie häufig der Welleneffekt wiederkehren soll

Perspektive

§Horizontal: Einstellung des horizontalen Fluchtwinkels für den Effekt der Perspektive nach rechts (positive Werte) bzw. nach links (negative Werte).

§Vertikal: Einstellung des vertikalen Fluchtwinkels für den Effekt der Perspektive nach unten (positive Werte) bzw. nach oben (negative Werte).

Verzerrung

§Horizontal: Einstellung des Punktes, zu dem die Verzerrung auf horizontaler Ebene nach rechts (positive Werte) bzw. nach links (negative Werte) erfolgen soll.

§Vertikal: Einstellung des Punktes, zu dem die Verzerrung auf vertikaler Ebene nach unten (positive Werte) bzw. nach oben (negative Werte) erfolgen soll.

Praktische Anwendung:

- | Die Arbeit mit Vorlagen
- | Wo finde ich neue Templates für WebSite X5 ?

Zusatzinformationen:

-

Funktionsprinzip der internen Suchmaschine von WebSite X5


Erstellen der Sitemap

Schritt 2 - Erstellen der Sitemap >

Erstellen der Sitemap

 Return to chapter overview
Versteckten Text zeigen/verstecken

Eine Website ist ein strukturierter Komplex verschiedener Seiten. Diese Struktur korrekt zu definieren ist sehr wichtig, da sie bestimmt, wie die Seiten untereinander verknüpft sind, und sie somit die Navigationswege festlegt, über die der Besucher zu bestimmten Informationen gelangt.

Eine gute Strukturierung gewährleistet, dass sich der Besucher während der Navigation immer orientieren kann, dass er weiß wo er sich befindet und in wenigen Schritten zur gewünschten Information gelangt. Eine mangelhafte Struktur hingegen verursacht Desorientierung, Frustration und führt im schlimmsten Fall dazu, dass der Besucher die Website verlässt.

Im Fenster Erstellen der Sitemap können Sie die Struktur der Website festlegen, alle gewünschten Seiten anlegen und diese auf Ebenen und Unterebenen organisieren. Nachdem Sie die Sitemap als reine Struktur ohne Inhalte konstruiert haben, können Sie damit beginnen, jede einzelne Seite zu gestalten. Mit jedem Klick auf die Schaltfläche Weiter öffnen sich nacheinander die Seiten in der gleichen Reihenfolge, mit der sie in die Sitemap eingefügt wurden. Alternativ können Sie die Sitemap verwenden, um direkt in das Programmfenster zu gelangen und dort eine bestimmte Seite zu bearbeiten: Klicken Sie hierzu doppelt auf den gewünschten Eintrag oder markieren Sie ihn und klicken dann auf Weiter.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Sitemap

Das Fenster Erstellen der Sitemap wird fast vollständig von der Übersicht ausgefüllt, in der Sie die Sitemap erstellen.

Als vordefinierte Basis finden Sie eine Struktur bestehend aus einer Homepage und einem Verzeichnis "Menü", das 3 Seiten enthält. Mit den entsprechenden Schaltflächen eingefügte Ebenen, Seiten und Trennelementen werden in das Verzeichnis "Menü" der Sitemap integriert, die auf diese Weise nach und nach ihre Form annimmt.

Wenn Sie in Schritt 4 - Erweiterte Einstellungen Elemente wie die interne Suchfunktion (siehe Gestaltung des Templates), eine Introseite ein Blog, ein geschützter Bereich (hierfür ist es hinreichend, dass auch nur eine Seite als geschützte Seite konfiguriert wird) oder ein Warenkorb für E-Commerce einfügen, wird der Sitemap das Verzeichnis "Spezialseiten" mit den entsprechenden Einträgen Suche, Introseite, Blog, Login-Seite und Warenkorb für E-Commerce hinzugefügt.

Außer der Baumstruktur der Sitemap sehen Sie einige nützliche Informationen über die angelegten Seiten, wie den Erweiterter Seitentitel und die Seitenbeschreibung. Damit diese Informationen angezeigt werden, müssen sie natürlich im Dialogfenster Eigenschaften der Seite zuvor eingegeben worden sein.
Klicken Sie um zu erweitern/minimieren Anleitung: Schaltflächen der Werkzeugleiste

Im Fenster Erstellen der Sitemap steht direkt über der Übersicht eine Werkzeugleiste mit folgenden Schaltflächen zur Verfügung:

Ausschneiden [Strg+X] - Kopieren [Strg+C] - Einfügen [Strg+V]

Mit diesen Schaltflächen können ausgewählte Seiten innerhalb eines Projekts oder auch projektübergreifend ausgeschnitten, kopiert und eingefügt werden. Diese Befehle sind auch über das Kontextmenü abrufbar, das bei Rechtsklick auf die Sitemap eingeblendet wird.

Erweitern - Reduzieren

Ein- und Ausblenden von Kategorieebenen, je nachdem, wie viele enthaltene Produkte angezeigt werden sollen.

Seite im Menü nicht sichtbar

Die ausgewählte Seite oder Ebene wird nicht in das Navigatinsmenü aufgenommen. Wenn eine Ebene unsichtbar gemacht wird, sind automatisch alle darin enthaltenen Seiten ebenfalls unsichtbar. Die aus dem Menü ausgeschlossenen Seiten können für Zusatzinformationen genutzt werden, die über interne Links aufgerufen werden. Es muss auf jeden Fall mindestens eine Verknüpfung zu unsichtbaren Seiten erstellt werden, da sie für die Besucher der Website sonst nicht erreichbar sind.

Geschützte Seite

Öffnet das Fenster Geschützte Seite, in dem die Seite durch Aktivierung der Option Diese Seite als geschützt einstellen als geschützt eingestellt werden kann. Anschließend müssen Sie festlegen, von welchen Gruppen und/oder einzelnen Benutzern diese Geschützte Seite angezeigt werden kann, indem Sie die jeweiligen Kontrollkästchen in der Liste darunter aktivieren. Zwischen der Aktivierung einer Gruppe und der Aktivierung aller enthaltenen Benutzer besteht ein Unterschied: Nur wenn Sie der ganzen Gruppe den Zugriff gestatten, können auch Benutzer, die der Gruppe später hinzugefügt werden, automatisch die entsprechenden geschützten Seiten anzeigen.

Klicken Sie um zu erweitern/minimieren
Fenster Geschützte Seite

Neue Gruppen / Benutzer können Sie im Fenster Zugangsverwaltung in Schritt 4 - Erweiterte Einstellungen erstellen.

§Auch die Homepage kann aus dem Menü ausgeschlossen werden. Dies wird jedoch nur dann empfohlen, wenn an anderen Stellen der Website Verknüpfungen zur Homepage eingebaut werden sollen, zum Beispiel im Header des Templates.

§Soll ein individuelles Navigationsmenü erstellt werden, können alle Seiten und Ebenen in der Sitemap ausgeblendet werden. Markieren Sie zu diesem Zweck die Seiten nicht einzeln, sondern direkt das Verzeichnis "Menü" und klicken Sie dann auf Seite im Menü nicht sichtbar.

Klicken Sie um zu erweitern/minimieren Anleitung: Schaltflächen zum Erstellen der Sitemap

Für die Definition der Sitemap stehen folgende Optionen zur Verfügung:

§Neue Ebene [Strg+L]: Fügt eine neue Menüebene ein. Die Anzahl der realisierbaren Ebenen und Unterebenen ist unbegrenzt.

§Neue Seite Strg+P]: Erstellt eine neue Seite, die automatisch in die ausgewählte Ebene eingefügt wird.

§Menütrennlinie: Fügt ein Trennelement ein, um die Menüeinträge auch visuell zu organisieren. Ein Trennelement kann ein Zwischenraum oder ein Titel sein und eignet sich besonders für die Erstellung von mehrspaltigen Menüs (siehe Stil des Drop-Down-Menüs | Menüelemente in Passo 4 - Erweiterte Einstellungen).

§Entfernen [Entf]: Löscht eine ausgewählte Seite, Ebene oder ein Trennelement.

§Umbenennen [F2]: Mit dieser Schaltfläche können Sie die Homepage, eine Seite, eine Ebene oder ein Trennelement umbenennen, nachdem Sie es markiert haben. Ebenen, Seiten und Trennelemente sollten mit korrekten Benennungen versehen werden, da die Menüpunkte in der Sitemap und in den Titeln der einzelnen Seiten sowie als Namen der entsprechenden HTML-Dateien wiederkehren, sofern im Fenster Eigenschaften der Seite nichts anderes eingestellt wurde.

§Nach oben [Strg+U] / Nach unten [Strg+D]: Hier können Sie die Anzeigereihenfolge der Seiten, Ebenen und Trennelemente verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

Alternativ können Sie die Reihenfolge der Seiten, Ebenen und Trennelemente auch direkt in der Sitemap ändern: Wählen Sie hierzu den Eintrag aus, den Sie verschieben wollen, und ziehen Sie ihn per Drag&Drop an die gewünschte Stelle. Mit gedrückter Strg- und Umschalttaste können auch mehrere Ebenen und/oder Seiten markiert werden.

§Eigenschaften...: Öffnet ein Fenster, in dem Sie die Eigenschaften einer Seite (Fenster Eigenschaften der Seite) oder einer Ebene (Fenster Eigenschaften der Ebene) festlegen können.

Praktische Anwendung:

-

Erstellen und Bearbeiten der Sitemap


Eigenschaften der Ebene Fenster

Schritt 2 - Erstellen der Sitemap > Erstellen der Sitemap >

Eigenschaften der Ebene Fenster

 Return to chapter overview
Versteckten Text zeigen/verstecken

Das Fenster Eigenschaften der Ebene das sich öffnet, wenn Sie in der Sitemap eine Ebene markieren und auf Eigenschaften..., enthält zwei Optionen, mit denen die Ebene innerhalb des Navigationsmenüs definiert werden kann.

In WebSite X5 haben Ebenen, im Unterschied zu Seiten, keine eigenen Inhalte. Vielmehr dienen sie als Kategorien, in denen Sie die Seiten organisieren und demzufolge das Navigationsmenü hierarchisch strukturieren, um dem Besucher die Navigation zu erleichtern.

Klicken Sie um zu erweitern/minimieren Anleitung: Eigenschaften der Ebenen

§Drop-Down-Menü in dieser Ebene nicht anzeigen: Wenn Sie diese Option aktivieren, wird das Drop-Down-Menü der Ebene bei Mauskontakt nicht angezeigt.

§Ebene als Link aktivieren: Hier können Sie über das Dialogfenster Link die Ebene direkt verlinken.

Das Drop-Down-Menü in einer Ebene nicht anzuzeigen und die Ebene als Link zu aktivieren empfiehlt sich beispielsweise, wenn man einen Link zu einer externen Seite direkt als Menüelement einbinden will, oder wenn ein Untermenü mit besonders vielen Menüelementen durch das Öffnen einer speziell erstellten Seite ersetzt werden soll, um die verschiedenen internen Bereiche aufzurufen.

§Icon, das im Menü angezeigt werden soll: Wählen Sie hier Bilddatei (Format .JPG, .GIF und .PNG), die im Navigationsmenü neben dem Seitennamen angezeigt wird.


Eigenschaften der Seite Fenster

Fenster Eigenschaften der Seite

Schritt 2 - Erstellen der Sitemap > Erstellen der Sitemap >

Fenster Eigenschaften der Seite

 Return to chapter overview
Versteckten Text zeigen/verstecken

Das Fenster Eigenschaften der Seite, das sich öffnet, wenn Sie eine Seite in der Sitemap markieren und dann auf Eigenschaften... klicken, enthält verschiedene Optionen für die Optimierung, individuelle grafische Gestaltung und die Eingabe von zusätzlichem Code.

Die hier verfügbaren Optionen sind in drei Bereiche gegliedert: Allgemein, Grafik und Erweitert.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den Optionen in diesem Bereich können Sie einige Parameter für die Optimierung der Seite festlegen:

§Erweiterter Seitentitel: Hier können Sie einen Titel eingeben, der von dem in der Sitemap angezeigten verschieden ist.

Der Name, der der Seite beim Aufbau der Sitemap gegeben wurde, wird im Navigationsmenü beibehalten. Der in den Eigenschaften der Seite angegebene Erweiterter Seitentitel hingegen wird als effektiver Seitentitel angezeigt.

Der Titel der Homepage wird nicht auf der Seite angezeigt, es kann aber trotzdem ein Erweiterter Seitentitel festgelegt werden: Der Titel erscheint immer im Menü. Der Titel oder ein Erweiterter Seitentitel (sofern vorhanden) wird außerdem für den Metatag <title> im HTML-Code der Seite verwendet.

§Seitenbeschreibung: Hier können Sie eine spezifische Beschreibung für die Seite eingeben. Die Beschreibung der Seite sollte kurz und aussagekräftig sein, da sie vom HTML-Code als Metatag <description> verwendet und von Suchmaschinen zur Indexierung verwendet wird.

§Keywords: Geben Sie hier durch Kommas getrennte Keywords ein, die für die Inhalte Ihrer Website charakteristisch sind. Diese Schlüsselwörter werden als Werte des Metatags <keywords> HTML-Code der Seite und von Suchmaschinen zur Indexierung verwendet.

§Name der erstellten Datei: Geben Sie hier der HTML-Datei der Seite einen Namen.

Wenn nicht anders angegeben, wird als Name der HTML-Datei automatisch der Name der Seite verwendet, der ihr beim Aufbau gegeben wurde. Wenn Sie den Dateien kurze und aussagekräftige Namen geben, bekommen Sie einfache und leicht zu merkende Adressen, was sich auch positiv auf die Indexierung durch die Suchmaschinen auswirkt. Für die Homepage ist diese Option nicht verfügbar.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Grafik

Mit den Funktionen in diesem Bereich legen Sie einige wichtige grafische Aspekte der Seite fest, an der Sie arbeiten.

Allem voran können Sie hier der Seite einen individuellen Hintergrund geben, der von dem der anderen Seiten (festgelegt mit dem Template) verschieden ist (siehe Auswahl der Vorlage). Dieser externe Bereich der Seite ist sichtbar, wenn das Fenster des geöffneten Browsers größere Abmessungen hat als die Auflösung der Website selbst erlaubt.

Für den Website-Hintergrund nur für diese Seite stehen folgende Optionen zur Verfügung:

§Hintergrundfarbe: Hier kann die Farbe für den Hintergrund auswählt werden.

§Bilddatei: Wählen Sie hier das Bild für den Hintergrund der Zelle aus. Sie können Dateien in den Formaten JPG, GIF und PNG verwenden.

§Anordnung: Hier können Sie festlegen, ob das ausgewählte Hintergrundbild wiederholt werden soll. Das Bild kann nur horizontal, nur vertikal oder in beide Richtungen wiederholt werden, bis es den zur Verfügung stehenden Platz ausfüllt.

§Ausrichtung: Legen Sie hier fest, wie das Hintergrundbild zum Seitenhintergrund ausgerichtet werden soll.

§Im Hintergrund fixiert: Bei Aktivierung dieser Option wird das Hintergrundbild fixiert, auch wenn der Seiteninhalt mit der Bildlaufleiste verschoben wird.

Auch der Hintergrund der Inhalte der aktuellen Seite kann anders als das Template (siehe Auswahl der Vorlage) für die anderen Seiten konfiguriert werden. Nutzen Sie hierfür die zu den gerade beschriebenen analogen Optionen unter Seiteninhalt nur für diese Seite.

Und schließlich können Sie einige allgemeine Optionen festlegen:

§Icon, das im Menü angezeigt werden soll: Wählen Sie hier eine Bilddatei (Format .JPG, .GIF und .PNG), die im Navigationsmenü neben dem Seitennamen angezeigt wird.

§Seite ohne Template erstellen: Bei Aktivierung dieser Option wird das für die Website gewählte oder individuell erstellte Template auf dieser Seite nicht angewendet (siehe Auswahl der Vorlage). Das heißt, die Seite enthält nur die eingegebenen Inhalte und es werden weder das Template noch das Navigationsmenü angezeigt.

§Seitenbreite: Diese Einstellung ist nur verfügbar, wenn die Option Seite ohne Template erstellen aktiviert wurde, und definiert die Breite der Seite in Pixeln.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Erweitert

Mit den Funktionen in diesem Bereich können Sie manuell den HTML-Code der aktuellen Seite bearbeiten.

§Dateinamenformat: Hier können Sie das Format bestimmen, mit dem die Datei der Seite gespeichert werden soll. Voreingestellt ist das Format .html, alternativ können Sie .php, .asp, .cfm und .jsp wählen. Auch die Datei index.html der Homepage kann in einem anderen Format gespeichert werden. Lediglich das Format geschützter Seiten (siehe Schaltfläche [image] Geschützte Seite in der Werkzeugleiste der Sitemap) kann nicht geändert werden und bleibt .php.

§Benutzerdefinierter Code: Sie können die Position innerhalb des Seitencodes festlegen, in den der individuelle Code eingefügt werden soll: Vor dem <HTML> Tag, Vor dem </HEAD> Tag, Innerhalb des <BODY> Tag (also innerhalb der Anweisung <BODY>, zum Beispiel: <BODY onload="alert('Hello!')">), Vor dem </BODY> Tag, Nach dem </BODY> Tag. nter der Auswahl der Position finden Sie das Feld, in das Sie den gewünschten Code kopieren oder eingeben der automatisch in der Seite eingefügt werden soll.

Die Option Benutzerdefinierter Code ist nützlich, wenn bestimmte Stylesheets (CSS) verbunden oder Events per Onload geladen werden sollen. Für die korrekte Funktion einiger JavaScripts, die mit der Funktion HTML und Widgets eingefügt werden können, müssen entsprechende Code-Zeilen in den Bereichen <HEAD> und <BODY> der HTML-Datei der Seite vorgesehen werden.

Im Bereich Einstellungen für die Sitemap finden Sie schließlich einige Optionen für die Sitemap der Website:

§Diese Seite in die Sitemap einbinden: Mit dieser standardmäßig aktivierten Option wird die Seite in die Sitemap der Website aufgenommen.

§Priorität des Inhalts: Hier können Sie der Seite eine Priorität zuweisen, die ihre Relevanz im Verhältnis zu anderen Seiten der Website zum Ausdruck bringt. Dieser Parameter wird auch in der erstellten Sitemap wiedergegeben.

§Aktualisierungsfrequenz: Hier können Sie bestimmen, wie oft die Seite aktualisiert werden soll. Dieser Parameter wird auch in der erstellten Sitemap wiedergegeben.

Hinweise zur Kompatibilität mit Vorgängerversionen:

Abweichend von den Vorgängerversionen können Sie in der aktuellen Versionn 10 das Fenster Eigenschaften der Seite auch für Spezialseiten öffnen, die automatisch in der Sitemap erscheinen, wenn die interne Suchfunktion (siehe Gestaltung des Templates), eine Introseite, ein Blog, ein geschützter Bereich oder ein Warenkorb für E-Commerce eingefügt wurden.

Weiterführende Informationen:

-

Der Webbrowser und der Browser von WebSite X5


Erstellen der Seiten

Schritt 3 - Erstellen der Seiten >

Erstellen der Seiten

 Return to chapter overview
Versteckten Text zeigen/verstecken

Nach der Strukturierung der Sitemap können Sie mit der Gestaltung der einzelnen Seiten beginnen. Im Fenster Erstellen der Seiten können Sie das Layout gestalten und die Inhalte eingeben.

Der Pfad und der Titel der Seite, an der Sie gerade arbeiten, wird hinter dem Eintrag Aktuelle Seite angezeigt.

Klicken Sie um zu erweitern/minimieren Anleitung: Das Layout-Schema

Für die komfortable Layout-Gestaltung bietet WebSite X5 ein Schema, das standardmäßig in zwei Zeilen und zwei Spalten gegliedert ist: Ziehen Sie einfach die verfügbaren Objekte in die Zellen dieses Schemas (ein Objekt pro Zelle), um die Seite zusammenzustellen.

Natürlich können Sie weitere Zeilen und Spalten hinzufügen, um mehr Zellen zur Verfügung zu haben. Außerdem kann die Breite der einzelnen Spalten manuell definiert werden. Dank dieser Gestaltungsoptionen im Schema und der Möglichkeit, Objekte auch über mehrere, nebeneinander liegende Zellen zu erweitern, können ausgesprochen attraktive Layouts realisiert werden.

Wichtiger Hinweis: Das Schema dient ausschließlich der Vereinfachung der Layout-Gestaltung. Außer in einigen wenigen, speziellen Fällen, wie bei besonders komplexen Objektkombinationen, wird das Layout-Schema im HTML-Code der Seiten nicht als Tabelle umgesetzt. Bei der Anzeige in einem Browser ist das Layout-Schema grundsätzlich nicht sichtbar.

Wie bereits erwähnt, kann jede Zelle des Schemas nur ein Objekt enthalten, während sich ein Objekt hingegen horizontal oder vertikal über mehrere nebeneinander liegende Zellen erstrecken kann, sodass es einen größeren Raum auf der Seite einnimmt.

Das Aussehen einer Zelle des Layout-Schemas hängt von ihrem jeweiligen Status ab:

§Enthält sie ein Objekt, das noch nicht konfiguriert wurde, wird das Symbol des Objekttyps auf einem grau schraffierten Hintergrund angezeigt.

§Wurde das enthaltene Objekt bereits konfiguriert, erscheint das Symbol des Objekttyps auf einem hellblauem Hintergrund verlauf.

§Ist das enthaltene Objekt markiert, wird der Umriss mit Ankerpunkten angezeigt.
Klicken Sie um zu erweitern/minimieren Anleitung: Schaltflächen der Werkzeugleiste

Direkt über dem Layout-Schema befindet sich eine Werkzeugleiste mit folgenden Schaltflächen:

Objektinhalt

Öffnet ein Fenster, in dem Sie das im Layout-Schema markierte Objekt erstellen können. Dieses Dialogfenster variiert je nach Objekttyp (Text, Bild usw.).

Zellenstil

Öffnet das Dialogfenster Zellenstil in dem Sie die grafischen Eigenschaften der aktiven Zelle im Layout-Schema definieren können.

Für das markierte Objekt einen Anker setzen

Dem im Layout-Schema markierten Objekt wird ein Anker zugewiesen. Mit Klick auf den Pfeil neben der Schaltfläche öffnet sich ein Menü mit den Optionen Anker einfügen..., Bearbeiten... und Entfernen.

Zeile einfügen / Spalte einfügen

Dem Layout-Schema wird eine neue Zeile oder Spalte hinzugefügt. Mit Klick auf den Pfeil neben den Schaltflächen kann festgelegt werden, ob die jeweilige Zeile/Spalte vor oder hinter der markierten Zelle eingefügt werden soll. Auf diese Weise können Raster mit bis zu 64 Zeilen und 12 Spalten erstellt werden.

Zeile löschen / Spalte löschen

Die markierte Zeile oder Spalte wird aus dem Layout-Schema entfernt. Das Layout-Schema muss mindestens eine Zelle (also eine Zeile und eine Spalte) enthalten.

Ein Anker ist ein Bezugspunkt, der die Position eines Objekts innerhalb der Seite identifiziert. Anker werden verwendet, um dem jeweiligen Objekt Direktlinks zuzuweisen.

Hinweise zur Kompatibilität mit Vorgängerversionen:

In den Vorgängerversionen waren die Optionen für die Zellenränder und die Ausrichtung der Zelleninhalte in den Menüs enthalten, die über die Schaltflächen [image] und [image] in der Werkzeugleiste oberhalb des Layout-Schemas aufgerufen wurden. In der aktuellen Version 10 sind diese Schaltflächen nicht mehr verfügbar und die Optionen wurden in das Fenster Zellenstil| Stil integriert.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Liste der verfügbaren Objekte

Neben den Layout-Schema finden Sie die verfügbaren Objekte. Um ein Objekt in eine Seite einzufügen, wählen Sie im Bereich Verfügbare Objekte ein Objekt aus und ziehen es im Layout-Schema in die gewünschte Zelle.

Die verfügbaren Objekte sind:

Objekt Text | Bildobjekt | Objekt Tabelle | Objekt Galerie
Video-/Audio-Objekt | Objekt E-Mail-Formular | Objekt Soziales Netzwerk | Gästebuch-Objekt
Kartenobjekt | Objekt Flash-Animation | Objekt Produktliste | HTML und Widgets

Nachdem Sie ein Objekt in das Layout-Schema eingefügt haben, klicken Sie auf die Schaltfläche [image] Bearbeiten (oder klicken doppelt auf das Objekt selbst), um das Fenster für die Bearbeitung zu öffnen.

Hinweise zur Kompatibilität mit Vorgängerversionen:

Verfügbare Objekte: Die Objekte Gästebuch-Objekt, Objekt Soziales Netzwerk und Kartenobjekt sind neu in Version 10 von WebSite X5: In der Vorgängerversion 9 waren sie als Widgets im HTML und Widgets verfügbar.

Praktische Anwendung:

-

Einrichten einer Seite mit dem Layout-Schema


Objekt Text

Schritt 3 - Erstellen der Seiten >

Objekt Text

 Return to chapter overview
Versteckten Text zeigen/verstecken

Neben Bildern, Videos und Flash-Animationen werden die Inhalte einer Website maßgeblich mit Texten übermittelt.

Für das Web zu schreiben, stellt andere Anforderungen als die Redaktion von Texten für den Druck. Jedes Kommunikationsmedium hat seine eigenen Charakteristiken. Beim Internet sind das vor allem die technische Grundlage (Display eines Computers oder Mobilgeräts), die Art der Informationsaufnahme (eher ein schnelles Scannen als dauerhaftes Lesen) und die Verfügbarkeit praktisch unbegrenzter Alternativen (man bedenke, wie viele Websites sich ein und demselben Thema widmen).

Um die Aufmerksamkeit des Lesers zu wecken, ihn zum Lesen anzuregen und im besten Fall von der Qualität unseres Angebots zu überzeugen, müssen die Textinhalte für die Veröffentlichung im Web geeignet sein: Vor allem müssen die Inhalte interessant präsentiert werden, sie müssen prägnant aber nicht steril sowie effizient sein. Die zu übermittelnde Botschaft sollte in kurze Abschnitte gegliedert werden. Dies erleichtert zum einen das Verständnis und wirkt zum anderen visuell aufgelockerter und weniger drückend. Und für eine bessere Lesbarkeit der Texte ist es schließlich wichtig, die typografischen Aspekte zu berücksichtigen, also zu entscheiden, wie Überschriften, Hervorhebungen, der Textkörper, Bildunterschriften und anderes formatiert werden sollen.

Diese Aspekte zu durchdenken und die Texte mit Sorgfalt zu verfassen, ist äußerst wichtig, wenn man eine Website erstellen will, die auf ihre Besucher positiv wirken soll. Langweilige Inhalte, vager Ausdruck, Grammatik, Orthografie- und Interpunktionsfehler lassen eine Website sofort nachlässig wirken und ein zweiter Besuch wird mit großer Wahrscheinlichkeit ausbleiben.

Abgesehen von dieser kurzen, aber notwendigen Betrachtungen zum Thema Web Writing stellt Ihnen WebSite X5 einen internen Editor zur Verfügung, in dem Sie Ihre Texte verfassen und formatieren können. Selbstverständlich können auch fertige, mit anderen Programmen erstellte Texte durch einfaches Kopieren und Einfügen verwendet werden.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Bediensfelder des Text Editor

In der Menüleiste des Text Editor stehen folgende Funktionen zur Verfügung:

Ausschneiden [Strg+X] - Kopieren [Strg+C] - Einfügen [Strg+V]

Mit der Funktion Einfügen werden alle eventuell vorhandenen Formatierungen aus dem Text entfernt und die im Editor festgelegten angewendet.

Inhalte einfügen

Mit diesem Befehl wird zuvor mit den entsprechenden Funktionen, Ausschneiden und Kopieren, ausgeschnittener oder kopierter Text eingefügt. Der so eingefügte Text behält seine Originalformatierungen.

Mit den Funktionen Ausschneiden, Kopieren und Einfügen können Texte übernommen werden, die zuvor mit anderen Textbearbeitungsanwendungen erstellt wurden.

Rückgängig [Strg+Z] - Wiederherstellen [ALT+UMSCHALT+BACKSPACE]

Zum Annullieren/Wiederherstellen der zuletzt durchgeführten/annullierten Operation.

Link einfügen [Strg+L]

Mit dieser Funktion können Sie markierte Textpassagen verlinken. Die Einstellungen für den Hyperlink können im Dialogfenster Link vorgenommen werden.

Bild einfügen

Fügen Sie ein Bild (Formate .JPG, .GIF, .PNG, .BMP) in den Text ein. In ein Textobjekt eingefügte Bilder werden automatisch neu dimensioniert, wenn sie größer sind als die im Layout-Schema zugewiesene Zelle. Außerdem kann die Größe der Bilder durch Ziehen an den Ankerpunkten frei angepasst werden. Für spezielle Layouts wird jedoch empfohlen, das eigens hierfür bereitgestellte Bildobjekt zu verwenden.

HTML-Code aktivieren

Mit dieser Funktion können Sie HTML-Code direkt auf der Seite eingeben. Im HTML-Modus werden die Zeichen < und > nicht als "kleiner als" bzw. "größer als" interpretiert, sondern in diese Zeichen eingefügter Text wird als HTML-Tag gelesen.

Rollover-Einstellungen

Hiermit können Sie Text mit RollOver-Effekt konfigurieren: Das heißt, der Text ist nicht mehr statisch, sondern kann gescrollt werden. Die RollOver-Einstellungen werden im Dialogfenster RollOver vorgenommen.

An Zellenbreite anpassen

Mit dieser Einstellung wird das Layout des Textes simuliert, das er im Inneren der Zelle Layout-Schema haben wird.

Heller/dunkler Hintergrund

Hier können Sie den Hintergrund des Text-Editors hell oder dunkel einstellen. Dies erleichtert zum Beispiel die Eingabe von hellem Text, der mit dem jeweils gewählten Template im Kontrast stehen soll.

Schrift - Schriftgröße

Hier können Sie eine Schrift (einen Font) auswählen und dessen Größe definieren.

Das Dropdown-Menü enthält alle Zeichensätze, die auf dem lokalen Computer installiert sind. Wenn der verwendete Zeichensatz nicht auch auf dem Computer der Anwender installiert ist, wird er automatisch durch eine ähnliche Systemschrift ersetzt.

Fett [Strg+B] - Kursiv [Strg+I] - Unterstrichen [Strg+U]

Mit diesen Schaltflächen werden auf markierten Text jeweils die entsprechenden Schriftschnitte angewendet.

Textfarbe - Hintergrundfarbe des Textes

Mit dieser Schaltfläche können Sie die gewünschte Farbe für den Text bzw. den Texthintergrund auswählen.

Aufzählung

Mit diesem Befehl können Sie eine Liste mit Aufzählungszeichen erstellen.

Zeileneinzug vergrößern / Zeileneinzug verkleinern

Hier können Sie den Einzug eines Absatzes vergrößern bzw. verkleinern.

Linksbündig - Zentriert - Rechtsbündig - Blocksatz

Stellen Sie hier die Ausrichtung Ihres Textes ein.

Text rechts - Standardeinstellung - Text links

Diese Schaltflächen sind aktiv, wenn ein in den Text eingefügtes Bild markiert wird. Sie können festlegen, ob der Text rechts oder links vom Bild verlaufen oder das Bild in den Textfluss eingebettet werden soll.

Mit Rechtsklick kann außerdem das Kontextmenü aufgerufen werden, das folgende Optionen enthält: Rückgängig, Ausschneiden, Kopieren, Einfügen, Inhalte einfügen und Alles markieren.


RollOver Fenster

Schritt 3 - Erstellen der Seiten > Objekt Text >

RollOver Fenster

 Return to chapter overview
Versteckten Text zeigen/verstecken

Diese Funktion kann mit der Schaltfläche [image] Editor des Objekt Text oder des Objekt Tabelle aufgerufen werden und ermöglicht die Einstellung für das Rollover der Texte.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Einstellungen des RollOver

Zunächst muss der Effekt mit der Option Rollover aktivieren ausgewählt werden.

Anschließend können Sie im Bereich Typ wählen:

§Bewegung: Legen Sie hier fest, wie der Text scrollen soll. Sie haben folgende Optionen zur Auswahl:

Kein - Bildlaufleiste anzeigen: Der Text wird nicht gescrollt, da aber die Zelle eine feste Höhe hat (siehe weiter unten die Option Höhe), wird automatisch eine Bildlaufleiste angezeigt, wenn diese Höhe nicht ausreicht.

Einzelnes Scrollen: Der Text wird in die definierte Richtung gescrollt und bleibt stehen, wenn er am Ende angelangt ist.

Fortlaufendes Scrollen: Der Text wird in die definierte Richtung gescrollt und die Bewegung wird, wenn er am Ende angelangt ist, wiederholt.

Abwechselndes Scrollen: Der Text wird in die definierte Richtung gescrollt und die Bewegung wird, wenn er am Ende angelangt ist, umgekehrt.

Sektionsweises Scrollen: Der Text wird virtuell in Sektionen, also in Blöcke mit der unter Höhe. festgelegten Höhe aufgeteilt. Der Text wird, unterbrochen durch kurze Pausen, sektionsweise gescrollt. Nach Durchlauf der letzten Sektion wiederholt sich der Vorgang. Für die optimale Darstellung des Effekts muss der Text so geschrieben und formatiert sein, dass er bei Einstellung einer angemessenen Höhe in Sektionen aufgeteilt werden kann.

§Richtung: Legen Sie hier fest, in welche Richtung der Text gescrollt werden soll. Er kann nach Rechts, Links, Unten oder Oben gescrollt werden.

Im Bereich Optionen können Sie folgende Einstellungen vornehmen:

§Effekt: Wählen Sie zwischen den Effekten Linear, Auf und Ab und Schwingen die für alle Bewegungstypen verfügbar sind, außer für das Fortlaufendes Scrollen.

§Höhe: Stellen Sie hier die Höhe der Zelle ein, die den Text enthält.

§Länge (Sek): Legen Sie hier fest, wie viele Sekunden der Effekt dauern soll. Wurde das Einzelnes Scrollen, das Fortlaufendes Scrollen oder das Abwechselndes Scrollen ausgewählt, definiert dieser Wert die Zeit der Bewegung, bis sie wiederholt wird. Wurde hingegen das Sektionsweises Scrollen, definiert dieser Wert die Anzeigedauer einer Sektion, bevor zur nächsten übergegangen wird.

§Bei Mauskontakt anhalten: Bei Aktivierung dieser Option wird der Scrollvorgang bei Mauskontakt angehalten.

Die Option Höhe ist nur dann verfügbar, wenn das Rollover vertikal eingestellt ist (Richtung nach oben oder nach unten). Bei horizontalem Rollover (Richtung nach links oder nach rechts) wird ein besserer Effekt erzielt, wenn das Textobjekt eine ganze Zeile des Layout-Schemas füllt.


Bildobjekt

Schritt 3 - Erstellen der Seiten >

Bildobjekt

 Return to chapter overview
Versteckten Text zeigen/verstecken

Bilder sind die Elemente, die bei der Erstellung von Websites am häufigsten verwendet werden. Mit Bildern können Sie Themen illustrieren, Produkte präsentieren, Botschaften übermitteln oder Ihre Inhalte einfach dekorativ bereichern. Bilder sind in jedem Fall wichtig, da sie zum Gesamtbild der Website beitragen und ihre ästhetisch ansprechende, professionelle Wirkung unterstreichen.

In WebSite X5 können Sie alle gebräuchlichen Bildformate importieren und es steht Ihnen ein praktischer, interner Grafik-Editor zur Verfügung, mit dem Sie Ihre Bilder zusätzlich bearbeiten und korrigieren können. Die verfügbaren Funktionen umfassen das Ausschneiden, Drehen und Retuschieren von Bildern und Sie können Masken, Filter und Rahmen anwenden. Ferner können Sie beeindruckende Panoramadarstellungen erstellen und Details herauszoomen.

Auch der Schutz vor unbefugter Nutzung von Bildern aus dem Internet wurde bei WebSite X5 berücksichtigt. Das Programm ist mit einem Schutzsystem ausgestattet, das den Zugriff auf die Originaldatei verhindert und Schutzmethoden wie Wasserzeichen und Urheberrechtsinformationen bereitstellt.

Die Funktionen, die Sie für die Gestaltung eines Bild-Objekts benötigen, sind die folgenden Bereiche gegliedert: Allgemein, Anzeige und Sitemap.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den in diesem Bereich verfügbaren Funktionen können Bilddateien importiert und bearbeitet werden.

WebSite X5 Sie können alle gebräuchlichen Bildformate (.JPG, .GIF, .PNG, .BMP, .PSD, .TIF, .DIB, .PCX, .RLE, .TGA und .WMF) importieren. Wählen Sie hierzu die gewünschte Datei aus den lokal gespeicherten oder direkt online aus.

Im Bereich Vorschau wird das importierte Bild dargestellt. Mit Klick auf die Schaltfläche Bearbeiten... unter der Vorschau öffnet sich der programminterne Grafik-Editor, in dem Sie das importierte Bild bearbeiten können.

Für das importierte Bild können Sie folgende Eigenschaften festlegen:

§Titel: Bildtitel, der in den HTML-Code der Seiten dem Attribut title des Tags <img> zugewiesen wird.

§Alternativtext: Hier können Sie einen Text eingeben, der an Stelle des Bildes erscheint, wenn dieses nicht angezeigt werden kann. Im HTML-Code der Seiten entspricht dies dem Attribut alt des Tags <img>.

Der Titel und der Alternativtext sind zwei Parameter, die sorgfältig durchdacht und vergeben werden sollten, da sie sowohl für die Zugänglichkeit als auch für die Optimierung der Website von Bedeutung sind.

§Link: Hier können Sie das Bild verlinken. Bei Klick auf die Schaltfläche [image] öffnet sich das Dialogfenster Link, in dem Sie den Aktionstyp des Links und die jeweiligen Optionen definieren können.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Anzeige

Mit den Funktionen in diesem Bereich legen Sie fest, wie das importierte Bild dargestellt werden soll: WebSite X5Sie können Panoramabilder erstellen und/oder Zoom- und Bewegungseffekte festlegen.

Für den Anzeigemodus können Sie folgende Einstellungen vornehmen:

Bildgröße automatisch anpassen: Mit dieser standardmäßig aktivierten Option wird das Bild den Abmessungen der Zelle im Layout-Schema angepasst.

Vergrößertes Bild zoomen und manuell verschieben: Bei Aktivierung dieser Option kann das Bild per Mausklick vergrößert werden, bis es den eingestellten Zoomfaktor erreicht. Anschließend kann das Bild verschoben werden, um das gewünschte Detail in den Vordergrund zu bringen. In diesem speziellen Fall muss das Bild manuell verschoben werden. Klicken Sie hierzu in das Bild und ziehen Sie es in die gewünschte Position.

Um diesen Effekt zu erzielen, werden zuerst die Abmessungen des Bildes denen der Zelle im Layout-Schema angepasst und anschließend neu berechnet, entweder auf der Grundlage des Maximalen Zooms (wenn Sie unter Modalità di spostamento Frei Verschieben gewählt haben) oder im Verhältnis zur festgelegten Höhe (wenn unter Modalità di spostamento die Option Horizontale Rundumsicht oder Vertikale Rundumsicht gewählt wurde). Auf diese Weise wird das Bild größer als die Anzeigefläche und kann darin verschoben werden.

Vergrößertes Bild zoomen und automatisch verschieben: Die Option entspricht der zuvor beschriebenen, mit dem einzigen Unterschied, dass das Bild verschoben wird, indem Sie den Mauszeiger an seinen Rändern positionieren.

Wenn unter Anzeigemodus die Option Bildgröße automatisch anpassen gewählt wurde, können folgende Einstellungen festgelegt werden:

§Qualität: Hier können Sie die Qualität festlegen, die beim Speichern des Bildes im Format JPG erhalten bleiben soll. Beim Import werden alle Bilder automatisch in das Format .JPG oder, sofern Transparenzen eingestellt sind, in das Format .PNG konvertiert. Je höher bei der Konvertierung in .JPG das Kompressions-Level ist, desto geringer wird die Qualität des Bildes.

Es wird empfohlen, Bilddateien in den Formaten .JPG, GIF oder JPG einzufügen. Alle Bilder, die in einem anderen Format als .JPG, .GIF oder .PNG importiert werden, werden automatisch mit dem eingestellten Kompressions-Level in das Format JPG konvertiert. Die Konvertierung in .JPG oder, sofern Transparenzen eingestellt sind, in .PNG, erfolgt auch dann, wenn das Originalbild größer ist als die zugewiesene Zelle im Layout-Schema und wenn es im Grafik-Editor bearbeitet wird.

In allen anderen Fällen wird das Bild unverändert kopiert. Das ist erforderlich, damit der auf das GIF-Format angewendete Transparenz-Effekt beibehalten werden kann.

§Art der Verkleinerung: Wählen Sie hier die Methode zum Verkleinern (Breite und Höhe) der Bilder. Sie haben die Auswahl zwischen:

-Bilinear (schneller): Diese Methode ist die schnellste, führt aber im Vergleich zu den anderen auch zu den größten Qualitätsverlusten.

-Decimate (mittel): Diese Methode bietet mittlere Werte sowohl bei der Leistung als auch bei der Qualität.

-Bicubic (langsamer, aber genauer): Diese Methode ist die langsamste, bietet aber die höchste Bildqualität.

Wenn unter Anzeigemodus die Option Vergrößertes Bild zoomen und manuell verschieben oder Vergrößertes Bild zoomen und automatisch verschieben gewählt wurde, können folgende Einstellungen eingestellt werden:

§Art der Verschiebung: Legen Sie hier fest, in welche Richtung das Bild manuell oder automatisch verschoben werden soll. Folgende Optionen stehen zur Verfügung:

-Frei Verschieben: Das Bild kann sowohl in horizontaler als auch vertikaler Richtung verschoben werden. In diesem Fall muss ein Maximaler Zoom festgelegt werden: Bei einem Zoomfaktor von 200% wird die Originalgröße des Bildes verdoppelt.

Originalbild | Bild mit Effekt

-Horizontale Rundumsicht: Das Bild kann nur in horizontaler Richtung verschoben werden. Um diesen Effekt optimal zu nutzen, sollten Bilder im Querformat verwendet werden. In diesem Fall müssen Sie im entsprechenden Feld die Höhe des Bildes in Pixeln angeben.

Originalbild | Bild mit Effekt

-Vertikale Rundumsicht: Das Bild kann nur in vertikaler Richtung verschoben werden. Hierfür eignen sich am besten Bilder im Hochformat und Sie müssen im entsprechenden Feld Höhe die Höhe in Pixeln angeben, die die entsprechende Zelle im Layout-Schema haben darf.

Originalbild | Bild mit Effekt

§Maximaler Zoom: Diese Einstellung steht nur für den Modus Frei Verschieben zur Verfügung und ermöglicht die Einstellung des Zoomfaktors, der auf das Bild angewendet werden soll, damit es größer ist als sein Anzeigebereich. Wenn das Bild nicht vergrößert wird, kann es auch nicht verschoben werden.

§Höhe: Diese Einstellung ist nur für die Optionen Horizontale Rundumsicht und Vertikale Rundumsicht verfügbar. Sie definiert im ersten Fall die Höhe des Bildes und im zweiten die Höhe der Zelle im Layout-Schema, in der das Bild dargestellt wird.

§Bild vergrößern: Diese standardmäßig aktivierte Option bewirkt, dass das Bild mit dem Mausrad vergrößert und verkleinert werden kann. Beim Öffnen der Seite wird das Bild in Originalgröße angezeigt und das Symbol in der unteren rechten Bildecke signalisiert, dass es gezoomt werden kann. Mit dem Mausrad wird das Bild basierend auf dem Maximaler Zoom vergrößert.

§Zoomleiste anzeigen: Diese Option ist nur verfügbar, wenn Bild vergrößern aktiviert ist, und fügt in das Bildfenster eine Leiste ein, über die der Zoomfaktor eingestellt werden kenn.

§Navigator anzeigen: Dies ist ein kleines Fenster im Bild, das eine Miniatur enthält. Das heißt, das Bild wird komplett angezeigt und im Navigator ist der aktuell gewählte Ausschnitt zu sehen. Dieser Ausschnitt kann innerhalb des Navigators verschoben werden, was dem manuellen Verschieben des Bildes entspricht. Wenn Sie den Mauszeiger in den Bereich außerhalb des Bildes verschieben, wird der Navigator mit einer Bewegung zum oberen Bildrand ausgeblendet.

§Bild automatisch bewegen.: Bei Aktivierung dieser Option wird das Bild während der Anzeige automatisch verschoben. Dies ist nützlich, um dem Nutzer zu zeigen, dass das Bild vergrößert werden kann. Er kann die Bewegung mit der Maus steuern und das Bild über die Zoomleiste oder das Mausrad, sofern verfügbar, zoomen.

Wenn für das aktive Bild die Option Bildgröße automatisch anpassen als Anzeigemodus eingestellt wurde, kann ein Mouse Over-Effekte vorgesehen werden:

§Mouse Over-Effekte: Wählen Sie aus den verfügbaren Optionen einen Effekt, der angezeigt werden soll, wenn der Mauszeiger über das Bild bewegt wird.

§Einstellungen: Je nach gewähltem Mouse Over-Effekte können verschiedene Parameter des Effekts festgelegt werden (zum Beispiel die Farbe und Stärke des Randes beim Effekt "Farbiger Rand").

Und schließlich können die Funktionen für den Schutz von Bildern genutzt werden, um ein unbefugtes Kopieren zu verhindern:

§Bilder urheberrechtlich schützen: Mit Aktivierung dieser Option verhindern Sie, dass Bilder mit Befehlen wie Bild speichern unter... in den Kontextmenüs des Browsers kopiert werden können.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Sitemap

Mit den in diesem Bereich verfügbaren Funktionen können Sie einige Zusatzinformationen über die Bilder festlegen, die beispielsweise für die Sitemap der Website von Nutzen sind.

Aktivieren Sie hierzu zunächst die Option Bild in die Sitemap einbinden: Auf diese Weise wird die von WebSite X5 automatisch erstellte Sitemap (siehe SiteMap automatisch erstellen in Allgemeine Einstellungen | Erweitert) mit den Bildinformationen vervollständigt. Anschließend müssen Sie folgende Einstellungen vornehmen:

§Titel: (Optionaler Parameter) Titel des Bildes.

§Kurzbeschreibung: (Optionaler Parameter) Beschreibung des Bildes oder Bildunterschrift.

§Geografische Lage (z.B. Adresse, Stadt etc.): (Optionaler Parameter) Zusatzinformationen wie eine Adresse, ein Ort oder ein Land, die die geografische Zuordnung des Bildes ermöglichen.

§Lizenz-URL: (Optionaler Parameter) URL der Lizenzdatei für das Bild.

Bilder, für die ein Kopierschutz aktiviert wurde, können nicht in die Sitemap aufgenommen werden (siehe hierzu Bilder urheberrechtlich schützen im vorstehenden Abschnitt Anzeige).

Praktische Anwendung:

-

Erstellen und Verlinken der Sitemap


Objekt Tabelle

Schritt 3 - Erstellen der Seiten >

Objekt Tabelle

 Return to chapter overview
Versteckten Text zeigen/verstecken

Tabellen eignen sich optimal, um Daten zu organisieren und zu präsentieren.

Oftmals ermöglicht eine Tabelle die effiziente, zusammenfassende Darstellung und Präsentation von großen Datenmengen, die andernfalls lange Texte erfordern würde. So ist beispielsweise eine Tabelle mit den Preisen eines Hotels, organisiert nach Zimmertyp und Saison, wesentlich einfacher zu lesen und verständlicher als ein Fließtext mit den gleichen Informationen.

Ein weiterer Vorzug von Tabellen ist, dass sie als grafisches Element eine Seite bereichern und die Monotonie eines langen Textes auflockern.

Damit diese Vorzüge auch wirklich ausgenutzt werden, müssen Tabellen gut strukturiert werden, sollten nicht zu komplex und ästhetisch ansprechend sein.

WebSite X5 ermöglicht das erstellen der Tabellen mit einen Editor der sehr änlich ist wie den jenigen im Objekt Text. Voreingestellt ist eine Tabelle mit zwei Zeilen und drei Spalten einer Gesamtbreite, die eine ganze Zelle im Layout-Schema ausfüllt. Sie können Zeilen oder Spalten hinzuzufügen oder entfernen, deren Größe bestimmen sowie Zellen verbinden oder teilen, um mehr oder weniger komplexe Tabellen zu erstellen.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Tabellen Editor

Folgende Funktionen stehen zur Verfügung:

Ausschneiden [Strg+X] - Kopieren [Strg+C] - Einfügen [Strg+V]

Mit der Funktion Einfügen werden alle eventuell vorhandenen Formatierungen aus dem Text entfernt und die im Editor festgelegten angewendet.

Inhalte einfügen

Mit diesem Befehl wird zuvor mit den entsprechenden Funktionen, Ausschneiden und Kopieren, ausgeschnittener oder kopierter Text eingefügt. Der so eingefügte Text behält seine Originalformatierungen.

Rückgängig [Strg+Z] - Wiederherstellen [ALT+UMSCHALT+BACKSPACE]

Zum Annullieren/Wiederherstellen der zuletzt durchgeführten/annullierten Operation.

Link einfügen [Strg+L]

Mit dieser Funktion können Sie markierte Textpassagen verlinken. Die Einstellungen für den Hyperlink können im Dialogfenster Link vorgenommen werden.

Bild einfügen

Fügen Sie ein Bild (Formate .JPG, .GIF, .PNG, .BMP) in eine Zelle der Tabelle ein. An den Ankerpunkten können Bilder außerdem frei in der Größe angepasst werden.

HTML-Code aktivieren

Mit dieser Funktion können Sie HTML-Code direkt in die Tabelle eingeben. Im HTML-Modus werden die Zeichen < und > nicht als "kleiner als" bzw. "größer als" interpretiert, sondern in diese Zeichen eingefügter Text wird als HTML-Tag gelesen.

Rollover-Einstellungen

Hiermit können Sie Text mit RollOver-Effekt konfigurieren: Das heißt, der Text ist nicht mehr statisch, sondern kann gescrollt werden. Die RollOver-Einstellungen werden im Dialogfenster RollOver vorgenommen.

Heller/dunkler Hintergrund

Hier können Sie den Hintergrund des Text-Editors hell oder dunkel einstellen. Dies erleichtert zum Beispiel die Eingabe von hellem Text, der mit dem jeweils gewählten Template im Kontrast stehen soll.

Zeile einfügen / Zeile löschen / Spalte einfügen / Spalte löschen

Mit diesen Schaltflächen können Sie nach der Zelle, in der der Cursor positioniert ist, eine Zeile oder Spalte einfügen bzw. löschen.

Zellen verbinden - Zellen teilen

Mit diesen Funktionen können Sie jeweils mehrere nebeneinander liegende Zellen zu einer verbinden oder die aktive Zelle horizontal in zwei Zellen teilen.

Schrift - Schriftgröße

Hier können Sie eine Schrift (einen Font) auswählen und dessen Größe definieren.

Das Dropdown-Menü enthält alle Zeichensätze, die auf dem lokalen Computer installiert sind. Wenn der verwendete Zeichensatz nicht auch auf dem Computer der Anwender installiert ist, wird er automatisch durch eine ähnliche Systemschrift ersetzt.

Fett [Strg+B] - Kursiv [Strg+I] - Unterstrichen [Strg+U]

Mit diesen Schaltflächen werden auf markierten Text jeweils die entsprechenden Schriftschnitte angewendet.

Textfarbe - Hintergrundfarbe

Mit diese Funktion können Sie die gewünschte Farbe für den Text bzw. den Zellenhintergrund auswählen können.

Zellenrandfarbe

Öffnet ein Dialogfenster, in dem Sie den Rändern der markierten Zellen Farben zuweisen können. Außer der Farbe können Sie auch die Breite der Ränder bestimmen, die die Zeilen und/oder Spalten der Tabelle begrenzen.

Aufzählung

Mit diesem Befehl können Sie eine Liste mit Aufzählungszeichen erstellen.

Linksbündig - Zentriert - Rechtsbündig - Blocksatz

Stellen Sie hier die Ausrichtung Ihres Textes ein.

Text rechts – Standardeinstellung – Text links

Diese Optionen sind aktiv, wenn in einer Zelle ein Bild gemeinsam mit Text markiert wurde, und definieren die Ausrichtung des Textes im Verhältnis zum Bild, sodass er rechts bzw. links davon positioniert oder das Bild, wie ein Wort, in den Text eingebunden wird.

Oben ausrichten - Zentrieren - Unten ausrichten

Definieren Sie hier die Position des Textes innerhalb der Zelle.

Mit Rechtsklick kann außerdem das Kontextmenü aufgerufen werden, das neben den Standardoptionen Rückgängig, Ausschneiden, Kopieren, Einfügen, Inhalte einfügen und Alles auswählen auch folgende Befehle enthält:

§Zeilenhöhe

Öffnet ein Dialogfenster, in dem Sie die Höhe markierter Zeilen in Pixeln einstellen können. Wenn Sie den Wert 0 eingeben, nehmen die Zeilen automatisch die erforderliche Mindesthöhe an, um den eingefügten Inhalt anzuzeigen.

§Spaltenbreite

Öffnet ein Dialogfenster, in dem Sie die Breite markierter Spalten in Pixeln einstellen können.

Die Abmessungen der Zeilen, Spalten oder der einzelnen Zellen können auch geändert werden, indem Sie mit dem Mauszeiger auf den Rand klicken, die linke Maustaste gedrückt halten und den Rand in die gewünschte Position ziehen. Wenn Sie eine Zelle auswählen und den linken und/oder rechten Rand der Zelle verschieben, werden nur die Abmessungen dieser Zelle geändert.


Objekt Galerie

Schritt 3 - Erstellen der Seiten >

Objekt Galerie

 Return to chapter overview
Versteckten Text zeigen/verstecken

Die starke Verbreitung der Digitalfotografie und hiermit verbundener Online-Dienste macht es ausgesprochen einfach, ganze Fotogalerien im Web mit anderen zu teilen. Sie können Ihre Familienfotos veröffentlichen, um sie entfernten Verwandten und Freunden zu zeigen, oder Alben und Kataloge erstellen, als Hobby oder für die Arbeit.

Mit WebSite X5 können Sie eindrucksvolle Galerien erstellen, um nicht nur Ihre Fotos, sondern auch Ihre Videos zu präsentieren. Jede der Galerien bietet andere Möglichkeiten für die Navigation und Anzeige. So können Sie beispielsweise eine Steuerleiste einfügen sowie die Bilder als Sequenz oder als Miniaturen darstellen. Unabhängig vom Typ basieren alle Galerien auf JavaScript und nutzen im Einzelnen HTML5 und CSS3 für die Umsetzung der Anzeigeeffekte.

Hinweise zur Kompatibilität mit Vorgängerversionen:

HTML5-Galerie versus FlashGalerie - Die HTML5-Galerien urden mit Version 9.1 von WebSite X5 eingeführt und ersetzen in der aktuellen Version 10 die früheren Flash-Galerien komplett.

Dieser Umstieg auf HTML5 war erforderlich, weil für die Anzeige von Flash-Galerien, die zweifellos vielseitige Darstellungsoptionen bieten, der Flash-Player installiert werden muss, der von Tablets und Mobilgeräten mit dem Betriebssystem iOS (zum Beispiel iPad® und iPhone®) jedoch nicht unterstützt wird. Außerdem haben HTML5-Galerien kürzere Ladezeiten, erfordern kein Plugin und werden auf allen Geräten mit modernen Betriebssystemen korrekt angezeigt.

HTML Gallerien korrekt auf Browsern dargestellt werden, die HTML5 nicht unterstützen. Aber Sie werden nicht in der Lage sein, die visuellen Effekte, die Sie für jedes Bild eingestellt haben zu sehen. In diesem Fall wird jeder Effekt automatisch vom Programm mit dem Fade-Effekt ersetzt.

Nur für den Fall, dass die Galerie ein Video in einem Format enthält, das von HTML5 nicht unterstützt wird, oder wenn der verwendete Browser das Einbinden des Videos in HTML5 nicht unterstützt, wird es automatisch mit Flash verwaltet, um die korrekte Anzeige zu gewährleisten.

Einige der verfügbaren Galerien haben eine Miniaturenleiste und eine ShowBox für die Anzeige der vergrößerten Bilder. In diesem Fall klickt der Benutzer auf eine der Miniaturansichten und das entsprechende Bild oder Video wird in einem separaten Fenster angezeigt, das die geöffnete Seite überlagert. Wird nun der Mauszeiger auf der vergrößerten Ansicht positioniert, werden Steuerelemente eingeblendet, mit denen Sie direkt zum vorherigen oder nächsten Bild gelangen, ohne zu den Miniaturansichten zurückkehren zu müssen.

Das Aussehen der ShowBox kann mit den im Bereich Stile und Modelle | ShowBox verfügbaren Optionen in Schritt 4 - Erweiterte Einstellungen individuell gestaltet werden.

Die Funktionen, die Sie für die Gestaltung eines Objekt Galerie benötigen, sind die folgenden Bereiche gegliedert: Stil, Liste und Miniaturbild.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Stil

Mit den Funktionen in diesem Bereich können Sie den zu realisierenden Galerietyp auswählen und die allgemeinen Einstellungen vornehmen.

Folgende Galerien stehen zur Verfügung:

Klicken Sie um zu erweitern/minimieren | Klassische Slideshow Bei diesem Galerietyp werden die Bilder und Videos als Sequenz, also nacheinander angezeigt. Wird dieser Typ ausgewählt, ist die Wiedergabemodalität vom Einblend-Effekt abhängig. Der Übergang von einem Bild zum nächsten erfolgt über die Bedienelemente der Steuerleiste. Auf der Leiste mit den Steuerelementen sehen Sie Miniaturen, sodass Sie direkt die gewünschten Bilder öffnen können.
Klicken Sie um zu erweitern/minimieren | Horizontale Bildergalerie In dieser Galerie sind die Miniaturen über oder unter dem jeweils ausgewählten Bild angeordnet. Wenn der Mauszeiger auf den Miniaturen positioniert wird, bewegt sich die Sequenz nach rechts oder links. Mit Klick auf eine Miniatur wird das jeweilige Bild bzw. Video und der Großansicht gezeigt. Die Art dieser Anzeige ist von dem eventuell eingestellten Einblend-Effekt abhängig.
Klicken Sie um zu erweitern/minimieren | Vertikale Bildergalerie Dieser Galerietyp entspricht dem vorstehend beschriebenen, mit dem einzigen Unterschied, dass die Miniaturen vertikal rechts oder links von der Großansicht dargestellt werden.
Klicken Sie um zu erweitern/minimieren | Miniaturbild In diesem Galerietyp sehen Sie nur ein Raster mit Miniaturen. Mit Klick auf eine Miniatur wird das jeweilige Bild bzw. Video in der ShowBox gezeigt.
Klicken Sie um zu erweitern/minimieren | Miniaturbilder in verschiedenen Sektionen Diese Galerie ist identisch mit der vorstehend beschriebenen, mit der zusätzlichen Möglichkeit, einzustellen, wie viele Bilder maximal angezeigt werden sollen. Diese Modalität bietet sich an, wenn die Galerie sehr viele Bilder bzw. Videos enthält. Der Benutzer kann mit dem Steuerelement von einer Gruppe zur nächsten umschalten und dabei immer auf der gleichen Seite der Website bleiben.
Klicken Sie um zu erweitern/minimieren | Horizontale Miniaturbilder In diesem Galerietyp wird nur eine horizontale Leiste mit Miniaturen angezeigt. Mit Klick auf eine Miniatur wird das jeweilige Bild bzw. Video in der ShowBox angezeigt.
Klicken Sie um zu erweitern/minimieren | Vertikale Miniaturbilder Dieser Galerietyp entspricht dem vorstehend beschriebenen, mit dem einzigen Unterschied, dass die Miniaturen vertikal dargestellt werden.

Je nach gewähltem Galerietyp werden bestimmte Einstellungen und Optionen vorgeschlagen, um das jeweilige Navigationsbefehle zu verwalten.

Einstellungen: | Klassische Slideshow | Horizontale Bildergalerie | Vertikale Bildergalerie
§Maximale Größe: Definieren Sie hier die Maximalabmessungen der Bilder in Pixeln. Wenn Sie die Option Größenverhältnis beibehalten aktiviert lassen, bleibt bei der Größeneinstellung die Proportion zwischen Breite und Höhe erhalten. | P | P | P
§Sichtbare Miniaturen: Hier können Sie festlegen, wie viele Miniaturen neben dem Hauptbild angezeigt werden. | - | P | P
§Position der Miniaturbilder: Hier können Sie festlegen, an welcher Seite des Hauptbilds die Miniaturen angezeigt werden sollen. | - | P | P
§Schrift der Beschreibung: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes. Diese Formatierungsoptionen wirken sich auf die Bildunterschriften aus, die im Feld Beschreibung des Bereichs Liste eingegeben wurden. | P | P | P
§Soundtrack: Hier können Sie eine Audiodatei auswählen, die während der Wiedergabe der Galerie als Soundtrack zu hören ist. | P | P | P
§Automatische Wiedergabe: Bei Aktivierung dieser Option werden die Bilder und Videos nach dem Start der Galerie automatisch wiedergegeben. | P | P | P
§Zufallsanzeige: Bei Aktivierung dieser Option werden die Bilder und Videos nicht in der Reihenfolge, in der sie angeordnet sind, sondern in einer zufälligen Abfolge wiedergegeben. | P | P | P
Navigationsbefehle:
§Button-Anzeige: Legen Sie hier fest, ob und wie die Steuerelemente am Hauptbild dargestellt derden sollen, mit denen der Besucher zum vorherigen oder nächsten Bild navigieren kann. Die Steuerelemente können Immer sichtbar, Nicht sichtbar (automatische Wiedergabe) oder Sichtbar bei Mauskontakt sein. | P | - | -
§Button-Stil: Definieren Sie hier den Stil der Steuerelemente, die am Hauptbild der Galerie angezeigt werden sollen, mit den verfügbaren Grafik-Optionen. | P | - | -
§Steuerleiste: Mit dieser standardmäßig aktivierten Option wird bei Mauskontakt eine Steuerleiste für die Navigation durch die Bilder und Videos der Galerie eingeblendet. Die Grundsteuerelemente sind [image] Präsentation starten, [image] Vorheriges Bild und [image] Nächstes Bild. | P | P | P
§Farbe: Hier können Sie für die Steuerleiste eine Hintergrundfarbe festlegen. | P | P | P
§Miniaturbilder in der Steuerleiste anzeigen: Diese standardmäßig aktivierte Option bewirkt, dass in der Steuerleiste, die bei Mauskontakt eingeblendet wird, außer den Steuerelementen auch Miniaturansichten aller Bilder angezeigt werden. Auf diese Weise muss der Betrachter die Bilder nicht zwingend nacheinander ansehen, sondern kann direkt ein Bild oder Video auswählen, das ihn interessiert. | P | - | -

Einstellungen: | Miniaturbild | Miniaturbilder in verschiedenen Sektionen | Horizontale Miniaturbilder | Vertikale Miniaturbilder
§Sichtbare Miniaturen: Hier können Sie festlegen, wie viele Miniaturen angezeigt werden sollen. | P | - | P | P
§Anzahl von Zeilen pro Sektion: Stellen Sie hier die Anzahl der Zeilen für das Miniaturenraster ein. | - | P | - | -
§Bei Klick das vergrößerte Bild in der ShowBox anzeigen: Aktiviert in den Miniaturen einen Link für die Anzeige es entsprechenden Bildes oder Videos in der ShowBox. | P | P | P | P
§Maximale Größe: Diese Einstellungen sind nur verfügbar, wenn die Option Bei Klick das vergrößerte Bild in der ShowBox anzeigen aktiviert wurde, und definieren die maximale Breite und Höhe der ShowBox. Wenn Sie die Option Größenverhältnis beibehalten aktiviert lassen, bleibt bei der Größeneinstellung die Proportion zwischen Breite und Höhe erhalten. | P | P | P | P
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Liste

Mit den Funktionen in diesem Bereich stellen Sie die Liste der Bilder und Videos zusammen, die in die Galerie eingefügt werden sollen.

Alle bereits importierten Dateien werden in der Dateiliste angezeigt: Wenn Sie eine von den in die Liste aufgenommenen Dateien auswählen, wird im entsprechenden Fenster eine Vorschau angezeigt.

Die Dateiliste enthält von jedem eingefügten Bild oder Video: den jeweiligen Dateipfad, den eventuell zugewiesenen Einblendeffekt, ein Häkchen, das auf die Zuweisung eines Links hinweist, sowie eine Beschreibung.

Für die Erstellung eines Galerie-Objekts stehen Ihnen folgende Funktionen zur Verfügung:

§Hinzufügen... / Entfernen: Fügen Sie neue Dateien hinzu oder löschen Sie ausgewählte. Unterstützt werden Bilddateien in den Formaten .JPG, .GIF, .PNG, .PSD, BMP, TIF, DIB, PCX, RLE, TGA und WMF sowie die Videoformate .FLV und .MP4.

Wenn Sie auf das kleine Dreieck in der Schaltfläche Hinzufügen... klicken, wird ein Submenü mit den folgenden Optionen eingeblendet: Bild hinzufügen..., Video hinzufügen... und YouTube-/Vimeo-Video hinzufügen....

Klicken Sie um zu erweitern/minimieren

In dem mit der Option YouTube-/Vimeo-Video hinzufügen... aufgerufenen Fenster können Sie die URL eines bereits auf Portalen wie YouTube™ oder Vimeo veröffentlichten Videos eingeben.

§Nach oben / Nach unten: Hier können Sie die Anzeigereihenfolge der Dateien in der Dateiliste verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

§Bearbeiten...: Diese Option öffnet den programminternen Grafik-Editor, in dem ein in der Dateiliste ausgewähltes Bild bearbeitet werden kann.

Je nach gewähltem Galerietyp können für jedes eingefügte Bild oder Video einige Optionen definiert werden:

§Link: Versieht das in der Dateiliste ausgewählte Bild oder Video mit einem Link. Bei Klick auf die Schaltfläche [image] öffnet sich das Dialogfenster Link, in dem Sie den Aktionstyp des Links und die jeweiligen Optionen definieren können. Bei Galerien mit Miniaturen ersetzt dieser Link den ursprünglichen, der zur vergrößerten Ansicht führt, auch dann wenn die Option Bei Klick das vergrößerte Bild in der ShowBox anzeigen aktiviert ist.

§Effekt: Hier können Sie im Fenster Effekteigenschaften der Effekte, das mit der Schaltfläche [image] aufgerufen wird, für das in der Dateiliste ausgewählte Bild oder Video einen Einblend-, Bewegungs- oder Zoom-Effekt festlegen.

HTML Gallerien korrekt auf Browsern dargestellt werden, die HTML5 nicht unterstützen. Aber Sie werden nicht in der Lage sein, die visuellen Effekte, die Sie für jedes Bild eingestellt haben zu sehen. In diesem Fall wird jeder Effekt automatisch vom Programm mit dem Fade-Effekt ersetzt.

§Beschreibung: Hier können Sie für das jeweilige, in der Dateiliste markierte Bild oder Video eine Beschreibung eingeben. Der Text wird unter dem Fenster angezeigt, das das vergrößerte Bild oder Video enthält.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Miniaturbild

Mit den Funktionen in diesem Bereich können Sie die Miniaturen der Galerie grafisch gestalten.

Das Miniaturbild ist eine verkleinerte Darstellung des in die Galerie eingefügten Bildes oder Videos, die vom Programm automatisch erstellt wird. Für eine ansprechendere Gestaltung können die Miniaturbilder in Rahmen dargestellt werden, in denen sie wie Dias, Fotogramme eines Films, Post-Its usw. wirken.

Für die Definition des Designs können Sie zwischen folgenden Optionen wählen:

§Vordefinierte Rahmen: Wählen Sie für die Miniaturen einen vordefinierten Rahmen aus.

§Individuell erstellte Rahmen: Wählen Sie eine Bilddatei (Format .JPG, .GIF, .PNG, .BMP, .PSD, .TIF, .DIB, .PCX, .RLE, .TGA und .WPG), die Sie als Rahmen verwenden möchten.

Um einen neuen Rahmen zu erstellen, muss ein Bild entsprechend vorbereitet und separat gespeichert werden. Es sollte quadratisch sein, sofern erforderlich, sollte die äußere Transparenz erhalten bleiben und es muss im Format .PNG gespeichert werden.

Für die Miniaturbilder stehen darüber hinaus folgende Optionen zur Verfügung:

§Äußerer Bildrand (%): Hier können Sie den Abstand definieren, der zwischen dem Miniaturbild und dem Rahmen bestehen bleiben soll.

§Farbänderung: Legen Sie hier eine Farbschattierung für den Rahmen der Miniaturen fest. Hierzu wird ein Colorize-Effekt angewendet, der den Rahmen in der ausgewählten Farbe schattiert.

Der Effekt der Farbvariante kann nur bei Rahmen verwendet werden, die nicht schwarz oder weiß sind. In diesen Fällen ist der Colorize-Effekt unwirksam.

Die Galerien können auch über einen Link innerhalb von Seiten gestartet werden: Für weitere Informationen siehe Link.


Video-/Audio-Objekt

Schritt 3 - Erstellen der Seiten >

Video-/Audio-Objekt

 Return to chapter overview
Versteckten Text zeigen/verstecken

In WebSite X5 können Sie auch Websites erstellen, mit denen Sie Ihre Besucher beispielsweise mit Videos und Musik unterhalten.

Videos haben heute eine Verbreitung, die bis vor Kurzem noch undenkbar war: Ein Video aufzuzeichnen, auf den Computer zu übertragen, dort zu bearbeiten und dann online zu stellen, ist heute für jeden möglich.

Mit WebSite X5 können Sie jeden Videotyp auf einfache Weise importieren, in Ihre Site einfügen und veröffentlichen. WebSite X5 unterstützt alle gängigen Formate und verfügt für die Widergabe von Dateien in den Formaten .FLV und .MP4 über einen internen Player. Es können sowohl lokal gespeicherte als auch online verfügbare Dateien eingebunden werden, auch von Portalen wie YouTube™ oder Vimeo.

Die Funktionen, die Sie für die Erstellung eines Video-/Audio-Objekt benötigen, sind die folgenden Bereiche gegliedert: Allgemein und Sitemap.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den Funktionen in diesem Bereich können Sie die Dateien für das Video-/Audio-Objekt importieren und einige Wiedergabemodalitäten einstellen.

Je nachdem, wo sich die zu importierende Ressource befindet, gibt es unterschiedliche Möglichkeiten, um ein Video-/Audio-Objekt einzufügen.

§Lokale Datei: Bei Aktivierung dieser Option können Sie auf die Schaltfläche [image] klicken, um aus den lokal verfügbaren Ressourcen eine Datei im Format MP4, .WEBM, .OGG, .FLV, .AVI, .WMV, .MPG, .MOV, .MP3, .WMA, .WAV, .MID, .AIF oder .M4A auszuwählen und zu importieren.

§URL oder Datei im Internet: Bei Aktivierung dieser Option müssen Sie hingegen die URL eingeben, unter der die Video- oder Audio-Datei online zur Verfügung steht.

§YouTube-/Vimeo-URL: Bei Aktivierung dieser Option müssen Sie die URL der YouTube™- oder Vimeo-Seite eingeben, unter der die Video- oder Audio-Datei abrufbar ist.

Wenn Sie auf diese Weise ein auf YouTube™ veröffentlichtes Video einfügen, wird die Originalgröße den Einstellungen von WebSite X5 angepasst. Für umfangreichere Steueroptionen wird empfohlen, YouTube™-Videos nicht als Video-/Audio-Objekt, sondern alsHTML und Widgets einzufügen.

Sie können die Vorschau des Video-/Audio-Objekts in einem eigenen Fenster anzeigen, indem Sie die Option Vorschau aktivieren.

Je nach dem Format der importierten Video- oder Audiodatei werden für die Wiedergabe unterschiedliche Player verwendet. Für Dateien in den Formaten .MP4, .WEBM und .OGG, wird, wenn der Browser das HTML5 Video-tag und den Datei-Codec unterstützt, die native Browser-Unterstützung über den WebSite X5 Media Player genutzt. Andernfalls und für alle anderen Formate gilt folgendes:

Player | Videodatei | Audiodatei
Adobe Flash Player® | .MP4 und .FLV | .MP3
Microsoft® Windows Media Player® | .AVI, .WMV und .MPG | .WAV und .WMA
QuickTime® Player | .MOV | .M4A und .AIF

Für eine höchstmögliche Kompatibilität wird empfohlen, die Formate .MP4 zu verwenden.

Unabhängig von dem für die Wiedergabe verwendeten Player können folgende Eigenschaften festgelegt werden:

§Alternativtext: Hier können Sie einen Text eingeben, der angezeigt wird, wenn die Video- oder Audiodatei nicht wiedergegeben werden kann.

§Größe: Stellen Sie hier die gewünschte Breite des Videos und die Höhe der Steuerleiste für die Audiowiedergabe in Pixeln ein. In Klammern ist der Höchstwert für die Breite des Objekts angegeben, je nachdem, wie es im Layout-Schema definiert wurde. Der zulässige Höchstwert für die Steuerleiste der Audiowiedergabe beträgt 35 Pixel, der ebenfalls in Klammern angegeben ist. Der Mindestwert hingegen beträgt 15 Pixel. Wenn Sie die Option Größenverhältnis beibehalten aktiviert lassen, bleibt bei der Größeneinstellung die Proportion zwischen Breite und Höhe erhalten.

§Automatische Wiedergabe: Bei Aktivierung dieser Option werden Video- und Audiodateien automatisch wiedergegeben.

§Button für Vollbildansicht aktivieren: Bei Aktivierung dieser Option wird der Steuerleiste ein Element hinzugefügt, mit dem die Videowiedergabe in den Vollbildmodus umgeschaltet werden kann.

Auch für die Anzeige der Steuerleiste können Einstellungen vorgenommen werden:

§Steuerleiste: Bei Aktivierung dieser Option wird eine Leiste mit allen Steuerelementen für die Wiedergabe und Verwaltung von Videos oder Musik eingeblendet.

Nur für die Wiedergabe der importierten Datei mit dem WebSite X5 Media Player stehen für die Steuerleiste zusätzlich die folgenden Optionen zur Verfügung:

§Steuerleiste automatisch ausblenden: Bei Aktivierung dieser Option wird die Steuerleiste nur bei Mauskontakt mit dem Wiedergabefenster angezeigt.

§Farbe: Hier können Sie für die Steuerleiste eine Hintergrundfarbe festlegen.

Für die Wiedergabe von Videos der Formate Microsoft® oder QuickTime® wird nicht der WebSite X5 Media Player verwendet, sodass in diesen Fällen eine korrekte Verwaltung der Steuerleiste nicht garantiert werden kann.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Sitemap

Mit den in diesem Bereich verfügbaren Funktionen können Sie einige Zusatzinformationen über Videos festlegen, die beispielsweise für die Sitemap der Website von Nutzen sind.

Aktivieren Sie hierzu zunächst die Option Video in die Sitemap einbinden: Auf diese Weise wird die von WebSite X5 automatisch erstellte Sitemap (siehe SiteMap automatisch erstellen in Allgemeine Einstellungen | Erweitert) mit den Videoinformationen vervollständigt. Anschließend müssen Sie folgende Einstellungen vornehmen:

§Titel: (Pflichtfeld) Titel des Videos. Die bei Google™ maximal zulässige Länge für Videotitel beträgt 100 Zeichen.

§Kurzbeschreibung: (Pflichtfeld) Kurze Beschreibung des Videos. Die bei Google™ maximal zulässige Länge für Beschreibungen beträgt 2048 Zeichen. Längere Beschreibungen werden abgebrochen.

§Kategorie: (Optionaler Parameter)Kategorie, der das Video seinem Inhalt nach zugeordnet werden könnte. Bei Google™ kann jedes Video nur einer Kategorie zugeordnet werden und der Name der Kategorie darf aus maximal 256 Zeichen bestehen.

§Keywords: (Optionaler Parameter)Tags, also Schlagwörter oder kurze Infos zum Thema Ihres Videos. Bei Google™ darf jedes Video maximal 32 Tags haben.

§Vorschaubild für das Video: (Pflichtfeld) Vorschaubild des Videos. Google™ empfiehlt für diese Miniaturen eine Mindestgröße von 120 x 90 Pixeln und das Bildformat .JPG, .PNG oder .GIF.

§Veröffentlichungsdatum: (Optionaler Parameter) Veröffentlichungsdatum des Videos.

§Länge (Sek): (Optionaler Parameter)Länge des Videos in Sekunden. Google™ empfiehlt dringend, diese Information bereitzustellen. Die Videolänge kann 0 bis 28800 Sekunden (8 Stunden) betragen.

§Inhalte für Minderjährige geeignet: (Optionaler Parameter) Mit Aktivierung dieser Option versichern Sie, dass der Inhalt des Videos für minderjährige Personen geeignet ist. Google™ weist darauf hin, dass Videos, die als ungeeignet für Minderjährige eingestuft sind, nur betrachtet werden können, wenn der Filter Safesearch™ deaktiviert ist. Die Funktion SafeSearch von Google™ filtert Websites mit sexuellen oder pornografischen Inhalten aus den Suchergebnissen heraus.

Praktische Anwendung:

-

Erstellen und Verlinken der Sitemap


Objekt E-Mail-Formular

Schritt 3 - Erstellen der Seiten >

Objekt E-Mail-Formular

 Return to chapter overview
Versteckten Text zeigen/verstecken

Beim Surfen im Internet haben Sie gewiss schon oft Formulare gesehen, die ausgefüllt werden müssen, um Daten per E-Mail zu versenden. Solche Module werden als Kontaktformulare verwendet, über die sich Benutzer zu bestimmten Diensten oder für den Zugang zu passwortgeschützten Bereichen anmelden oder mit denen Recherchen und Umfragen durchgeführt werden.

Welchen Zweck auch immer sie erfüllen, WebSite X5 können Sie auf sehr einfache Weise ein E-Mail-Formular erstellen, indem Sie die gewünschten Felder, das Layout und die grafischen Eigenschaften definieren und vor allem festlegen, auf welche Weise der Versand und die Erfassung der Daten erfolgen soll.

Die Funktionen, die Sie für die Gestaltung eines Objekts E-Mail-Formular benötigen, sind die folgenden Bereiche gegliedert: Liste, Senden und Stil.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Bediensfelder der Sektion Liste

Mit den Funktionen im Tab Liste von dieser Sektion können Sie die Liste der Felder zusammenstellen, aus denen sich das E-Mail-Formular zusammensetzen soll.

Die bereits aufgenommenen Felder werden in der Übersicht angezeigt, die von jedem Eintrag folgende Informationen enthalten: Feldname, Feldtyp, Breite, ob es sich um ein Pflichtfeld sowie eine Beschreibung. Alle diese Parameter können bei der Erstellung des Felds im Dialogfenster Feld eingeben definiert werden.

Die Übersicht fasst nicht nur die wichtigsten Daten der ausgewählten Felder zusammen, sondern ist auch ein praktisches Tool mit verschiedenen Optionen:

§Mit Doppelklick auf ein Feld öffnet sich das Dialogfenster Feld eingeben, wo Sie die Parameter ändern können;

§Mit einem zweiten Klick auf ein bereits markiertes Feld können Sie dessen Namen ändern. Dies entspricht dem Öffnen des Dialogfensters Feld eingeben und dem dortigen Ändern der Beschriftung;

§Nachdem Sie ein Feld markiert haben, können Sie außerdem die Schaltflächen an der rechten Seite nutzen, um eine Kopie zu erstellen sowie das Feld zu löschen, nach oben oder unten zu verschieben oder dessen Einstellungen zu ändern.

Über die Tabelle kann auch die Anordnung der Felder im Formular gesteuert werden. Eine hell gestrichelte Linie symbolisiert die Zeilen des Formulars. Wird ein Feld neben einem anderen positioniert, erscheint neben der Breiteangabe das Symbol [image] . Sind zwei nebeneinander positionierte Felder breiter als der verfügbare Raum, wird dies mit dem Symbol [image] signalisiert: Ändern Sie die Breite nicht, werden die Felder auf zwei Zeilen angezeigt.

Rechts neben der Übersicht finden Sie einige Schaltflächen, mit denen Sie die Liste der Felder für das Formular erstellen können:

§Hinzufügen...: Öffnet das Dialogfenster Feld eingeben, mit dem Sie ein neues Feld in das Formular einfügen können.

§Duplizieren: Hier können Sie von einem bestehenden, markierten Feld eine Kopie erstellen.

§Entfernen: Mit dieser Schaltfläche löschen Sie ein markiertes Feld aus dem Formular.

§Nach oben / Nach unten: Mit diesen Schaltflächen können Sie ein markiertes Feld vor oder hinter das jeweils benachbarte verschieben.

§Bearbeiten...: Öffnet das Dialogfenster Feld eingeben, in dem Sie die Einstellungen des zuvor in der Liste markierten Felds ändern können.

Die Schaltflächen Senden für den Versand des ausgefüllten Formulars und Zurücksetzen zum Löschen aller in das Formular eingegebenen Inhalte werden automatisch vom Programm erstellt und am Ende des Formulars eingefügt.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Bediensfelder der Sektion Senden

Mit den Bediensfelder dieser Sektion können Sie die Modalitäten festlegen, mit denen die im Formular erfassten Daten per E-Mail versendet werden sollen.

Im Bereich Datenversand wird angegeben, wie die über das Formular erfassten Daten an den Eigentümer der Website versendet werden sollen. Sie haben folgende Optionen zur Auswahl:

Datenversand per E-Mail: Diese Option ist als Standard ausgewählt. Die über das Formular erfassten Daten werden mit Hilfe eines vordefinierten PHP-Skripts automatisch per E-Mail gesendet.

Datenversand an eine Datenbank: Die über das Formular erfassten Daten werden mit Hilfe eines vordefinierten PHP-Skripts automatisch an eine bestimmte MySQL Datenbank gesendet.

Datenversand an eine Datei: Die über das Formular erfassten Daten werden mit Hilfe eines bestimmten Skripts (PHP, ASP usw.) verwaltet. Diese Alternative bietet sich an, wenn ein eigenes Skript verwendet werden soll, zum Beispiel für den Datenversand, wenn der genutzte Server kein PHP unterstützt, oder wenn spezielle Verfahren und Verwaltungsmethoden verwendet werden sollen.

Je nach Art des gewählten Datenversands müssen einige Parameter festgelegt werden:

Datenversand per E-Mail:

§E-Mail des Absenders: Bei Aktivierung dieser Option können Sie angeben, welche Adresse als Absender der über das Formular versendeten E-Mail mit den erfassten Daten verwendet werden soll.

§Standardmäßig wird hier die E-Mail-Adresse des Empfängers verwendet, die in diesem Fall der des Webseitenbetreibers entspricht. Wird festgelegt, dass als Absender der E-Mail die Adresse des Benutzers verwendet werden soll, der das Formular ausgefüllt hat, kann beispielsweise der Befehl Antworten des E-Mail-Clients verwendet werden.

§E-Mail des Empfängers: Hier können Sie angeben, an welche Adresse die über das Formular erfassten Daten gesendet werden sollen. Es können auch mehrere E-Mail-Adressen angegeben werden. Geben Sie hierzu alle Adressen, getrennt durch ein Semikolon, ein.

§Betreff: Geben Sie hier den Betreff für die E-Mail mit den über das Formular erfassten Daten an.

§Nachricht: Geben Sie hier einen Einleitungstext für die mit dem Formular erfassten Daten ein.

§Daten im CSV-Format erfassen: Bei Aktivierung dieser Option werden die erfassten Daten auch in einer CSV-Datei gespeichert, die an die E-Mail angehängt wird. In einer CSV-Datei werden di Daten als Liste durch Semikolon getrennter Werte im Textformat gespeichert. Diese Dateien können komfortabel in Tabellenkalkulationsprogramme (z.B. Microsoft Excel) importiert werden.

Datenversand an eine Datenbank:

§Datenbankname: Name der zu verwendenden Datenbank, die aus der Liste der mit dem aktuellen Projekt verknüpften Datenbanken ausgewählt werden kann. Die Liste der Datenbanken die mit dem Projekt verbunden sind, muss im voraus im Datenmanagement Fenster eingetragen werden.

§Tabellenname: Geben Sie hier den Namen der Tabelle in der Datenbank ein, in der Sie die Daten erfassen wollen. Wird ein Tabellenname eingegeben, der noch nicht existiert, wird die Tabelle automatisch erstellt.

§Den Empfang der Daten per E-Mail bestätigen: Bewirkt, dass bei Eingang neuer Daten automatisch eine Benachrichtigungs-E-Mail versendet wird.

§E-Mail des Empfängers: Gibt die Adresse an, an die die E-Mail mit der Benachrichtigung über den Eingang neuer Daten gesendet werden soll.

Datenversand an eine Datei:

§Skriptdatei (z.B. PHP, ASP): Importieren Sie die Skriptdatei, die Sie für die Erfassung und den Versand der Daten verwenden wollen. In diesem Fall muss die Sktriptdatei manuell erstellt werden, um die gewünschte Aufgabe zu erfüllen.

Im Bereich Bestätigungs-E-Mail an den Anwender senden, wenn als Datenversand nicht die Option Datenversand an eine Datei ausgewählt wird, stehen folgende Optionen zur Verfügung:

§Bestätigungs-E-Mail an den Benutzer: Bei Aktivierung dieser Option erhält der Benutzer, nachdem er das Formular ausgefüllt und die Daten gesendet hat, automatisch eine Bestätigungs-E-Mail.

§E-Mail des Absenders: Bei Aktivierung dieser Option kann hier eine gültige und aktive E-Mail-Adresse eingegeben werden, die in der Bestätigungs-E-Mail als Absender verwendet wird.

Der Standard-Absender ist die E-Mail-Adresse des Seitenbetreibers, d.h. es wird die Adresse verwendet, die als E-Mail des Empfängers im Bereich Datenversand eingegeben wurde. Geben Sie unter E-Mail des Absenders eine andere Adresse ein, können die Bestätigungs-E-Mails von einer Adresse versendet werden, die von der Empfangsadresse der Daten verschieden ist. Diese Option ist nützlich, wenn für die Kommunikation mit den Benutzern eine neutrale Adresse (vom Typ info@meinunternehmen.com oder noreply@meinunternehmen.com) anstelle einer persönlichen (name.nachname@meinunternehmen.com) verwendet werden soll.

§E-Mail des Empfängers: Hier kann bestimmt werden, aus welchem der Formularfelder die E-Mail-Adresse des Benutzers bezogen werden soll, an die die Bestätigung geschickt werden soll.

§Betreff: Geben Sie hier den Betreff der Bestätigungs-E-Mail ein.

§Nachricht: Geben Sie hier die Nachricht der Bestätigungs-E-Mail ein.

§Einfügen der erfassten Daten am Ende der Nachricht: Bei Aktivierung dieser Option werden die über das Formular erfassten Daten hinter der Nachricht eingefügt.

Im Bereich Optionen stehen schließlich folgende Optionen zur Verfügung:

§Antispam-Filter 'Captcha' aktivieren: Bei Aktivierung dieser Option wird am Ende des Formulars die Anti-Spam-Kontrolle Captcha eingefügt. Bei dieser Methode werden einige Buchstaben verzerrt auf einem verworrenen Hintergrund dargestellt. Der Anwender muss die Buchstaben korrekt in ein bestimmtes Feld eingeben, um die Nachricht senden zu können.

§Bestätigungsseite nach dem Datenversand: Legen Sie hier über die Sitemap die Seite fest, die automatisch angezeigt wird, wenn das Formular ausgefüllt und die eingegebenen Daten per E-Mail versendet wurden. Anstelle der Homepage empfiehlt es sich hier, eine spezifische Seite mit einer Danksagung einzufügen. Diese Seite muss mit der entsprechenden Option Schritt 2 - Erstellen der Sitemap als Seite im Menü nicht sichtbar im Menü eingestellt werden.

Die grafischen Eigenschaften der mit dem Formular versendeten E-Mails können Sie im Bereich Stile und Modelle | E-Mail in Schritt 4 - Erweiterte Einstellungen individuell anpassen.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Bediensfelder der Sektion Stil

Mit den Bediensfelder dieser Sektion können einige grafische Eigenschaften des E-Mail-Formulars festgelegt werden.

Wählen Sie zunächst das Formularelement aus, das Sie bearbeiten möchten: Die Auswahl kann über das gleichnamige Drop-Down-Menü erfolgen oder direkt per Klick auf das Element in der Vorschau.

Folgende Elemente können angepasst werden:

Textbeschreibungen: Dies ist die Feldbeschriftung, die angibt, welche Information eingegeben werden muss, oder die Frage, die beantwortet werden soll.

Felder: Feld, in das der Benutzer sie geforderte Information eingibt.

Senden'- und 'Zurücksetzen' -Button: Die Schaltflächen, die automatisch am Formularende eingefügt werden. Mit Klick auf diese Buttons werden die in die Felder eingegebenen Daten jeweils versendet oder gelöscht.

Beschreibung und Validierung der Felder: Dies sind Meldungen, die Zusatzinformationen enthalten, z.B. Hinweise zum Ausfüllen der Felder, für die Korrektur eingegebener Daten oder die Aufforderung, ein leer gelassenes Pflichtfeld auszufüllen.

Je nach gewähltem Element können im Bereich Stil verschiedene Optionen genutzt werden:

Textbeschreibungen:

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Farbe: Definiert die Farbe, die für den Text benutzt werden soll.

§Anordnung: Legen Sie hier fest, wo die Feldbeschriftung angezeigt werden soll. Sie haben folgende Optionen zur Auswahl: Beschriftung über den Feldern anzeigen, Beschriftung innerhalb der Felder anzeigen und Beschriftung links neben den Feldern anzeigen. Wenn Sie die Beschriftungen links neben den Feldern anzeigen wollen, kann die Breite (%), festgelegt werden, also der Ausrichtung der von der Beschriftung belegt werden kann, als Prozentsatz.

Felder:

§Farbe: Öffnet das Dialogfenster Farbe, in dem Sie die Farben für den Text (normal und ausgewählt), den Hintergrund (normal und ausgewählt) und den Rand (normal und bei Eingabe eines Fehlers) festlegen können.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Schatten: Fügt im Inneren der Felder einen Schatteneffekt ein, der ihnen optische Tiefe verleiht.

Senden'- und 'Zurücksetzen' -Button:

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Farbe: Definiert die Farbe die für den Text, den Hintergrund, und den Rand der Buttons benutzt werden soll.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Hintergrundbild: Wählen Sie hier das Bild für den Hintergrund der Zelle aus. Sie können Dateien in den Formaten JPG, GIF und PNG verwenden.

§Zurücksetzen' - Button anzeigen: Diese Option ist standardmäßig aktiviert und fügt am Formularende außer dem Button "Senden" automatisch auch den Button "Zurücksetzen" ein (zum Leeren aller ausgefüllten Felder).

Beschreibung und Validierung der Felder:

§Icon-Datei für die Feldbeschreibung: Hier können Sie eine Bilddatei (Format .JPG, .GIF und .PNG) importieren, die neben dem Feld als Icon erscheint und auf die Verfügbarkeit weiterführender Informationen hinweist.

§Beschreibung bei Auswahl des Feldes anzeigen: Bei Aktivierung dieser Option wird die Meldung mit den Zusatzinformationen automatisch angezeigt, sobald in das Feld geklickt wird.

§Falls eine Fehlermeldung bei der Datenverarbeitung erfolgt: Legen Sie hier fest, wie die Fehlermeldung angezeigt werden soll, wenn ein Feld nicht korrekt ausgefüllt wurde bzw. in einem Pflichtfeld die Eingabe fehlt. Sie haben folgende Optionen zur Auswahl: Browser Dialogfenster anzeigen, Internes Popupfenster anzeigen oder QuickInfo neben dem ungültigen Feld anzeigen neben dem ungültigen Feld anzeigen.

Wenn die Funktion der erstellten Seite lokal getestet wird, erscheint ein Hinweis, dass die E-Mail den im Formular erfassten Daten nicht gesendet wird. Das E-Mail-Formular funktioniert erst nach der Veröffentlichung der Website auf dem Server vollständigt.

Für den korrekten Betrieb des E-Mail-Formulars muss der Server, auf dem die Website veröffentlicht wird, die Programmiersprache PHP unterstützen und der Befehl MAIL muss aktiviert sein. Diese Informationen über den Server finden Sie im Bereich WebSite Test des Control Panels online.

Treten Probleme mit dem Versenden von E-Mails auf, ist der verwendete Server wahrscheinlich nicht im Standard-Modus konfiguriert. Versuchen Sie in diesem Fall, im Dialogfenster Erweiterte Einstellungen | Datenmanagement den Skripttyp und die Methode für den E-Mail-Versand zu ändern. Für weitere Informationen wenden Sie sich bitte an Ihren Webspace-Anbieter.


Feld eingeben Fenster

Finestra Feld eingeben

Schritt 3 - Erstellen der Seiten > Objekt E-Mail-Formular >

Finestra Feld eingeben

 Return to chapter overview
Versteckten Text zeigen/verstecken

Im Fenster Feld eingeben, das sich mit den Schaltflächen Hinzufügen... und Bearbeiten... im Fenster des Objekt E-Mail-Formular öffnet, können Sie die Felder definieren, die das E-Mail-Formular effektiv haben soll.

Zur Auswahl stehen folgende Bereiche: Feldtyp und Optionen.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Feldtyp

Mit den Funktionen in diesem Bereich erstellen Sie die Felder, die in Ihrem E-Mail-Formular erscheinen sollen.

Zur Auswahl stehen folgende Feldtypen:

Textfeld: Das auf einer Zeile angeordnete Textfeld wird als leerer Rahmen angezeigt, in dem der Anwender seine Eingabe frei formulieren kann.

E-Mail-Adresse: Spezifisches Textfeld, in das der Anwender eine E-Mail Adresse eingeben kann. In diesen Fällen wird automatisch ein Filter eingerichtet, der prüft, ob die eingegebenen Daten korrekt sind. Um gültig zu sein, muss eine E-Mail-Adresse zum Beispiel das Zeichen @ sowie im Text dahinter einen Punkt enthalten.

Textbereich: in auf mehreren Zeilen angeordnetes Textfeld, in das der Anwender einen Kommentar oder eine Frage eingeben kann.

Datum: Spezifisches Textfeld, mit dem der Anwender zur Eingabe eines Datums aufgefordert wird. Dieses Datum kann eingegeben oder in einem Kalender ausgewählt werden.

Drop-Down-Liste: Die möglichen Optionen, aus der der Anwender nur eine auswählen kann, werden als Drop-Down-Liste angezeigt.

Liste: Die möglichen Optionen, aus der der Anwender nur eine auswählen kann, werden als Liste angezeigt.

Mehrfachauswahl: Die möglichen Optionen, aus denen der Anwender mehrere auswählen kann, werden hintereinander als Aufzählung angezeigt.

Einfache Auswahl: Die möglichen Optionen, aus denen der Anwender nur eine auswählen kann, werden hintereinander als Aufzählung angezeigt.

Passwort: Textfeld, in dem die eingegebenen Zeichen verborgen als Punkte oder Sterne (abhängig vom verwendeten Betriebssystem) angezeigt werden. Mit dieser Option können Sie Anwendern die Möglichkeit geben, ein Passwort festzulegen, mit dem sie sich für einen Dienst registrieren.

Dateianhang: Textfeld, über das der Anwender mit der Schaltfläche [image] Ressourcen durchsuchen und eine Datei als Anhang auswählen kann.

In Bezug auf Dateianhänge wenden Sie sich bitte an Ihren Webspace-Provider, um zu prüfen, ob dieser Dienst aktiv ist.

Sicherheitsfrage: Textfeld, in das der Anwender die Antwort auf eine Frage eingeben muss. Auf diese Weise kann zwischen realen Anwendern und Programmen unterschieden werden, die Online-Kontaktformulare für den Versand von Spam nutzen.

Vertragsbedingungen: Textfeld mit den Nutzungsbedingungen, die der Anwender akzeptieren muss, um Daten versenden zu können. In diesem Feld können zum Beispiel die Datenschutzbestimmungen angezeigt werden.

Menütrennlinie: Dies ist kein Feld, sondern ein grafisches Element, mit dem Sie die Felder in Abschnitte untergliedern und so längere Formulare, in die viele Informationen eingegeben werden müssen, übersichtlicher zu gestalten.

Je nach ausgewähltem Feldtyp stehen verschiedene Optionen zur Verfügung. Folgende Optionen sind für alle Feldtypen verfügbar:

§Beschriftung: Geben Sie hier die Beschreibung des Feldes ein. Dieser Text wird über, neben oder in dem entsprechenden Feld angezeigt. Sie können die Beschriftung nutzen, um die erfragte Information näher zu erklären oder die Frage zu stellen, die der Anwender beantworten soll.

§Breite (%): Geben Sie hier die Breite des Feldes als Prozentsatz der verfügbaren Gesamtbreite ein (5% bis 100%).

§In der selben Zeile anzeigen, wie das vorherige Feld: Bei Aktivierung dieser Option wird das Feld nicht in einer neuen Zeile, sondern neben dem vorhergehenden angezeigt. Zwei Felder können nur dann nebeneinander angezeigt werden, wenn die Summe der eingestellten Breitenwerte nicht 100% der verfügbaren Gesamtbreite überschreitet.

§Als obligatorische Eingabe kennzeichnen: Mit dieser Option wird das jeweilige Feld als Pflichtfeld konfiguriert. Für die Mehrfachauswahl ist die Option nicht verfügbar und bei der Sicherheitsfrage ist sie als Standard aktiviert.

Neben diesen allgemeinen Eigenschaften stehen für die einzelnen Feldtypen folgende spezifische Optionen zur Verfügung:

Textfeld:

§Max. Zeichen: Legt fest die maximal zulässige Anzahl von Zeichen die in das Feld eingegeben werden können. Sie können diese Zahl zum Beispiel auf 15 festlegen, wenn das Feld die Steuernummer des Kunden enthalten soll.

§Filter für die Texteingabe: Hier können Sie eine Kontrolle der Korrektheit der in das Feld eingegebenen Daten einstellen. Folgende Filter stehen zur Auswahl:

-Keine (Zeichen und Zahlen): Es können sowohl Buchstaben als auch Zahlen eingegeben werden.

-Nur Zahlen: Es können nur Zahlen eingegeben werden.

-Telefon-/Faxnummer (Zahlen und die Zeichen '-' und ' '): Es können Zahlen, Bindestriche und Leerzeichen eingegeben werden.

-Datum (Zahlen und die Zeichen '/' und '.'): Es können Zahlen, Punkte und das Zeichen "/" eingegeben werden.

E-Mail-Adresse:

§Bestätigung der E-Mail-Adresse anfordern: Bei Aktivierung dieser Option wird automatisch ein Feld hinzugefügt, in das der Anwender seine E-Mail-Adresse ein zweites Mal eingeben muss. Die beiden Eingaben werden automatisch verglichen und bei Nichtübereinstimmung wird ein entsprechender Hinweis angezeigt.

Textbereich:

§Max. Zeichen: Legt fest die maximal zulässige Anzahl von Zeichen die in das Feld eingegeben werden können.

§Zeilenanzahl: Hier können Sie die Höhe des Feldes bestimmen, indem Sie die zulässige Zeilenzahl festlegen (maximal 30).

Datum:

§Datumsformat: Wählen Sie hier das gewünschte Format für die Eingabe des Datums aus den verschiedenen nationalen und internationalen Formaten.

§Kalendersymbol anzeigen: Mit dieser standardmäßig aktivierten Option wird neben dem Feld für das Datum ein Kalendersymbol angezeigt. Bei Klick auf dieses Symbol wird ein Kalender angezeigt, aus dem der Anwender ein Datum auswählen kann, ohne es manuell eingeben zu müssen.

Liste:

§Zeilenanzahl: Hier können Sie die Höhe des Feldes bestimmen, indem Sie die zulässige Zeilenzahl festlegen (maximal 30).

Mehrfachauswahl/Einfache Auswahl:

§Spaltenanzahl: Legen Sie hier die Anzahl der Spalten fest, auf die die möglichen Antworten verteilt werden können.

Passwort:

§Passwortbestätigung anfordern: Bei Aktivierung dieser Option wird automatisch ein Feld hinzugefügt, in das der Anwender sein Passwort ein zweites Mal eingeben muss. Die beiden Eingaben werden automatisch verglichen und bei Nichtübereinstimmung wird ein entsprechender Hinweis angezeigt.

Sicherheitsfrage:

§Richtige Antwort: Geben Sie hier die richtige Antwort auf die Frage ein, die dann mit der Eingabe des Anwenders verglichen wird.

Vertragsbedingungen:

§Text der Vertragsbedingungen: Geben Sie hier den Text für die Bedingungen ein, die der Kunde akzeptieren muss, bevor er Daten versenden kann.

Bei den Feldtypen Drop-Down-Liste, Liste, Mehrfachauswahl und Einfache Auswahl stehen zur Erstellung der jeweiligen Listen ferner folgende Optionen zur Auswahl:

§Hinzufügen / Entfernen: Mit diesen Schaltflächen können Sie neue Antwortoptionen hinzufügen bzw. markierte aus der Liste löschen.

§Nach oben / Nach unten: Hier können Sie die Anzeigereihenfolge der Eingaben verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

§Bearbeiten: Hier können Sie eine ausgewählte Option bearbeiten.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Optionen

Mit den Optionen in diesen Bereich können Sie einige erweiterte Einstellungen für die Felder des E-Mail-Formulars vornehmen.

Im Einzelnen stehen Ihnen folgende erweiterte Funktionen zur Verfügung:

§Feldbeschreibung: Geben Sie hier eine Beschreibung ein, die erklärt, welche Information in das Feld eingegeben werden soll. Sofern konfiguriert, wird neben dem Feld ein (individuell anpassbares) Symbol dargestellt, das auf die Verfügbarkeit weiterführender Informationen hinweist. Bei Bewegung des Mauszeigers über dieses Symbol werden diese Informationen in einer Quickinfo angezeigt.

§Attribut <name>: Geben Sie hier den Wert ein, der bei Erstellung des HTML-Codes dem Attribut <name> des Feldes zugewiesen werden soll. Diese Option erweist sich beispielsweise als nützlich, wenn als Methode für den Datenversand (siehe Objekt E-Mail-Formular | Senden) Datenversand an eine Datei ausgewählt wurde.

§Name des Felds Datenbank: Geben Sie hier einen Namen für das Feld ein, der gewährleistet, dass die erfassten Daten korrekt erkannt und in einer Datenbank hinterlegt werden. Diese Option erweist sich beispielsweise als nützlich, wenn als Methode für den Datenversand (siehe Objekt E-Mail-Formular | Senden) Datenversand an eine Datenbank ausgewählt wurde.


Objekt Soziales Netzwerk

Schritt 3 - Erstellen der Seiten >

Objekt Soziales Netzwerk

 Return to chapter overview
Versteckten Text zeigen/verstecken

Es ist wahrscheinlich, dass jeder von uns heute Mitglied eines oder mehrerer sozialer Netzwerke ist. Dort teilen wir Nachrichten, Bilder, Videos und andere Inhalte, erstellen unsere Online-Profile, knüpfen Freundschaften und erweitern konstant unsere Kontakte.

Da also fast jeder heute in sozialen Netzwerken aktiv ist, ist es wichtig, dass auch unsere Website über diese Kanäle kommunizieren kann. In WebSite X5 erreichen Sie dies mit dem Objekt Soziales Netzwerk, das die Plugins von einigen der bekanntesten sozialen Netzwerke wie Facebook, Google+, Twitter und Pinterest nutzt. Die erreichbaren Ergebnisse variieren natürlich in Abhängigkeit von dem jeweils gewählten Plugin, im Allgemeinen zielen sie jedoch alle darauf ab, Besucher unserer Website auch als Netzwerkkontakte zu gewinnen und das Teilen unserer Inhalte anzuregen.

Klicken Sie um zu erweitern/minimieren Anleitung: Soziale Netzwerke

Wählen Sie zunächst aus der Liste Soziales Netzwerk das Element, das Sie einfügen möchten. Folgende Optionen stehen zur Verfügung:

§AddThis - 'Teilen' Buttons: Mit dieser Option wird eine Steuerleiste mit Buttons und/oder einem Menü eingefügt, über die Besucher ein Netzwerk auswählen können, in dem sie die Inhalte mit ihren Kontakten teilen möchten.

Für weitere Informationen über die Funktionsweise des Social Plugins AddThis siehe: http://www.addthis.com/social-plugins

§Facebook - Kommentarfeld: Fügen Sie mit dieser Option ein Feld für Facebook ein, in dem Besucher Kommentare abgeben können.

§Facebook - Feld 'Gefällt mir': Mit dieser Option wird ein Feld eingefügt, in dem Besucher die neuesten auf einer Facebook-Seite veröffentlichten Meldungen lesen und direkt auf den Button "Gefällt mir" klicken können, um die Seite zu abonnieren.

§Facebook - Button 'Gefällt mir': Diese Option fügt den Button "Gefällt mir" ein, auf den Besucher klicken können, um Inhalte mit ihren Facebook-Kontakten zu teilen.

Für weitere Informationen über die Funktionsweise der Social Plugins für Facebook siehe: https://developers.facebook.com/docs/plugins/

§Google + - Button '+ 1': Diese Option fügt den Button "Folgen" ein, auf den Besucher klicken können, um Inhalte mit ihren Kontakten bei Google+ zu teilen.

§Google + - Badge: Diese Option fügt ein Badge ein, über das Besucher das Google+ Profil einer Person öffnen und ihr ggf. folgen können.

§Google + - Icon: Diese Option fügt eine Schaltfläche ein, über die Besucher das Google+ Profil einer Person öffnen und ihr ggf. folgen können.

Für weitere Informationen über die Funktionsweise der Social Plugins für Google+ siehe: https://developers.google.com/+/plugins/

§Twitter - Button 'Tweet': Diese Option fügt den Button "Tweet" ein, auf den Besucher klicken können, um Inhalte mit ihren Twitter-Followern zu teilen.

§Twitter - Konto-Feld: Mit dieser Option wird ein Feld eingefügt, in dem Besucher die neuesten von einem Twitter-Konto veröffentlichten Tweets lesen und sich, falls gewünscht, an der Konversation beteiligen können.

§Twitter - Button 'Folgen': Diese Option fügt den Button "Folgen" ein, auf den Besucher klicken können, um einem Twitter-Konto zu folgen.

Für weitere Informationen über die Funktionsweise der Social Plugins für Twitter siehe: https://dev.twitter.com/docs/twitter-for-websites

§Pinterest - Button 'Follow': Diese Option fügt den Button "Folgen" ein, auf den Besucher klicken können, um einem Pinterest-Konto zu folgen.

§Pinterest - Button 'Pin It': Diese Option fügt den Button "Pin it" ein, auf den Besucher klicken können, um Inhalte auf Pinterest zu teilen.

Für weitere Informationen über die Funktionsweise der Social Plugins für Pinterest siehe: http://pinterest.com/about/goodies/
Klicken Sie um zu erweitern/minimieren Anleitung: Verfügbare Einstellungen

Für jedes Element in der Liste Soziales Netzwerk sind natürlich spezifische Einstellungen verfügbar, mit denen das Aussehen und die Funktionsweise definiert werden können. Abgesehen von den Optionen für die rein grafische Gestaltung sollten die folgenden Parameter sorgfältig festgelegt werden:

AddThis - 'Teilen' Buttons | §Benutzername: Dies ist der Benutzername, der beim Öffnen eines AddThis-Kontos zugewiesen wird. Wenn Sie als Website-Administrator über ein AddThis-Konto verfügen, sollten Sie Ihren Benutzernamen hier eingeben, da Sie auf diese Weise einige Statistiken über die Nutzung des Dienstes vonseiten Ihrer Website-Besucher abrufen können.
Facebook - Kommentarfeld | §URL der Website: URL der Website, die die Besucher kommentieren. In der Regel wird das Kommentarfeld direkt in die einzelnen Seiten der Website eingefügt, zu der Besucher ihre Kommentare abgeben können. In diesen Fällen entspricht die URL, die hier eingegeben werden muss, jener der Seite, die das Kommentarfeld enthält.
Facebook - Feld 'Gefällt mir' | §Profil-URL: URL der Facebook-Seite, die verlinkt werden soll, um die Inhalte anzuzeigen und Besuchern die Möglichkeit zu geben, sie mit Klick auf die Schaltfläche "Gefällt mir" zu abonnieren.
Facebook - Button 'Gefällt mir' | §URL der Website: URL der Website, für die die Besucher mit Klick auf "Gefällt mir" ihr Interesse bekunden können.
Google + - Button '+ 1' | §URL der Website: URL der Website, die die Besucher ihren Kontakten empfehlen können.
Google + - Badge / Google + - Icon | §Profil-URL: URL des Google+ Profils, das verlinkt werden soll, damit Besucher dem Kreis beitreten können.
Twitter - Button 'Tweet' | §URL der Website: URL der Website, die Besucher in ihrem Twitter-Profil posten können.
Twitter - Konto-Feld / Twitter - Button 'Folgen' | §Benutzername: Benutzername des Twitter-Kontos.
Pinterest - Button 'Follow' | §Benutzername: Benutzername des Pinterest-Kontos.
Pinterest - Button 'Pin It' | §URL der Website: URL der Website mit den Bildern, die die Besucher an ihrer Pinterest-Pinwand posten können. §Bild-URL: URL des Bildes, das die Besucher an ihrer Pinterest-pinwand posten können.

Hinweise zur Kompatibilität mit Vorgängerversionen:

In der Vorgängerversion 9 war dieses Objekt als Widget unter HTML und Widgets verfügbar.


Gästebuch-Objekt

Schritt 3 - Erstellen der Seiten >

Gästebuch-Objekt

 Return to chapter overview
Versteckten Text zeigen/verstecken

Im Gästebuch einer Website können Besucher Kommentare und/oder Bewertungen hinterlassen. Es besteht au einem kurzen Formular, das die Besucher ausfüllen, sowie der Liste der bereits von anderen Personen hinterlassenen Einträge.

Mit WebSite X5 können Sie Ihr Gästebuch nicht nur gestalten, sondern auch die Veröffentlichung der Kommentare über ein spezifisches Control Panel online verwalten.

Klicken Sie um zu erweitern/minimieren Anleitung: Einstellungen für das Gästebuch

Für die Erstellung eines Gästebuchs müssen Sie zunächst die Art des Inhalts bestimmen. Zur Auswahl stehen:

Kommentar und Abstimmung: Die Besucher können einen Kommentar und zusätzlich eine Bewertung abgeben.

Kommentar: Die Besucher können einen Kommentar, aber keine Bewertung abgeben.

Abbstimung: Die Besucher können eine Bewertung, aber keinen Kommentar abgeben.

Je nach gewählter Art des Inhalts können einige Optionen für die Verwaltung der Kommentare definiert werden:

§Anzeigemodus: Definiert, ob die Kommentare von Besuchern direkt online angezeigt werden können oder erst im Control Panel online genehmigt werden müssen.

§Bestellung anzeigen: Definiert, in welcher chronologischen Reihenfolge die veröffentlichten Kommentare angezeigt werden sollen, d.h. mit den neuesten oben oder umgekehrt.

§Button 'Missbrauch melden' anzeigen: Bei Aktivierung dieser Option wird ein Button "Missbrauch melden" eingeblendet, über den Besucher eventuell inkorrektes Verhalten anderer Nutzer signalisieren können.

§Antispam-Filter 'Captcha' aktivieren: Bei Aktivierung dieser Option wird am Ende des Kommentar-Formulars die Anti-Spam-Kontrolle Captcha eingefügt. Bei dieser Methode werden einige Buchstaben verzerrt auf einem verworrenen Hintergrund dargestellt. Der Anwender muss die Buchstaben korrekt in das angezeigte Feld eingeben, um den Kommentar senden zu können.

§Stil für Bewertung: Definiert den Stil des grafischen Elements (z.B. eine Reihe mit 5 Sternen) zur Abgabe von Bewertungen. Dies ist die einzige verfügbare Option, wenn Abbstimung als Art des Inhalts gewählt wurde.

Für jede Art des Inhalts können folgende Eigenschaften festgelegt werden:

§Höhe: Höhe des Gästebuch-Objekt in Pixeln. Jedes Mal, wenn ein Besucher einen Kommentar einträgt und dieser veröffentlicht wurde, wird er der Liste der bereits vorhandenen hinzugefügt. Durch die Definition der Objekthöhe wird neben den Kommentaren eine Scroll-Leiste eingeblendet, wenn die Liste länger wird. Auf diese Weise kann durch Scrollen die gesamte Seite der Kommentare angezeigt werden.
Klicken Sie um zu erweitern/minimieren Anleitung: Methoden für die Übermittlung der Gästebuchdaten

Im Bereich Datenspeichermodus können Sie festlegen wie die Daten, die über das Formular gesammelt wurden um ein Kommentar hinterzulassen, gerettet und dem Betreiber der Website gesendet werden sollen:

§Datenunterordner auf dem Server speichern: Definiert, in welchem Unterverzeichnis mit PHP-Schreibzugriff die Daten auf dem Server gespeichert werden. Das Hauptverzeichnis auf dem Server wird mit der Option Serververzeichnis mit Schreibzugriff festgelegt, die Sie im Fenster Datenmanagement finden. Wurde kein Unterverzeichnis definiert, werden die Daten direkt im Hauptverzeichnis auf dem Server gespeichert.

§Bei Empfang eines Kommentars E-Mail-Benachrichtigung senden: Bewirkt, dass bei Eingang neuer Daten automatisch eine Benachrichtigungs-E-Mail versendet wird.

§E-Mail des Empfängers: Gibt die Adresse an, an die die E-Mail mit der Benachrichtigung über den Eingang neuer Daten gesendet werden soll.

Normalerweise gestatten Provider den Schreibzugriff in jedem Verzeichnis des Servers. In diesem Fall ist es nicht notwendig, einen Pfad zum öffentlichen Ordner anzugeben. Andernfalls müssen Sie den vollständigen Pfad zum öffentlichen Ordner bei Ihrem Webspace-Provider erfragen.

Im Bereich WebSite Test des Control Panels online können Sie prüfen, ob das angegebene Verzeichnis mit Schreibzugriff und die eventuellen Unterverzeichnisse existieren sowie, wenn dies der Fall ist, ob in diese Verzeichnisse effektiv Daten geschrieben werden können.

Damit das Gästebuch-Objekt korrekt funktioniert, muss die Seite, die es enthält, als PHP-Datei gespeichert werden.

Der Dateityp kann mit der Option Dateinamenformat im Fenster Eigenschaften der Seite | Erweitert festgelegt werden.

Hinweise zur Kompatibilität mit Vorgängerversionen:

In der Vorgängerversion 9 war dieses Objekt als Widget unter HTML und Widgets verfügbar.

Praktische Anwendung:

-

Verwaltung von Blog- und Gästebuchkommentaren im Control Panel online

Weiterführende Informationen:

-

Control Panel online


Kartenobjekt

Schritt 3 - Erstellen der Seiten >

Kartenobjekt

 Return to chapter overview
Versteckten Text zeigen/verstecken

Auf gewerblichen Websites findet man in der Regel eine Seite mit Kontaktinformationen, die auch eine interaktive Karte zur Darstellung des Standorts enthalten kann. Solche Karten sind äußerst praktisch, weil sie nicht nur die Adresse enthalten, sondern potenziellen Kunden auch Hinweise für die Anfahrt vermitteln.

WebSite X5 bietet die Möglichkeit, mit dem entsprechenden Kartenobjekt einen über Google Maps™ erstellten Kartenausschnitt einzufügen.

Klicken Sie um zu erweitern/minimieren Anleitung: Einstellungen zum Erstellen einer interaktiven Karte

Für die Erstellung einer interaktiven Karte müssen folgende Einstellungen festgelegt werden:

§Anschrift: Die auf der Karte anzuzeigende Adresse.

§Anzeige: Anzeigemodus. Zur Auswahl stehen Karte, Satellit oder Gelände.

§Sprache: Sprache, in der die Karte angezeigt werden soll.

§Größe: Abmessungen der Karte. Wenn Sie die Option Größenverhältnis beibehalten aktiviert lassen, bleibt bei der Größeneinstellung die Proportion zwischen Breite und Höhe erhalten.

Hinweise zur Kompatibilität mit Vorgängerversionen:

In der Vorgängerversion 9 war dieses Objekt als Widget unter HTML und Widgets verfügbar.


Objekt Flash-Animation

Schritt 3 - Erstellen der Seiten >

Objekt Flash-Animation

 Return to chapter overview
Versteckten Text zeigen/verstecken

Mit WebSite X5 können Sie in die Seiten verschiedene Animationstypen und Effekte einfügen, um sie attraktiver und ansprechender zu gestalten.

Sie können eine beliebige Flash-Animation (Format .SWF) einfügen: vom einfachen Banner mit Text und Bildern bis hin zu komplexen, interaktiven Videos, die lokal auf Ihrem PC gespeichert oder im Internet veröffentlicht sind.

Die Funktionen, die Sie für die Gestaltung einer Objekt Flash-Animation benötigen, sind die folgenden Bereiche gegliedert: Allgemein und Erweitert.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Tab Allgemein

Mit den in diesem Bereich verfügbaren Funktionen kann die Datei importiert werden, die für die Erstellung der Objekt Flash-Animation verwendet werden soll.

Die Flash-Animation kann eine lokale Datei sein oder aus dem Internet importiert werden. Aktivieren Sie im ersten Fall die Option Lokale Datei, und klicken Sie auf die Schaltfläche [image] neben dem Feld, um die entsprechende Ressource im Format .SWF auszuwählen. m zweiten Fall aktivieren Sie die Option URL oder Datei im Internet und geben in das Feld die URL ein, unter der die Ressource online verfügbar ist.

Sie können die Vorschau der importierten Animation in einem eigenen Fenster anzeigen, indem Sie die Option Vorschau aktivieren.

Um die Vorschau anzuzeigen, müssen Sie den Adobe® Flash® Player installieren, den Sie von der Website http://get.adobe.com/de/flashplayer/otherversions/ (Option „Andere Browser“) herunterladen können.

Für die eingefügte Animation können Sie folgende Eigenschaften festlegen:

§Alternativtext: Geben Sie hier den Text ein, der alternativ angezeigt werden soll, wenn die Flash-Animation nicht wiedergegeben werden kann.

§Größe: Definiert die Breite und Höhe der Flash-Animation in Pixeln. Der Höchstwert für die Breite des Objekts ist in Klammern angegeben, je nachdem, wie es im Layout-Schema definiert wurde. Wenn Sie die Option Größenverhältnis beibehalten aktiviert lassen, bleibt bei der Größeneinstellung die Proportion zwischen Breite und Höhe erhalten.

§Playerversion: Wählen Sie hier die Version des Flash-Players aus, die für die Anzeige der Animation erforderlich ist. Verfügt der Benutzer nicht über die hier angegebene Version, wird automatisch ein Fenster mit einer Update-Aufforderung eingeblendet.

§Transparenter Hintergrund: Bei Aktivierung dieser Option wird der Hintergrund der eingefügten Animation transparent.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Tab Erweitert

Mit den in diesem Bereich verfügbaren Funktionen können Sie bei Bedarf Dateien importieren, die mit der Flash-Animation verknüpft sind und für deren korrekte Funktion benötigt werden.

Alle mit der Flash-Animation verknüpften Dateien werden in der Übersicht angezeigt. Außer den Dateinamen enthält die Tabelle auch den jeweilige Serverpfad.

Um die Liste der mit der Flash-Animation verknüpften Dateien zusammenzustellen, stehen Ihnen folgende Optionen zur Verfügung:

§Hinzufügen...: Öffnet das Dialogfenster Verlinkte Datei hochladen,s in dem Sie eine neue verknüpfte Datei auswählen können.

§Bearbeiten...: Öffnet ebenfalls das Dialogfenster Verlinkte Datei hochladen, in dem Sie die Einstellungen für die aus der Liste der verknüpften Dateien ausgewählte Datei ändern können.

§Entfernen: Löschen einer markierten Datei aus der Übersicht der verlinkten Dateien.

Ferner steht folgende Option zur Verfügung:

§Pfad, um die Flash-Datei zu veröffentlichen: Geben Sie hier den Pfad zu dem Verzeichnis an, in dem die .SWF-Datei der Flash-Animation veröffentlicht werden soll.


Objekt Produktliste

Schritt 3 - Erstellen der Seiten >

Objekt Produktliste

 Return to chapter overview
Versteckten Text zeigen/verstecken

Eine der interessantesten Funktionen von WebSite X5 ist die Möglichkeit, einen Online-Shop für E-commerce einzurichten, in dem Sie sich nicht nur ein potenziell weltweit sichtbares Schaufenster für Ihre Produkte schaffen, sondern diese auch direkt online zum Kauf anbieten können.

Neben dem Einstellen der Produkte und deren Verwaltung können Sie mit WebSite X5 mit dem eigens hierfür bestimmten Objekt "Produktliste" einen authentischen Produktkatalog zusammenstellen. Mit diesem Objekt können Sie eine Gruppe von Produkten aus dem Gesamtkatalog präsentieren. Hierzu stellen Sie die einzelnen Produktdatenblätter zusammen, in denen die Hauptinformationen für den jeweiligen Artikel zusammengefasst sind und die den Online-Kauf ermöglichen.

Die Optionen um eine Produktliste einzurichten sind in zwei Bereiche gegliedert: Liste und Einstellungen.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Liste

In diesen Bereich kann festgelegt werden, welche Produkte im Objekt Produktliste angezeigt werden sollen.

In der linken Spalte der Anzeige finden Sie die Kategorien- und Produktliste die in Schritt 4 - Erweiterte Einstellungen bei der Erstellung des Warenkorb für E-Commerce eingefügt wurden.

Neben jedem Produkt und jeder Kategorie befindet sich ein Kontrollkästchen. Aktivieren Sie die Kontrollkästchen der Kategorien und/oder Produkte, die in das Objekt Produktliste aufgenommen werden sollen.. Alle ausgewählten Produkte werden automatisch in der rechten Spalte des Fensters angezeigt.

Zwischen der Aktivierung einer Kategorie und der Aktivierung aller enthaltenen Produkte besteht ein Unterschied: Nur wenn Sie eine ganze Kategorie auswählen, werden später dieser Kategorie hinzugefügte Produkte automatisch auch in die Produktliste aufgenommen.

Die in die rechte Spalte des Fensters eingefügten Produkte können mit Klick auf die Schaltfläche Sortierung nach Benutzerdefiniert, Vorname, Kategorie, Preis, Aufsteigend oder Absteigend sortiert werden.

Bei Auswahl der Benutzerdefiniert sortierung können Sie mit den Schaltflächen Nach oben / Nach unten die Reihenfolge der Produkte manuell festlegen.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Einstellungen

Mit den Funktionen in diesen Bereich können Sie einige grafische Einstellungen für die Produktdatenblätter vornehmen, mit denen die Produkte in die Liste aufgenommen werden.

Allem voran müssen Sie den Anzeigemodus festlegen. Hier haben Sie die Wahl zwischen folgenden Optionen:

Nur Text

Das Produktdatenblatt enthält nacheinander folgende Informationen: Produktname, eine Beschreibung, eine Liste der verfügbaren Varianten (sofern verfügbar), den Preis und daneben ein Eingabefeld für die Menge sowie den Button "Kaufen".

Bild und Text

Das Produktdatenblatt enthält links das Bild des Produkts und rechts alle zugehörigen Informationen.

Text und Bild

Dieser Anzeigemodus entspricht dem vorhergehenden, mit dem Unterschied, dass der Text hier links und das Bild rechts angeordnet ist

Nur Bild

Bei dieser Option werden unter dem Bild die Produktinformationen mit Ausnahme der Beschreibung angezeigt.

Bild und Text abwechseln

In diesem Anzeigemodus werden Produktdatenblätter mit Bild und Text rechts sowie solche mit Bild und Text links abwechselnd angezeigt.

Im Bereich Frame-Einstellungen können Sie festlegen:

§Anzahl Felder pro Zeile: Definieren Sie hier, wie viele Produktdatenblätter in einer Zeile angezeigt werden sollen.

§Feldhöhe: Hier können Sie die gewünschte Höhe der einzelnen Produktdatenblätter in Pixeln festlegen. Die den Produkten zugeordneten Bilder werden dieser Einstellung automatisch angepasst. Wenn die Produktbeschreibungen zu lang sind, um vollständig angezeigt zu werden, erscheint eine Bildlaufleiste.

§Bildbreite (%): Wenn Sie einen Anzeigemodus gewählt haben, bei dem Text und Bild nebeneinander positioniert sind, können Sie hier festlegen, wie viel Raum des Datenblatts jeweils vom Bild und vom Text ausgefüllt sein soll. Dies bedeutet beispielsweise, wenn das Bild 30% der Breite des Produktdatenblattes einnimmt, stehen für den Text die übrigen 70% zur Verfügung.

§Innenabstand: Dies ist der Abstand zwischen dem Rand des Produktdatenblatts und seinem Inhalt. Sie legen hier also fest, wie viel Freiraum horizontal und/oder vertikal um den Inhalt innerhalb des Produktdatenblatts bestehen soll.

Im Bereich Grafik können Sie festlegen:

§Textfarbe/Hintergrundfarbe: Definiert die Textfarbe und die Hintergrundfarbe des Textes auf den Produktseiten.

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

Im Bereich Optionen können Sie festlegen:

§Breite: Definiert die Breite der Ränder, auch einzeln.

§Farbe: Definiert die Farbe der Ränder, auch einzeln.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Schatten: Fügt einen Schatten ein, dessen Farbe, Position, Streuung und Breite definiert werden können.

Im Bereich Optionen können Sie festlegen:

§Preis anzeigen: Zeigt auf den Produktseiten den Preis des Produkts mit oder ohne MwSt. an.

§Feld für Menge anzeigen: Bei Aktivierung dieser Option wird im Produktdatenblatt ein Feld für die Mengenangabe angezeigt, in dem der Benutzer wählen kann, wie viele Einheiten des Produkts er in den Warenkorb legen möchte.

§Link über Bild aktivieren: Bei Aktivierung dieser Option wird allen Bildern der Produktdatenblätter automatisch ein Link zu den vergrößerten Bildern zugeordnet. Diese vergrößerten Darstellungen werden in einer ShowBox angezeigt.

Das Aussehen der ShowBox kann komplett individuell gestaltet werden: Mit den Optionen in Stile und Modelle | E-Mail in Schritt 4 - Erweiterte Einstellungen können Sie beispielsweise Farben, Schatten, die Deckkraft und Einblendeffekte festlegen.

Das Objekt Produktliste funktioniert nur dann, wenn zuvor im Bereich Warenkorb für E-Commerce in Schritt 4 - Erweiterte Einstellungen Artikel eingefügt wurden.


HTML und Widgets

Schritt 3 - Erstellen der Seiten >

HTML und Widgets

 Return to chapter overview
Versteckten Text zeigen/verstecken

Für jeden Inhalt, der auf einer Seite angezeigt werden kann, bietet WebSite X5 in spezifisches Objekt, wie Text, Bild, Flash-Animation, E-Mail-Formular usw. Dank der Möglichkeit, darüber hinaus auch HTML und Widgets zu verwalten, werden die Möglichkeiten praktisch unbegrenzt. Mit dem Objekt HTML und Widgets können direkt Code-Blöcke eingefügt werden, um spezifische Funktionen umzusetzen, auch wenn diese standardmäßig nicht vorgesehen sind.

Ganz besonders nützlich sind hierbei die verfügbaren Widgets: kleine bereits komplette und funktionsfähige Anwendungen, die eine bestimmte Aufgabe erfüllen. Ein einfaches Beispiel ist das Widget für Google News™: Mit der Definition weniger Parameter können Sie einen Box mit aktuellen Nachrichten, die ich Echtzeit aktualisiert werden, einfügen.

ie Optionen für die Erstellung eines HTML und Widgets sind in folgende Bereiche gegliedert: HTML-Code und Erweitert.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich HTML-Code

In diesen Bereich können Sie in dem dort verfügbaren Editor HTML-Code eingeben, der in die Website übernommen werden soll. Den Code können Sie individuell schreiben oder durch Anklicken eines der verfügbaren Widgets übernehmen.

Der Editor im Bereich HTML-Code bietet folgende Optionen:

Ausschneiden [Strg+X] - Kopieren [Strg+C] - Einfügen [Strg+V]

Ausschneiden, Kopieren und Einfügen ausgewählter Code-Abschnitte.

Rückgängig [Strg+Z] - Wiederherstellen [ALT+UMSCHALT+BACKSPACE]

zum Annullieren/Wiederherstellen der zuletzt durchgeführten/annullierten Operation.

Für ein komfortables Lesen und Schreiben des Codes bietet der HTML-Editor Syntaxhervorhebung (Syntax Highlighting). Mit dieser Funktion werden bestimmte Elemente des Codes in unterschiedlichen Farben dargestellt, ohne dass dies die Bedeutung der Textsequenzen beeinflusst. Dank Syntaxhervorhebung wird die Code-Struktur übersichtlicher und eventuelle Fehler werden leichter gefunden.

Im Bereich Widgetliste finden Sie alle verfügbaren Widgets. Mit Doppelklick auf ein Widget wird das Dialogfenster Widget geöffnet, in dem Sie die vorgesehenen Parameter definieren können. Nach der Bestätigung der Eingabe wird der entsprechende HTML-Code erstellt und automatisch in den Editor eingefügt.

Hinweise zur Kompatibilität mit Vorgängerversionen:

Verfügbare Objekte - Während in der Vorgängerversion 9 das Gästebuch sowie die Buttons für Soziale Netzwerke und die Karten als Widgets zur Verfügung standen, sind sie in der aktuellen Version 10 nun eigenständige Objekte (siehe PSchritt 3 - Erstellen der Seiten).

Im Bereich Eigenschaften stehen folgende Optionen zur Verfügung:

§Breite: Hier wird die Breite des HTML und Widgets angezeigt. Dieser Wert wird auf der Grundlage des im Layout-Schema verfügbaren Platzes automatisch definiert.

§Höhe: Hier kann die Höhe des HTML und Widgets eingestellt werden.

§Bildlaufleisten anzeigen: Diese Option ist standardmäßig aktiviert und bewirkt das auomatische Einfügen einer Bildlaufleiste, wenn das HTML und Widgets höher ist, als unter Höhe eingestellt wurde.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen des Bereichs Erweitert

Mit den Funktionen dieses Bereichs Sie ein Stylesheet (CSS) erstellen und/oder die Liste der Dateien definieren, die mit dem aktiven Objekt HTML und Widgets verknüpft werden sollen.

Im Bereich CSS-Code befindet sich ein Editor (identisch mit dem im Tab HTML-Code), in den Sie den Code für ein Stylesheet eingeben können. Zur Erinnerung: Mit Stylesheets definieren Sie die grafischen Eigenschaften der HTML-Seiten, mit denen sie verknüpft sind.

Im Bereich Mit dem HTML-Code verlinkte Dateien hingegen werden alle verknüpften Dateien in einer Übersicht angezeigt, die neben den Dateinamen auch deren Serverpfad enthält.

Um die Liste der mit dem HTML-Code verknüpften Dateien zusammenzustellen, stehen Ihnen folgende Optionen zur Verfügung:

§Hinzufügen...: Öffnet das Dialogfenster Verlinkte Datei hochladen, in dem Sie eine neue verknüpfte Datei auswählen können.

§Bearbeiten...: Öffnet ebenfalls das Dialogfenster Verlinkte Datei hochladen, in dem Sie die Einstellungen für die aus der Liste der verknüpften Dateien ausgewählte Datei ändern können.

§Entfernen: Löschen einer markierten Datei aus der Übersicht der verlinkten Dateien.


Grafik-Editor

Schritt 3 - Erstellen der Seiten > Allgemeine Funktionen >

Grafik-Editor

 Return to chapter overview
Versteckten Text zeigen/verstecken

WebSite X5 optimiert importierte Bilder automatisch und stellt zusätzlich einen vielseitigen Grafik-Editor zur Verfügung, mit dem die Bilder bearbeitet werden können.

Der Grafik-Editor kann überall dort aufgerufen werden, wo die Schaltfläche Bearbeiten... erfügbar ist, generell in Fenstern, wo eine Bilddatei importiert werden kann wie zum Beispiel in Bildobjekt, Objekt Galerie, oder bei der Erstellung eines neuen Produkts im Warenkorb für E-Commerce.

Der Grafik-Editor ist in folgende Bereiche gegliedert: Zuschneiden und Drehen, Filter, Wasserzeichen, Maske, Rahmen, Effekte und Bibliothek.

Darüber hinaus finden Sie im Grafik-Editor folgende Schaltflächen:

§OK: Schließen des Grafik-Editor und Rückkehr zum Hauptfenster. Alle Änderungen am Bild werden gespeichert.

§Abbrechen: Schließen des Grafik-Editor und Rückkehr zum Hauptfenster. Eventuelle Änderungen am Bild werden nicht gespeichert.

§Speichern als...: Speichern einer Kopie des Original-Bildes im Format .PNG.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Zuschneiden und Drehen

Mit den Funktionen in diesen Bereich kann ein bestimmter Bildbereich ausgeschnitten und der Rest entfernt werden.

Sie können den auszuschneidenden Bereich direkt in der Vorschau auswählen und an den Ankerpunkten zusätzlich anpassen. Die Auswahl kann verschoben werden, um den gewünschten Bereich genau zu bestimmen. Klicken Sie hierzu in den Bereich und ziehen Sie den Bereich in die gewünschte Position.

Das Ausschneiden muss nicht bestätigt werden. Der Bereich außerhalb des (dunkler dargestellten) ausgeschnittenen Teils wird nicht berücksichtigt. Um den Ausschnitt wieder zu entfernen, klicken Sie auf den Bereich außerhalb der markierten Fläche.

Neben dem Bild stehen Ihnen für die Bearbeitung folgende Bereiche zur Verfügung:

§Ausschneiden: Hier werden die Werte der X-Koordinate und der Y-Koordinate der oberen linken Ecke des Ausschnitts sowie dessen Breite und Höhe in Pixeln angezeigt. Diese Werte werden nicht notwendigerweise direkt aus dem Schnittbereich entnommen, sondern können auch in die entsprechenden Felder eingegeben oder mit den Pfeilschaltflächen definiert werden.

§Spiegelung: Durch Aktivierung der jeweiligen Kontrollkästchen kann das Bild horizontal (an der senkrechten Achse) und/oder vertikal (an der waagerechten Achse) gespiegelt werden.

§Drehung: Hier können Sie das Bild im Uhrzeigersinn um 90°, 180° oder 270° drehen oder unverändert lassen.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Filter

Mit den Funktionen in diesen Bereich können an dem importierten Bild die wesentlichen Farbeigenschaften korrigiert sowie einige grafische Effekte angewendet werden.

Um einen Filter zu konfigurieren, ist es hinreichend, ihn aus der Liste auszuwählen, zu aktivieren und die gewünschten Einstellungen vorzunehmen. Änderungen an Filtern werden sofort angewendet und in der Vorschau angezeigt.

§Filter: Hier finden Sie eine Auswahl von Filtern, die auf das Bild angewendet werden können. Die Liste umfasst die Effekte Helligkeit/Kontrast, Farbbalance (RGB), Farbton/Sättigung (HSL), Detail, Weichzeichnung, Schwarz-Weiß, Sepia, Mosaik, Körnung, Diffusion, Ölgemälde, Leinwand, Rauschen, Marmor. m einen Filter anzuwenden, aktivieren Sie das entsprechende Kontrollkästchen.

§Einstellungen: Hier finden Sie die Einstellungen, mit denen Sie den ausgewählten Filter definieren können.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Wasserzeichen

Mit den Funktionen im Tab Wasserzeichen des Grafik-Editors kann über das importierte Bild ein Wasserzeichen gelegt werden. Zweck eines Wasserzeichens ist die Veränderung des Bildes, zum Beispiel, um ausdrücklich auf das Urheberrecht hinzuweisen und unbefugtem Kopieren und Nutzen vorzubeugen.

§Wasserzeichen: Hier finden Sie eine Auswahl von Wasserzeichen, die auf das Bild angewendet werden können. Neben den hier angezeigten Vorlagen können Sie auch ein individuelles Wasserzeichen erstellen: Wählen Sie hierzu die zweite Option aus der Liste aus (Benutzerdefiniert...) und importieren Sie eine entsprechend vorbereitete Bilddatei.

§Einstellungen: Sie können das ausgewählte Wasserzeichen um 90°, 180° oder 270° drehen sowie horizontal oder vertikal spiegeln.

Ein Wasserzeichen muss als Bilddatei im Format .GIF, .PNG, .PSD oder .WMF mit Transparenz vorbereitet werden. Das Wasserzeichen wird dann über das Original-Bild gelegt, von dem nur die Teile im transparenten Bereich sichtbar bleiben.

Da das Format .GIF nur eine transparente Ebene unterstützt, während in den Formaten .PNG und .PSD bis zu 256 verwaltet werden können, empfiehlt es sich, das Wasserzeichen in einem dieser beiden Formate zu speichern.

+

=

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Maske

Mit den Funktionen in diesen Bereich kann auf das importierte Bild eine Maske angewendet werden.

§Maske: Hier finden Sie eine Auswahl von Masken, die ausgewählt werden können und auf das Bild angewendet werden können. Neben den hier angezeigten Vorlagen können Sie auch eine individuelle Maske erstellen: Wählen Sie hierzu die zweite Option aus der Liste aus (Benutzerdefiniert...) und importieren Sie eine entsprechend vorbereitete Bilddatei.

§Einstellungen: Sie können die ausgewählte Maske um 90°, 180° oder 270° drehen sowie horizontal oder vertikal spiegeln.

Eine Maske ist ein Bild (256 Farben) in Graustufen. Dieses Bild wird so auf das Originalbild gelegt, dass die vom Schwarz bedeckten Teile unsichtbar werden und die weißen Teile sichtbar bleiben.

+

=

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Rahmen

Mit den Funktionen in diesen Bereich kann dem importierten Bild ein Rahmen hinzugefügt werden.

§Rahmen: Hier finden Sie eine Auswahl von Rahmen, die auf das Bild angewendet werden können. Neben den hier angezeigten Vorlagen können Sie auch einen individuellen Rahmen erstellen: Wählen Sie hierzu die zweite Option aus der Liste aus (Benutzerdefiniert...) und importieren Sie eine entsprechend vorbereitete Bilddatei.

§Einstellungen: Sie können den ausgewählten Rahmen um 90°, 180° oder 270° drehen sowie horizontal oder vertikal spiegeln.

Ein Rahmen muss als Bilddatei im Format .GIF, .PNG, .PSD oder .WMF mit Transparenz vorbereitet werden. Der Rahmen wird dann über das Original-Bild gelegt, von dem nur die Teile im transparenten Bereich sichtbar bleiben.

Da das Format .GIF nur eine transparente Ebene unterstützt, während in den Formaten .PNG und .PSD bis zu 256 verwaltet werden können, empfiehlt es sich, den Rahmen in einem dieser beiden Formate zu speichern.

+

=

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Effekte

Mit den Funktionen in diesen Bereich können an dem importierten Bild einige grafische Effekte angewendet werden.

§Effekte: Hier finden Sie eine Auswahl von Effekten, die auf das Bild angewendet werden können. Die Liste umfasst die Effekte Schatten, Spiegelung, Äußerer Glanz, Farbiger Rand, Verlauf, Plastischer Rand, Relief, Rahmen, Drehung, Perspektive, Verzerrung e Deckkraft. Um einen Effekt anzuwenden, aktivieren Sie das entsprechende Kontrollkästchen.

§Einstellungen: In diesem Bereich finden Sie die Einstellungen, mit denen Sie den ausgewählten Effekt definieren können.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Bibliothek

In diesen Bereich können Sie ein zuvor als Stil gespeichertes Set von Einstellungen auswählen und auf das aktive Bild anwenden oder die für das aktive Bild festgelegten Eigenschaften als neuen Stil speichern, um ihn später auch auf andere Bilder anzuwenden.

§Übernehmen: Alle Einstellungen des ausgewählten Stils werden auf das aktive Bild angewendet.

§Hinzufügen: Hiermit können Sie alle Einstellungen, die in den anderen Tabs des Grafik-Editor für das aktive Bild vorgenommen wurden, als Stil in den Benutzerdefiniert Stilen speichern.

§Entfernen: Mit Klick auf diese Schaltfläche löschen Sie einen ausgewählten Stil aus den Benutzerdefiniert Stilen. Die Standardeinstellungen Stile können nicht gelöscht werden.


Zellenstil

Schritt 3 - Erstellen der Seiten > Allgemeine Funktionen >

Zellenstil

 Return to chapter overview
Versteckten Text zeigen/verstecken

WebSite X5 ermöglicht die Erstellung aller Seiten einer Website in einem Layout-Schema, das den verfügbaren Raum in Zellen gliedert. Die Zahl der verfügbaren Zellen ist von der Zahl der eingegebenen Zeilen und Spalten abhängig und in jede Zelle können verschiedene Inhalte eingegeben werden (durch einfaches Drag&Drop der verfügbaren Objekte).

Die Zelle entspricht somit einem bestimmten Bestandteil der Seite: Sie hat einen bestimmten Inhalt und kann individuell grafisch gestaltet werden. Durch Gestaltung der Ränder, Rahmen und Hintergründe einer Zelle können also innerhalb einer Seite Bereiche erstellt werden, um die Inhalte zu organisieren und Bestandteile wie gewünscht hervorzuheben.

Um die grafische Gestaltung einer Zelle zu definieren, markieren Sie sie und klicken dann auf die Schaltfläche [image]. Es öffnet sich das Fenster Zellenstil, deren Optionen in die folgenden Bereiche gegliedert sind: Stil, Text und Bibliothek.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Stil

Über die Befehle dieser Sektion können die grafischen Einstellungen der im Layout-Schema aktuell markierten Zelle bestimmt werden.

Legen Sie zunächst den Hintergrund für die Zelle fest, für den folgende Optionen zur Verfügung stehen:

Farbiger Hintergrund: Die Zelle erhält einen einfarbigen Hintergrund.

Hintergrund mit Farbverlauf: Der Hintergrund der Zelle wird mit einem Farbverlauf ausgefüllt, für den die Anfangsfarbe, die Endfarbe und die Verlaufsrichtung festgelegt werden können.

Bildhintergrund: Der Hintergrund der Zelle wird mit einem importierten Bild ausgefüllt.

Bild an Zelle anpassen: Für den Hintergrund der Zelle wird ein importiertes Bild in Blöcke aufgeteilt und so wieder zusammengesetzt, dass es sich perfekt den Abmessungen der Zelle anpasst. (siehe Gestaltung einer Zelle)

Je nach Hintergrundtyp können unter Einstellungen verschiedene Optionen gewählt werden.

 | Farbiger Hintergrund | Hintergrund mit Farbverlauf | Bildhintergrund | Bild an Zelle anpassen
§Hintergrundfarbe: Hier können Sie die Hintergrundfarbe festlegen. | P | - | P | P
§Anfangsfarbe / Endfarbe: Legen Sie hier die Anfangs- und die Endfarbe für den Farbverlauf des Zellenhintergrundes fest. | - | P | - | -
§Diffusion: Hier können Sie festlegen, ob im Farbverlauf die Anfangs- oder die Endfarbe dominieren soll. Hierzu geben Sie an, in welchem Abstand (in Pixeln) der Übergang von der einen zur anderen Farbe erfolgen soll. Stellen Sie beispielsweise einen vertikalen Farbverlauf von Grau nach Weiß mit einer Diffusion von 250 ein, erfolgt der Übergang innerhalb der ersten 250 Pixel und dahinter ist der Hintergrund durchgehend weiß. | - | P | - | -
§Richtung: Hier können Sie die Richtung des Farbverlaufs festlegen, das heißt, ob er vonoben, von unten, von links oder von rechts beginnen soll. | - | P | - | -
§Bilddatei: Wählen Sie hier das Bild für den Hintergrund der Zelle aus. Sie können Dateien in den Formaten JPG, GIF und PNG verwenden. | - | - | P | P
§Anordnung: Hier können Sie festlegen, ob das ausgewählte Hintergrundbild wiederholt werden soll. Das Bild kann nur horizontal, nur vertikal oder in beide Richtungen wiederholt werden, bis es den zur Verfügung stehenden Platz ausfüllt. | - | - | P | -
§Ausrichtung: Legen Sie hier fest, wie das eingefügte Hintergrundbild zur Zellenfläche ausgerichtet werden soll. | - | - | P | -
§Farbsättigung: Hier können Sie eine Farbe auswählen, mit der das Hintergrundbild der Zelle schattiert werden soll. Das heißt, es wird ein Colorize-Effekt angewendet, der das gesamte Bild in der ausgewählten Farbe schattiert. | - | - | P | -
§Blockbreite / Blockhöhe: Hier können Sie die Abmessungen der Blöcke einstellen, in die das Hintergrundbild aufgeteilt wird. Damit legen Sie fest, welche Bildteile unverändert bleiben und welche wiederholt werden sollen. (siehe Gestaltung einer Zelle) | - | - | - | P
§Deckkraft: Legen Sie hier die Deckkraft der Hintergrundfarbe / des Farbverlaufs / des Hintergrundbildes fest. Je kleiner der eingestellte Wert ist, desto geringer wird die Deckkraft, das heißt, die Hintergrundfarbe der Zelle wird transparenter und lässt den Hintergrund der Seite stärker durchscheinen. | P | P | P | P

Im Bereich Rand können Sie festlegen:

§Breite: Definiert die Breite der Ränder, auch einzeln.

§Farbe: Definiert die Farbe der Ränder, auch einzeln.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Schatten: Fügt einen Schatten ein, dessen Farbe, Position, Streuung und Breite definiert werden können.

Und mit den Optionen im Bereich Ausrichtung und Rand definieren Sie:

§Ausrichtung: Mit dieser Option können Sie das in der aktuellen Zelle enthaltene Objekt oben/zentral/unten sowie links/zentral/rechtszur Zelle ausrichten.

§Außenrand / Innenabstand: Stellen Sie hier die Breite der externen und internen Ränder der Zelle in Pixeln ein (siehe Das Box-Modell in WebSite X5).

Hinweise zur Kompatibilität mit Vorgängerversionen:

In den Vorgängerversionen waren die Optionen für die Zellenränder und die Ausrichtung der Zelleninhalte in den Menüs enthalten, die über die Schaltflächen [image] und [image] in der Werkzeugleiste oberhalb des Layout-Schemas aufgerufen wurden. In der aktuellen Version 10 sind diese Schaltflächen nicht mehr verfügbar und die Optionen wurden in das Fenster Zellenstil| Stil integriert.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Text

Über die Optionen in diesem Bereich können Sie die grafischen Einstellungen der Textelemente der im Layout-Schema aktuell markierten Zelle vornehmen.

Zunächst muss das Element (Text oder Bild) ausgewählt werden, das eingefügt oder bearbeitet werden soll. Hierzu stehen folgende Optionen zur Auswahl:

Titel: Text, der als Überschrift der aktiven Zelle angezeigt wird.

Headerbild: Dies ist ein Bild, das in den Header der aktiven Zelle eingefügt werden kann, eventuell neben dem Titel.

Beschreibungstext: Text, der als Beschreibung der aktiven Zelle angezeigt wird.

Nach Eingabe können die verschiedenen Elemente aus dem Dropdown-Menü oder direkt durch Klick auf das Vorschaubild ausgewählt werden.

Je nach gewähltem Element können im Bereich Einstellungen verschiedene Funktionen angewendet werden.

Für die Elemente Titel und Beschreibungstext stehen folgende Optionen zur Verfügung:

§Inhalt: Feld für die Eingabe der Überschrift oder einer Beschreibung der Zelle.

§Hintergrundfarbe / Textfarbe: Hier definieren Sie die Hintergrundfarbe für den Text und die Textfarbe.

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Ausrichtung des Textes links, in der Mitte oder rechts im Verhältnis zur Zelle.

§Aussenrand / Innenabstand: Stellen Sie hier die Breite der Seitenränder des Textes in Pixeln ein. Auf diese Weise können Sie Ihren Text präzise positionieren und den Abstand zum Zellenrand festlegen.

Für das Element Headerbild stehen folgende Einstellungen zur Verfügung:

§Bilddatei: Wählen Sie hier das Bild für den Hintergrund der Zelle aus. Sie können Dateien in den Formaten JPG, GIF und PNG verwenden.

§Ausrichtung: Ausrichtung des eingefügten Bildes links, in der Mitte oder rechts im Verhältnis zur Zelle.

§Rand: Stellen Sie hier die Bildränder in Pixeln ein. Auf diese Weise können Sie das Bild präzise positionieren und den Abstand zum Zellenrand und zur eventuell eingegebenen Titel festlegen.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Bibliothek

In diesem Bereich des Fensters Zellenstil können Sie ein zuvor als Stil gespeichertes Set von Einstellungen auswählen und auf die aktive Zelle anwenden oder die für die aktive Zelle festgelegten Eigenschaften als neuen Stil speichern, um ihn später auch auf andere Zellen anzuwenden.

In der Bibliothek finden Sie alle Stile (Standardeinstellungen und Benutzerdefiniert). Außerdem stehen die folgenden Schaltflächen zur Verfügung:

§Übernehmen: Alle Einstellungen des ausgewählten Stils werden auf die aktive Zelle angewendet.

§Hinzufügen: Speichert alle grafischen Einstellungen, die in den Bereichen Stil und Text für die aktuelle Zelle in einem Stil vorgenommen wurden und fügt den Stil der Stil-Liste Benutzerdefiniert hinzu.

§Entfernen: Löscht den ausgewählten Stil aus der Stil-Liste Benutzerdefiniert. Vordefinierte Stile (Standardeinstellungen) können nicht gelöscht werden.

Bei der Erstellung eines Stils werden alle grafischen Einstellungen der Zelle gespeichert, aber nicht ihre Inhalte, die von Zelle zu Zelle verschieden sein können. Dies bedeutet zum Beispiel, in dem Stil werden die Textfarbe oder die Schriftart, aber nicht der Inhalt der Elemente wie Titel und Beschreibungstext gespeichert, der für die Zelle festgelegt wurde.

Praktische Anwendung:

-

Die Arbeit am Zellenstil

Weiterführende Informationen:

-

Das Box-Modell in WebSite X5


Link Fenster

Schritt 3 - Erstellen der Seiten > Allgemeine Funktionen >

Link Fenster

 Return to chapter overview
Versteckten Text zeigen/verstecken

Neben den festen Navigationsmenüs, die auf der Grundlage der Sitemap automatisch erstellt werden, können Sie mit WebSite X5 Texte, Bilder und andere Elemente mit Verknüpfungen versehen, die verschiedene Aktionen ermöglichen, wie das Öffnen interner oder externer Seiten, das Aufrufen von Dateien, das Anzeigen von Bildern, das Hinzufügen eines Produkts zum Warenkorb usw.

Bei der Konfiguration einer solchen Verknüpfung können Sie nicht nur die gewünschte Aktion auswählen, sondern auch die jeweilige Quickinfo definieren und individuell gestalten, die erläutert, welche Aktion der Klick auf den Link auslöst.

Die Funktionen für die Einstellung von Hyperlinks sind in die Bereiche: Aktion und Beschreibung gegliedert.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Aktion

In diesen Bereich können Sie festlegen, welche Aktion beim Anklicken des Links ausgeführt werden soll:

Seite der Website

Verlinkung mit einer anderen Seite der Website. Klicken Sie auf die Schaltfläche [image] um über die Sitemap die zu verlinkende Seite der Website auszuwählen. Falls erforderlich, kann auch ein Interner Seitenanker der zu verlinkenden Seite angegeben werden. Wählen Sie hierzu den gewünschten Anker aus der Liste aus. Und schließlich können Sie festlegen, ob die verlinkte Seite im selben Fenster, in einem neuen Fenster des Browsers oder als Popup-Fenster angezeigt werden soll. Bei Auswahl des Popup-Fensters können dessen Abmessungen (Breite des ToolTips und Höhe) festgelegt werden.

Die Anker müssen vorher den Objekten zugewiesen worden sein, um in der Liste der Interner Seitenanker angezeigt zu werden.

Um eine Anker an einen Objekt zu zuweisen, klicken Sie auf die Schaltfläche [image] im Schritt 3 - Erstellen der Seiten.

Datei oder URL

Der Link führt zu einer anderen Datenquelle, einer Datei oder einer HTML-Seite, lokal oder im WEB. PerUm festzulegen, womit verlinkt werden soll, wählen Sie Lokale Datei und klicken dann auf die Schaltfläche [image] um lokal eine Ressource auszuwählen, oder URL oder Datei im Internet und geben dann die Adresse (URL) der gewünschten Ressource an.

ie können angeben, ob die verlinkte Ressource im selben Fenster, in einem neuen Fenster des Browsers oder als Popup-Fenster mit einstellbaren Abmessungen (Breite des ToolTips und Höhe) angezeigt werden soll.

Datei oder URL mit ShowBox

Der Link führt zu einer beliebigen Ressource, lokal oder im WEB, die in einer eigenen ShowBox angezeigt wird. Im Gegensatz zum externen Popup-Fenster wird die verlinkte Datei in einer ShowBox angezeigt. Diese überlagert die ursprüngliche Seite, die im Hintergrund heller oder dunkler angezeigt wird.

Um festzulegen, womit verlinkt werden soll, wählen Sie Lokale Datei und klicken dann auf die Schaltfläche [image] um lokal eine Ressource auszuwählen, oder URL oder Datei im Internet und geben dann die Adresse (URL) der gewünschten Ressource an. Für die ShowBox können Sie die Abmessungen (Breite des ToolTips und Höhe) sowie eine Beschreibung festlegen, die darunter angezeigt wird.

Die Verlinkung mit ShowBox eignet sich besonders für die Anzeige von Bildern, kann aber auch für andere Ressourcen wie zum Beispiel PDF-Dokumente verwendet werden.

ShowBox-Galerie

Mit Klick auf den Link wird in einer ShowBox eine Bildergalerie angezeigt. ür die Erstellung der Bilderliste stehen Ihnen folgende Befehle zur Verfügung: Hinzufügen..., Entfernen, Nach oben und Nach unten. Außerdem können die Abmessungen (Maximum Breite und maximum Höhe) der ShowBox festgelegt werden.

Das Aussehen der ShowBox kann komplett individuell gestaltet werden: Mit den Optionen in Stile und Modelle | E-Mail in Schritt 4 - Erweiterte Einstellungen können Sie beispielsweise Farben, Schatten, die Deckkraft und Einblendeffekte festlegen.

E-Mail-Adresse

Der Link öffnet den Standard-E-Mail-Client, um von dort eine E-Mail zu versenden. Geben Sie die E-Mail-Adresse ein, an die die Nachricht gesendet werden soll.

Bei Auswahl der Option Schutz der E-Mail Adresse aktivieren wird die angegebene E-Mail-Adresse im HTML-Code der Seite verschlüsselt gespeichert: Auf diese Weise wird sie nicht von Spam-Robots erkannt, die das WEB auf der Suche nach E-Mail-Adressen scannen.

Internetanruf

Der Link öffnet ein Programm für Internettelefonie (zum Beispiel Skype), über das mit einem bestimmten Teilnehmer Kontakt aufgenommen werden kann. Der Link öffnet ein Programm für Internettelefonie (zum Beispiel Skype), über das mit einem bestimmten Teilnehmer Kontakt aufgenommen werden kann. v Aktionstyp festgelegt werden. Sie haben die Wahl zwischen: Anrufen, Kontakt hinzufügen, Chat, Profil anzeigen, Skype-Voicemail und Dateien senden.

Ton

Der Link löst die Wiedergabe eines Sounds aus. Um festzulegen, womit verlinkt werden soll, wählen Sie Lokale Datei und klicken dann auf die Schaltfläche [image] m lokal eine Ressource auszuwählen, oder URL oder Datei im Internet und geben dann die Adresse (URL) der gewünschten Ressource an.Es können nur Dateien im Format .MP3 verlinkt werden.

Bei Klick auf den Link wird ein ToolTip mit einer Play/Pause-Taste angezeigt, mit der die Wiedergabe gestartet bzw. unterbrochen werden kann. Bewegt man den Mauszeiger aus dem Fenster des ToolTips heraus, wird die Wiedergabe unterbrochen.

Der ToolTip für den Sound-Link wird vom Programm automatisch generiert. Die grafische Gestaltung richtet sich nach den Einstellungen unter Schritt 4 - Erweiterte Einstellungen im Bereich Stile und Modelle | Text.

Seite drucken

Bei Klick auf den Link wird die angezeigte Seite ausgedruckt.

Hinweis

Bei Klick auf den Link wird ein Hinweis angezeigt. Geben Sie hierzu den Text der Nachricht in das entsprechende Feld ein. Bei Aktivierung der Option Als Popupfenster anzeigen ird der Hinweis in einem Dialogfenster im Windows-Stil angezeigt.

RSS-Feed

Der Link führt zum RSS-Feed der Website: Diese Verlinkung ist nur aktiv, wenn in dem entsprechenden Fenster in Schritt 4 - Erweiterte Einstellungen ein RSS-Feed konfiguriert wurde.

Wenn Sie die Funktionsfähigkeit der lokal erstellten Website testen, weist eine Meldung darauf hin, dass der RSS-Feeds erst funktionieren, wenn die Website online ist.

Blog

Der Link führt zu dem mit der Website verknüpften Blog. Voraussetzung für das Funktionieren dieses Links ist, dass in Schritt 4 - Erweiterte Einstellungen zuvor ein Blog erstellt wurde.

Mit den verfügbaren Optionen können Sie einstellen, ob der Blog im gleichen oder in einem neuen Fenster des Browsers angezeigt werden soll.

Sitemap

Mit Klick auf den Link wird die komplette Sitemap in einem separaten Fenster angezeigt. Alle Einträge in der Sitemap sind ihrerseits mit den entsprechenden Seiten verlinkt. Die Sitemap ist daher ein nützliches Hilfsmittel zur Orientierung und Navigation für den Anwender. Die Anzeige der Sitemap-Inhalte kann mit den Optionen Erweitern und Ausblenden angepasst werden.

Warenkorb anzeigen

Mit Klick auf den Link wird die Seite mit dem Warenkorb und eventuell bereits bestellten Produkten angezeigt.

Zum Warenkorb hinzufügen

Mit Klick auf den Link wird der Benutzer zum Warenkorb geleitet, um eine Bestellung aufzugeben, oder kann ein bestimmtes Produkt in den Warenkorb legen.

Bei Auswahl der Option Produktliste der ausgewählten Kategorie anzeigen der ausgewählten Kategorie anzeigen muss in der Übersicht des Produktkatalogs die gewünschte Kategorie ausgewählt werden.

Bei Auswahl der Option Das ausgewählte Produkt direkt in den Warenkorb legen muss in der Übersicht das jeweilige Produkt gewählt werden. Außerdem müssen die Option und die Anzahl des Produkts angegeben werden, das in den Warenkorb gelegt werden soll.

Die Links Warenkorb anzeigen und Zum Warenkorb hinzufügen funktionieren nur dann, wenn zuvor unter Warenkorb für E-Commerce in Schritt 4 - Erweiterte Einstellungen ein E-Shop konfiguriert wurde.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Beschreibung

In diesen Bereich können Sie Ihrem Link eine Beschreibung zuweisen: Diese Beschreibung wird für die Erstellung einer erläuternden Anmerkung ("ToolTip" oder "Tip") verwendet. Ein ToolTip erscheint neben dem Mauszeiger, wenn dieser auf dem Link positioniert wird, und enthält eine Erläuterung der Aktion, die der Klick auf den Link auslöst, d.h. dass auf eine andere Seite oder Website umgeleitet, ein Bild angezeigt, der Download einer Datei gestartet wird usw.

Die Optionen in diesen Bereich die zur Verfügung stehen sind:

§Text: Geben Sie hier die Beschreibung des Links ein.

§Bilddatei: Hier können Sie ein Bild auswählen, das im ToolTip anstelle oder gemeinsam mit der Beschreibung angezeigt werden soll.

§Breite des ToolTips: Legen Sie hier die gewünschte Breite des ToolTips fest.

§Bildbreite (%): Prozentuale Breite des Bildes im Verhältnis zur Breite des ToolTips.

§Bildposition: Position des eingefügten Bildes im Verhältnis zum Text.

Die Parameter Text, Bilddatei und Breite des ToolTips variieren je nach Linktyp und müssen daher für jeden Link separat definiert werden. Die grafische Gestaltung des ToolTips richtet sich nach den Einstellungen unter Stile und Modelle | Text in Schritt 4 - Erweiterte Einstellungen.


Effekteigenschaften der Effekte Fenster

Schritt 3 - Erstellen der Seiten > Allgemeine Funktionen >

Effekteigenschaften der Effekte Fenster

 Return to chapter overview
Versteckten Text zeigen/verstecken

Dieses Dialogfenster enthält die Funktionen, mit denen Sie Einblendeffekte der für eine Slideshow ausgewählten Bilder festlegen können. Die Funktion ist im Editor für die Gestaltung des Templates, für die Bilder im Objekt Objekt Galerie sowie für die ausgewählten Bilder verfügbar (siehe Objekt Produktliste).

Die Funktionen sind die folgenden Bereiche gegliedert: Effekttyp, Zoom und Bewegung und Seite.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Effekttyp

Wählen Sie hier den Einblendeffekt für die Bilder, die Sie bearbeiten:

§Liste der Effekte: Liste der zur Auswahl stehenden Effekte. Wenn Sie die Option "1 - Zufall" wählen, wird nach dem Zufallsprinzip automatisch ein Effekt ausgewählt. Nach der Auswahl eines Effekts wird dieser im Vorschaufenster angezeigt.

§Anzeigedauer: Stellen Sie hier die Dauer (in Sekunden) ein, für die jedes einzelne Bild angezeigt werden soll.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Zoom und Bewegung

Hier können Sie für die Bilder den Bewegungstyp und einen Zoomfaktor auswählen:

§Startposition: Definieren Sie hier den Zoomfaktor und die Koordinaten X und Y der Startposition für die Bildbewegung.

§Endposition: Definieren Sie hier den Zoomfaktor und die Koordinaten X und Y der Endposition für die Bildbewegung.

In beiden Fällen können Sie zum Festlegen der Start- und Endposition auch direkt das Vorschaubild in die gewünschte Position ziehen.

Für ein Bild können ein Einblendeffekt sowie ein Bewegungs- und Zoom-Effekt eingestellt werden. In diesem Fall wird erst der Einblendeffekt angewendet und das Bild wird mit den Koordinaten und Abmessungen dargestellt, die für die Startposition festgelegt wurden. Anschließend wird die Bewegung und eventuell der Zoom dargestellt, bis das Bild die Koordinaten und Abmessungen erreicht, die für die Endposition festgelegt wurden.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen der Sektion Seite

Dieser Bereich ist nur aktiv, wenn Bilder eines Slideshow-Objekts in den Header bzw. die Fußzeile des Templates eingefügt wurden (siehe Gestaltung des Templates).

Hier wird erneut die Sitemap angezeigt: Durch Aktivierung des Kontrollkästchens neben den Seiten können jene ausgewählt werden, auf denen das Bild aus der Slideshow, an dem Sie gerade arbeiten, angezeigt werden soll. Auf diese Weise können Bestandteile des gleichen Slideshow-Objekts, die in den Header bzw. die Fußzeile des Templates eingefügt wurden, in verschiedenen Bereichen der Website angezeigt werden.

Festzulegen, auf welchen Seiten bestimmte Bilder einer Slideshow angezeigt werden sollen, kann sich zum Beispiel als besonders nützlich erweisen, wenn man Werbebotschaften veröffentlicht. Werbebanner werden mit der Slideshow-Funktion konfiguriert und dann können Sie festlegen, dass auf jeder Seite und in jedem Bereich nur die jeweils zugehörigen Botschaften angezeigt werden.


Verlinkte Datei hochladen Fenster

Schritt 3 - Erstellen der Seiten > Allgemeine Funktionen >

Verlinkte Datei hochladen Fenster

 Return to chapter overview

Dieses Dialogfenster öffnet sich bei Klick auf die Schaltfläche Hinzufügen... beim Zusammenstellen der Liste verlinkter Dateien, bei der Konfiguration einer Flash-Animation (siehe Objekt Objekt Flash-Animation | Erweitert) oder beim Eingeben von HTML-Code (siehe HTML und Widgets | Erweitert).

Folgende Befehle sind verfügbar:

§Verlinkte Datei zur Veröffentlichung auf dem Server: Hier können Sie eine Datei importieren, die mit dem aktuell bearbeiteten Objekt verlinkt ist.

§Serverpfad: Geben Sie hier den Pfad zu dem Verzeichnis an, in dem die importierte, mit dem Objekt verknüpfte Datei veröffentlicht werden soll.

§Datei mit der Seite verknüpfen (ausschließlich .js oder .css Dateien): Handelt es sich bei der importierten Datei um ein JavaScript (Format .js) oder ein Stylesheet (format .css), muss sie, um zu funktionieren, mit der Seite verknüpft werden. Mit Aktivierung dieser Option wird der Code automatisch in den Bereich <HEAD> des HTML-Codes der Seite eingefügt.


Erweiterte Einstellungen

Schritt 4 - Erweiterte Einstellungen >

Erweiterte Einstellungen

 Return to chapter overview

Nachdem Sie in Schritt 2 die Sitemap strukturiert und in Schritt 3 die einzelnen Seiten erstellt und alle Inhalte eingegeben haben, werden Ihnen im 4. Schritt verschiedene erweiterte Funktionen angeboten. Hier können Sie den Stil der Navigationsmenüs und der Texte gestalten, aber auch wichtige Bereiche der Website wie einen E-Shop, einen Blog oder einen geschützten Bereich erstellen.

Im Einzelnen stehen Ihnen folgende erweiterte Funktionen zur Verfügung:

Hauptmenü

Hier können Sie die Ebenen des Hauptmenüs gestalten, also des Menüs, das oben (Struktur mit horizontalem Menü) oder seitlich (Struktur mit vertikalem Menü) immer sichtbar ist.

Drop-Down-Menü

Definieren Sie hier den Stil des Drop-Down-Menüs, das bei Bewegung des Mauszeigers über einen Eintrag eines Menüs der ersten Ebene eingeblendet wird.

Seitenmenü

Gestalten Sie hier die grafischen Eigenschaften des Seitenmenüs, also des Menüs, das die Liste der Seiten der jeweils aktuellen Ebene anzeigt.

Stile und Modelle

Definieren Sie in diesem Bereich die Stile der Textelemente auf den verschiedenen Seiten, in der ShowBox des Objekts Objekt Galerie, der ToolTips, die den Link zugewiesen werden können, der mit dem Objekt Objekt E-Mail-Formular erstellten E-Mails oder im Warenkorb für E-Commerce.

Introseite

In dieser Sektion können Sie für Ihre Website eine Intro gestalten, die mit Sound hinterlegt werden kann und die Links für die Sprachauswahl enthält.

Werbebotschaft

Hier können Sie eine Werbebotschaft konfigurieren und individuell gestalten, die nur auf der Homepage oder auf allen Seiten in einer bestimmten Position angezeigt wird.

Blog

In dieser Sektion können Sie einen Blog erstellen und verwalten. Ein Blog ist eine Art Web-Tagebuch, in dem Sie Nachrichten veröffentlichen, die von den Anwendern ggf. kommentiert werden können.

RSS-Feed

In diesem Bereich können Sie ein RSS-Feed als Kanal für regelmäßig aktualisierte Informationen erstellen und verwalten.

Datenmanagement

In diesem Fenster legen Sie die Methoden zur Verwaltung der Daten fest, die in bestimmten Bereichen der Website wie in E-Mail-Formularen, im Blog, im Gästebuch oder im Warenkorb für E-Commerce erfasst werden.

Zugangsverwaltung

Erstellen Sie hier Profile für Benutzer, die Zugang zu den geschützten Bereichen der Website erhalten und organisieren Sie sie in Gruppen. Die geschützten Seiten, die Sie in Schritt 2 Erstellen der Sitemap als solche definieren, bilden gemeinsam den geschützten Bereich, auf den Benutzer nur zugreifen können, nachdem sie sich eingeloggt haben, wobei die zugewiesenen Zugriffsrechte bestimmen, welche geschützten Seiten jeweils angezeigt werden können.

Warenkorb für E-Commerce

In diesem Bereich können Sie einen E-Shop einrichten und hierfür Parameter wie die Produktliste, Versand- und Zahlungsarten oder das Bestellformular definieren.

Für weitere Informationen über die Erstellung der Sitemap und die Unterscheidung zwischen Einträgen der ersten und der zweiten Ebene, Drop-Down-Menüs und Untermenüs siehe Erstellen der Sitemap.


Stil des Hauptmenüs

Schritt 4 - Erweiterte Einstellungen >

Stil des Hauptmenüs

 Return to chapter overview
Versteckten Text zeigen/verstecken

Dieses Fenster enthält die Funktionen, mit denen Sie einige erweiterte, grafische Einstellungen an den Elementen des Hauptmenüs vornehmen können.

Die Menüs werden auf der Grundlage der in Schritt 2 - Erstellen der Sitemap generierten Sitemap vom Programm automatisch erstellt und aktualisiert. Das Hauptmenü enthält die Einträge der ersten Ebene der Sitemap, die den festen Navigationsbereich der Website bilden. Bei Websites mit horizontalem Menü befindet sich das Hauptmenü direkt über oder unter dem Header und ist immer sichtbar. Bei Websites mit vertikalem Menü befindet sich das Hauptmenü in einer Spalte rechts oder links neben dem Inhalt und ist ebenfalls immer sichtbar.

Die Funktionen für die individuelle Gestaltung der Menüelemente sind in folgende Bereiche gegliedert: Allgemein, Menüelemente und 3D-Stil.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den Funktionen in Bereich können einige allgemeine Einstellungen für das Hauptmenü vorgenommen werden.

Im Bereich Stil stehen folgende Optionen zur Verfügung:

§Breite: Legen Sie hier die Breite der Menü-Buttons in Pixeln fest.

§Rand: Definiert den horizontalen und vertikalen Rand in Pixeln, also den Freiraum zwischen dem Rahmen der Schaltfläche und deren Aufschrift.

§Abstand zwischen Buttons: Bestimmen Sie hier den Außenrand, also den Abstand zwischen zwei Buttons.

§Automatischer Menülauf des Menüs: Bei Aktivierung dieser Option bewegt sich das Navigationsmenü automatisch mit dem Seiteninhalt, sodass es immer sichtbar und verfügbar bleibt.

Bei der Einstellung der Button-Breite muss auch der für das Menü insgesamt verfügbare Platz berücksichtigt werden. Falls Sie kein vordefiniertes Template verwenden, können Sie diesen Parameter ändern (siehe Individuelles Template).

Im Bereich Text stehen folgende Optionen zur Verfügung:

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Wählen Sie hier, ob die Button-Beschriftung Links, Zentriert oder Rechts ausgerichtet werden soll.

§Antialias auf Text anwenden: Bei Aktivierung dieser Option wird ein Antialias-Effekt auf den Text angewendet, der die Kanten des Schriftbildes glättet.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Menüelemente

Mit den Funktionen in diesem Bereich können Sie die Hintergrundbilder und den Stil der Texte für einen bestimmten Status der Schaltflächen des Hauptmenüs bestimmen.

Wählen Sie zunächst das Menüelement, das Sie bearbeiten möchten. Sie können das Einstellungen für das [image] Menüelement, das [image] Element bei Mauskontakt/aktuelle Seite vornehmen. Sie können das Menüelement aus dem Dropdown-Menü oder direkt in der Vorschau auswählen, die in Echtzeit aktualisiert wird.

Für alle Elementtypen stehen im Bereich Stil folgende Optionen zur Verfügung:

§Hintergrundfarbe / Textfarbe / Randfarbe: Mit Klick auf der Schaltfläche können Sie die Farbe für den Hintergrund, den Text und den Rand des Buttons auswählen.

§Hintergrundbild: Wählen Sie hier ein Bild aus, das als Hintergrund für den Button verwendet werden soll. Klicken Sie hierzu auf die Schaltfläche [image], um die verfügbaren Ressourcen zu durchsuchen. Sie können Dateien in den Formaten .JPG, .GIF und .PNG verwenden. Alternativ können sie auf den Pfeil neben dem Feld klicken, um die Buttons-Sammlung zu öffnen und Sie das Bild, das Sie benützen mochten, auszuwählen.

§Schriftstil: Definiert für das Menüelement den Textstil. Zur Auswahl stehen die Optionen Kein, Basrelief, Hochrelief und Schatten. Für das Element bei Mauskontakt/aktuelle Seite wird automatisch die Einstellung für das Menüelement übernommen. Zusätzlich können Sie den Schriftschnitt Normale, Fett, Kursiv und Fett Kursiv hinzufügen.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich 3D-Stil

Mit den Optionen in diesen Bereich können Sie die Form und das Aussehen der 3D-Buttons definieren.

Im Bereich Form stehen folgende Optionen zur Verfügung:

§Form: Wählen Sie hier die Form des Buttons.

§Abrundung: Hier können Sie einen Abrundungsfaktor definieren, um die Ecken der Buttons abzurunden oder diesen eine Form zu geben, die vom Rechteck verschieden ist.

§Form der Buttons verbinden: Bei Aktivierung dieser Option werden die Buttons verbunden und die gewählte Form wird auf alle Buttons als Komplex angewendet.

Im Bereich 3D-Stil stehen folgende Optionen zur Verfügung:

§Stil: Hier können Sie dem Button Eigenschaften wie Profilkanten, Flach, Flach plastisch, Tiefliegendusw. zuweisen.

§Lichteinfall: Definieren Sie hier den Effekt eines Lichteinfalls auf den Button.

§Schattierung: Mit dieser Option können Sie einen Schattierungseffekt auf den Button anwenden.

§Transparenz des Bildes: Mit dieser Funktion können Sie auf Hintergrundbilder, die den Buttons im Tab Menüelemente zugewiesen wurden, eine Transparenz anwenden.

Im Bereich 3D-Rand können Sie schließlich folgende Einstellungen vornehmen:

§Randstil: Wählen Sie einen Stil für den Rand der Buttons, wie Normal, Profilkanten oder Tiefliegend.

§Äußere Breite / Innere Breite: Hier können Sie jeweils die äußere und innere Breite der Ränder festlegen.

§Nur Außenrand: Bei Aktivierung dieser Option wird der Rand mit den vorgenommenen Einstellungen nicht auf jeden einzelnen Button, sondern auf den gesamten Button-Block in seiner Gesamtheit angewendet.


Stil des Drop-Down-Menüs

Schritt 4 - Erweiterte Einstellungen >

Stil des Drop-Down-Menüs

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Fenster finden Sie die Funktionen, mit denen Sie einige erweiterte Einstellungen des grafischen Stils der Drop-Down-Menüs vornehmen können.

Die Menüs werden auf der Grundlage der in Schritt 2 - Erstellen der Sitemap generierten Sitemap vom Programm automatisch erstellt und aktualisiert. Die Drop-Down-Menüs werden bei Mauskontakt mit einer Ebene des Hauptmenüs angezeigt.

Die Funktionen für die individuelle Gestaltung der Menüelemente sind in folgende Bereiche gegliedert: Allgemein, Menüelemente und 3D-Stil.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den Funktionen in diesem Bereich können einige allgemeine Einstellungen für das Drop-Down-Menü vorgenommen werden.

Allem voran müssen Sie den Menütyp festlegen. Hier haben Sie die Wahl zwischen folgenden Optionen:

In einer Spalte anordnen: Alle Elemente des Drop-Down-Menüs werden in einer Spalte untereinander angeordnet.

In mehreren Spalten anordnen: Die Elemente des Drop-Down-Menüs werden in mehreren, nebeneinander angeordneten Spalten organisiert. Es wird automatisch eine neue Spalte generiert, wenn:

§die Anzahl der Menüelemente den unter Max. Einträge pro Spalte; eingestellten Wert erreicht oder überschreitet;

§in der Seitenliste ein Trennelement eingefügt wurde (siehe Erstellen der Sitemap).

Wenn im Fenster Auswahl der Vorlage oder Individuelles Template ein vertikales Menü gewählt wurde, steht außerdem folgende Option zur Verfügung:

Vertikales Akkordeon-Menü: Alle Elemente des Drop-Down-Menüs werden in einer Spalte organisiert. Bei Klick auf einen Eintrag verschieben sich die folgenden Elemente nach unten und lassen Raum für die Anzeige der jeweiligen Unterelemente.

Nachdem Sie den Menütyp ausgewählt haben, können Sie hierfür die im Bereich Stil verfügbaren Optionen festlegen:

§Breite: Legen Sie hier die Breite der Menü-Buttons in Pixeln fest.

§Rand: Definiert den horizontalen und vertikalen Rand in Pixeln, also den Freiraum zwischen dem Rahmen der Schaltfläche und deren Aufschrift.

§Max. Einträge pro Spalte: Diese Option ist nur für den Menütyp In mehreren Spalten anordnen verfügbar und ermöglicht die Einstellung der Maximalzahl der Elemente, die jede Spalte des Drop-Down-Menüs enthalten kann.

Im Bereich Text stehen folgende Optionen zur Verfügung:

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Wählen Sie hier, ob die Button-Beschriftung Links, Zentriert oder Rechts ausgerichtet werden soll.

Und im Bereich Optionen finden Sie schließlich die Option:

§Effekt: Stellen Sie hier den gewünschten Anzeigeeffekt ein. Zur Auswahl stehen die Optionen Kein, Einblenden, Öffnen von oben, Öffnen von links und Öffnen von links oben.

§Die aktuelle Seite automatisch auswählen: Diese Option ist nur für den Menütyp Vertikales Akkordeon-Menü aktiv und bewirkt, dass das Menü je nachdem, welche Seite der Website geöffnet ist, automatisch erweitert wird, um die entsprechende Option als ausgewählt darzustellen.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen in Bereich Menüelemente

Mit den Funktionen in diesem Bereich können Sie die Farben, die Hintergrundbilder und den Stil der Texte für einen bestimmten Status der Schaltflächen des Drop-Down-Menüs bestimmen.

Wählen Sie zunächst das Menüelement, das Sie bearbeiten möchten. Sie können Einstellungen für das [image] Menüelement, das [image] Element bei Mauskontakt und die [image] Menütrennlinie vornehmen. Sie können das Menüelement aus dem Dropdown-Menü oder direkt in der Vorschau auswählen, die in Echtzeit aktualisiert wird.

Für alle Elementtypen stehen im Bereich Stil folgende Optionen zur Verfügung:

§Hintergrundfarbe / Textfarbe / Randfarbe: Mit Klick auf der Schaltfläche können Sie die Farbe für den Hintergrund, den Text und den Rand des Buttons auswählen. Für die Menütrennlinie ist die Option Textfarbe verfügbar.

§Schriftstil: Definiert für das Element bei Mauskontakt und die Menütrennlinie den Textstil. Zur Auswahl stehen Normal, Fett, Kursiv und Fett Kursiv.

§Hintergrundbild: Verfügbar nur für das Menüelement und das Element bei Mauskontakt, Wählen Sie hier ein Bild aus, das als Hintergrund für den Button verwendet werden soll. Klicken Sie hierzu auf die Schaltfläche [image], um die verfügbaren Ressourcen zu durchsuchen. Sie können Dateien in den Formaten .JPG, .GIF und .PNG verwenden. Alternativ können sie auf den Pfeil neben dem Feld klicken, um die Buttons-Sammlung zu öffnen und Sie das Bild, das Sie benützen mochten, auszuwählen.

§Icon Aufzählungszeichen: Hier können Sie ein Bild auswählen, dass neben den Menüoptionen oder Menütrennlinien als Aufzählungszeichen verwendet wird. Klicken Sie hierzu auf die Schaltfläche [image] und wählen Sie die gewünschte Bilddatei im Format .JPG, .GIF oder .PNG aus.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich 3D-Stil

Mit den Optionen in diesen Bereich können Sie die Form und das Aussehen der 3D-Buttons definieren.

Im Bereich Form stehen folgende Optionen zur Verfügung:

§Form: Wählen Sie hier die Form des Buttons.

§Abrundung: Hier können Sie einen Abrundungsfaktor definieren, um die Ecken der Buttons abzurunden oder diesen eine Form zu geben, die vom Rechteck verschieden ist.

§Form der Buttons verbinden: Bei Aktivierung dieser Option werden die Buttons verbunden und die gewählte Form wird auf alle Buttons als Komplex angewendet.

Im Bereich 3D-Stil stehen folgende Optionen zur Verfügung:

§Stil: Hier können Sie dem Button Eigenschaften wie Profilkanten, Flach, Flach plastisch, Tiefliegendusw. zuweisen.

§Lichteinfall: Definieren Sie hier den Effekt eines Lichteinfalls auf den Button.

§Schattierung: Mit dieser Option können Sie einen Schattierungseffekt auf den Button anwenden.

§Transparenz des Bildes: Mit dieser Funktion können Sie auf Hintergrundbilder, die den Buttons im Tab Menüelemente zugewiesen wurden, eine Transparenz anwenden.

Im Bereich 3D-Rand können Sie schließlich folgende Einstellungen vornehmen:

§Randstil: Wählen Sie einen Stil für den Rand der Buttons, wie Normal, Profilkanten oder Tiefliegend.

§Äußere Breite / Innere Breite: Hier können Sie jeweils die äußere und innere Breite der Ränder festlegen.

§Nur Außenrand: Bei Aktivierung dieser Option wird der Rand mit den vorgenommenen Einstellungen nicht auf jeden einzelnen Button, sondern auf den gesamten Button-Block in seiner Gesamtheit angewendet.


Stil des Seitenmenüs

Schritt 4 - Erweiterte Einstellungen >

Stil des Seitenmenüs

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Fenster finden Sie die Funktionen, mit denen Sie einige erweiterte grafische Einstellungen für die Menü-Buttons der Seitenmenüs vornehmen können.

Die Menüs werden auf der Grundlage der in Schritt 2 - Erstellen der Sitemap generierten Sitemap vom Programm automatisch erstellt und aktualisiert. Seitenmenüs können optional dargestellt werden, um die Liste der Seiten der jeweiligen Ebene anzuzeigen. Das heißt, wenn Sie die Seite einer bestimmten Ebene öffnen und diese Ebene weitere Seiten enthält, werden diese im Seitenmenü angezeigt. Seitenmenüs sind immer vertikal angeordnet und rechts oder links vom Seiteninhalt positioniert.

Die Funktionen für die individuelle Gestaltung der Menüelemente sind in folgende Bereiche gegliedert: Allgemein und Menüelemente.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den Funktionen in diesem Bereich können einige allgemeine Einstellungen für die Seitenmenüs vorgenommen werden.

Soll das Seitenmenü mit den Seiten der aktiven Ebene angezeigt werden, müssen Sie zunächst die Option Seitenmenü anzeigen aktivieren.

Anschließend können Sie im Bereich Stil: folgende Optionen nutzen:

§Position des Menüs: Legen Sie hier fest, ob das Seitenmenü am rechten oder linken Seitenrand angezeigt werden soll.

§Breite: Legen Sie hier die Breite der Menü-Buttons in Pixeln fest.

§Rand: Definiert den horizontalen und vertikalen Rand in Pixeln, also den Freiraum zwischen dem Rahmen der Schaltfläche und deren Aufschrift.

§Abstand zwischen Buttons: Bestimmen Sie hier den Außenrand, also den Abstand zwischen zwei Buttons.

Im Bereich Text stehen folgende Optionen zur Verfügung:

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Wählen Sie hier, ob die Button-Beschriftung Links, Zentriert oder Rechts ausgerichtet werden soll.

Und im Bereich Rand können Sie für das Seitenmenü (nicht die einzelnen Einträge) einen Rahmen erstellen und folgendermaßen konfigurieren:

§Breite: Definiert die Breite der Ränder, auch einzeln.

§Farbe: Definiert die Farbe der Ränder, auch einzeln.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Schatten: Fügt einen Schatten ein, dessen Farbe, Position, Streuung und Breite definiert werden können.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Menüelemente

Mit den Funktionen in diesem Bereich können einige grafische Parameter für die Bestandteile des Seitenmenüs einstellen.

Wählen Sie zunächst das Menüelement, das Sie bearbeiten möchten. Sie können Einstellungen für das [image] Menüelement, das [image] Element bei Mauskontakt/aktuelle Seite, die [image] Menütrennlinie und die [image] Trennlinie vornehmen. Sie können das Menüelement aus dem Dropdown-Menü oder direkt in der Vorschau auswählen, die in Echtzeit aktualisiert wird.

§Hintergrundfarbe / Textfarbe / Linienfarbe: Hintergrundfarbe und Textfarbe für das Menüelement, das Element bei Mauskontakt/aktuelle Seite und die Menütrennlinie sowie die Linienfarbe für die Trennlinie.

§Icon Aufzählungszeichen: Mit dieser für das Menüelement, Element bei Mauskontakt/aktuelle Seite und die Menütrennlinie verfügbaren Option können Sie ein Bild (Dateiformate .JPG, .GIF, .PNG) importieren, um es als Aufzählungszeichen vor den einzelnen Menüelementen anzuzeigen.

§Schriftstil: Verfügbar für das Element bei Mauskontakt/aktuelle Seite und die Menütrennlinie, Auswahl des Schriftschnitts: Normal, Fett, Kursiv und Fett Kursiv.

§Linienstil: Nur verfügbar für die Trennlinie. Definieren Sie hier die Linienform. Zur Auswahl stehen Durchgehende Linie, Strichlinie, Punktlinie, Basrelief und Hochrelief.


Stile und Modelle

Schritt 4 - Erweiterte Einstellungen >

Stile und Modelle

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Fenster finden Sie die Funktionen, mit denen Sie die Stile der Textelemente auf den verschiedenen Seiten, in der ShowBox von Elementen wie des Objekts Objekt Galerie des Objekts Objekt Produktliste, der ToolTips, die Link zugewiesen werden können, der mit dem Objekt E-Mail-Formular erstellten E-Mails oder im Warenkorb für E-Commerce gestalten können.

Ein Stil kann im Allgemeinen als eine Gesamtheit von Textformatierungen und grafischen Eigenschaften verstanden werden, die auf ein Element angewendet werden, um sein Erscheinungsbild zu verändern. Die Anwendung eines Stils ermöglicht die gleichzeitige Zuweisung mehrerer Formatierungsoptionen in einem einzigen Arbeitsschritt.

Die Funktionen für die Gestaltung der Stile sind in folgende Bereiche gegliedert: Text, ShowBox, Tooltip und E-Mail.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Text

Mit den Optionen in diesen Bereich können Sie die Stile für die in der Website verwendeten Texte definieren.

Wählen Sie zunächst aus dem Drop-Down-Menü das l'Seitenelement, dessen Stil Sie gestalten möchten. Alternativ können Sie auch direkt in den entsprechenden Bereich der Vorschau klicken.

Im Einzelnen können folgende Seitenelemente durch Anwendung eines Stils gestaltet werden:

Seitentitel: Dies ist die Überschrift der Seite. Hier wird der Name übernommen, der den Seiten beim Erstellen der Sitemap der, falls verschieden, unter Erweiterter Seitentitel im Dialogfenster Eigenschaften der Seite gegeben wurde.

Seitenpfad: Dieser Text steht direkt unter dem Seitentitel und zeigt den Pfad zur aktuellen Seite (Breadcrumb-Navigation). Der logische Pfad wird automatisch vom Programm erstellt.

Seitentext: Dies ist der eigentliche Seiteninhalt, der im Objekt Text. eingegeben wurde. Der Stil dieses Elements wird automatisch angewendet, wenn Sie im Editor des Objekt Text. Über die Befehle des Editors können dann weitere Änderungen und Anpassungen vorgenommen werden. Der für dieses Element definierte Stil wird auch auf alle Texte angewendet, die das Programm automatisch generiert und einfügt, beispielsweise auf die Seiten des Geschützten Bereichs, des Blogs, der internen Suichmaschine und der Sitemap.

Aktiver Link / Verlinkung bei Mauskontakt / Bereits verwendeter Link: Dies sind die Hyperlinks, die im Objekt Text. erstellt wurden. Ein Hyperlink kann je nach Status unterschiedlich aussehen. Unterschieden wird zwischen aktiven Links, Verlinkung bei Mauskontakt (Mouseover) und verwendeten Links. Einen aktiven Link visuell von einem bereits verwendeten zu unterscheiden, erleichtert dem Besucher die Navigation, da er sofort sieht, welche Bereiche er bereits besucht hat.

Feld / Button: Felder und Schaltflächen der Formulare, die im Objekt Objekt E-Mail-Formular oder im Warenkorb für E-Commerce erstellt wurden, aber auch andere Elemente wie das Suchfeld (siehe Gestaltung des Templates | Suchfeld einfügen),, die Login- und Logout-Felder im geschützten Bereich uswDer Stil dieser Elemente wird standardmäßig definiert, wenn Sie ein neues Objekt E-Mail-Formular erstellen. Die Einstellungen für das einzelne Modul können anschließend mit den Optionen im Objekt E-Mail-Formular | Stil geändert werden.

Menü am unteren Seitenrand: In diesem Menü, das unten auf jeder Seite erscheint, werden erneut die Elemente des Hauptmenüs angezeigt.

Nach Auswahl des Seitenelement können Sie es mit folgenden Optionen des Bereichs Stil gestalten:

§Anzeigen: Mit dieser Option legen Sie fest, ob das jeweilige Seitenelement angezeigt werden soll oder nicht. Für das Element Seitentext, und die verschiedenen Links ist die Option nicht verfügbar, da diese nicht ausgeschlossen werden können. Bitte berücksichtigen Sie: Wenn Sie ein Seitenelement unsichtbar machen, bleibt es dennoch im Code der Seite erhalten. Wenn Sie zum Beispiel den Seitentitel Bitte berücksichtigen Sie: Wenn Sie ein Seitenelement unsichtbar machen, bleibt es dennoch im Code der Seite erhalten. Wenn Sie zum Beispiel den <title> aus dem HTML-Code entfernt.

§Hintergrundfarbe / Textfarbe: Mit Klick auf die Schaltfläche Farbe öffnet sich die Farbpalette, in der Sie die Farbe für den Hintergrund und den Text des Seitenelements auswählen können. Nur für den Seitentext kein Hintergrund festgelegt werden, da dieser von dem gewählten Template (siehe Auswahl der Vorlage, oder Individuelles Template) und/oder vom Zellenstil in den das Objekt Text eingefügt wurde.

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Wählen Sie hier, ob das Seitenelement Links, Zentriert oder Rechts ausgerichtet sein soll. Diese Option ist für die verschiedenen Links nicht verfügbar, da die Ausrichtung der Hyperlinks unabhängig vom Stil bei der Erstellung des Objekt Text, weder für die Felder und Buttons.

§Textstil: Diese Option ist nur für die verschiedenen Links verfügbar und Sie können zwischen Normal und Unterstrichen wählen.

§Mauszeiger: Diese Option ist nur für Aktiver Link, verfügbar und wird für die beiden anderen Linktypen übernommen. Sie können festlegen, wie der Mauszeiger aussehen soll, wenn er über einen Link bewegt wird. Klicken Sie auf die Schaltfläche [image] und wählen Sie eine Datei .CUR oder .ICO aus.

§Randfarbe: Definiert die Farbe der Ränder, die dem Seitentitel, dem Seitenpfad, einem Feld, eines Button oder dem Menü am unteren Seitenrand hinzugefügt werden können.

§Abgerundete Ecken: Definiert die Rundung der Ecken eines Feld oder einen Button, auch einzeln.

§Schatten: Fügt im Feld einen Schatten ein, dessen Farbe, Position, Streuung und Breite definiert werden können.

§Horizontaler Seitenrand: Definiert den horizontalen Seitenrand des Seitentitel, des Seitenpfad und des Menü am unteren Seitenrand.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich ShowBox

Mit den Optionen in diesen Bereich können Sie einen Stil für die ShowBox festlegen, die in den JavaScript-Galerien (siehe Objekt Galerie), im Link ShowBox-Galerie (siehe Link | Aktion) und im Objekt Produktliste verwendet wird. In allen Fällen wird die ShowBox über einen Link geöffnet und zeigt ein vergrößertes Bild, ein Video oder eine Bildsequenz an. Bei Klick auf den Link wird das Browserfenster verdunkelt, um den Inhalt der ShowBox hervorzuheben, die mit dem eingestellten Einblendeffekt die ursprüngliche Seite überlagert.

Im Bereich Stil stehen folgende Optionen zur Verfügung:

§Einblendeffekt: Legen Sie hier den Einblendeffekt für die ShowBox fest. Zur Auswahl stehen die Optionen Keiner, Einblenden, Bildlauf von oben, Zoom, Startbild zoomen und ausblenden. Die Zoom und Startbild zoomen und ausblenden Effekte sind ähnlich, der einzige Unterschied ist, dass das Bild, das Sie eingestellt haben während des Zoom sichtbar oder nicht sichtbar sein kann. Der Startbild zoomen und ausblenden ist sehr nützlich, wenn Ihre Showbox mit einem Bild, anstelle von einem Text, verbunden ist.

§Farbe außen / Farbe innen: Hier können Sie die Farbe für den externen und/oder internen Hintergrund des ShowBox-Fensters auswählen. Die externe Hintergrundfarbe ist halbtransparent (abhängig von dem unter Hintergrundtransparenz eingestellten Wert) und wird verwendet, um die vom Browser angezeigte Seite darunter zu verdunkeln.

§Hintergrundtransparenz: Definieren Sie hier die Deckkraft der Hintergrundfarbe der ShowBox, die die darunter liegende Seite abdunkelt. Je höher Sie diesen Wert einstellen, desto weniger ist von der überlagerten Seite sichtbar.

Im Bereich Text können Sie folgende Einstellungen vornehmen:

§Textfarbe: Sie können die Farbe für den Text der ShowBox festlegen.

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Wählen Sie hier, ob der Text zum Fenster der ShowBox Links, Zentriert oder Rechts ausgerichtet sein soll.

Im Bereich Rand können Sie folgende Einstellungen vornehmen:

§Breite: Definiert die Breite der Ränder, auch einzeln.

§Farbe: Definiert die Farbe der Ränder, auch einzeln.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Schatten: Fügt einen Schatten ein, dessen Farbe, Position, Streuung und Breite definiert werden können.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Tooltip

Mit den Optionen in diesen Bereich können Sie den Stil der ToolTips definieren, die mit der entsprechenden Funktion Inserisci collegamento Link einfügen Text- oder Bild-Links zugewiesen wurden. Ein ToolTip ist ein kurzer Text, der einer Box erscheint, wenn der Mauszeiger über einen Link bewegt wird, und der die Aktion bei Klick auf diesen Link erläutert.

Für die Gestaltung des ToolTips stehen Ihnen die Optionen im Bereich Stil zur Verfügung:

§Position des Tooltip: Legen Sie hier fest, in welcher Position der ToolTip zum jeweiligen Link angezeigt werden soll. Zur Auswahl stehen Oben, Unten, Links und Rechts.

§Einblendeffekt: Definieren Sie hier, ob auf die ToolTips ein Einblendeffekt angewendet werden soll. Zur Auswahl stehen Keiner, Einblenden und Auf und Ab.

§Hintergrundfarbe: Hier können Sie eine Hintergrundfarbe für den ToolTip festlegen.

§Hintergrundtransparenz: Definieren Sie hier die Deckkraft der Hintergrundfarbe der ShowBox, die die darunter liegende Seite abdunkelt. Je höher Sie diesen Wert einstellen, desto weniger ist von der überlagerten Seite sichtbar.

§Pfeilende anzeigen: Bei Aktivierung dieser Option erhält die Sprechblase des ToolTips einen Pfeil, der zu dem jeweils zugehörigen Link führt.

Im Bereich Text stehen folgende Optionen zur Verfügung:

§Textfarbe: Definiert die Farbe für den Text im Tooltip.

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Wählen Sie hier, ob der Text im ToolTip Links, Zentriert oder Rechts ausgerichtet sein soll.

Im Bereich Rand stehen folgende Optionen zur Verfügung:

§Breite: Definiert die Breite der Ränder, auch einzeln.

§Farbe: Definiert die Farbe der Ränder, auch einzeln.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Schatten: Fügt einen Schatten ein, dessen Farbe, Position, Streuung und Breite definiert werden können.

Die Stileinstellungen werden auf das gesamte Projekt angewendet, das heißt, alle ToolTips der Website sind einheitlich gestaltet. Die Definition der ToolTip-Inhalte (Texte und Bilder) hingegen erfolgt im Dialogfenster Link | Beschreibung.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich E-Mail

Mit den Optionen in diesen Bereich können Sie den Stil der E-Mails gestalten, die im Objekt E-Mail-Formular oder Warenkorb für E-Commerce konfiguriert wurden.

Wählen Sie zunächst aus dem Drop-Down-Menü das E-Mail-Element das Sie bearbeiten möchten. Alternativ können Sie auch direkt in den entsprechenden Bereich der Vorschau klicken.

Im Einzelnen können folgende E-Mail-Elemente durch Anwendung eines Stils gestaltet werden:

E-Mail-Layout: Alle vom Programm generierten E-Mails haben ein einheitliches Layout mit einem Rahmen und einem Mittelteil für die Nachricht. Zwischen dem Rahmen und dem Mittelteil kann ein Randelement eingefügt werden, das als Trennelement wirkt oder optische Tiefe schafft.

Bild/Firmenlogo: Dies ist ein Bild, das dem Header der Mail hinzugefügt werden kann. Sie können sowohl ein einfaches Logo als auch ein Banner verwenden, das über die gesamte Breite der E-Mail verläuft.

Inhalt der Nachricht: Dies ist der zentrale Teil der E-Mail, in den die Nachricht eingegeben wird.

Fußnote: Fußnoten schließen die Nachricht ab. Sie enthalten meistens Standardtext und unterscheiden sich von der eigentlichen Nachricht mindestens dadurch, dass der Text kleiner formatiert ist.

Für jedes E-Mail-Element stehen Ihnen im Bereich Stil verschiedene Optionen zur Verfügung:

E-Mail-Layout

§Hintergrundfarbe: Hier können Sie die Farben für den Außenrand und den Hintergrund des Mittelteils wählen.

§Randfarbe / Breite: Definieren Sie hier jeweils die Farbe und die Breite des Randes, der den Rahmen vom Mittelteil trennt.

Bild/Firmenlogo

§Bilddatei: Wählen Sie ein Bild aus, das im Mail-Header angezeigt werden soll. Klicken Sie auf die Schaltfläche [image] und importieren Sie die gewünschte Bilddatei im Format .JPG, .GIF oder .PNG.

§Ausrichtung: Wählen Sie hier, ob das Bild Links, Zentriert oder Rechts ausgerichtet sein soll.

§Position: Wählen Sie hier, ob das Bild Innerhalb des Rahmens oder Außerhalb des Rahmens der E-Mail-Nachricht positioniert werden soll.

§Breite: Hier wird automatisch die Originalbreite des Bildes angeziegt, die jedoch frei verändert werden kann. Die Maximalbreite für Bilder sind 700 Pixel und der Wert ist von dem jeweiligen E-Mail-Layout abhängig. Dieser Parameter gewährleistet die korrekte Anzeige in allen E-Mail-Clients.

Inhalt der Nachricht

§Hintergrundfarbe: Hier können Sie die Farbe für den Hintergrund der Nachricht auswählen.

§Textfarbe: Hier können Sie die Farbe für den Text der Nachricht auswählen.

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

Fußnote

§Hintergrundfarbe: Hier können Sie die Farbe für den Hintergrund der Fussnote auswählen.

§Textfarbe: Hier können Sie die Farbe für den Text der Fussnote auswählen.

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Ausrichtung: Wählen Sie hier, ob der Text Links, Zentriert oder Rechts ausgerichtet sein soll.

§Position: Wählen Sie hier, ob die Fußnote Innerhalb des Rahmens oder Außerhalb des Rahmens der E-Mail-Nachricht positioniert werden soll.

§Text: Geben Sie hier den Text Ihrer Fußnote ein. Als Standard ist ein Text über die Vertraulichkeit der Nachricht vordefiniert.


Introseite

Schritt 4 - Erweiterte Einstellungen >

Introseite

 Return to chapter overview
Versteckten Text zeigen/verstecken

Dieses Fenster enthält die Funktionen, mit denen Sie für Ihre Website eine Introseite mit Sprachauswahl erstellen können.

Wie der Name schon vermuten lässt, ist eine Introseite vergleichbar mit einem Deckblatt. In der Regel enthält sie lediglich ein Bild, ein Video oder eine Flash-Animation und der Besucher gelangt von hier zur Homepage, nachdem eine bestimmte Zeit verstrichen ist, oder indem er auf einen Link klickt. Falls gewünscht, kann die Introseite auch eine Sprachauswahl beinhalten, also Links, die zu den verschiedenen Sprachversionen der Website führen.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen zur Erstellung der Introseite

Da die Introseite ein fakultatives Element der Website ist, muss sie zunächst mit der Option Introseite anzeigen aktiviert werden. Sofern aktiviert, wird die Introseite als erste angezeigt und erst nach Verstreichen einer vordefinierten Zeit oder bei Klick auf einen entsprechenden Link gelangt der Besucher zur Homepage.

Die Introseite kann mit einem eigenen Hintergrund, Inhalten und eventuell einem Soundtrack individuell gestaltet werden.

Im Bereich Seiteninhalt stehen folgende Optionen zur Verfügung:

§Typ: Definieren Sie hier, welche Art von Inhalt in die Introseite eingefügt werden soll. Zur Auswahl stehen Bild, Flash-Animation, Video und HTML-Code.

§Datei: Wenn Sie unter Typ die Option Bild, Flash-Animation oder Video gewählt haben, können Sie jeweils Bilddateien in den Formaten .JPG, .GIF, .PNG, Flash-Dateien im Format .SWF oder Videodateien in den Formaten .FLV, ..MP4, .WEBM oder .OGG verwenden.

§HTML-Code: Wenn Sie unter Typ die Option HTML-Code gewählt haben, können Sie den Code für die Introseite eingeben. Es stehen folgende Funktionen zur Verfügung:

Ausschneiden [CTRL+X] - Kopieren [CTRL+C] - Einfügen [CTRL+V]

Ausschneiden, Kopieren und Einfügen von ausgewähltem Text.

Rückgängig [Strg+Z] - Wiederherstellen [ALT+UMSCHALT+BACKSPACE]

Zum Annullieren/Wiederherstellen der zuletzt durchgeführten/annullierten Operation.

Widgets einfügen

Fügt den Code des ausgewählten Widgets ein: Klicken Sie auf den Pfeil neben der Schaltfläche, um die Liste aller verfügbaren Widgets aus HTML und Widgets anzuzeigen. Mit einen Klick auf ein Widget wird das Dialogfenster Widget geöffnet, in dem Sie die vorgesehenen Parameter definieren können. Nach der Bestätigung der Eingabe wird der entsprechende HTML-Code erstellt und automatisch in den Editor eingefügt.

§Größe: Geben Sie hier die Breite und die Höhe des Bildes, der Flash-Animation, des Videos oder des HTML-Codes in Pixeln an. Wenn Sie die Option Größenverhältnis beibehalten aktiviert lassen, bleibt bei der Größeneinstellung die Proportion zwischen Breite und Höhe erhalten.

Im Bereich Seitenhintergrund stehen folgende Optionen zur Verfügung:

§Hintergrundfarbe: Wählen Sie die Hintergrundfarbe für die Introseite.

§Bilddatei: Wählen Sie hier das Bild für den Hintergrund der Zelle aus. Sie können Dateien in den Formaten JPG, GIF und PNG verwenden.

§Anordnung: Hier können Sie festlegen, ob das ausgewählte Hintergrundbild wiederholt werden soll. Das Bild kann nur horizontal, nur vertikal oder in beide Richtungen wiederholt werden, bis es den zur Verfügung stehenden Platz ausfüllt.

§Ausrichtung: Legen Sie hier fest, wie das Bild zum Browserfenster ausgerichtet werden soll.

Im Bereich Optionen können Sie schließlich folgende Einstellungen vornehmen:

§Ton: Hier können Sie eine Audiodatei (in dem .MP3 Format) auswählen, die als musikalische Untermalung während der Anzeige der Introseite verwendet werden soll.

§Zur Homepage nach [Sekunden]: Bei Aktivierung dieser Option können Sie angeben, nach wie vielen Sekunden von der Introseite automatisch zur Homepage gewechselt werden soll. Nach Ablauf des eingestellten Zeitintervalls wird automatisch die Homepage angezeigt.
Klicken Sie um zu erweitern/minimieren Anleitung: Optionen für die Spracheinstellung

Wenn Ihre Website in mehreren Sprachen verfügbar sein soll und Sie Besuchern die Möglichkeit geben wollen, die gewünschte Sprache auf der Introseite auszuwählen, aktivieren Sie zunächst die Option Links zu anderen Sprachen anzeigen.

In der Sprachliste können Sie die Sprachen festlegen, in denen die Website verfügbar sein soll. Standardmäßig enthält diese Liste 5 Sprachen, die jedoch mit den verfügbaren Schaltflächen jederzeit geändert werden können:

§Hinzufügen... / Entfernen: Für die Definition Ihrer individuellen Sprachliste können Sie hier eine neue Sprache hinzufügen (Dialogfenster Spracheinstellungen) oder eine bereits enthaltene Sprache löschen.

§Nach oben / Nach unten: Mit diesen Befehlen können Sie die Liste ordnen, indem Sie markierte Sprachen nach oben oder nach unten verschieben.

§Hauptsprache: Mit Klick auf diese Schaltfläche definieren Sie eine in der Sprachliste markierte Sprache als "Hauptsprache". Für jede Website muss eine Hauptsprache verfügbar sein, in der die Benutzer unmittelbar und vor der Sprachauswahl auf die Seite zugreifen können. Nur die Website in der Hauptsprache enthält die Introseiteo (für weitere Informationen, siehe Erstellen einer mersprächigen Website).

§Bearbeiten...: Öffnet das Dialogfenster Spracheinstellungen in dem Sie die Parameter einer in der Sprachliste ändern können.

Ferner steht folgende Option zur Verfügung:

§Links in neuem Fenster öffnen: Bei Aktivierung dieser Option wird die Website in einem neuen, von dem der Introseite verschiedenen Browserfenster geöffnet.

Auch wenn in Bezug auf die Introseite explizit die Gestaltung in mehreren Sprachen beschrieben wird, kann diese Funktion auch für andere Zwecke genutzt werden, um verschiedene Versionen einer Website zu gestalten. So können Sie beispielsweise die Auswahl zwischen einer HTML-Version und einer Flash-Version oder einer Version mit Eignung für ein minderjähriges Publikum und einer Version ausschließlich für Erwachsene einstellen.

Bei Aktivierung der Introseite wird in der Sitemap die Spezialseite „Introseite“ angezeigt. Sie können diese Seite auswählen und das Fenster Eigenschaften der Seite öffnen, um die Haupteigenschaften festzulegen.

Praktische Anwendung:

- | Sprachverwaltung für automatisch eingefügten Text
- | Erstellen einer mehrsprachigen Website


Spracheinstellungen Fenster

Schritt 4 - Erweiterte Einstellungen > Introseite >

Spracheinstellungen Fenster

 Return to chapter overview

In diesem Fenster, das sich mit Klick auf die Schaltfläche Hinzufügen... oder Bearbeiten... auf der Introseite eingestellt werden, in der die Website angeboten werden soll.

Folgende Optionen stehen zur Verfügung:

§Anzuzeigende Sprachbezeichnung: Geben Sie hier den Namen der Sprache ein, der angezeigt werden soll. Mit Klick auf den Pfeil neben dem Feld öffnet sich ein Dropdown-Menü mit einer Liste verschiedener Sprachen, aus der Sie die gewünschte auswählen können. Alternativ kann der Name der Sprache auch direkt eingegeben werden.

§Bilddatei für die Sprache (Flagge): Hier können Sie eine Bilddatei importieren, um den Link zur jeweiligen Sprachversion zu erstellen. Klicken Sie auf die Schaltfläche [image] und wählen Sie eine Datei im Format .JPG, .GIF oder .PNG aus, beispielsweise einen Button mit der entsprechenden Flagge.

Wird hier keine Bilddatei importiert, generiert das Programm automatisch einen Textlink mit der Anzuzeigende Sprachbezeichnung in einer Farbe, die zum Seitenhintergrund einen guten Kontrast bildet.

§Link für diese Sprache (z.B. Website in dieser Sprache anzeigen): Verlinkt das Bild, das mit der Option Bilddatei für die Sprache (Flagge) importiert wurde. Bei Klick auf die Schaltfläche [image] öffnet sich das Dialogfenster Link, in dem Sie den Aktionstyp des Links und die jeweiligen Optionen definieren können.

Wurde beispielsweise die Website in der von der Flagge angezeigten Sprache bereits veröffentlicht, kann die Aktion Datei oder URL gewählt und diese Website (z.B. http://www.meinewebsite.de/en/index.html). darüber verlinkt werden. Wenn Sie in der Sprache arbeiten, die als Hauptsprache eingestellt wurde, sehen Sie hingegen keinen Link, da sie automatisch mit der Homepage der aktiven Website verlinkt wird.

Hinweise zur Kompatibilität mit Vorgängerversionen:

Im Vergleich zur Vorgängerversion 9 wurde das Fenster Spracheinstellungen in der aktuellen Version 10 wie folgt aktualisiert:

§Die Option Serverpfad oder URL der Website für diese Sprache wurde durch die Option Link für diese Sprache (z.B. Website in dieser Sprache anzeigen): Auf diese Weise kann, wie vorher, der Link eingegeben werden, der zu einem Verzeichnis auf dem Server oder zur URL der Website in einer bestimmten Sprache führt, es stehen aber auch weitere Aktionen zur Verfügung.

§Die Option Sprache in der Auswahl anzeigen aber darauf hinweisen, dass sie noch nicht verfügbar ist steht nicht länger zur Verfügung, weil nun die Möglichkeit besteht, eine individuelle Meldung zu erstellen und das Flaggensymbol entsprechend zu verlinken.

Praktische Anwendung:

- | Sprachverwaltung für automatisch eingefügten Text
- | Erstellen einer mehrsprachigen Website


Werbebotschaft

Schritt 4 - Erweiterte Einstellungen >

Werbebotschaft

 Return to chapter overview
Versteckten Text zeigen/verstecken

Dieses Fenster enthält die Befehle, mit denen Sie eine Werbebotschaft für die Homepage oder alle Seiten der Website einstellen können.

Die Werbebotschaft kann ein Bild oder eine Flash-Animation sein, sie kann an einer bestimmten Position der Seite angezeigt werden und enthält den Link zu einer Landing Page (Zielseite). Natürlich sollte diese Landing Page, die nichts anderes als eine interne Seite der Website ist, gut geplant werden, um den Benutzer zu überzeugen, die gewünschte Aktion auszuführen: ein Formular auszufüllen, einen Artikel zu kaufen usw.

Klicken Sie um zu erweitern/minimieren Anleitung: Eine Werbebotschaft einstellen

Wenn Sie eine Werbebotschaft einfügen wollen, aktivieren Sie zunächst die Option Werbebotschaft anzeigen.

Um den Typ der Botschaft festzulegen, wählen Sie bitte eine der verfügbaren Optionen:

Werbung in der rechten oberen Ecke anzeigen: Dies ist der Anzeigemodus, der generell als PagePeel bezeichnet wird: Fährt der Betrachter mit dem Mauszeiger über die rechte obere Bildschirmecke, klappt die Fläche auf und es wird eine Werbebotschaft angezeigt.

Werbung im Kasten anzeigen: Die Werbebotschaft erscheint in einem Rechteck, das den Seiteninhalt überlagert und an einer bestimmten Position des Browserfensters angezeigt wird.

Werbung als horizontale Leiste anzeigen: Die Werbebotschaft erscheint in einer Leiste, die am oberen Rand des Browserfensters vor dessen Inhalt angezeigt wird oder im unteren Bereich den Seiteninhalt überlagert.

Für jeden ausgewählten Typ der Botschaft können unter Einstellungen jeweils weitere Optionen festgelegt werden:

§Bilddatei: Hier können Sie die Bilddatei (im Format .JPG, .GIF oder .PNG) oder eine Flash-Animation (im Format .SWF) auswählen, die Ihre Werbebotschaft enthält.

Für die Option Werbung in der rechten oberen Ecke anzeigen können zusätzlich folgende Einstellungen vorgenommen werden:

§Stil: Neben dem klassischen Eselsohr-Effekt (PagePeel) stehen weitere, auch themenspezifische Animationen zur Verfügung. Der Effekt bleibt dabei unverändert: Wird die Maus über die Animation bewegt, öffnet sich die eigentliche Werbebotschaft.

§Breite/Höhe: Hier können Sie einen Wert in Pixeln für die Breite und Höhe des Bereichs eingeben, der für die Anzeige der Werbebotschaft bestimmt ist.

Für die Option Werbung im Kasten anzeigen können zusätzlich folgende Einstellungen vorgenommen werden:

§Position: Hier können Sie festlegen, an welcher Position die Werbebotschaft im Browserfenster angezeigt werden soll. Zur Auswahl stehen die Positionen Mitte, Oben - Links, Oben - Rechts, Unten - Links und Unten - Rechts.

§Effekt: Stellen Sie hier den gewünschten Anzeigeeffekt ein. Zur Auswahl stehen die Optionen Einblenden, Einblenden von oben, Einblenden von unten, Einblenden von links und Einblenden von rechts.

§Diese Botschaft nur ein Mal anzeigen: Wenn Sie dieses Kontrollkästchen aktivieren, wird die Werbebotschaft nur ein Mal beim ersten Öffnen einer Seite der Website angezeigt. Auch beim Öffnen einer neuen Navigationssitzung erscheint die Werbebotschaft erneut.

Für die Option Werbung als horizontale Leiste anzeigen können zusätzlich folgende Einstellungen vorgenommen werden:

§Position: Hier können Sie festlegen, ob die Werbebotschaft oben vor dem Seiteninhalt angezeigt werden, oder im unteren Seitenbereich die Inhalte überlagern soll.

§Hintergrundfarbe: Hier können Sie das Dialogfenster Farben öffnen und für die horizontale Leiste, die die Werbebotschaft enthält, eine Hintergrundfarbe festlegen.

§Diese Botschaft nur ein Mal anzeigen: Wenn Sie dieses Kontrollkästchen aktivieren, wird die Werbebotschaft nur ein Mal beim ersten Öffnen einer Seite der Website angezeigt. Auch beim Öffnen einer neuen Navigationssitzung erscheint die Werbebotschaft erneut.

Die Einstellungen im Bereich Optionen stehen für alle Anzeigetypen zur Verfügung und sind die Folgenden:

§Link: Hier können Sie die Seite (Landing Page) bestimmen, die mit der Werbebotschaft verbunden ist. Bei Klick auf die Schaltfläche [image] öffnet sich das Dialogfenster Link, in dem Sie den Aktionstyp des Links und die jeweiligen Optionen definieren können.

§Ton: Hier können Sie den Sound (Format MP3) bestimmen, der während der Anzeige der Werbebotschaft wiedergegeben wird.

Was ist eine Landing Page?

Die Landing-Page ist eine Seite, die nach einem Klick z.B. auf einen Link oder ein Werbebanner erscheint und dem Besucher Informationen liefert. Wie der Name schon vermuten lässt, sollte diese Seite, auf der der Besucher "landet", so erstellt werden, dass er sofort die gewünschten Informationen erhält, ohne die Website durchsuchen zu müssen.

Der Mechanismus lässt sich gut an einem Beispiel verdeutlichen: Wir veröffentlichen ein Werbebanner, um ein Produkt zum Verkauf anzubieten. Ein Banner enthält nur die wesentlichen Informationen in kompakter Form, aber für den an unserer Website interessierten Besucher kann ein weiterführender Link eingestellt werden. In diesem Fall wäre die direkte Verlinkung auf unsere Homepage von Nachteil: Die Homepage ist zu allgemein gehalten, das heißt, der Besucher müsste erst durch die Seiten navigieren, bevor er die gewünschten Informationen über das Produkt und die Möglichkeiten, wie er es kaufen kann, findet. Dies birgt die Gefahr, einen potentiellen Kunden sofort wieder zu verlieren. Die beste Lösung besteht darin, eine Ad-hoc-Seite zu erstellen, auf der mit einem einfachen, zweckmäßigen Layout alle Informationen präsentiert werden, die der Anwender bezüglich des Produktes auf dem Werbebanner zu finden erwartet, einschließlich der Anleitungen für den Kauf. Oftmals muss eine solche Seite speziell zu diesem Zweck erstellt werden. Bei geschickter Umsetzung bietet sie jedoch den Vorteil, dass sie den Besucher, dessen Interesse unsere Werbebotschaft geweckt hat, direkt zum Ziel (beispielsweise zum Kauf eines Produkts) führt.

Für die Option Anzeigemodus können zusätzlich folgende Einstellungen vorgenommen werden:

§Nur auf der Homepage anzeigen / Auf allen Seiten anzeigen: In diesem Bereich können sie festlegen, ob die Werbebotschaft nur auf Ihrer Homepage oder auf allen Seiten der Website angezeigt werden soll.


Blog

Schritt 4 - Erweiterte Einstellungen >

Blog

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Fenster finden Sie die Instrumente und Optionen für die Erstellung eines Blogs und die Verwaltung der Kommentare, die Ihre Blogleser zu den Blogartikeln abgeben.

Ein Blog ist eine Art Web-Tagebuch, in dem der Autor in mehr oder weniger regelmäßigen Abständen Artikel (sogenannte Posts) veröffentlicht.

Nach der Veröffentlichung bildet der mit WebSite X5 erstellte Blog einen eigentändigen Bestandteil der Website und wird in der Sitemap unter Spezielle Seiten (siehe Erstellen der Sitemap) aufgeführt. Soll der Eintrag "Blog" in das Navigationsmenü aufgenommen werden, müssen Sie einen Alias der Speziellen Seite erstellen, indem Sie sie markieren und in den Ordner Menü ziehen.

Da der Blog Teil der Website ist, wird dort automatisch die grafische Vorlage der Website übernommen.

Der Blog wird unter der URL http://www.meinewebsite.de/blog veröffentlicht, wobei http://www.meinewebsite.de der URL der Website entspricht, mit der er verknüpft ist.

Auf der Hauptseite des Blogs erscheint die Liste aller veröffentlichter Artikel (oder Posts), die in chronologischer Reihenfolge aufgeführt sind. Von jedem Artikel werden der Titel, der Autor, die Kategorie, Datum und Uhrzeit der Veröffentlichung angezeigt und wenn die Option es als reduziert anzeigen aktiviert wurde wird die Kurzbeschreibung sowie der Link "Lesen..." angezeigt. Der Link "Lesen..." führt zur eigenständigen Seite des Blogposts: Hier wird der gesamte Text des Artikels angezeigt, gefolgt von der Liste der bereits veröffentlichten Kommentare und dem Formular, in das die Leser einen neuen Kommentar eingeben können.

Abgesehen von den jeweiligen Inhalten haben die Seiten des Blogs einen einheitlichen Aufbau mit einer Spalte am rechten Seitenrand, in der verschiedene Instrumente für die Navigation zur Verfügung stehen, wie zum Beispiel Links zu den neuesten Artikeln, zu einem Archiv (geordnet nach Monaten oder Kategorien) und Clouds. Diese Spalte kann nach den individuellen Anforderungen gestaltet werden, das heißt, Sie können festlegen, welche Instrumente in welcher Reihenfolge angezeigt werden sollen.

Wie bereits erwähnt, ist eine der Besonderheiten von Blogs, dass die Leser der Artikel Kommentare abgeben können. Auf diese Weise kann zwischen dem Autor des veröffentlichten Posts und seinen Lesern ein Dialog generiert werden. Um die Veröffentlichung unerwünschter Kommentare zu vermeiden, die beleidigend sind oder nicht zum Thema passen, ist eine Verwaltungsfunktion erforderlich. Hierfür stellt Ihnen WebSite X5 das Control Panel zur Verfügung.

Um einen Blog zu erstellen, müssen Sie lediglich einige allgemeine Parameter festlegen und eine Liste der Informationen erstellen, die Sie veröffentlichen wollen.

Nach der Erstellung des Blogs sollten Sie in regelmäßigen Abständen neue Artikel veröffentlichen, um das Interesse Ihrer Leser wachzuhalten. Hierfür steht Ihnen im Dialogfenster Nur RSS-Feed/Blog hochladen die Option Export der Website ins Internet zur Verfügung.

Die Funktionen, die Sie für die Konfiguration des Blogs und für die Erstellung der Artikel benötigen, sind in die Bereiche Posts, Layout und Kommentare gegliedert.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Posts

Mit den Optionen in diesen Bereich können Sie einige allgemeine Parameter definieren und die Liste der Artikel (Posts) erstellen, die im Blog veröffentlicht werden sollen.

Im Bereich Allgemeine Einstellungen stehen folgende Optionen zur Verfügung:

§Titel: Geben Sie hier einen Titel für Ihren Blog ein. Dieser Titel wird in der Titelleiste des Browsers angezeigt und ist ein wichtiger Parameter, damit Benutzer Ihren Blog in Suchmaschinen finden.

Wenn Sie Ihrem Blog keinen eigenen Titel geben, wird automatisch der Titel verwendet, den Sie im Dialogfenster Allgemeine Einstellungen | Allgemein für Ihre Website eingegeben haben.

§Beschreibung: In dieses Feld können Sie eine Kurzbeschreibung Ihres Blogs eingeben. Diese Beschreibung sollte prägnant und aussagekräftig für den Blog sein, da sie vom HTML-Code als Metatag <description> verwendet und von den Spidern der Suchmaschinen analysiert wird.

Wenn Sie für Ihren Blog keine Beschreibung eingeben, wird automatisch die Beschreibung Ihrer Website verwendet, die Sie im Dialogfenster Allgemeine Einstellungen | Allgemein eingegeben haben.

§RSS-Feed aus den Bloginhalten erstellen: Mit dieser standardmäßig aktivierten Funktion wird automatisch ein RSS-Feed all Ihrer Blog-Posts erstellt. Die RSS-Feed der Bloginhalte werden auf http://www.meinewebsite.de/blog/x5feed.xml wobei http://www.meinewebsite.de die URL der Website ist, mit der diese verlinkt sind.

Der Bereich Liste der Posts bietet eine Übersicht mit den Spalten Titel, Autor, Kategorie und Datum aller bereits geposteten Artikel sowie einige Schaltflächen für die Verwaltung:

§Hinzufügen...: Öffnet das Dialogfenster Post erstellen, in dem Sie einen neuen Artikel eingeben können.

§Entfernen: Mit dieser Schaltfläche können Sie einen markierten Artikel aus der Liste der Posts löschen.

§Bearbeiten...: Öffnet das Dialogfenster Post erstellen in dem Sie einen markierten Artikel aus der Liste der Posts bearbeiten können.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Layout

Mit den Optionen in diesen Bereich können Sie einige grafische Eigenschaften für den Blog festlegen.

Im Bereich Generell stehen folgende Optionen zur Verfügung:

§Anzeigemodus für Posts: Sie können einstellen, dass nur der erste Artikel komplett und alle anderen verkürzt oder dass alle komplett oder alle verkürzt angezeigt werden. Verkürzt angezeigte Artikel werden nur mit einer kurzen Beschreibung präsentiert, hinter der ein Link „Weiterlesen“ angezeigt wird.

§Anzeigen des 'AddThis'-Buttons, um die Inhalte der Internet-Community zugänglich zu machen.: Wenn Sie diese Option aktivieren, wird unter jedem Blog-Post automatisch der Button "AddThis" angezeigt. Klickt der Leser diesen Button an, erscheint ein Untermenü mit einer Liste der bekanntesten Social Networks. Wenn er über ein Profil in einem dieser Netzwerke verfügt, kann er es auswählen und den Link zum Post in diesem Netzwerk teilen.

§Button-Typ: Wählen Sie hier den gewünschten "AddThis"-Button aus dem Dropdown-Menü.

§AddThis-Account: Wenn Sie über ein Konto bei AddThis verfügen, können Sie dies hier angeben. Mit einem solchen Konto erhalten Sie Zugriff auf Statistiken über die Nutzungshäufigkeit des Dienstes AddThis.

Um weitere Informationen über AddThis zu erhalten und um ein Konto anzumelden, klicken Sie bitte auf den Button [image] um zur offiziellen Website des Dienstes: www.addthis.com zu gelangen.

Der Bereich Seitenblöcke bietet eine Übersicht mit den Spalten Titel, Typ und Breite die in die rechte Spalte des Blogs eingefügt wurden, sowie die Schaltflächen für die Erstellung solcher Blöcke:

§Hinzufügen...: Öffnet das Dialogfenster Seitenblock zur Erstellung eines neuen Blocks.

§Duplizieren: Hier können Sie von einem bestehenden, markierten Block eine Kopie erstellen.

§Entfernen: Mit Klick auf diese Schaltfläche löschen Sie einen markierten Block aus der Liste Seitenblöcke.

§Nach oben / Nach unten: Mit diesen Schaltflächen können Sie einen markierten Block in der Liste Seitenblöcke vor oder hinter den jeweils benachbarten verschieben.

§Bearbeiten...: Öffnet das Dialogfenster Seitenblock, in dem Sie einen markierten Block aus der Liste Seitenblöcke bearbeiten können.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Kommentare

Mit den Optionen in diesen Bereich können Sie die Kommentare Ihrer Blog-Leser verwalten.

Damit Besucher die im Blog veröffentlichten Artikel kommentieren können, müssen Sie die Option Kommentare zum Blog zulassen aktivieren.

Anschließend müssen Sie die Art des Inhalts festlegen. Zur Auswahl stehen die folgenden Optionen:

Kommentar und Abstimmung: Die Besucher können einen Kommentar und zusätzlich eine Bewertung abgeben.

Kommentar: Die Besucher können einen Kommentar, aber keine Bewertung abgeben.

Abbstimung: Die Besucher können eine Bewertung, aber keinen Kommentar abgeben.

Im Bereich Einstellungen für Kommentare stehen folgende Optionen zur Verfügung:

§Anzeigemodus: Definiert, ob die Kommentare von Besuchern direkt online angezeigt werden können oder erst im Control Panel online genehmigt werden müssen.

§Bestellung anzeigen: Definiert, in welcher chronologischen Reihenfolge die veröffentlichten Kommentare angezeigt werden sollen, d.h. mit den neuesten oben oder umgekehrt.

§Button 'Missbrauch melden' anzeigen: Bei Aktivierung dieser Option wird ein Button "Missbrauch melden" eingeblendet, über den Besucher eventuell inkorrektes Verhalten anderer Nutzer signalisieren können.

§Antispam-Filter 'Captcha' aktivieren: Bei Aktivierung dieser Option wird am Ende des Kommentar-Formulars die Anti-Spam-Kontrolle Captcha eingefügt. Bei dieser Methode werden einige Buchstaben verzerrt auf einem verworrenen Hintergrund dargestellt. Der Anwender muss die Buchstaben korrekt in das angezeigte Feld eingeben, um den Kommentar senden zu können.

§Stil für Bewertung: Definiert den Stil des grafischen Elements (z.B. eine Reihe mit 5 Sternen) zur Abgabe von Bewertungen. Dies ist die einzige verfügbare Option, wenn Abbstimung als Art des Inhalts gewählt wurde.

Im Bereich Datenspeichermodus können Sie festlegen wie die Daten, die über das Formular gesammelt wurden um ein Kommentar hinterzulassen, gerettet und dem Betreiber der Website gesendet werden sollen:

§Datenunterordner auf dem Server speichern: Definiert, in welchem Unterverzeichnis mit PHP-Schreibzugriff die Daten auf dem Server gespeichert werden. Das Hauptverzeichnis auf dem Server wird mit der Option Serververzeichnis mit Schreibzugriff festgelegt, die Sie im Fenster Datenmanagement finden. Wurde kein Unterverzeichnis definiert, werden die Daten direkt im Hauptverzeichnis auf dem Server gespeichert.

§Bei Empfang eines Kommentars E-Mail-Benachrichtigung senden: Bewirkt, dass bei Eingang neuer Daten automatisch eine Benachrichtigungs-E-Mail versendet wird.

§E-Mail des Empfängers: Gibt die Adresse an, an die die E-Mail mit der Benachrichtigung über den Eingang neuer Daten gesendet werden soll.

Normalerweise gestatten Provider den Schreibzugriff in jedem Verzeichnis des Servers. In diesem Fall ist es nicht notwendig, einen Pfad zum öffentlichen Ordner anzugeben. Andernfalls müssen Sie den vollständigen Pfad zum öffentlichen Ordner bei Ihrem Webspace-Provider erfragen.

Im Bereich WebSite Test des Control Panels online können Sie prüfen, ob das angegebene Verzeichnis mit Schreibzugriff und die eventuellen Unterverzeichnisse existieren sowie, wenn dies der Fall ist, ob in diese Verzeichnisse effektiv Daten geschrieben werden können.

Wenn Sie einen Blog erstellen, automatisch die Spezialseite „Blog“ in die Sitemap eingefügt. Sie können diese Seite auswählen und das Fenster Eigenschaften der Seite öffnen, um die Haupteigenschaften festzulegen.

Praktische Anwendung:

-

Management der Blog- und Gästebuch-Kommentare im Control Panel

Zusatzinformationen:

-

Control Panel online


Post erstellen Fenster

Blog | Post erstellen

Schritt 4 - Erweiterte Einstellungen > Blog >

Blog | Post erstellen

 Return to chapter overview
Versteckten Text zeigen/verstecken

Im Fenster Post erstellen, das sich mit der Schaltfläche Hinzufügen... oder Bearbeiten... im Fenster Blog | Posts öffnet, können Sie einen Blog-Artikel schreiben oder einen bestehenden ändern.

Dieses Dialogfenster gliedert sich in die folgenden Bereiche: Allgemein und Erweitert.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen der Sektion Allgemein

Folgende Optionen stehen zur Verfügung:

§Titel: Geben Sie hier die Überschrift Ihres Artikels ein.

§Veröffentlichungsdatum: Hier können Sie das Datum der Veröffentlichung Ihres Artikels aus dem Kalender auswählen.

§Autor: Hier kann der Autor des Artikels angegeben werden. Sie können den Namen direkt eingeben oder die Dropdown-Liste öffnen und einen der bereits eingegebenen Namen auswählen.

§Kategorie: Wählen Sie hier, welcher Kategorie Ihr Artikel zugeordnet werden soll. Ebenso wie beim Feld Autor können Sie den Namen einer neuen Kategorie angeben oder eine bestehende aus der Dropdown-Liste wählen.

§Tag: Geben Sie hier die Tags ein, also Schlagwörter oder kurze Infos zum Thema Ihres Artikels. Den Artikeln können auch mehrere Tags zugewiesen werden. Trennen Sie diese durch Kommas, zum Beispiel: "tag1, tag2, tag3, ...".

§Inhalt: Hier geben Sie Ihren Artikel in einen Editor ein, der mit dem unter Objekt Text identisch ist.

§Kurzbeschreibung: Hier können Sie eine kurze Beschreibung Ihres Artikels eingeben.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen der Sektion Erweitert

Folgende Optionen stehen zur Verfügung:

§Link zu Video/Audio: Hier können Sie eine Audiodatei (Formate .MP3, .WMA, .WAV, .MID, .AIF, .M4A) oder eine Videodatei (Formate .MP4, .FLV, .AVI, .WMV, .MPG, .MOV) auswählen, die mit dem Artikel verknüpft wird. Wenn Sie diese Option verwenden, wird automatisch ein Link zur Audio/Videodatei erstellt, der unterhalb des Artikels erscheint.

Sie können das Video auch direkt in den Artikel einfügen, indem Sie bei der Erstellung des Posts den entsprechenden HTML-Code manuell in den Texteditor eingeben.

Beispielsweise ist es möglich, den Code eines YouTube-Videos, wie es im Portal angezeigt wird, zu kopieren und in den Artikel einzufügen.

§Quellen des Eintrags: Hier können Sie ein Quellverzeichnis für Ihren Artikel erstellen. Hierzu stehen Ihnen folgende Optionen zur Verfügung:

-Hinzufügen... / Entfernen: Hier können Sie eine neue Quelle hinzufügen oder eine bestehende entfernen.

-Nach oben / Nach unten: Hier können Sie die Anzeigereihenfolge der eingetragenen Quellen verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

-Bearbeiten: Hier können Sie einen markierten Eintrag bearbeiten. Um eine Quelle korrekt einzugeben, muss der Name der Website, gefolgt von der URL zwischen den Zeichen < > eingegeben werden (Beispiel:WebSite X5 <http://www.websitex5.com>"). Als Quelle wird nur der Text angezeigt, während die URL zur Erstellung des Links verwendet wird.

§Kommentarfunktion für Benutzer sperren: Bei Aktivierung des Kontrollkästchens können Ihre Leser den erstellten Artikel nicht kommentieren.

Praktische Anwendung:

-

Management der Blog- und Gästebuch-Kommentare im Control Panel

Zusatzinformationen:

-

Control Panel online


Seitenblock Fenster

Blog | Seitenblock

Schritt 4 - Erweiterte Einstellungen > Blog >

Blog | Seitenblock

 Return to chapter overview
Versteckten Text zeigen/verstecken

Im Fenster Seitenblock, das sich mit der Schaltfläche Hinzufügen oder Bearbeiten im Fenster Blog | Layout öffnet, können Sie die Blöcke definieren, die in der rechten Spalte aller Blogseiten angezeigt werden.

Dieses Dialogfenster gliedert sich in die folgenden Bereiche: Allgemein und Stil.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den Funktionen in diesem Bereich erstellen Sie die Liste der Content-Blöcke, die die Seiten Ihres Blogs vervollständigen.

Zur Auswahl stehen folgende Block-Typen:

Letzte Posts: Block, in dem die zuletzt veröffentlichten Posts angezeigt werden. Mit Klick auf den Titel gelangt der Leser zur Seite des jeweiligen Artikels.

Kategorien: Dieser Block enthält die Liste aller Kategorien, in denen Sie Ihre Blog-Posts organisiert haben. Bei Klick auf eine Kategorie wird eine Liste der Artikel angezeigt, die dieser Kategorie zugeordnet wurden.

Monatliche Posts: Block mit einer Liste der veröffentlichten Posts, nach Monaten geordnet.

Clouds: Block mit einer Anzeige aller Kategorien oder Tags, die veröffentlichten Artikeln zugewiesen wurden. Die Anzeige erfolgt in einer Cloud, das heißt mit unterschiedlicher Textgröße je nach Anzahl der zugewiesenen Posts: Je mehr Posts einer bestimmten Kategorie oder einem bestimmten Tag zugeordnet wurden, desto größer wird die Schrift dargestellt. Bei Klick auf einen Eintrag (Kategorie oder Tag) wird eine Liste der Artikel angezeigt, die diesem Eintrag zugeordnet wurden.

Blogroll: Hier wird eine Liste anderer Websites oder Blogs angezeigt, die Sie Ihren Lesern durch Verlinkung empfehlen möchten.

Facebook: Dieser Block nutzt das Social Plugin "Like Box" von Facebook, mit dem die Benutzer:

§sehen können, wie vielen Personen und/oder Freunden die jeweilige Facebook-Seite gefällt;

§die neuesten, auf der jeweiligen Facebook-Seite veröffentlichten Posts lesen können;

§signalisieren können, dass ihnen die jeweilige Facebook-Seite gefällt, ohne sie besuchen zu müssen.

Google AdSense Werbung: Block für die Anzeige von Google AdSense™ Werbung.

HTML-Code: Dieser völlig frei programmierbare Block kann genutzt werden, um beliebige Funktionen einzufügen, die nicht automatisch vom Programm vorgesehen sind.

Je nach Typ des ausgewählten Blocks werden verschiedene Optionen angeboten, mit denen Sie arbeiten können.

Für alle Blöcke gemeinsame Optionen:

§Titel: Geben Sie hier einen Titel für den Block ein.

§Breite: Definieren Sie hier die Breite des Blocks.

Neben diesen allgemeinen Eigenschaften stehen für die einzelnen Blöcke folgende spezifische Optionen zur Verfügung:

Letzte Posts / Kategorien /

Monatliche Posts:

§Höchstzahl Einträge: Hier können Sie festlegen, wie viele Einträge in einem Block höchstens angezeigt werden sollen.

Clouds:

§Kategorien als Cloud anzeigen / Tags als Cloud anzeigen: Wählen Sie hier, ob die Clouds aus den Kategorien oder den Tags der veröffentlichten Artikel erstellt werden sollen.

Blogroll:

§Blogroll: Hier können Sie die Liste der empfohlenen Websites erstellen. Hierzu stehen Ihnen folgende Optionen zur Verfügung:

-Hinzufügen / Entfernen: Neue Websites hinzufügen bzw. markierte löschen.

-Nach oben / Nach unten: Hier können Sie die Anzeigereihenfolge der empfohlenen Websites verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

-Bearbeiten: Hier können Sie einen markierten Eintrag bearbeiten. Sie können einen Eintrag auch bearbeiten, wenn Sie erneut darauf klicken.

Um eine Website-Empfehlung korrekt einzufügen, muss der Name, gefolgt von der URL zwischen den Zeichen < > eingegeben werden (Beispiel: "WebSite X5 <http://www.websitex5.com>"): Im Blogroll wird nur der Text angezeigt, während die URL zur Erstellung des Links verwendet wird.

Facebook:

§Facebook-URL: Geben Sie hier die URL der Facebook-Seite ein, die Sie präsentieren möchten.

§Hintergrundfarbe: Wählen Sie, ob der Hintergrund des Blocks hell oder dunkel sein soll.

§Höhe: Definieren Sie hier die Blockhöhe in Pixeln.

§Facebook Connections anzeigen: Bei Aktivierung dieser Option werden im Block auch die Profilfotos der Freunde (Connections) angezeigt.

§Stream anzeigen: Bei Aktivierung dieser Option werden im Block automatisch die letzten Pinnwandeinträge der präsentierten Facebook-Seite angezeigt.

§Facebook Header anzeigen: Bei Aktivierung dieser Option wird im Block auch der Facebookheader angezeigt.

Google AdSense Werbung:

§HTML-Code Google AdSense: Hier kann der von Google AdSense™ bereitgestellte HTML-Code zur Anzeige von Werbe-Botschaften eingefügt werden.

HTML-Code:

§HTML-Code: Hier können Sie frei HTML-Code eingeben, um einen individuellen Block zu erstellen.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Stil

Mit den Funktionen in diesem Bereich können Sie die Content-Blöcke, die die Seiten Ihres Blogs vervollständigen, grafisch gestalten.

Im Bereich Text stehen folgende Optionen zur Verfügung:

§Schriftart: Definiert die Schriftart, den Schriftschnitt und die Größe des Textes.

§Textfarbe: Definiert die Farbe, die für den Text benutzt werden soll.

§Rand: Abstand zwischen dem Blockrand und dem enthaltenen Text in Pixeln.

Unter Hintergrund stehen hingegen folgende Optionen zur Verfügung:

§Hintergrundfarbe: Hier kann die Farbe für den Hintergrund auswählt werden.

§Bilddatei: Wählen Sie hier das Bild für den Hintergrund der Zelle aus. Sie können Dateien in den Formaten JPG, GIF und PNG verwenden.

§Anordnung: Hier können Sie festlegen, ob das ausgewählte Hintergrundbild wiederholt werden soll. Das Bild kann nur horizontal, nur vertikal oder in beide Richtungen wiederholt werden, bis es den zur Verfügung stehenden Platz ausfüllt.

§Ausrichtung: Legen Sie hier fest, wie das Hintergrundbild zur Blockfläche ausgerichtet werden soll.

Unter Rand stehen schließlich folgende Optionen zur Verfügung:

§Breite: Definiert die Breite der Ränder, auch einzeln.

§Farbe: Definiert die Farbe der Ränder, auch einzeln.

§Abgerundete Ecken: Definiert die Rundung der Ecken, auch einzeln.

§Schatten: Fügt einen Schatten ein, dessen Farbe, Position, Streuung und Breite definiert werden können.

Praktische Anwendung:

-

Management der Blog- und Gästebuch-Kommentare im Control Panel

Zusatzinformationen:

-

Control Panel online


RSS-Feed

Schritt 4 - Erweiterte Einstellungen >

RSS-Feed

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Fenster finden Sie die Werkzeuge und Optionen zur Erstellung eines RSS-Feeds. RSS-Feeds zählen zu den verbreitetsten Formaten für die Verbreitung von Inhalten im Web.

Ein RSS-Feed ist ein sehr vielseitiges Instrument für die Verbreitung von Nachrichten, Bildern und Videos: Es erweist sich als nützlich, wenn man viele Nachrichten mit einer gewissen Regelmäßigkeit anbieten oder über Ereignisse, Aktualisierungen an einer Website oder neue Posts und Kommentare eines Blogs informieren möchte.

Besucher, die den RSS-Feed einer Website abonnieren, werden konstant informiert und können die Meldungen direkt in ihrem Feedreader lesen.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Bedienelemente um ein RSS-Feed erstellen

Um einen RSS-Feed zu erstellen, müssen Sie lediglich einige allgemeine Parameter festlegen und die Liste der Meldungen erstellen, die Sie verbreiten wollen.

Der Bereich Liste der Posts bietet eine Übersicht mit den Spalten Titel und Datum der bereits eingegebenen Informationen sowie einige Schaltflächen für die Verwaltung:

§Hinzufügen...: Öffnet das Dialogfenster Post erstellen in dem Sie einen neuen Artikel eingeben können.

§Entfernen: Mit dieser Schaltfläche können Sie einen markierten Artikel aus der Liste der Posts löschen.

§Bearbeiten...: Öffnet das Dialogfenster Post erstellen in dem Sie einen markierten Artikel aus der Liste der Posts bearbeiten können.

Neben der Artikelliste müssen folgende Parameter im Bereich Allgemeine Einstellungen definiert werden:

§Titel: (Pflichtfeld)Geben Sie hier den Titel des mit der Website verknüpften RSS-Feeds ein.

§Bild: Hier können Sie ein Bild (Format .JPG, .GIF oder .PNG) auswählen, das dem RSS-Feed zugeordnet werden soll. Dieses Bild (in der Regel das Logo des Unternehmens oder der Website) wird im Feedreader angezeigt.

§Beschreibung: (Pflichtfeld)Geben Sie hier eine Beschreibung für den mit der Website verknüpften RSS-Feed ein.

Wenn Sie die Funktionsfähigkeit der lokal erstellten Website testen, weist eine Meldung darauf hin, dass der RSS-Feeds erst funktionieren, wenn die Website online ist.


Post erstellen Fenster

RSS-Feed | Post erstellen

Schritt 4 - Erweiterte Einstellungen > RSS-Feed >

RSS-Feed | Post erstellen

 Return to chapter overview

Das Dialogfenster Post erstellen, das sich nach dem Anklicken der Schaltflächen Hinzufügen... oder Bearbeiten... öffnet, die sich im RSS-Feed Fenster finden, bieten die Möglichkeit RSS-Feeds herzustellen oder zu bearbeiten.

§Titel: Geben Sie hier die Überschrift Ihres Artikels ein.

§Veröffentlichungsdatum: Hier können Sie das Datum der Veröffentlichung Ihres Artikels aus dem Kalender auswählen.

§Inhalt: Hier geben Sie Ihren Artikel in einen Editor ein, der mit dem unter Objekt Text identisch ist.

§Link zur Seite: Mit der Schaltfläche neben dem Feld öffnen Sie die Sitemap, um festzulegen, mit welcher Seite der Artikel verknüpft werden soll.


Datenmanagement

Schritt 4 - Erweiterte Einstellungen >

Datenmanagement

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Fenster legen Sie die Methoden zur Verwaltung der Daten fest, die in bestimmten Bereichen der Website wie in E-Mail-Formularen, im Blog, im Gästebuch erfasst werden.

Mit den verfügbaren Funktionen Datenbank kann eine Liste der mit dem jeweiligen Projekt verknüpften Datenbanken erstellt werden, um diese komfortabel zu bearbeiten. Alle bereits erstellten Datenbanken werden in einer Übersicht mit den Parametern Beschreibung, Datenbankname, Hostname und Benutzername angezeigt.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen zum Erstellen der Datenbankliste

Zum Erstellen einer Datenbankliste, die mit dem aktiven Projekt verknüpft ist, stehen folgende Funktionen zur Verfügung:

§Hinzufügen...: Öffnet das Fenster Datenbankeinstellungen zum Erstellen einer neuen Datenbank.

§Entfernen: Die in der Liste ausgewählte Datenbank wird gelöscht.

§Bearbeiten...: Öffnet das Fenster Datenbankeinstellungen zum Ändern von Daten einer ausgewählten Datenbank. Das Dialogfenster öffnet sich auch mit Doppelklick auf eine Datenbank.

Die mit dem Projekt vernüpfte Datenbankliste muss erstellt werden, bevor eine Datenbank für die Datenübertragung aus dem Objekt E-Mail-Formular genutzt werden kann.
Klicken Sie um zu erweitern/minimieren Anleitung: Optionen für das Senden von E-Mails und das Speichern auf dem Server

Mit den Optionen im Bereich E-Mail senden können die Methoden für den E-Mail-Versand definiert werden:

§Scripttyp für E-Mail-Versand: Wählen Sie hier, welches Skript für den E-Mail-Versand durch WebSite X5, beispielsweise aus dem Objekt E-Mail-Formular oder dem Warenkorb für E-Commerce, verwendet werden soll. Voreingestellt ist das vollständige Skript. Funktioniert dieses Skript aufgrund der Konfiguration des verwendeten Servers nicht, wird empfohlen, eine der anderen Optionen, also das Skript für Server mit minderer Qualität oder das Low-Level-Skript auszuprobieren.

§Methoden für den Datenversand des E-Mail-Formulars: Hier können Sie die Methode für den Datenversand des Objekts E-Mail-Formular festlegen. Der voreingestellte Standard ist POST. Da einige Server aber möglicherweise hierfür nicht angemessen konfiguriert sind, kann auch die Methode GET gewählt werden.

Wie Sie wissen, ist HTTP (Hypertext Transfer Protocol) das Hauptprotokoll für die Datenübertragung im WEB. Dieses Protokoll arbeitet auf der Grundlage eines Anfrage-Antwort-Mechanismus, bei dem der Client eine Anfrage sendet und der Server die Antwort zurückgibt. Im Allgemeinen ist somit Ihr Browser der Client und die Website der Server.

Die HTTP-Anfragen und -antworten haben natürlich eine bestimmte Syntax. In den Anfragen muss eine Methode angegeben werden und die gebräuchlichsten sind GET und POST.

Bei der Methode GET bildet der Inhalt der angegebenen Ressource den Gegenstand der Anfrage (zum Beispiel eine Website, die angezeigt werden soll).

Die Methode POST hingegen wird generell verwendet, um Informationen an den Server zu senden (zum Beispiel Daten eines Formulars).

Im speziellen Fall der E-Mail-Formulare ist es somit korrekter, die Methode POST zu verwenden. Wird diese jedoch vom Server nicht unterstützt, können Sie mit WebSite X5 alternativ die Methode GET nutzen.

Und schließlich können Sie das Verzeichnis mit Schreibzugriff festlegen:

§Serververzeichnis mit Schreibzugriff: Geben Sie in dieses Feld den Pfad zu dem Verzeichnis auf dem Server ein, in dem der PHP-Code Schreibzugriff auf die Dateien zulässt.

Normalerweise gestatten Provider den Schreibzugriff in jedem Verzeichnis des Servers. In diesem Fall ist es nicht notwendig, einen Pfad zum öffentlichen Ordner anzugeben. Andernfalls müssen Sie den vollständigen Pfad zum öffentlichen Ordner bei Ihrem Webspace-Provider erfragen.

Im Bereich WebSite Test des Control Panels online können Sie prüfen, ob das angegebene Verzeichnis mit Schreibzugriff und die eventuellen Unterverzeichnisse existieren sowie, wenn dies der Fall ist, ob in diese Verzeichnisse effektiv Daten geschrieben werden können.


Datenbankeinstellungen Fenster

Datenbankeinstellungen

Schritt 4 - Erweiterte Einstellungen > Datenmanagement >

Datenbankeinstellungen

 Return to chapter overview

In diesem Fenster, das sich mit dem Befehl Hinzufügen... im Fenster Datenmanagement öffnet, können Sie die Einstellungen für eine neue, mit dem aktiven Projekt verknüpfte Datenbank vornehmen.

Folgende Datenbankeinstellungen müssen vorgenommen werden:

§Beschreibung: Dies ist ein Name, der der Datenbank frei zugewiesen werden kann, um sie leichter zu identifizieren.

§Hostname: Geben Sie hier die URL des MySQL-Servers ein, auf dem sich die zu verwendende Datenbank befindet. In den meisten Fällen liegt die Datenbank auf dem gleichen Server wie die Website, mit der sie verknüpft ist, und kann daher als "localhost" identifiziert werden. In jedem Fall empfiehlt es sich, diesen Parameter beim Webspace-Anbieter zu erfragen.

§Datenbankname: Geben Sie in dieses Feld den Namen der Datenbank ein, mit der Sie arbeiten möchten (beim Provider erfragen).

§Benutzername: Geben Sie hier den Benutzernamen ein, mit dem Sie auf die Online-Datenbank zugreifen können (beim Provider erfragen).

§Passwort: Geben Sie hier das Passwort ein, mit dem Sie auf die Online-Datenbank zugreifen können (beim Provider erfragen).


Zugangsverwaltung

Schritt 4 - Erweiterte Einstellungen >

Zugangsverwaltung

 Return to chapter overview
Versteckten Text zeigen/verstecken

In dieser Ansicht können Sie Benutzerprofile erstellen und verwalten. Sie können festlegen, welche Benutzer Zugang zum passwortgeschützten Bereich erhalten sollen, also zu den Seiten, die in der Phase Erstellen der Sitemap als Geschützte Seiten definiert wurden.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen um Benutzerprofile zu erstellen

Im Bereich Gruppen und Benutzer mit Zugang zu den Geschützten Seiten wird eine Übersicht angezeigt, in der die bereits erstellten Gruppen/Benutzer, deren Benutzername und eventuell zugewiesene Anmerkungen aufgeführt sind.

Rechts neben der Tabelle finden Sie Schaltflächen zum Erstellen neuer Gruppen und Benutzer, denen der Zugang zu den geschützten Seiten der Website gewährt werden soll.

§Neue Gruppe: Erstellen einer neuen Gruppe, um Benutzer in Kategorien zu gliedern und die Verwaltung zu vereinfachen. Gruppen haben keine besonderen Einstellungen: Sie dienen lediglich als "Behälter" und werden daher direkt in die Übersicht übernommen. Mit einem Doppelklick auf eine bereits erstellte Gruppe kann diese umbenannt werden.

Um die Benutzerzugänge optimal zu organisieren, können auch Untergruppen erstellt werden: Hinsichtlich der nutzbaren Gruppen und Untergruppen besteht keine spezifische Einschränkung.

Nach der Installation sind standardmäßig zwei Gruppen vorinstalliert: Administratoren und Benutzer. Die Gruppe Administratoren ist für die Administratoren der Website, die automatisch Zugriff auf alle geschützten Seiten haben.

Mit ihren Zugangsdaten (Benutzername und Passwort) können die Administratoren auf das Control Panel können die Administratoren auf das Control Panel online (http://www.meinewebsite.de/admin wobei http://www.meinewebsite.de die URL Ihrer Website ist) zugreifen, um dort die Kommentare zu Posts im Blog und die Gästebucheinträge zu verwalten sowie Informationen für die Diagnose und Suchmaschinenoptimierung anzuzeigen.

§Neuer Benutzer: Mit Klick auf die Schaltfläche Benutzereinstellungen öffnet sich ein Dialogfenster, in dem innerhalb der ausgewählten Gruppe ein neuer Benutzer mit entsprechenden Zugangsdaten angelegt werden kann.

§Alias erstellen: Bei Klick auf diese Schaltfläche wird von dem ausgewählten Benutzer ein Alias erstellt. Diese Option erweist sich als nützlich, wenn ein Benutzer in mehrere Gruppen aufgenommen werden soll, um ihm Zugang zu verschiedenen geschützten Seiten zu gewähren. Daher ist die Option nicht für die Benutzer der Gruppe Administratoren aktiv, weil diese automatisch Zugang zu allen geschützten Seiten haben. Ein Alias bleibt stets mit dem Benutzer verknüpft. jede Änderung am Benutzer-Konto wird automatisch auch auf dessen Alias angewendet. Um einen Alias schnell zu erstellen, können Sie alternativ einen Benutzer markieren, in eine andere Gruppe ziehen und STRG drücken, bevor Sie die Maustaste loslassen.

§Entfernen: Mit diesem Befehl kann nach Markierung eine bestehende Gruppe bzw. ein bestehender Benutzer gelöscht werden. Die Gruppe Administratoren und der darin angelegte Benutzer Admin, die standardmäßig angelegt sind, können nicht gelöscht werden.

§Bearbeiten...: Diese Schaltfläche öffnet das Dialogfenster Benutzereinstellungen, in dem die Einstellungen für den ausgewählten Benutzer geändert werden können.

Nachdem Sie die Benutzer mit ihren jeweiligen Zugangsdaten erstellt und in Gruppen organisiert haben, können Sie zu Schritt 2 - Erstellen der Sitemap zurückkehren, um dort die Seiten zu definieren, die geschützt werden sollen, sowie um festzulegen, welche Gruppen bzw. Benutzer welche geschützten Seiten anzeigen können.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen zur Zugangsverwaltung

Unter der Übersicht stehen im Bereich Einstellungen der Eingabeseite für Login und Passwort folgende Optionen zur Verfügung:

§Willkommensnachricht: Hier können Sie einen Text eingeben, der angezeigt wird, wenn der Benutzer eine geschützte Seite öffnen möchte, ohne sich zuvor eingeloggt zu haben. In diesem Fall wird er zu einer anderen, automatisch vom Programm generierten Seite weitergeleitet, die folgende Elemente enthält:

-die festgelegte Willkommensnachricht;

-Felder für die Eingabe von Login und Passwort;

-bei Definition einer Registrierungsseite (siehe folgende Option) die Schaltfläche Registrieren.

§Registrierungsseite: Mit Klick auf das Ordnersymbol wird die Sitemap angezeigt, wo Sie festlegen können, welche Seite angezeigt werden soll, wenn der Benutzer auf Registrieren klickt, um Zugangsdaten für den Zugriff auf geschützte Seiten zu erhalten.

Wird auch nur eine Seite als geschützt eingestellt (und damit ein geschützter Bereich aktiviert), erscheint in der Sitemap automatisch die Spezialseite „Login-Seite“. Sie können diese Seite auswählen und das Fenster Eigenschaften der Seite öffnen, um die Haupteigenschaften festzulegen.

Wird die erstellte Seite lokal getestet, erscheint ein Fenster mit dem Hinweis, dass die geschützten Seiten ohne Abfrage der Zugangsdaten angezeigt werden. Die Aktivierung der geschützten Seiten erfolgt erst bei der Veröffentlichung der Website auf dem Server.

Für die korrekte Funktion der geschützten Bereiche muss der Server, auf den die Website hochgeladen wird, die Programmiersprache PHP und Sitzungen unterstützen. Diese Informationen über den Server finden Sie im Bereich WebSite Test des Control Panel online.

Zusatzinformationen:

-

Control Panel online


Benutzereinstellungen Fenster

Schritt 4 - Erweiterte Einstellungen > Zugangsverwaltung >

Benutzereinstellungen Fenster

 Return to chapter overview

Das Dialogfenster Benutzereinstellungen, das sich nach dem Anklicken der Schaltflächen Neuer Benutzer oder Bearbeiten... im Zugangsverwaltung Fenster öffnet, bietet die Möglichkeit die Zugangsdaten von einen neuen Benutzer festzulegen.

Optionen für die Erstellung eines neuen Benutzers:

§Vor- und Nachname: Geben Sie hier den Namen des Benutzers ein, dem Sie für den Zugriff auf geschützte Seiten der Website Zugangsdaten zuweisen wollen.

§Benutzername / Passwort: Geben Sie in diese Felder den Benutzernamen und das Passwort ein, die der Benutzer verwenden soll, um die für ihn freigegebenen geschützte Seiten anzuzeigen. Es wird automatisch nach dem Zufallsprinzip ein Passwort aus 8 Zeichen (Buchstaben und Ziffern) generiert. Dieses Passwort kann jedoch frei geändert werden.

§Starteite: Mit Klick auf das Ordnersymbol wird die Sitemap angezeigt, wo Sie auswählen können, welche Seite angezeigt werden soll, nachdem der Benutzer seine Zugangsdaten eingegeben hat.

§Anmerkung: Hier können Sie fakultativ Anmerkungen zu dem jeweiligen Benutzer eingeben.

§Registrierungsdatum: Mit einem Klick auf das Kalendersymbol können Sie das Datum auswählen, an dem der Benutzer registriert wurde.

Die Angaben in den Feldern Anmerkung und Registrierungsdatum werden nicht in den Code der realisierten Website aufgenommen. Sie dienen ausschließlich der komfortablen Benutzerverwaltung durch die Site-Administratoren.


Warenkorb für E-Commerce

Schritt 4 - Erweiterte Einstellungen >

Warenkorb für E-Commerce

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Fenster finden Sie die nötigen Werkzeuge und Optionen zur Erstellung und Verwaltung eines Online-Shops mit den Produkten, die Sie auf Ihrer Webseite anbieten.

Um einen solchen Shop zu realisieren, müssen Sie zunächst einen Produktkatalog erstellen und die Produkte in Kategorien und Unterkategorien organisieren. Für jedes Produkt müssen einige obligatorische Informationen wie ein Name, eine Beschreibung und der Preis eingegeben werden. Zusätzlich können ein oder mehrere Bilder zugeordnet und Produktvarianten (z.B. verschiedene Größen, Farben, Modelle usw.) vorgesehen werden. Nach Erstellung des Katalogs müssen die gewünschte Zahlungs- und Versandart festgelegt, das Bestellformular definiert und die E-Mails konfiguriert werden, die den Kunden, die Bestellungen aufgeben, und dem Seitenbetreiber gesendet werden sollen.

Die einzelnen Optionen zur Konfiguration des Shops werden in den folgenden Bereichen definiert: Produkte, , Kundendetails, Bestellung senden und Optionen.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Produkte

Mit den in diesem Bereich verfügbaren Funktionen können Produkte in das Shop-Sortiment aufgenommen und in Kategorien organisiert werden.

Alle eingegebenen Produkte werden in der Übersicht angezeigt, die für alle bereits erstellten Kategorien die jeweiligen Produkte mit ihrer Beschreibung und ihrem Preis enthalten.

Am oberen Rand der Übersicht finden Sie eine Werkzeugleiste mit folgenden Schaltflächen:

Ausschneiden [CTRL+X] - Kopieren [CTRL+C] - Einfügen [CTRL+V]

Ausschneiden, Kopieren und Einfügen ausgewählter Produkte. Diese Befehle sind auch über das Kontextmenü abrufbar, das bei Rechtsklick auf die Produktliste eingeblendet wird.

Erweitern / Reduzieren

Ein- und Ausblenden von Kategorieebenen, je nachdem, wie viele enthaltene Produkte angezeigt werden sollen.

Produkte importieren

Importieren einer Liste von Produkten, die direkt aus einer externen Datei (Format .TXT oder .CSV von Microsoft Excel) eingegfügt werden sollen.

Produkte exportieren

Export des Produktkatalogs in eine Datei mit dem Format .TXT oder .CSV.

Für weitere Informationen zu den Funktionen Produkte importieren/Produkte exportieren sowie die Erstellung und Verwaltung von Dateien im Produktkatalog siehe: Export / Import von Produkten aus dem / in den Warenkorb.

Neben der Werkzeugleiste sind für die Erstellung einer übersichtlichen Produktliste zur Verwaltung über den Shop folgende Schaltflächen verfügbar:

§Neue Kategorie: Erstellt eine neue Kategorie, um verfügbare Produkte zu organisieren. Kategorien haben keine besonderen Einstellungen: Sie dienen lediglich als "Behälter" und werden daher direkt in die Übersicht übernommen. Mit einem Doppelklick auf eine bereits erstellte Kategorie kann diese umbenannt werden.

Um den Produktkatalog optimal zu organisieren, können auch Unterkategorien erstellt werden: Hinsichtlich der nutzbaren Anzahl von Kategorien und Unterkategorien besteht keine spezifische Einschränkung.

§Neues Produkt: Öffnet das Fenster Produkteinstellungen zum Einfügen eines neuen Produkts in die ausgewählte Kategorie.

§Entfernen: Löscht die ausgewählte Kategorie mit allen enthaltenen Produkten oder einzelne, markierte Produkte.

§Bearbeiten...: Öffnet das Fenster Produkteinstellungen zum Ändern der Einstellungen des ausgewählten Produkts.

Das Verschieben von Produkten zwischen Kategorien kann direkt über die Produktliste erfolgen: Hierzu das jeweilige Produkt markieren und in die gewünschte Kategorie ziehen (Drag&Drop). Mit gedrückter Strg- und Umschalttaste können auch mehrere Produkte markiert werden.

Erst nachdem im Warenkorb für E-Commerce Kategorien angelegt und Produkte eingegeben wurden, kann das Objekt Produktliste genutzt werden, um den eigentlichen Online-Produktkatalog zu erstellen.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich

Mit den in diesem Bereich verfügbaren Funktionen werden die Versand- und Zahlungsmodalitäten definiert, die im Online-Shop angeboten werden sollen.

Der Bereich Liste Versandarten enthält eine Liste aller festgelegten Versandarten mit dem jeweils zugewiesenen Namen, der Beschreibung und den Kosten.

Für die Erstellung der Liste mit Versand- und Zahlungsarten stehen folgende Optionen zur Verfügung:

§Hinzufügen...: Öffnet das Fenster Versandart zum Definieren einer neuen Versandart.

§Duplizieren: Eine ausgewählte Versandart wird kopiert, um das Erstellen einer weiteren zu beschleunigen.

§Entfernen: Löscht die ausgewählte Versandart.

§Nach oben / Nach unten: Hier können Sie die Anzeigereihenfolge der Versandarten verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

§Bearbeiten...: Öffnet das Fenster Versandart zum Ändern einer ausgewählten Versandart. Das Dialogfenster öffnet sich auch mit Doppelklick auf eine Versandart.

Analog enthält der Bereich Liste Zahlungsarten die Liste der definierten Zahlungsarten mit dem jeweils zugewiesenen Namen, der Beschreibung und den Kosten.

Die Befehle zum Erstellen der Zahlungsarten sind mit denen der Versandarten identisch, mit dem einzigen Unterschied, dass die Schaltflächen Hinzufügen... und Bearbeiten... das Dialogfenster Zahlungsart öffnen.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Kundendetails

Mit den in diesem Bereich verfügbaren Funktionen können Sie das Formular erstellen, das Kunden ausfüllen müssen, um Produkte im Shop zu bestellen.

Im Bereich Bestellformular finden Sie ein Feldliste mit einer Liste der Felder, aus denen das Bestellformular zusammengesetzt werden kann: Es stehen verschiedene Felder vom Typ Standardeinstellungen und Benutzerdefiniert zur Verfügung und für jedes Feld wird angezeigt, ob es Sichtbar und/oder Pflichtfeld ist.

Mit den Schaltflächen über derFeldliste können Sie:

Benutzerdefiniertes Feld hinzufügen

Dem Formular unter Benutzerdefiniert ein neues Feld hinzufügen.

Feld entfernen

Ein ausgewähltes Feld aus dem Formular entfernen. Die Felder vom Typ Standardeinstellungen können nicht gelöscht werden.

Feld umbenennen

Ein ausgewähltes Feld umbenennen. Die Felder vom Typ Standardeinstellungen können nicht umbenannt werden.

Nach oben / Nach unten

Hier können Sie die Anzeigereihenfolge der bereits eingefügten Felder verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben. Die Reihenfolge sowohl der Felder vom Typ Standardeinstellungen als auch jenen vom Typ Benutzerdefiniert kann innerhalb der jeweiligen Kategorie geändert werden. Es ist hingegen nicht möglich, Felder vom Typ Benutzerdefiniert in die Kategorie Standardeinstellungen zu verschieben oder umgekehrt.

Sichtbares Feld

Mit dieser Funktion kann eingestellt werden, ob ein ausgewähltes Feld im Formular sichtbar oder unsichtbar sein soll.

Pflichtfeld

Mit dieser Funktion kann eingestellt werden, ob das ausgewählte Feld ein Pflichtfeld sein soll oder nicht. Pflichtfelder müssen vom Kunden ausgefüllt werden, um mit der Bestellung fortfahren zu können.

Die Standardliste enthält bereits alle Felder, die normalerweise in einem Registrierungsformular verwendet werden.

Abweichend von den anderen kann das Feld "E-Mail-Adresse" nicht ausgeblendet werden und ist immer ein Pflichtfeld, da die Kenntnis der E-Mail-Adresse des Kunden, der die Bestellung sendet, für die Abwicklung der Bestellung zwingend notwendig ist.

Unter der Feldliste sehen Sie die Option

§Formular für Versanddaten anzeigen: Mit dieser Funktion wird dem Bestellformular automatisch ein Bereich mit den Feldern für die Erfassung der Versanddaten hinzugefügt, für den Fall, dass die Lieferadresse von der Rechnungsadresse abweicht.

Neben den Feldern für die Rechnungs- und Versandangaben müssen Bestellformulare nach gesetzlicher Vorschrift auch die allgemeinen Geschäftsbedingungen enthalten, die die Arbeitsweise des Online-Shops regeln und die von allen Kunden gelesen und ausdrücklich akzeptiert werden müssen.

Im Bereich Allgemeine Geschäftsbedingungen befindet sich ein Texteditor, in dem die AGB-Text verfasst werden können. Im Eingabefeld des Texteditors ist bereits ein Standardsatz vorgegeben, in den Links (mit der Schaltfläche [image]) eingefügt werden können, beispielsweise um PDF-Dateien zu öffnen, die die Datenschutzinformationen und Wiederrufsbestimmungen enthalten. Es besteht aber auch die Möglichkeit, nach den jeweiligen Anforderungen selbst einen anderen Text zu verfassen.

Obwohl es nach geltender Gesetzgebung hinreichend ist, dass die Allgemeine Geschäftsbedingungen vor der Schaltfläche "Kaufen" angezeigt werden, mit der die Bestellung aufgegeben wird, steht zusätzlich folgende Option zur Verfügung:

§Einverständnis mit den Vertragsbedingungen fordern: Mit dieser Funktion wird am Ende des Formulars, direkt über der Schaltfläche "Kaufen", die Aufforderung eingefügt, die Allgemeine Geschäftsbedingungen durch Anklicken eines entsprechenden Kontrollkästchens explizit zu akzeptieren.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Bestellung senden

Mit den Optionen in diesem Bereich können Sie die Modalitäten für die Übertragung der im Bestellformular erfassten Daten sowie die Texte für die Bestellbestätigung festlegen, die dem Kunden automatisch per E-Mail zugesendet wird.

Im Bereich Bestellung senden können Sie festlegen, wie die über das Bestellformular erfassten Daten gespeichert und an den Seitenbetreiber übermittelt werden sollen:

§E-Mail-Adresse für den Eingang der Bestellungen: Hier können Sie angeben, an welche Adresse die über das Formular erfassten Daten gesendet werden sollen. Es können auch mehrere E-Mail-Adressen angegeben werden. Geben Sie hierzu alle Adressen, getrennt durch ein Semikolon, ein.

§Einfügen der erfassten Daten im CSV-Format: Bei Aktivierung dieser Option werden die erfassten Daten auch in einer CSV-Datei gespeichert, die an die E-Mail angehängt wird. In einer CSV-Datei werden di Daten als Liste durch Semikolon getrennter Werte im Textformat gespeichert. Diese Dateien können komfortabel in Tabellenkalkulationsprogramme (z.B. Microsoft Excel) importiert werden.

Im Bereich E-Mail mit Bestellbestätigung für den Kunden finden Sie schließlich die Felder, in denen Sie den Einführungstext und den Fußzeilentext für die Bestätigungs-E-Mail festlegen können, die dem Kunden gesendet werden soll. Außer dem Header- und Fußzeilentext werden in dieser E-Mail auch die gewählte Zahlungs- und Versandart angegeben.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Optionen

Über die Optionen in diesem Bereich können Sie einige grafische Einstellungen vornehmen sowie die Währung und den Mehrwertsteuersatz für den Shop festlegen.

Im Bereich Einstellung der Währung stehen folgende Optionen zur Verfügung:

§Währung: Einstellung der im Shop zu verwendenden Währung. Im Dropdown-Menü finden Sie bereits eine Auswahl. Um die Einträge in dieser Liste zu ändern, klicken Sie auf die Schaltfläche [image], um das Dialogfenster Währungsliste einzublenden.

§Gruppierung von Ziffern: Hier können Sie einstellen, wie die Preise der Produkte dargestellt werden, also ob als 1000er-Trennzeichen ein Punkt und zur Trennung der Dezimalstellen ein Komma verwendet werden soll oder umgekehrt (1.000,00 oder 1,000.00).

§Währung rechts anzeigen: Bei Aktivierung dieser Option erscheint das Währungssysmbol rechts vom Preis.

§Dezimalstellen: Bei Aktivierung dieser Option werden die Preise mit zwei Dezimalstellen angezeigt.

Im Bereich Angabe der MwSt. stehen folgende Optionen zur Verfügung:

Typ: Legen Sie hier fest, ob die Mehrwertsteuer für alle Preise eingeschlossen, ausgeschlossen oder nicht angegeben werden soll.

Standardwert (%): Legen Sie hier den Mehrwertsteuersatz fest, der als Standard auf alle Produkte berechnet werden soll, mit Ausnahme jener, für die mit der Option MwSt. (%) im Fenster Produkteinstellungen | Allgemein ein spezieller Satz definiert wurde.

Im Bereich Optionen stehen folgende Befehle zur Verfügung:

§Mindestbestellwert festlegen: Bei Aktivierung dieser Option werden nur Bestellungen ab dem hier festgelegten Mindestbestellwert akzeptiert.

§Mindestgesamtbetrag: Dieses Feld ist nur verfügbar, wenn die Option Mindestbestellwert festlegen aktiviert ist. Hier können Sie den Mindestbetrag festlegen, den die gesamte Bestellung erreichen muss, um akzeptiert zu werden.Mit den Optionen im Bereich Optionen kann das Aussehen der Tabellen definiert werden, in denen die verfügbaren oder in den Warenkorb gelegten Produkte aufgelistet werden:

§Header-Hintergrund / Header-Text / Farbe der Zelle / Zellentext / Tabellenrand: Definition der Farben für die verschiedenen Tabellenelemente.

§Abgerundete Ecken: Abgerundete Ecken für die Tabellen, auch einzeln einstellbar.

§Alternative Zeilenfarbe: Bei Aktivierung dieser Option werden die Tabellenzeilen abwechselnd mit zwei Hintergrundfarben dargestellt, wobei die in Farbe der Zelle eingestellte Farbe automatisch als ein dunklerer Ton der ersten Farbe definiert wird. Abwechselnde Hintergrundfarben von Tabellenzeilen erleichtern das Lesen, insbesondere wenn eine Tabelle sehr lang ist.

Mit den Optionen im Bereich Bilder können einige Bilder für die Darstellung auf den Shop-Seiten ausgewählt werden:

§In den Warenkorb legen/ Aus dem Warenkorb entfernen: Wählen Sie hier Bilder für die Schaltflächen "Dem Warenkorb hinzufügen" und "Aus dem Warenkorb entfernen".

§Vorschau nicht verfügbar: Hier können Sie ein Bild auswählen, das angezeigt werden soll, wenn einem Produkt keine Abbildung zugewiesen wurde (in Produkteinstellungen | Bild) und in Objekt Produktliste | Einstellungen wurde als Anzeigemodus für die Produktansichten die Darstellung "Bild und Text" oder "Text und Bild" gewählt.

Nachdem Sie Ihren Online-Shop konfiguriert haben, müssen Sie in die Website die entsprechenden Informationen und Links einbinden, damit die Kunden Produktinformationen anzeigen und Bestellungen aufgeben können. Hierzu können Sie auf verschiedene Weise vorgehen:

1.Erstellen Sie spezifische Seiten, auf denen Sie die Produkte wie gewünscht präsentieren (mit Bildern, Texten, Tabellen usw.) und fügen Sie dort die Schaltfläche "Kaufen" ein. Die Schaltfläche "Kaufen" kann in diesem Fall mit dem Link Zum Warenkorb hinzufügen (siehe Link) erstellt werden.

2.Erstellen Sie Seiten, auf denen Sie die Produkte mit den vordefinierten und bereits mit der Schaltfläche "Kaufen" ausgestatteten Modulen präsentieren. In diesem Fall muss das Objekt Produktliste verwendet werden.

Wenn Sie einen Online-Shop konfigurieren, wird in der Sitemap automatisch die Spezialseite "Warenkorb für e-Commerce" angezeigt. Sie können diese Seite auswählen und das Fenster Eigenschaften der Seite öffnen, um die Haupteigenschaften festzulegen.

Wenn Sie die Funktionsfähigkeit der lokal erstellten Website testen, weist eine Meldung darauf hin, dass die Bestellung nicht versendet wird und Sie automatisch zur Seite der Bestellbestätigung zurückgeleitet werden. Der Warenkorb für E-Commerce funktioniert erst nach der Veröffentlichung der Website auf dem Server vollständig.

Für den korrekten Betrieb des Shops muss der Server, auf dem die Website veröffentlicht wird, die Programmiersprache PHP unterstützen und der Befehl MAIL muss aktiviert sein. Diese Informationen über den Server finden Sie im Bereich WebSite Test des Control Panels online.

Treten Probleme mit dem Versenden von E-Mails auf, ist der verwendete Server wahrscheinlich nicht im Standard-Modus konfiguriert. Versuchen Sie in diesem Fall, im Erweiterte Einstellungen | Datenmanagement den Skripttyp für den E-Mail-Versand zu ändern. Für weitere Informationen wenden Sie sich bitte an Ihren Webspace-Anbieter.

Praktische Anwendung:

- | Export / Import von Produkten aus dem / in den Warenkorb
- | Inhalt der E-Mail zur Bestellbestätigung

Weiterführende Informationen:

-

Control Panel online


Produkteinstellungen Fenster

Warenkorb für E-Commerce | Fenster Produkteinstellungen

Schritt 4 - Erweiterte Einstellungen > Warenkorb für E-Commerce >

Warenkorb für E-Commerce | Fenster Produkteinstellungen

 Return to chapter overview
Versteckten Text zeigen/verstecken

Im Fenster Produkteinstellungen, das sich mit der Schaltfläche Neues Produkt oder Bearbeiten... in Warenkorb für E-Commerce | Produkte öffnet, können Sie ein neues Produkt eingeben.

Das Dialogfenster gliedert sich in die folgenden Bereiche: Allgemein, Bild, Optionen, Rabatt.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Mit den Optionen in diesem Bereich können Sie einige Grundinformationen über ein neues Produkt eingeben, das in den Warenkorb für E-Commerce aufgenommen werden soll.

Für die Definition eines neuen Produkts stehen Ihnen folgende Funktionen zur Verfügung:

§Produktbezeichnung/Code: Name oder Artikelcode für das aktuelle Produkt.

§Beschreibung: Beschreibung für das aktuelle Produkt.

§Preis: Preis für das aktuelle Produkt.

§MwSt. (%): Sofern die Option aktiv ist, kann hier der Umsatzsteuersatz für das aktuelle Produkt eingegeben werden. Das Feld ist nur aktiv, wenn im Tab Warenkorb für E-Commerce | Optionen Typ "MwSt. Inkl." oder "MwSt. Exkl." im Bereich Angabe der MwSt. ausgewählt wurde.

Je nachdem, wie der Online-Shop konfiguriert werden soll, können für die Produkte Preise inklusive Umsatzsteuer eingegeben werden. Alternativ, vor allem bei Produkten mit anderen Umsatzsteuersätzen, können Sie die Preise ohne Umsatzsteuer eingeben und diese dann spezifisch festlegen.

§Gewicht: Geben Sie hier das Gewicht des aktuellen Produkts ein, um die Versandkosten zu berechnen (siehe Fenster Versandart).

Je nachdem, welche Produkte Sie in Ihrem Online-Shop anbieten, können Sie unter Gewicht das Gewicht in Kilogramm oder Gramm, aber auch das Volumen in Litern oder Kubikmetern angeben oder jede sonstige Maßeinheit verwenden. Damit die Versandkosten korrekt berechnet werden, ist es wichtig, eine Maßeinheit zu wählen und diese auf alle angebotenen Produkte anzuwenden.

§Link (z.B. Produktseite): Öffnet das Fenster Link , in dem Sie das aktuelle Produkt verlinken können. Dieser Link kann beispielsweise zu der Seite führen, wo das Produkt detailliert beschrieben wird.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Bild

Mit den Funktionen in diesem Bereich können Sie dem Produkt, das im Warenkorb für E-Commerce angeboten werden soll, ein oder mehrere Bilder zuweisen.

Wenn Sie mehrere Bilder importieren, können Sie eine Slideshow erstellen. Bei Klick auf die einzelnen Bilder werden diese in der ShowBox vergrößert angezeigt.

Nur das erste der zugewiesenen Bilder wird im Shop angezeigt. Alle weiteren, eventuell hochgeladenen Bilder werden hingegen auf den Produktseiten angezeigt, wenn Sie das Objekt Objekt Produktliste verwenden.

Für die Erstellung einer Liste von Bildern, die dem Produkt zugewiesen werden sollen, stehen folgende Optionen zur Verfügung:

§Hinzufügen... / Entfernen: Mit diesen Schaltflächen können Sie jeweils neue Bilder hinzufügen oder in der Liste für die Slideshow ausgewählte Bilder löschen. Im Dialogfenster Datei auswählen können auch mehrere Bilder gleichzeitig ausgewählt werden.

§Nach oben / Nach unten: Hier können Sie die Anzeigereihenfolge der bereits eingefügten Bilder verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

§Bearbeiten...: Diese Option öffnet den Grafik-Editor zum Bearbeiten des ausgewählten Bildes.

Außerdem können Sie unter Eigenschaften ShowBox folgende Optionen nutzen:

§Maximale Größe: Hier definieren Sie die Höchstmaße für die ShowBox, in der die vergrößerten Bilder angezeigt werden. Wenn Sie die Option Größenverhältnis beibehalten aktiviert lassen, bleibt bei der Größeneinstellung die Proportion zwischen Breite und Höhe erhalten.

§Effekt: Im Fenster Effekteigenschaften der Effekte, das sich mit Klick auf die Schaltfläche [image] öffnet, können Sie Übergangseffekte für die Bilder in der ShowBox festlegen.

Das Aussehen der ShowBox kann komplett individuell gestaltet werden: Mit den Optionen in Stile und Modelle | E-Mail in Schritt 4 - Erweiterte Einstellungen können Sie beispielsweise Farben, Schatten, die Deckkraft und Einblendeffekte festlegen.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Optionen

Mit den Funktionen in diesem Bereich erstellen Sie die Liste der Varianten des neuen Produkts, das Sie im Warenkorb für E-Commerce anbieten möchten.

Dies können verschiedene Größen oder Farben eines Kleidungstücks oder sonstige Modellvarianten eines beliebigen Artikels sein.

Der Kunde sieht die verfügbaren Varianten in einer Liste im Online-Shop und/oder auf den einzelnen Produktseiten, die Sie mit dem Objekt Produktliste erstellt haben, und kann so direkt den gewünschten Artikel auswählen.

Für die Erstellung der Liste der Hauptvarianten stehen folgende Optionen zur Verfügung:

§Hinzufügen...: Erstellt eine neue Hauptvariante des aktuellen Produkts. Die erstellte Variante wird in der Liste der Hauptvarianten angezeigt und kann mit den Optionen im Bereich Einstellungen für Hauptvariante bearbeitet werden.

§Entfernen: Löscht die markierte Hauptvariante aus derListe der Hauptvarianten.

§Nach oben / Nach unten: Hier können Sie die Anzeigereihenfolge der bereits eingefügten Produktvarianten verändern, indem Sie ein ausgewähltes Element nach oben oder unten verschieben.

Jede einzelne Hauptvariante kann unter Einstellungen für Hauptvariante individuell konfiguriert werden:

§Produktbezeichnung/Code: Weisen Sie der zu erstellenden Hauptvariante einen Namen oder Code zu.

§Preisdifferenz: Preisdifferenz der Hauptvariante im Verhältnis zum Preis des unter Allgemein eingegebenen Produkts.

§Gewichtdifferenz: Preisdifferenz der Hauptvariante im Verhältnis zum Gewicht des unter Allgemein eingegebenen Produkts.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Rabatt

Mit den Optionen in diesem Bereich können Sie einige Grundinformationen über ein neues Produkt eingeben, das im Warenkorb für E-Commerce angeboten werden soll. Wenn Sie die Option Mengenrabatt aktivieren wählen, können Sie ferner eine Liste mit Rabatten anlegen, die auf der Grundlage der Bestellmenge angewendet werden. Auch die eingegebenen Mengenrabatte werden in einer Liste angezeigt und es stehen folgende Optionen zur Verfügung:

§Hinzufügen...: Öffnet das Fenster Mengenrabatt zum Einstellen eines Mengenrabatts für das aktive Produkt. Konkret geben Sie hier die Anzahl ein, die erreicht oder übertroffen werden muss, um den vorgesehenen Rabatt (%) zu erhalten.

§Entfernen: Löscht den ausgewählten Mengenrabatt aus der Liste.

§Bearbeiten...: Öffnet das Fenster Mengenrabatt, in dem die Einstellungen für den ausgewählten Mengenrabatt geändert werden können. Das Dialogfenster öffnet sich auch mit Doppelklick auf einen Rabatt.


Versandart Fenster

Warenkorb für E-Commerce | Versandart Fenster

Schritt 4 - Erweiterte Einstellungen > Warenkorb für E-Commerce >

Warenkorb für E-Commerce | Versandart Fenster

 Return to chapter overview
Versteckten Text zeigen/verstecken

Im Dialogfenster Versandart, das sich per Klick auf die Schaltfläche Hinzufügen... oder Bearbeiten... unter Liste Liste Versandarten im Tab Warenkorb für E-Commerce | öffnet,können Sie die Versandarten definieren, die auf den Warenkorb für E-Commerce angewendet werden sollen.

Das Fenster Versandart ist in folgende Bereiche gegliedert: Allgemein, Kosten und E-Mail-Nachricht.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Allgemein

Mit den Optionen in diesen Bereich können Sie eine neue Versandart einfügen:

§Name: Geben Sie der Versandmethode einen eindeutigen, prägnanten Namen.

§Beschreibung: Geben Sie hier eine komplette Beschreibung für die Methode ein.

§Bild: Auswahl des Bildes, das der Beschreibung der aktuellen Methode auf den Seiten des Online-Shops zugeordnet werden soll.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich Kosten

In diesen bereich können Sie die Zusatzkosten angeben, die bei der Nutzung der jeweiligen Versandmethode entstehen. Dieser Betrag kann nach folgenden Modalitäten eingestellt werden:

§Festkosten: Fester Versandkostenbetrag für die Versandart. Dieser Betrag bleibt unabhängig von allen Bestellparametern unverändert.

§Kosten für Bestellwert: Hier können in Abhängigkeit vom Bestellwert ein oder mehrere Kostenbereiche für die Versandart festgelegt werden. Mit den Schaltflächen Hinzufügen... und Bearbeiten... wird das Dialogfenster Versandkosten aufgerufen. Hier können Sie den Bestellwert eingeben, der erreicht oder überschritten werden muss, um die angegebenen Preis anzuwenden.

§Kosten für Gesamtgewicht: Hier können in Abhängigkeit vom Gesamtgewicht der bestellten Produkte ein oder mehrere Kostenbereiche für die Versandart festgelegt werden. Auch hier öffnen Sie mit den Schaltflächen Hinzufügen... und Bearbeiten... das Dialogfenster Versandkosten:, in dem Sie das Gesamtgewicht das erreicht oder überschritten werden muss, um die angegebenen Preis anzuwenden.

Wenn auf der Grundlage des Gesamtgewichts eine Preisstaffel festgelegt werden soll, muss im Dialogfenster Produkteinstellungen | Allgemein für jedes angebotene Produkt das Gewicht eingegeben werden, um die Versandkosten korrekt zu berechnen.

Ferner steht folgende Option zur Verfügung:

§MwSt. (%): Sofern die Option aktiv ist, kann hier der Mehrwertsteuersatz für die Kosten der Versandmethode eingegeben werden. Das Feld ist nur aktiv, wenn im Tab Warenkorb für E-Commerce | Optionen Typ "MwSt. Inkl." oder "MwSt. Exkl." im Bereich Angabe der MwSt. ausgewählt wurde.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen im Bereich E-Mail-Nachricht

In diesem Bereich finden Sie ein Feld, in das Sie eine Beschreibung der jeweiligen Versandmethode eingeben können. Formulieren Sie diese Nachricht mit Sorgfalt, da sie in der Bestätigungs-E-Mail an den Kunden enthalten ist.

Praktische Anwendung:

-

Inhalt der E-Mail zur Bestellbestätigung


Zahlungsart Fenster

Warenkorb für E-Commerce | Fenster Zahlungsart

Schritt 4 - Erweiterte Einstellungen > Warenkorb für E-Commerce >

Warenkorb für E-Commerce | Fenster Zahlungsart

 Return to chapter overview
Versteckten Text zeigen/verstecken

Im Fenster Zahlungsart, das sich mit der Schaltfläche Hinzufügen... oder Bearbeiten... im Bereich Liste Zahlungsarten unter Warenkorb für E-Commerce | öffnet, können Sie die Zahlungsmodalitäten für Ihren Online-Shop festlegen.

Das Fenster Zahlungsart gliedert sich in die folgenden Bereiche: Allgemein, Typ und E-Mail-Nachricht.

Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Allgemein

Über die hier verfügbaren Schaltflächen kann eine neue Zahlungsmethode eingestellt werden:

§Name: Geben Sie der Versandmethode einen eindeutigen, prägnanten Namen.

§Beschreibung: Geben Sie hier eine komplette Beschreibung für die Methode ein.

§Bild: Auswahl des Bildes, das der Beschreibung der aktuellen Methode auf den Seiten des Online-Shops zugeordnet werden soll.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich Typ

Mit den Schaltflächen in diesem Bereich legen Sie die Zahlungsart fest, wobei folgende Optionen zur Verfügung stehen:

§Später bezahlen: Der Kunde kann die Bestellung abschließen und erst zu einem späteren Zeitpunkt bezahlen. Diese Methode eignet sich beispielsweise für Zahlungen per Banküberweisung.

§Sofort bezahlen: In diesem Fall muss der Kunde gleich nach Abschluss der Bestellung die Zahlung vornehmen, beispielsweise mit PayPal™, ähnlichen Diensten oder Kreditkarten.

Bei Aktivierung der Option Sofort bezahlen müssen Sie die Zahlungsart festlegen und hierfür einige Parameter eingeben:

PayPal/Kreditkarte

§PayPal-Account: Geben Sie das Konto ein, das Sie als eingetragener Benutzer von PayPal™ erhalten.

§Seite Zahlungsbestätigung: Öffnet die Sitemap, wo Sie die Seite auswählen können, die nach erfolgter Zahlung angezeigt werden soll.

§Seite Zahlungsfehler: Öffnet die Sitemap, wo Sie die Seite auswählen können, die angezeigt werden soll, wenn während des Zahlvorgangs ein Fehler aufgetreten ist.

Benutzerdefinierter Code

§HTML-Code für die Button-Verbindung zum Zahlvorgang eingeben: Soll ein von PayPal™ verschiedenes Zahlungssystem verwendet werden, können Sie nach der Registrierung den vom Anbieter bereitgestellten HTML-Code eingeben.

Der vom Anbieter bereitgestellte HTML-Code erstellt den Button "Jetzt zahlen" und muss mit Angaben über das jeweilige Produkt und den entsprechenden Preis vervollständigt werden. Damit das E-Shopsystem funktioniert, müssen folgende Tags manuell in den Code integriert werden:

§[ORDER_NO] - Nummer der Bestellung;

§[PRICE] - Preis.

Ferner stehen folgende Optionen zur Verfügung:

§Preis: Hier können die Zusatzkosten angegeben werden, die bei der Nutzung der jeweiligen Zahlungsmethode berechnet werden sollen.

§MwSt. (%): Sofern die Option aktiv ist, kann hier der Umsatzsteuersatz für Kosten der Zahlungsmethode eingegeben werden. Das Feld ist nur aktiv, wenn im Tab Warenkorb für E-Commerce | Optionen Typ "MwSt. Inkl." oder "MwSt. Exkl." im Bereich Angabe der MwSt. ausgewählt wurde.
Klicken Sie um zu erweitern/minimieren Anleitung: Funktionen im Bereich E-Mail-Nachricht

In das Feld dieses Bereichs können Sie einen Text eingeben, der die aktuelle Zahlungsmethode beschreibt und erläutert. Formulieren Sie diese Nachricht mit Sorgfalt, da sie in der Bestätigungs-E-Mail an den Kunden enthalten ist.

Praktische Anwendung:

-

Inhalt der E-Mail zur Bestellbestätigung


Export

Schritt 5 - Export >

Export

 Return to chapter overview

Nach Abschluss einer Arbeitssitzung oder nach Fertigstellung der Website können Sie in Schritt 5 von WebSite X5 für Ihr Projekt eine Exportoption wählen. Dank dem integrierten FTP-Client können Sie zunächst Ihre Dateien direkt auf einem Server veröffentlichen: WebSite X5 unterstützt sichere Verbindungen und ermöglicht effizientes Arbeiten über Mehrfachverbindungen und mit der Option, nur geänderte Dateien zu übertragen. Alternativ können Sie die Website auf ein Laufwerk Ihres Computers exportieren, um eine lokale Kopie der veröffentlichten Seiten zu speichern. Und schließlich können die Dateien des Projekts in ein gemeinsames Verzeichnis exportiert werden, um sie komfortabel zur weiteren Bearbeitung auf einen anderen Computer zu übertragen.

Folgende Exportoptionen stehen zur Verfügung:

Export der Website ins Internet

Export der Website auf ein Laufwerk

Projekt exportieren


Export der Website ins Internet

Schritt 5 - Export >

Export der Website ins Internet

 Return to chapter overview
Versteckten Text zeigen/verstecken

In diesem Bereich können Sie Ihre fertige Website veröffentlichen.

WebSite X5 ist mit einem internen FTP-Client ausgestattet, über den Sie Ihre erstellten Seiten direkt online stellen können. Alle für die korrekte Darstellung der Seite im Web benötigten Dateien werden auf dem Computer gespeichert, an dem sie erstellt wurden. Damit die Anwender unsere Seiten im Web sehen können, müssen diese Dateien auf den Server kopiert werden, d.h. auf einen Computer, der permanent mit dem Internet verbunden ist.

Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen für den Verbindungsaufbau mit dem Server

Um alle Dateien der Website zu exportieren, müssen zunächst die folgenden Verbindungsparameter konfiguriert werden (vom Webspace-Anbieter bereitgestellt):

§Servertyp: Wählen Sie hier den Verbindungstyp aus, der für die Veröffentlichung der Dateien auf dem Server verwendet werden soll. Je nachdem, welches Protokoll der Server unterstützt, wählen Sie zwischen:

-FTP - File Transfer Protocol: Standardeinstellung. FTP ist eins der ersten Protokolle für den Datentransfer und weit verbreitet. FTP in seiner ursprünglichen Form unterstützt keinerlei Verschlüsselung der Daten, die zwischen Client und Server ausgetauscht werden.

-SFTP - SSH File Transfer Protocol: Dieses Protokoll ermöglicht einen sicheren Datentransfer, da es verschlüsselte Remote-Verbindungen aufbaut und die Remote-Bearbeitung von Dateien unterstützt.

-FTPS - FTP über implizites TLS/SSL: Um Sicherheitsproblemen vorzubeugen, können dem Protokoll FTP der Verschlüsselungs-Layer SSL/TLS sowie einige Befehls- und Antwort-Codes hinzugefügt werden.

§FTP-Adresse: Geben Sie hier Ihre FTP-Adresse ein. Beispiel: "ftp.websitex5.com", wobei "websitex5.com" der Domainname ist.Geben Sie hier Ihre FTP-Adresse ein. Beispiel: "ftp.websitex5.com", wobei "websitex5.com" der Domainname ist.

§Benutzername / Passwort: Geben Sie in diese Felder Ihren Benutzernamen und Ihr Passwort ein.

§Passwort speichern: Bei Aktivierung dieser Option wird das eingegebene Passwort gespeichert und muss nicht erneut eingegeben werden.

Zusätzlich können einige Optionale Parameter eingegeben werden, die für den Verbindungsaufbau mit dem Server nicht zwingend erforderlich sind:

§Zielverzeichnis: Geben Sie hier das Zielverzeichnis ein, das Ihnen von Ihrem Webspace-Anbieter zugewiesen wurde. Wenn Sie hier keinen Pfad eingeben, können Sie ihn auch im folgenden Schritt eingeben.

§Port: Geben Sie hier den Port des Servers ein, über den die Verbindung hergestellt wird (vom Webspace-Anbieter bereitgestellt). In den meisten Fällen muss der hier vordefinierte Standardwert nicht geändert werden

§Gleichzeitige Übertragungen: Geben Sie hier die Anzahl der Serververbindungen ein, die der FTP-Client des Programms gleichzeitig öffnen soll, um die Dateien der Website zu veröffentlichen. Die Anzahl der Verbindungen entspricht der Anzahl der Dateien, die gleichzeitig exportiert werden können.

Le Gleichzeitige Übertragungen Mehrere gleichzeitige Verbindungen müssen von dem jeweils genutzten Server unterstützt werden. Sofern gleichzeitige Verbindungen unterstützt werden, führt die Erhöhung dieser Zahl über eine bestimmte Grenze hinaus zu keiner effektiven Zeiteinsparung mehr. Es wird empfohlen, mit 3 Verbindungen zu beginnen und den Parameter schrittweise zu erhöhen, um die optimale Anzahl im Verhältnis zur Bandbreite des genutzten Servers festzustellen. Generell sollten nicht mehr als 10 gleichzeitige Verbindungen eingestellt werden.

§Passives FTP verwenden: Diese Option ist standardmässig aktiviert und sieht die Nutzung von passivem FTP für den Datentransfer vor. Dieser Modus empfiehlt sich für eine höhere Kompatibilität mit dem Server.

§GZip-Komprimierung aktivieren: Diese Option ist standardmäßig aktiviert und bewirkt, dass die Dateien der Website zum Export komprimiert werden, um den Prozess der Veröffentlichung zu beschleunigen.

Nicht alle Server unterstützen GZip-Komprimierung. Wenn die Option aktiviert ist, aber vom Server nicht unterstützt wird, werden die Dateien dennoch veröffentlicht, aber unkomprimiert übertragen. Die GZip-Komprimierung eignet sich besonders für sehr große Dateien (die z. B. viele Bilder oder Videos enthalten), während sie bei kleinen Dateien nicht zu empfehlen ist.

Nach der Konfigurierung der Parameter für die Serververbindung können die Upload-Optionen festgelegt werden. Hier definieren Sie, welche Dateien effektiv hochgeladen werden sollen:

§Alle Dateien der Website hochladen: Alle Dateien der Website hochladen: In diesem Fall wird die ganze Website veröffentlicht. Dieser Typ ist geeignet, wenn das Projekt zum ersten Mal veröffentlicht wird oder wenn zahlreiche und wichtige Änderungen an der Webseite vorgenommen wurden.

§Nur die Dateien hochladen, die seit dem letzten Export am {0} geänderten wurden: In diesem Fall werden nur die Dateien veröffentlicht, die seit dem letzten Export geändert worden sind. Dieser Typ ist für Webseiten geeignet, die häufig aktualisiert werden. Er bietet den Vorteil, dass die Veröffentlichung schneller erfolgt als bei Übertragung der kompletten Webseite.

Das Datum der Veröffentlichung wird in der Projektdatei gespeichert: Daher ist es wichtig, nach der Veröffentlichung der Dateien alle Änderungen zu speichern.

Auch wenn Sie nur die geänderten Dateien exportieren, werden die HTML-Seiten und Ressourcen-Dateien (im Unterverzeichnis Res) erneut veröffentlicht, da es möglich ist, dass sie aktualisiert wurden.

§Nur RSS-Feed/Blog hochladen: Bei Aktivierung dieser Option werden nur die .PHP- und .XML-Dateien des Blog sowie die .XML-Dateien des RSS-Feed veröffentlicht, die Sie in den entsprechenden Bereichen von Schritt 4 - Erweiterte Einstellungen verwalten. Diese Option, die nur verfügbar ist, wenn ein bereits ein Blog oder RSS-Feed veröffentlicht wurde, ist geeignet, wenn keine Aktualisierungen an der Webseite vorgenommen, sondern nur neue Blog-Posts oder Einträge für den RSS-Feed hinzugefügt wurden.
Klicken Sie um zu erweitern/minimieren Anleitung: Die Optionen um die Website zu veröffentlichen

Klicken Sie nach der Einstellung der erforderlichen Parameter auf die Schaltfläche Weiter um die Verbindung zum Server aufzubauen. Nach Verbindungsaufbau werden die dort bereits vorhandenen Verzeichnisse in einem Fenster angezeigt. Öffnen Sie hier mit Hilfe der verfügbaren Befehle das Verzeichnis, in dem die Website veröffentlicht werden soll.

Das Verzeichnis, in dem eine Website veröffentlicht wird, enthält in der Regel eine Datei index.html. Bei Zweifeln hinsichtlich des Verzeichnisses wenden Sie sich bitte an Ihren Webspace-Anbieter, da nicht alle Verzeichnisse auf dem Server sind für Veröffentlichungen geeignet sind.

Klicken Sie um zu erweitern/minimieren

Im Einzelnen stehen Ihnen für die Interaktion mit Dateien auf dem Server folgende Befehle zur Verfügung:

Auf übergeordnetes Verzeichnis zugreifen

Öffnen des in der Ordnerhierarchie jeweils übergeordneten Verzeichnisses.

Neu laden

Hier können Sie den Inhalt des aktuellen Verzeichnisses erneut laden.

Neues Verzeichnis

Hier können Sie ein neues Verzeichnis erstellen.

Löschen

Mit dieser Schaltfläche können Sie eine ausgewählte Datei oder ein ausgewähltes Verzeichnis löschen.

Umbenennen

Mit dieser Schaltfläche können Sie eine ausgewählte Datei oder ein ausgewähltes Verzeichnis umbenennen.

Datei auf den Server hochladen / Ausgewählte Datei vom Server herunterladen

Mit diesen Schaltflächen können Sie jeweils eine oder mehrere Dateien, die nicht Teil des Projekts sind, auf den Server hochladen bzw. bereits veröffentlichte Dateien auf den lokalen PC herunterladen.

Liste / Details

Hier legen Sie fest, wie die Dateien angezeigt werden sollen.

Und schließlich finden Sie einen Bereich, in dem Sie eine der folgenden Ansichten einstellen können:

§Log: Anzeige der Log- und eventuellen Fehlermeldungen, die während der Kommunikation mit dem Server generiert wurden.

§Dateien in Warteschlange: Anzeige der Dateien (die Höchstzahl dieser Dateien ist von den eingestellten gleichzeitigen Verbindungen abhängig), die veröffentlicht werden. Die Veröffentlichung jeder Datei kann über eine Fortschrittsanzeige mitverfolgt werden. Sobald die Veröffentlichung abgeschlossen ist, wird diese Datei in der Warteschlange nicht mehr angezeigt.

Während des Exports kopiert WebSite X5 alle im Eintragungsverzeichnis enthaltenen Dateien auf den Server. Wenn dieses Verzeichnis bereits Dateien enthält, die den gleichen Namen haben wie die Dateien für die Veröffentlichung, werden diese überschrieben. WebSite X5 löscht keine Dateien auf den Server. Um Dateien zu löschen müssen diese manuell gelöscht werden.


Exportvorgang abgeschlossen

Schritt 5 - Export > Export der Website ins Internet >

Exportvorgang abgeschlossen

 Return to chapter overview

Nachdem die Website erfolgreich im Internet veröffentlicht wurde (siehe Export der Website ins Internet), finden Sie auf dieser Seite einige Hinweise, wie Sie Ihre Website bekannt machen können, beispielsweise in der Gallery von WebSite X5 sowie Google™, Facebook und Twitter.

Im Einzelnen stehen stehen Ihnen folgende Funktionen zur Verfügung:

Ihre Webseite ist online!

Hier können Sie Ihren Standard-Browser starten und in Ihrer soeben veröffentlichten Website surfen, um zu prüfen, ob alles korrekt funktioniert.

WebSite X5 Gallery

Über diesen Link gelangen Sie zur Galerie auf WebSite X5 Answers, um dort Ihre soeben veröffentlichte Website vorzustellen. Diese Galerie ist eine vielseitige Sammlung von Seiten, die mit WebSite X5 erstellt wurden und dort von ihren Autoren präsentiert werden.

SiteMap bei Google aktualisieren

Hier können Sie die SiteMap der soeben veröffentlichten Website an Google™ versenden, um die Indexierung durch den Spider der Suchmaschine zu beschleunigen.

Veröffentlichung auf Facebook teilen

Dieser Link führt zu einer Facebook-Seite, auf der Sie sich einloggen und dann all Ihre Kontakte über die neu veröffentlichte Website informieren können. Der Kommentar wird an der Pinnwand Ihres Facebook-Profils veröffentlicht.

Die Veröffentlichung auf Twitter bekannt geben

Dieser Link führt zu einer Twitter-Seite, auf der Sie sich einloggen und dann Ihre Follower über die neu veröffentlichte Website informieren können. Der Kommentar wird in der Timeline Ihres Twitter-Profils veröffentlicht.


Export auf ein Laufwerk

Schritt 5 - Export >

Export auf ein Laufwerk

 Return to chapter overview

In diesem Dialogfenster können Sie die erstellte Website auf einem Laufwerk des Computers speichern.

Auf diese Weise sichern Sie eine Kopie aller Dateien, die auf dem Server veröffentlicht werden sollen, lokal auf dem PC, um sie dann auf CD, DVD oder USB-Medien zu übertragen und vor der effektiven Veröffentlichung noch Änderungen an den HTML-Seiten vorzunehmen.

Um alle Dateien des Projekts zu exportieren, müssen Sie angeben:

§Zielverzeichnis: Das Verzeichnis, in das die erstellte Website exportiert werden soll. Wenn das genannte Verzeichnis nicht existiert, wird es automatisch generiert.

Die Option Export auf ein Laufwerk ist nicht geeignet um Backup Kopien der Projekte zu herstellen, da die generierten Dateien für die Veröffentlichung der Website gedacht sind und nicht im Programm wieder importiert werden können.

Um eine Sicherheitskopie des Projekts herzustellen die das widerherstellen aus vorheringen Versionen anbietet, benutzen Sie die Backup Funktionen die sie im Speichern Menü finden.

Um eine Sicherheitskopie des Projekts zu haben, im Fall das originale Projekt verloren geht, benutzen Sie die Projekt exportieren Funktion. Auf diese Weise erstellen Sie eine Kopie aller Original-Dateien des Projekts.

Praktische Anwendung:

-

Verwaltung von Projekt-Backups


Projekt exportieren

Schritt 5 - Export >

Projekt exportieren

 Return to chapter overview

In diesem Fenster können Sie alle mit dem Projekt verknüpften Dateien als eine Archivdatei exportieren, um sie auf einen anderen Computer zu übertragen oder eine Sicherungskopie zu erstellen.

Für den Export eines Projekts müssen Sie angeben:

§Zielverzeichnis: Wählen Sie das Zielverzeichnis aus, in das das Projekt exportiert werden soll. Wenn das genannte Verzeichnis nicht existiert, wird es automatisch generiert.

Beim Export wird im Zielverzeichnis eine einzige, komprimierte Archivdatei erstellt, die den gleichen Namen trägt wie das Projekt und die Endung .IWZIP hat. Heißt Ihr Projekt zum Beispiel "MeinProjekt", wird die Datei MeinProjekt.iwzip generiert.

Dieses komprimierte Archiv enthält sowohl die Projektdateien (.IWPRJ Datei) als auch alle verknüpften Dateien (z. B. importierte Bilder, Videos oder Animationen).

Bevor Sie das Export starten können Sie folgende Optionen aktivieren:

§Kopie der Vorschaudateien der Website einbeziehen: Enthält im komprimierten .IWZIP Archiv auch die notwendingen Dateien für die lokale Vorschau der Website. Mit dem einbeziehen dieser Dateien, wird die .IWZIP Datei grösser sein, aber es wird nicht mehr notwendig sein diese erneut zu erzeugen wenn das Projekt auf einen neuen Computer importiert wird.

Das Archiv .IWZIP kann auf einen anderen Computer übertragen und dort im Programm mit der Funktion Importieren..., im Fenster Projektauswahl geöffnet werden.

Praktische Anwendung:

-

Verwaltung von Projekt-Backups


Verwaltung von Projekt-Backups

Praktische Anwendung > Voreinstellungen >

Verwaltung von Projekt-Backups

 Return to chapter overview
Versteckten Text zeigen/verstecken

Das Erstellen von Backups ist bei der Arbeit mit Projekten von fundamentaler Bedeutung.

Von einem Projekt ein Backup zu erstellen, bedeutet, lokal auf dem PC oder auf einem externen Medium eine Sicherheitskopie zu speichern, um die Daten zu sichern.

Die Verfügbarkeit von zwei oder mehr Sicherheitskopien eines Projekts löst im Allgemeinen zwei Probleme:

§Desaster Recovery - Das Projekt kann bei Bedarf wiederhergestellt werden, beispielsweise bei einem irreversiblen Defekt des Computers oder wenn Daten versehentlich gelöscht wurden.

§Versioning - Von einem Projekt können unterschiedliche Versionen erstellt werden, um beispielsweise Änderungen, die in einer bestimmten Arbeitssitzung vorgenommen wurden, rückgängig zu machen, indem man einfach die zuvor gespeicherte Sicherheitskopie wiederherstellt.

Um wirksam zu sein, muss die Aktivität der Backup-Erstellung natürlich korrekt eingestellt sein und mit einer gewissen Regelmäßigkeit durchgeführt werden.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Versioning - Einstellungen für die automatische Erstellung von Backup-Kopien

Um die automatische Erstellung von Backup-Kopien einzustellen, gehen Sie bitte wie folgt vor:

§Das Projekt öffnen.

§Die Option Beim ersten Speichern des projekts eine Sicherungskopie erstellen im Menü Speichern wählen.

§Alternativ oder gleichzeitig die Option Bei jedem Hochladen eine Sicherungskopie erstellen aktivieren, die ebenfalls im Menü Speichern enthalten ist.

Mit der Option Beim ersten Speichern des projekts eine Sicherungskopie erstellen wird ein Projekt-Backup vor dem ersten Speichern erstellt, während die Option Bei jedem Hochladen eine Sicherungskopie erstellen das Backup vor der Veröffentlichung der Website online generiert.

Alle auf diese Weise erstellten Backup-Kopien werden in der Verzeichnis der Projekte im Fenster Einstellungen angezeigt.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Versioning - Wiederherstellung eines Projekts aus einer Backup-Kopie

Zur Wiederherstellung eines Projekts aus einer Backup-Kopie gehen Sie bitte wie folgt vor:

§Das Unterverzeichnis Backup im Ordner Verzeichnis der Projekte (im Fenster Einstellungen) öffnen und die Datei der Backup-Kopie auswählen, die wiederhergestellt werden soll: Dies ist eine Datei Backup.iwprj, die mit der Funktion Beim ersten Speichern des projekts eine Sicherungskopie erstellen erstellt wurde, oder eine Datei Uploaded_timestamp.iwprj, erstellt mit der Funktion Bei jedem Hochladen eine Sicherungskopie erstellen.

§Die Datei im Unterverzeichnis Backup ausschneiden und in Verzeichnis der Projekte einfügen.

§Die Datei Project.iwprj löschen und die Backup-Datei "Project.iwprj" nennen.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Desaster Recovery - Erstellen einer Backup-Kopie von einem Projekt

Um von einem Projekt eine Backup-Kopie zu erstellen und auf einem externen Medium (verschieden von dem PC an dem gearbeitet wird) zu speichern, gehen Sie bitte wie folgt vor:

§Im Schritt 5 - Export die Option Projekt exportieren wählen, um alle Dateien eines Projekts in eine Archivdatei (.IWZIP) zu exportieren.

§Die Archivdatei .IWZIP auf das Speichermedium kopieren, auf dem die Sicherheitskopie aufbewahrt werden soll.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Desaster Recovery - Wiederherstellung der Backup-Kopie von einem Projekt

Um die auf einem externen Medium (verschieden von dem PC an dem gearbeitet wird) gespeicherte Backup-Kopie wiederherzustellen, gehen Sie bitte wie folgt vor:

§Im Fenster Projektauswahl die Schaltfläche Importieren... anklicken, um die Archivdatei (.IWZIP) des wiederherzustellenden Projekts auszuwählen.

§Das wiederhergestellte Projekt öffnen und mit der Arbeit fortfahren.


Sprachverwaltung für automatisch eingefügten Text

Praktische Anwendung > Schritt 1 - Allgemeine Einstellungen >

Sprachverwaltung für automatisch eingefügten Text

 Return to chapter overview
Versteckten Text zeigen/verstecken

Einige Texte auf den mit WebSite X5 vengono erstellten Seiten werden automatisch vom Programm eingefügt, wie zum Beispiel die Links zu internen Ankern, die Schaltflächen des Objekt Galerie, die Etiketten des Objekt E-Mail-Formular, die Etiketten und Texte des Objekts Warenkorb für E-Commerce oder die Texte der Sitemap.

Damit diese Texte in der richtigen Sprache eingefügt werden, muss mit der Option Sprache der Website unter Allgemeine Einstellungen die Hauptsprache der Website festgelegt werden. Standardmäßig können Sie in WebSite X5 zwischen verschiedenen Sprachen, unter anderem Deutsch, Englisch und Italienisch, wählen, für die bereits alle benötigten Übersetzungen verfügbar sind. Die vordefinierten Sprachoptionen können geändert werden, ebenso wie nicht benötigte Sprachen gelöscht und neue hinzugefügt oder importiert werden können. Öffnen Sie hierzu das Dialogfenster Sprachenzentrum mit Klick auf die Schaltfläche [image] neben dem Feld Sprache der Website.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Ändern einer bestehenden Sprache

Ein Beispiel für die automatisch vom Programm eingefügten Texte sind die Schaltflächen "Senden" und "Zurücksetzen", die am Ende des Kontaktformulars angezeigt werden.

Soll das Etikett "Zurücksetzen" beispielsweise in "Abbrechen" geändert werden, nachdem als Sprache der Website "Deutsch" eingestellt wurde, gehen Sie bitte folgendermaßen vor:

§Klicken Sie im Dialogfenster Sprachenzentrum, sofern sie noch nicht aktiviert ist, auf die Sprache "DE-Deutsch", um die Spalte mit den Inhalten anzuzeigen.

§Suchen Sie in der ersten Spalte nach der ID "form_rest", die dem zu ändernden Etikett entspricht: Verfolgen Sie nun die Zeile bis zur Spalte der Sprache Deutsch. Mit einem Doppelklick auf die Zelle wird der Eingabecursor angezeigt: Löschen Sie den Eintrag "Zurücksetzen" und geben Sie "Abbrechen" ein.

§Schliessen Sie das Fenster: In dieser weise werden alle Änderungen automatisch gespeichert.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Hinzufügen einer neuen Sprache

Um eine Website in einer Sprache zu erstellen, die noch nicht vorgesehen ist (zum Beispiel Portugiesisch), muss diese Sprachversion durch Eingabe der entsprechenden Übersetzungen erstellt werden, um zu vermeiden, dass die jeweiligen automatisch verwalteten Texte in englischer Sprache (Standard) eingefügt werden. Wenn Sie über die erforderlichen Sprachkenntnisse verfügen, ist dies sehr einfach:

§Klicken Sie im Sprachenzentrum auf die Schaltfläche Neue Sprache hinzufügen und geben Sie in das Dialogfenster "PT - Português" ein: Nun erscheint der neue Eintrag in der Liste der verfügbaren Sprachen.

§Klicken Sie auf den Eintrag "PT - Português", um die Spalte der Sprache in der Tabelle der Übersetzungen anzuzeigen.

§Klicken Sie in die einzelnen Zellen der Spalte "PT - Português", um die benötigten Übersetzungen einzugeben.

§Geben Sie die Überstetzungen ein und schliessen Sie das Fenster: In dieser weise werden alle Änderungen automatisch gespeichert.

§Im Allgemeine Einstellungen Fenster wählen Sie "PT - Português" als Sprache der Website.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Import/Export einer Sprache

Soll an zwei Computern eine Website in einer Sprache erstellt werden, die vom Programm nicht auf beiden PCs als Standardsprache vorgesehen ist, kann die Sprache an einem Arbeitsplatz konfiguriert und dann am zweiten importiert werden, ohne alle Eingaben erneut vornehmen zu müssen.

§Öffnen Sie hierzu am ersten PC das Fenster Sprachenzentrum, klicken Sie auf Neue Sprache hinzufügen und konfigurieren Sie die gewünschte Sprache.

§Markieren Sie die so erstellte Sprache in der Sprachenliste und klicken Sie auf [image] Ausgewählte Sprache exportieren: In dem angegebenen Verzeichnis wird eine .XML-Datei gespeichert.

§Die .XML-Datei auf dem anderen PC importieren:

§Öffnen Sie im Programm das Fenster Sprachenzentrum klicken Sie auf [image] Neue Sprache importieren und wählen Sie die gespeicherte .XML-Datei aus.

Wenn die importierte Sprache in der Liste bereits enthalten ist, wird sie nicht dupliziert, sondern es werden nur neue Elemente hinzugefügt und geänderte aktualisiert.

Praktische Anwendung:

-

Erstellen einer mehrsprachigen Website


Nutzung der Google Webmasterzentrale™

Praktische Anwendung > Schritt 1 - Allgemeine Einstellungen > Einbinden von Google-Tools >

Nutzung der Google Webmasterzentrale™

 Return to chapter overview

Die Google Webmasterzentrale™ ist eine von Google kostenlos bereitgestellte Sammlung von Tools, die Webmaster dabei unterstützen, ihre Websites in Konformität mit den Vorgaben von Google zu gestalten. Mit Hilfe dieser Werkzeuge lässt sich feststellen, wie Google die Website sieht. Außerdem können eventuelle Probleme diagnostiziert werden. Bei korrekter Verwendung tragen diese Tools dazu bei, die Sichtbarkeit des Internetauftritts in Suchmaschinen zu steigern.

Um die Google Webmasterzentrale™ nutzen zu können, benötigen Sie ein Google-Konto, mit dem Sie nachweisen, dass Sie wirklich der Inhaber der Website sind, die Sie analysieren möchten. Eine Nachweismethode besteht darin, einen von Google™ ereitgestellten Meta-Tag zu kopieren und auf der Homepage im ersten <head> Bereich der Seite vor dem <body> einzufügen.

Zusammenfassend:

§Sie müssen über ein Google™-Konto verfügen.

§Öffnen Sie die Startseite der Google Webmasterzentrale™ und loggen Sie sich ein.

§Klicken Sie auf der Startseite auf Website hinzufügen , geben Sie die URL der zu überwachenden Website ein und bestätigen Sie mit Weiter.

§Wählen Sie auf der Seit Eigentümerschaft überprüfen die Prüfmethode Ein Meta-Tag zur Startseite Ihrer Website hinzufügen.

§Kopieren Sie den von Google™ bereitgestellten Code in das Feld Metatag für Google Webmaster-Zentrale des Fensters Allgemeine Einstellungen | Erweitert von WebSite X5: Das Programm fügt den Metatag an der korrekten Position in den HTML-Code Ihrer Homepage ein.

§Der von Google™ bereitgestellte Metatag präsentiert sich wie in diesem Beispiel:

<meta name="verify-v1" content="VOPYsjbR4uw/YqV+MWLB0lVmJt0niwdkv9PQTsTREHQ=" />

§Kehren Sie nach der Veröffentlichung der Website auf diese Seite der Google Webmasterzentrale™ und vervollständigen Sie den Vorgang, in dem Sie auf Bestätigen klicken.


Aktivierung von Statistikdiensten wie Google Analytics™

Praktische Anwendung > Schritt 1 - Allgemeine Einstellungen > Einbinden von Google-Tools >

Aktivierung von Statistikdiensten wie Google Analytics™

 Return to chapter overview

Im Internet werden verschiedene Dienste zur Erstellung von Statistiken angeboten, unter anderen Google Analytics™. Mit diesem kostenlosen Tool können Sie zahlreiche Protokolle abrufen, um die Zugriffe auf die Website zu überwachen und detailliert zu analysieren. Google Analytics™ kann auf verschiedenen Ebenen genutzt werden: Sie können damit beginnen, einfach die Anzahl der Besuche zu ermitteln, oder weiter forschen, und den Erfolg Ihrer Werbekampagnen untersuchen, die Sie über Google Adsense™ betreiben.

Um Google Analytics™ zu nutzen, muss der Suchmaschine mitgeteilt werden, welche Website analysiert werden soll und welche Seiten im Einzelnen überwacht werden sollen. Hierzu müssen Sie Code Ihrer Seiten einen Tracking-Code einfügen.

Zusammenfassend:

§Sie müssen über ein Google™-Konto verfügen.

§Öffnen Sie die Startseite von Google Analytics™ und loggen Sie sich ein.

§Geben Sie auf der Seite Analytics-Einstellungen unter Websiteprofil hinzufügen die Website an, die überwacht werden soll.

§Nach Erstellung des Profils klicken Sie auf der Seite Übersicht auf Bearbeiten in der Spalte Aktionen für die ausgewählte Website.

§Auf der Seite Profileinstellungen lesen Sie oben rechts "Tracking für Unbekannt": Klicken Sie auf Status überprüfen, um den Code anzuzeigen, der für die Überwachung der Seiten verwendet wird.

§Kopieren Sie den von Google™ bereitgestellten Code, öffnen Sie das Fenster Allgemeine Einstellungen | Erweitert von WebSite X5 und fügen Sie den Code im Benutzerdefinierter Code Feld. Bitte wählen Sie die Option das es vor dem schliessen des Head Tag eingefügt wird.

Der von Google™ bereitgestellte Überwachungscode entspricht dem des nachstehenden Beispiels:

<script type="text/javascript">

var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");

document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));

</script>

<script type="text/javascript">

try {

var pageTracker = _gat._getTracker("UA-110367-1");

pageTracker._trackPageview();

} catch(err) {}</script>


Erstellen und Verlinken der Sitemap

Praktische Anwendung > Schritt 1 - Allgemeine Einstellungen > Einbinden von Google-Tools >

Erstellen und Verlinken der Sitemap

 Return to chapter overview
Versteckten Text zeigen/verstecken

WebSite X5 erstellt die SiteMap XML der Website automatisch.

Die Sitemap ist eine XML-Datei, die die Liste der Seiten einer Website enthält. Sie wurde von Google™ eingeführt (und wird jetzt auch von Yahoo! und MSN verwendet), um Websites schneller und besser scannen zu können. Durch das Erstellen und Senden einer Sitemap wird sichergestellt, dass die Suchmaschine, in diesem Fall Google™, alle Seiten einer Website erfasst, die mit einem herkömmlichen Scanvorgang nicht auffindbar wären.

Mit der Sitemap werden den Suchmaschinen auch Informationen über die Inhalte einer Website wie Videos, Bilder, Nachrichten usw. bereitgestellt. Außerdem kann eine Sitemap Zusatzinformationen enthalten, wie zum Beispiel die Häufigkeit, mit der jede Seite aktualisiert wird, das Datum der letzten Aktualisierung oder die Priorität jeder Seite im Kontext der Website (diese Priorität beeinflusst jedoch nicht die Positionierung der Seiten in den Suchergebnissen).

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Aktivieren der Sitemap

Damit die Sitemap Ihrer Website erstellt und verknüpft wird, ist es hinreichend, die standardmäßig aktivierte Option SiteMap automatisch erstellen im Fenster Allgemeine Einstellungen | Erweitert beizubehalten.

Anschließend können Sie in die Sitemap einige spezifische Zusatzinformationen für jede Seite einfügen:

§Wählen Sie in Schritt 2 - Erstellen der Sitemap die Seite aus, die Sie bearbeiten möchten.

§Klicken Sie auf Eigenschaften..., um das Fenster Eigenschaften der Seite und dort den Bereich Erweitert zu öffnen.

§Lassen Sie die Option Diese Seite in die Sitemap einbinden aktiviert und stellen Sie die Priorität des Inhalts und die Aktualisierungsfrequenz ein.

§Wiederholen Sie den Vorgang für alle Seiten der Website.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Einbinden von Bildern in die Sitemap

Die Sitemap kann genutzt werden, um auch Zusatzinformationen über Bilder einer Website an Google™ zu übermitteln. Dies erleichtert das Auffinden von Bildern, die andernfalls nicht erkannt werden würden (z. B. weil sie in JavaScript-Objekte eingebunden sind), und das Verständnis ihrer Relevanz im Verhältnis zu anderen. Wenn man Bilder eines grafisch gestalteten Templates oder solche, die ausschließlich der Dekoration dienen, beispielsweise nicht in die Sitemap einbindet, signalisiert dies bei Google™ ihre geringere Relevanz im Vergleich zu anderen.

Google™ legt fest, dass in eine Sitemap maximal 1.000 Bilder pro Seite eingefügt werden können, wobei jedoch nicht garantiert werden kann, dass alle Bilder indexiert und alle eingefügten Informationen genutzt werden.

Nachdem Sie die automatische Erstellung der Sitemap aktiviert haben, können Sie Informationen über ein Bild auf sehr einfache Weise einfügen:

§Öffnen Sie per Doppelklick auf das Bildobjekt, das Sie bearbeiten möchten, das Fenster Bildobjekt.

§Aktivieren Sie im Bereich Sitemap die Option Bild in die Sitemap einbinden.

§Falls gewünscht, können Sie auch die Felder Titel, Kurzbeschreibung, Geografische Lage (z.B. Adresse, Stadt etc.) und Lizenz-URL ausfüllen.

§Wiederholen Sie den Vorgang für alle Bilder der Website.

Für weitere Informationen siehe Bildobjekt | Sitemap.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Einbinden Videoinformationen in die Sitemap

Sie können die Sitemap auch nutzen, um Informationen über die in Ihrer Website enthaltenen Videos an Google™ zu übermitteln. Auch in diesem Fall gewährt Google™ keine Garantien, dennoch kann die Einbindung von Videoinformationen in die Sitemap dazu beitragen, dass diese Inhalte leichter gefunden und somit in den Ergebnissen der Suche unter Google Video™ angezeigt werden.

Über die Sitemap können Sie einige Zusatzinformationen wie den Titel, die Beschreibung oder die Dauer eines Videos übertragen, die die Suche erleichtern. Diese Zusatzinformationen werden dann auf den Seiten mit den Suchergebnissen (SERP) angezeigt. Im Fall von Abweichungen kann Google Video™ allerdings in den SERP die Texte der Videos verwenden, die auf der jeweiligen Seite verfügbar sind, und nicht die in die Sitemap eingefügten.

So fügen Sie Videoinformationen in die Sitemap ein:

§Öffnen Sie per Doppelklick auf das Video-/Audio-Objekt, das Sie bearbeiten möchten, das Fenster Video-/Audio-Objekt.

§Aktivieren Sie im Bereich Sitemap die Option Video in die Sitemap einbinden.

§Geben Sie die für die Einbindung in die Sitemap obligatorischen Informationen ein: Titel, Kurzbeschreibung und Vorschaubild für das Video.

§Optional können Sie ferner folgende Parameter definieren: Kategorie, Keywords, Veröffentlichungsdatum, Länge (Sek) und Inhalte für Minderjährige geeignet.

§Wiederholen Sie den Vorgang für alle Videos der Website.

Für weitere Informationen siehe Video-/Audio-Objekt | Sitemap.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Löschen einer Seite aus der Sitemap

Nachdem die Erstellung der Sitemap aktiviert wurde, werden standardmäßig alle Seiten der Website dort eingebunden. Falls Sie es vorziehen, dass eine oder mehrere Seiten von Suchmaschinen nicht berücksichtigt werden, können Sie diese jedoch auch aus der Sitemap entfernen. Gehen Sie hierzu wie folgt vor:

§Markieren Sie im Fenster Schritt 2 - Erstellen der Sitemap die Seite, die Sie aus der Sitemap löschen möchten.

§Klicken Sie auf Eigenschaften..., um das Fenster Eigenschaften der Seite und dort den Bereich Erweitert zu öffnen.

§Deaktivieren Sie das Kontrollkästchen neben der Option Diese Seite in die Sitemap einbinden.

§Die Eingabe muss bestätigt und gespeichert werden.

Quellen:

- | Sitemap (Wikipedia.de)
- | Informationen über Sitemaps (Google Webmaster-Zentrale)
- | Zusätzliche Bildinformationen in der Sitemap (Google Webmaster-Zentrale)
- | Informationen über Videoinhalte in der Sitemap (Google Webmaster-Zentrale)


Die Arbeit mit Vorlagen

Praktische Anwendung > Schritt 1 - Allgemeine Einstellungen > Die Vorlagen >

Die Arbeit mit Vorlagen

 Return to chapter overview
Versteckten Text zeigen/verstecken

WebSite X5 ermöglicht eine komfortable, flexible Verwaltung der grafischen Vorlagen. Dank der großen Auswahl an vordefinierten Templates, zahlreichen Optionen für die individuelle Gestaltung und vor allem dank der Möglichkeit, Templates von Grund auf selbst zu erstellen, kann jeder die jeweils am besten geeignete Methode auswählen und die gewünschten Ergebnisse erzielen.

Und die Möglichkeit, Templates außerdem zu importieren und exportieren (d.h. sie von dem Projekt, für das sie erstellt wurden, zu trennen), erleichtert erheblich die Nutzung dieser Ressourcen durch mehrere Personen.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Auswahl eines vordefinierten Templates

WebSite X5 Enthält eine Galerie mit über 1.500 vordefinierten, gebrauchsfertigen Templates. Und auch die Auswahl eines Templates aus den verfügbaren Vorschlägen ist sehr einfach:

§Öffnen Sie das Fenster Auswahl der Vorlage und nutzen Sie den Filter nach Menütyp, um nur die Templates anzeigen zu lassen, deren Menü sich in der von Ihnen gewünschten Position befindet (horizontal oder vertikal ausgerichtet).

§Sehen Sie sich die Vorschaubilder an und wählen Sie eine Vorlage, die zum Thema Ihrer Website passt.

§Markieren Sie das gewünschte Template und klicken Sie auf die Schaltfläche Weiter, um es Ihrem Projekt zuzuweisen und das Fenster Gestaltung des Templates zu öffnen, wo Sie den Header und die Fußzeile gestalten können.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Erstellen eines vordefinierten Templates

Nachdem Sie mit einem externen Grafikeditor ein Layout erstellt haben, können Sie dieses in WebSite X5 auf der Grundlage eines individuellen Templates einstellen:

§Öffnen Sie das Fenster Auswahl der Vorlage und nutzen Sie den Filter der Kategorien, um nur die individuellen Templates anzeigen zu lassen.

§Solange noch keine weiteren erstellt wurden, enthält die Liste nur ein individuelles Template. Markieren Sie es und klicken Sie auf Bearbeiten... (oder öffnen Sie es per Doppelklick), um das Fenster Individuelles Template einzublenden.

§Wenn Sie hingegen ein individuelles Template erstellen und der Galerie hinzufügen möchten, klicken Sie auf Neue Vorlage. Nun können Sie dem Template einen Namen geben und mit der Gestaltung beginnen.

Alle erstellten individuellen Templates werden der Galerie hinzugefügt und stehen somit auch für andere, zukünftige Projekte zur Verfügung.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Erstellen einer neuen Vorlage aus einem vordefinierten Template

Ein vordefiniertes Template kann einen hervorragenden Ausgangspunkt für ein neues, individuelles Template sein, um ein noch originelleres und optimal auf den Zweck der Website abgestimmtes Ergebnis zu erzielen. Gehen Sie hierzu folgendermaßen vor:

§Öffnen Sie das Fenster Auswahl der Vorlage und nutzen Sie die Filter für die Auswahl eines passenden vordefinierten Templates, das Sie als Ausgangspunkt verwenden.

§Klicken Sie auf Duplizieren, um das Template zu kopieren. Diese Kopie wird unter den vordefinierten Templates gespeichert.

§Markieren Sie die Kopie und klicken Sie auf Weiter, um das Fenster Individuelles Template zu öffnen und die gewünschten Änderungen vorzunehmen.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Import/Export eines Templates

Das für ein Projekt erstellte Template kann exportiert werden, um dann auf anderen PCs importiert und, auch von anderen Nutzern, verwendet zu werden.

Export eines erstellten Templates:

§Öffnen Sie das Fenster Auswahl der Vorlage, markieren Sie das erstellte Template und klicken Sie auf Exportieren...: In dem angegebenen Exportverzeichnis wird eine Datei mit der Endung .IWTLP generiert.

§Kopieren Sie die .IWTPL-Datei auf den Computer, an dem das Template importiert werden soll.

Import eines zuvor mit WebSite X5 erstellten Templates:

§Öffnen Sie das Fenster Auswahl der Vorlage und klicken Sie auf Importieren.... Wählen Sie die .IWTPL-Datei des zu importierenden Templates.

§Das importierte Template steht nun in der Liste der individuellen Templates zur Verfügung.

In den .IWTPL-Dateien werden nur die Bilder und Einstellungen des Templates gespeichert. Das heißt, die das Projekt betreffenden Informationen werden beim Export nicht erhalten.

Für den Export eines ganzen Projekts nutzen Sie bitte die entsprechenden Funktionen in Schritt 5 - Export.

Praktische Anwendung:

-

Wo finde ich neue Templates für WebSite X5 ?


Wo finde ich weitere Templates für WebSite X5?

Praktische Anwendung > Schritt 1 - Allgemeine Einstellungen > Die Vorlagen >

Wo finde ich weitere Templates für WebSite X5?

 Return to chapter overview

Wenn Sie für die Neu- oder Umgestaltung Ihrer Website nach einem neuen Template suchen, finden Sie diese unter WebSite X5 Templates. Diese Sektion der offiziellen Internetpräsenz von WebSite X5 finden Sie unter der Adresse http://answers.websitex5.com/templates.

Auf WebSite X5 Templates finden Sie zahlreiche, teils kostenlose teils kostenpflichtige Vorlagen von Incomedia und anderen Benutzern, die Sie herunterladen und für Ihr Projekt verwenden können.

Außerdem können Sie Ihre eigenen Kreationen einstellen und so zur Bereicherung des Archivs beitragen. Wenn Sie sich für Webdesign interessieren, können Sie Partner-Designer werden, Ihre Templates bei uns anbieten und damit Geld verdienen. Weitere Informationen über das Partnerprogramm finden Sie unter http://answers.websitex5.com/templates.

Und nicht vergessen: Schauen Sie regelmäßig auf WebSite X5 Templates vorbei, um zu erfahren, was es Neues gibt. Sie können auch den RSS-Feed abonnieren, um über alle Neuzugänge informiert zu werden.


Erstellen und bearbeiten der Sitemap

Praktische Anwendung > Schritt 2 - Erstellen der Sitemap >

Erstellen und bearbeiten der Sitemap

 Return to chapter overview
Versteckten Text zeigen/verstecken

In WebSite X5 hat die Sitemap die typische Baumstruktur: Ausgehend von der Homepage gelangt man zu den verschiedenen Ebenen mit den jeweiligen Seiten. Beim Erstellen der Sitemap werden neben der Homepage, die immer vorhanden ist, auch eine Reihe von Seiten definiert, die über das Menü verbunden sind. Daher müssen alle diese Seiten eingefügt und gleichzeitig die einzelnen Menüebenen aufgebaut werden.

In WebSite X5 haben Ebenen, im Unterschied zu Seiten, keine eigenen Inhalte. Vereinfachend könnte man Ebenen als „Behälter für Seiten“ bezeichnen.

Auch die Trennelemente haben keine eigenen Inhalte, sondern tragen lediglich dazu bei, das Navigationsmenü visuell zu strukturieren.

Klicken Sie um zu erweitern/minimieren

Ziel des Aufbaus der Sitemap ist es also, eine Struktur zu erstellen, innerhalb der alle Inhalte der Website logisch organisiert sind, damit sie von den Besuchern der Website schnell gefunden werden.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Erstellen der Sitemap

us praktischer Sicht ist das Erstellen der Sitemap in WebSite X5 sehr einfach:

§erwenden Sie im Fenster von Schritt 2 - Erstellen der Sitemap die Schaltflächen Neue Ebene, Neue Seite und Menütrennlinie um diese Elemente der Sitemap hinzuzufügen.

§Formulieren Sie alle Einträge der Sitemap mit Sorgfalt, da sie automatisch als Optionen des Navigationsmenüs und für die Dateinamen übernommen werden. Zum Umbenennen eines Eintrags können Sie darauf doppelklicken oder die Schaltfläche Umbenennen verwenden.

§Sie können die Sitemap jederzeit ändern und beispielsweise Seiten, Ebenen und Trennelemente verschieben. Wählen Sie hierzu einfach den jeweiligen Eintrag und ziehen Sie ihn mit der Maus (Drag&Drop an die gewünschte Stelle. Alternativ können auch die Schaltfläche Nach oben / Nach unten verwendet werden.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Erstellen und Bearbeiten der Sitemap (Befehle und Shortcuts)

Einige Operationen können direkt in der Sitemap-Ansicht durchgeführt werden:

§Wenn Sie auf eine bereits markierte Ebene oder Seite unter der Homepage erneut klicken, können Sie sie umbenennen (alternativ mit der Schaltfläche Umbenennen). Auch die Alias der speziellen Seiten im Verzeichnis Menü können umbenannt werden, die speziellen Seiten selbst jedoch nicht.

§Wenn Sie eine Seite markieren und dann auf die Einträge unter Erweiterter Seitentitel oder Beschreibung klicken, können Sie die dort eingegebenen Texte direkt ändern (alternativ im Dialogfenster Eigenschaften der Seite).

§Mit einem Doppelklick auf eine Ebene können Sie diese erweitern, um die enthaltenen Seiten anzuzeigen, bzw. ausblenden (alternativ mit den Schaltflächen Erweitern und Reduzieren). Außerdem können Sie eine Ebene erweitern oder ausblenden, indem Sie auf den Pfeil links neben dem Namen klicken.

§Mit Doppelklick auf eine Seite öffnet sich das Fenster Erstellen der Seiten, wo Sie die entsprechende Seite gestalten können.

§Mit Doppelklick auf eine spezielle Seite wird das Fenster Schritt 4 - Erweiterte Einstellungen geöffnet, wo Sie diese Seite gestalten bzw. aktualisieren können.

§Wenn Sie eine Ebene markieren und an eine neue Position ziehen, werden alle darin enthaltenen Seiten mit verschoben (alternativ mit den Schaltflächen Nach oben und Nach unten).

§Wenn Sie eine oder mehrere Seiten markieren, können Sie diese an eine neue Position ziehen (alternativ mit den Schaltflächen Nach oben und Nach unten). Für die Mehrfachauswahl halten Sie auf der Tastatur gleichzeitig zum Klick die Taste Strg oder Umschalt gedrückt.

§Wenn Sie das Verzeichnis Menü markieren, können Sie das gesamte Navigationsmenü ausblenden, indem Sie auf die Schaltfläche Seite im Menü nicht sichtbar klicken.

§Wenn Sie eine Spezielle Seite markieren und in das Verzeichnis Menü, bzw. zwischen die Seiten und Ebenen ziehen, aus denen sich das Navigationsmenü zusammensetzt, wird eine neue Ebene erstellt, die sich wie ein Alias der Speziellen Seite verhält. Diese Ebene trägt den gleichen Namen der Speziellen Seite und ist mit der Originalseite verlinkt. Auf diese Weise kann in das Navigationsmenü ein aktiver Menüpunkt integriert werden, der zur Introseite, zum Blog, zur Login-Seite oder zum Warenkorb für E-Commerce führt.

§Nach dem Markieren einer oder mehrerer Seiten können diese innerhalb des gleichen Projekts oder in ein anderes Projekt kopiert werden, das in einem weiteren Programmfenster geöffnet ist. Das Kopieren und Einfügen kann über die Werkzeugleiste, das mit Rechtsklick aufrufbare Kontextmenü oder die Tastenkombinationen Strg+C und Strg+V erfolgen. Bei Speziellen Seiten können die Befehle Kopieren und Einfügen nicht genutzt werden.


Einrichten einer Seite mit dem Layout-Schema

Praktische Anwendung > Schritt 3 - Erstellen der Seiten >

Einrichten einer Seite mit dem Layout-Schema

 Return to chapter overview
Versteckten Text zeigen/verstecken

WebSite X5 bietet ein einzigartiges Layout-System, mit dem die Seiten komplett im visuellen Modus erstellt werden können.

Hierzu wird die Seite als Raster dargestellt, dessen Zeilen- und Spaltenzahl festgelegt werden kann, um die Zellen für die einzelnen Inhalte zu definieren.

Anschließend können die verfügbaren Objekte per Drag&Drop in diese Zellen gezogen werden, um die effektiven Inhalte einzufügen.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Konfiguration des Layout-Schemas

In seiner Standardkonfiguration hat das Layout-Schema zwei Zeilen und zwei Spalten. Diesen können Sie je nach gewünschtem Seitenlayout weitere hinzufügen und anschließend die jeweiligen Objekte in den Zellen positionieren..

Um dem Layout-Schema Zeilen und Spalten hinzuzufügen, verwenden Sie die entsprechenden Schaltflächen [image] [image] in der Werkzeugleiste. Auf diese Weise können Raster mit bis zu 64 Zeilen und 12 Spalten erstellt werden.

Standardmäßig haben alle Zeilen bzw. Spalten des Layout-Schemas die gleiche Breite bzw. Höhe. Mit den Cursors am unteren Rand des Schemas können Sie den Wert der Spalten manuell absolut (Pixel) oder relativ (Prozentsatz) einstellen:

§Durch Ziehen eines Pfeils wird die Begrenzungslinie der Spalte verschoben. Während Sie den Cursor in eine andere Position ziehen, wird eine Infobox mit dem jeweiligen Pixelwert und Prozentsatz angezeigt, den die Spaltenbegrenzung jeweils annimmt. Wenn Sie beim Ziehen des Cursors gleichzeitig die Taste Strg gedrückt halten, wird der Cursor pixelweise verschoben. Andernfalls verschiebt er sich in Schritten von einem Zehntel des verfügbaren Raums.

Klicken Sie um zu erweitern/minimieren

§Mit Rechtsklick auf den Cursor wird ein Kontextmenü eingeblendet. Wählen Sie hier die Option Spaltenbreite festlegen, um die Spaltenbreite direkt in Pixeln einzugeben.

Klicken Sie um zu erweitern/minimieren

§Wählen Sie hingegen die Option Spalten auf gleiche Breite bringen, um für alle Spalten die gleiche Breite einzustellen.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Einfügen von Inhalten in das Layout-Schema

Um ein Objekt in eine Seite einzufügen, wählen Sie im Bereich Verfügbare Objekte ein Objekt aus und ziehen es in die gewünschte Zelle.

Jede Zelle des Schemas kann nur ein Objekt enthalten, umgekehrt kann ein Objekt aber sowohl horizontal als auch vertikal mehrere nebeneinander liegende Zellen belegen.

Ziehen Sie hierzu das jeweilige Objektsymbol in die gewünschte Richtung über die Ränder der Zellen hinaus, sodass das Feld den Platz der entsprechenden Zellen belegt. Das Objekt kann auch an seinen Ankerpunkten über mehrere Zellen gezogen werden.

Nachdem die Anzahl der Zellen festgelegt wurde, die ein Objekt belegen soll, wird diese - vorbehaltlich der Kompatibilität mit der Position anderer Objekte - beibehalten, auch wenn es an andere Stellen des Schemas verschoben wird. Alternativ können Sie sich innerhalb des Schemas auch mit den Pfeiltasten Ihrer Tastatur bewegen:

§Pfeiltasten: Verschieben der Auswahl innerhalb des Schemas von einer Zelle in eine andere.

§Strg + Pfeiltasten: Verschieben eines markierten Objekts (unter Beibehaltung seiner Abmessungen) in eine andere Zelle des Schemas.

§UMSCHALT + Pfeiltasten: Ändern der Abmessungen eines markierten Objekts (vorbehaltlich Kompatibilität mit eventuellen weiteren Objekten), um es auf eine andere Zellenzahl im Layout-Schema zu vergrößern oder zu verkleinern.

Mit Rechtsklick auf das Objektsymbol oder in eine leere Zelle wird ein Kontextmenü mit den Optionen Ausschneiden, Kopieren, Einfügen, Entfernen, Zellenstil, Zeile einfügen, Spalte einfügen, Zeile löschen und Spalte löschen angezeigt.

Über diese Befehle können Sie zum Beispiel eine Kopie eines Objekts erstellen, um diese dann in eine andere Zelle oder eine andere Seite einzufügen, oder ein Objekt löschen. Ein eingefügtes Objekt kann auch von der Seite entfernt werden, indem Sie es in einen Bereich außerhalb des Layout-Schemas ziehen oder die Taste Entf drücken. Wird ein neues Objekt in einer Zelle positioniert, die bereits von einem anderen belegt ist, wird dieses von dem neuen ersetzt. Wird hingegen ein bereits positioniertes Objekt auf eine belegte Zelle gezogen, tauschen die beiden Objekte ihre Position.

Mit den Optionen Kopieren und Einfügen im Untermenü der Option Zellenstil können Sie einen Zellenstil automatisch auf eine andere Zelle anwenden.

Nachdem Sie ein Objekt in das Schema eingefügt haben, können Sie per Doppelklick auf die jeweilige Zelle des Layout-Schemas oder durch Markieren des Objekts und Anklicken der Schaltfläche [image] Objektinhalt definieren den jeweiligen Inhalt festlegen ( (Objekt Text, Bildobjekt, Objekt Tabelle, Objekt Galerie, Video-/Audio-Objekt, Objekt E-Mail-Formular, Gästebuch-Objekt, Objekt Soziales Netzwerk, Kartenobjekt, Objekt Flash-Animation, Objekt Produktliste, HTML und Widgets).

Es müssen nicht alle Zellen des Layout-Schemas ausgefüllt werden. Berücksichtigen Sie hierbei bitte jedoch, dass eine leere Zelle einem leeren Platz auf der Seite entspricht.

Die Layout-Möglichkeiten optimal zu nutzen, beachten Sie, dass die Software nach folgenden Regeln arbeitet:

§Die Seitenbreite wird vom jeweiligen Template bestimmt.

§Die Spaltenbreite des Layout-Schemas ist der Quotient aus der Seitenbreite und der Anzahl der eingefügten Spalten. Standardmäßig haben alle Spalten die gleiche Breite, dieser Parameter kann jedoch manuell geändert werden.

§Alle auf der gleichen Zeile angeordneten Zellen der Tabelle haben die gleiche Höhe: Standardmäßig wird dieser Wert durch das höchste der in den Zellen enthaltenen Objekte bestimmt.

§Die eingefügten Objekte werden automatisch der Zellengröße im Layout-Schema angepasst.

Zusatzinformationen:

-

Das Box-Model in WebSite X5


Die Arbeit am Zellenstil

Praktische Anwendung > Schritt 3 - Erstellen der Seiten >

Die Arbeit am Zellenstil

 Return to chapter overview
Versteckten Text zeigen/verstecken

In der Bearbeitungsphase Erstellen der Seiten, können Sie, nachdem Sie eins der verfügbaren Objekte in eine Zelle des Layout-Schemas In der Bearbeitungsphase Erstellen der Seiten können Sie, nachdem Sie eins der verfügbaren Objekte in eine Zelle des Layout-Schemas gezogen haben, die grafische Gestaltung dieser Zelle mit klick auf den [image] Button und mit Hilfe der Optionen im Dialogfenster Zellenstil festlegen.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Erstellen eines Hintergrundbildes, das sich an die Abmessungen der Zelle anpasst

Das Aussehen der Zelle kann auf verschiedene Weise individuell gestaltet werden. Beispielsweise können Sie ein Bild (Dateiformat JPG, GIF oder PNG) importieren und als Hintergrund für die Zelle verwenden. Je nach Art des gewählten Bilds haben Sie die Wahl zwischen den Optionen Bildhintergrund, wo Sie unter Anordnung und Ausrichtung verschiedene Einstellungen vornehmen können, und Bild an Zelle anpassen, um das jeweils optimale Ergebnis zu erzielen.

Beispiel 1

Das importierte Bild hat die gleichen Abmessungen wie die Zelle.

Hintergrund: Bildhintergrund

Anordnung: Nicht wiederholen

Ausrichtung: Oben - Links

Klicken Sie um zu erweitern/minimieren

Beispiel 2

Das importierte Bild ist ein Pattern, der so gestaltet ist, dass beim horizontalen oder vertikalen Aneinanderfügen der Übergang zwischen den einzelnen Bildern nicht sichtbar ist.

Hintergrund: Bildhintergrund

Anordnung: Wiederholung in beide Richtungen

Ausrichtung: Oben - Links

Klicken Sie um zu erweitern/minimieren

Beispiel 3

Das importierte Bild ist ein Rahmen, der an Zellen verschiedener Abmessungen angepasst werden soll.

Hintergrund: Bild an Zelle anpassen

Blockbreite / Blockhöhe: Die Blockmaße nach Bedarf anpassen.

Klicken Sie um zu erweitern/minimieren

Um die Option Bild an Zelle anpassen, das Konzept der Blöcke und deren Größenanpassung besser zu verstehen, betrachten Sie bitte nachstehende Abbildungen:

Bild 1 | Bild 2 | Bild 3

Das Originalbild (Bild 1) ist ein komplexer Rahmen, der sich jedoch dazu eignet, in Blöcke aufgeteilt zu werden und somit problemlos an jede Zellengröße angepasst werden kann: Die Ornamente in den Ecken belegen einen leicht abgrenzbaren Bereich und alle Farbübergänge können ohne unerwünschte Änderungen des Farbtons als Pattern widerholt werden.

In Abbildung 2 sehen Sie die Blöcke, deren Maße Sie festlegen müssen (Optionen Blockbreite und Blockhöhe). Die Breite und Höhe der Blöcke (alle gleich) werden als Prozentsatz von der Breite und Höhe des Originalbilds definiert, der zwischen 5% und 45% einstellbar ist. In diesem Beispiel muss für beide Blockseiten ein Ausschnitt von 35% gewählt werden, damit die Eckelemente voll abgedeckt sind.

In Abbildung 3 sehen Sie, dass nach Festlegung der Blöcke A, B, C und D als zusätzliche Ausschnitte die Blöcke a, b, c, d und e entstehen: Diese Ausschnitte werden vom Programm erzeugt, um das Originalbild in alle Komponenten zu gliedern, die erforderlich sind, um den Hintergrund der Zelle zusammenzusetzen. Das heißt, während die Bildausschnitte der Blöcke A, B, C und D unverändert beibehalten und in den Ecken positioniert werden, werden die Bildausschnitte der Blöcke a, b, c, d und e so wiederholt, dass der gesamte benötigte Raum ausgefüllt wird.

Es ist offensichtlich, dass dieses Verfahren erhebliche Flexibilität bietet: Ausgehend von einem einzigen, angemessen realisierten Bild können auch Zellen sehr unterschiedlicher Abmessungen gestaltet werden.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Benutzen der Zellen-Stil-Bibliothek

Mit der Bibliothek können Sie die Bearbeitung Ihrer Seiten erheblich beschleunigen: Sollen für mehrere Zellen die gleichen grafischen Einstellungen verwendet werden, bietet es sich an, diese für die erste Zelle zu definieren, sie dann als Stil zu speichern und bei Bedarf auf andere Zellen anzuwenden, ohne sie noch einmal vornehmen zu müssen.

Erstellen eines neuen Stils:

§Wählen Sie im Layout-Schema die Zelle aus, die Sie bearbeiten möchten und klicken Sie auf die Schaltfläche [image], um das Dialogfenster Zellenstil zu öffnen.

§Nutzen Sie zur Gestaltung die Optionen, die Ihnen in den Tabs Stil und Text zur Verfügung stehen, bis Sie das gewünschte Ergebnis erzielt haben.

§Klicken Sie nun auf den Tab Bibliothek und dort auf die Schaltfläche Hinzufügen: Mit den zuvor definierten Einstellungen wird ein neuer Stil erstellt. Der Liste der Benutzerdefiniert wird eine Vorschau des soeben erstellten Stils hinzugefügt.

Anwenden eines Stils:

§Wählen Sie im Layout-Schema die Zelle aus, die Sie bearbeiten möchten und klicken Sie auf die Schaltfläche [image], um das Dialogfenster Zellenstil zu öffnen.

§Öffnen Sie den Tab Bibliothek und markieren Sie in der Liste der Standardeinstellungen Stile oder Benutzerdefiniert Stile die Vorschau des Stils, den Sie verwenden möchten.

§Klicken Sie auf die Schaltfläche Übernehmen.

Zusatzinformationen:

-

Das Box-Model in WebSite X5


Erstellen einer mehrsprachigen Website

Praktische Anwendung > Schritt 4 - Erweiterte Einstellungen >

Erstellen einer mehrsprachigen Website

 Return to chapter overview
Versteckten Text zeigen/verstecken

Das Internet ermöglicht es uns, Landesgrenzen zu überwinden, und wenn Ihre Website voraussichtlich auch von Personen anderer Nationalitäten besucht wird, empfiehlt es sich, die Inhalte in mehreren Sprachen anzubieten.

Die Verwaltung einer mehrsprachigen Website erhöht zweifellos die Komplexität des Projekts, dank der Funktionen, die Ihnen WebSite X5 zur Verfügung stellt und mit Hilfe eines zuverlässigen Übersetzungsdienstes kann Ihnen jedoch auch dieses Vorhaben brillant gelingen.

Allem voran muss hervorgehoben werden, dass WebSite X5 alle HTML-Dateien für die Seiten der Website mit UTF-8-Kodifizierung (Unicode Transformation Format, 8 bit) erstellt. Mit UTF-8 können Websites in beliebigen Sprachen realisiert werden, einschließlich solchen mit nicht lateinischen Alphabeten wie zum Beispiel Griechisch, Kyrillisch, Koptisch, Armenisch, Hebräisch und Arabisch, aber auch Chinesisch, Japanisch oder Koreanisch. Außerdem können Sie nicht nur die Website in einer beliebigen Sprache erstellen, sondern auch innerhalb dieser Website Texte in verschiedenen Sprachen vorsehen, ohne Probleme mit der Zeichendarstellung zu haben. Das heißt beispielsweise, das Sie problemlos einen russischen Text und gleich daneben die italienische Übersetzung veröffentlichen können.

Bei der Erstellung einer Website können Sie in WebSite X5 zunächst Ihrem Projekt eine Sprache zuweisen (unter Allgemeine Einstellungen | Allgemein, Option Sprache der Website): Dieser Schritt ist sehr wichtig, um die Texte, die vom Programm automatisch eingefügt werden, korrekt zu verwalten. Neben der Verfügbarkeit einiger vorinstallierter Sprachen können Sie im Fenster Sprachenzentrum die Schaltfläche [image] anklicken, um andere Sprachversionen zu erstellen bzw. zu importieren oder um die Einträge der bereits vorgesehenen zu ändern (siehe hierzu Sprachverwaltung für automatisch eingefügten Text).

Und schließlich haben Sie die Möglichkeit, mit WebSite X5 eine mehrsprachige Website zu erstellen, auf der die Besucher aus verschiedenen verfügbaren Sprachen die bevorzugte auswählen können. Hierfür ist es hinreichend, für jede Sprache ein Projekt zu erstellen und diese zu verknüpfen, als handle es sich um verschiedene Sektionen ein und derselben Website. Zum Verknüpfen von Projekten, die sich nur in ihrer Sprache unterscheiden, stehen Ihnen hauptsächlich zwei Methoden zur Verfügung: Die erste nutzt die Introseite, die zweite hingegen die Möglichkeit, Verknüpfungen direkt in den Header des Templates einzufügen.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Erstellen einer mehrsprachigen Website über die Introseite

Angenommen, Sie möchten eine Website erstellen, die in deutscher, englischer und portugiesischer Sprache verfügbar ist. Hierzu können Sie in die Introseite Schaltflächen einfügen, über die die Besucher auswählen können, in welcher Sprache die Inhalte angezeigt werden sollen.

§Erstellen Sie zunächst die Website in deutscher Sprache, definieren Sie die Struktur und die Inhalte und stellen Sie unter Allgemeine Einstellungen | Allgemein "DE - Deutsch" als Sprache der Website ein.

§Klicken Sie in Schritt 4 - Erweiterte Einstellungen auf die Schaltfläche Introseite, aktivieren Sie im entsprechenden Dialogfenster die Option Introseite anzeigen, legen Sie fest, welches Bild oder welche Animation als Seitenhintergrund angezeigt werden soll und nehmen Sie alle Einstellungen vor, um die Anzeige wie gewünscht zu gestalten.

§Zum Erstellen der Schaltflächen für die Sprachauswahl aktivieren Sie die Option Links zu anderen Sprachen anzeigen.

§Mit Hilfe der verfügbaren Funktionen können Sie die gewünschte Sprachliste zusammenstellen. Wählen Sie in der Liste die nicht benötigten Sprachen und klicken Sie auf Entfernen. Klicken Sie dann auf Hinzufügen..., um das Fenster Spracheinstellungen zu öffnen und die portugiesische Sprache hinzuzufügen: Geben Sie unter Anzuzeigende Sprachbezeichnung "Português" ein und importieren Sie eine Bilddatei, die der Sprache zugeordnet werden soll.

§Wählen Sie analog die Optionen "Deutsch" und "English" und klicken Sie auf Bearbeiten..., um das Fenster Spracheinstellungen zu öffnen und auch diesen Sprachen die Bilder der jeweiligen Flaggen zuzuweisen.

§Da für das aktuelle Projekt die deutsche Sprache festgelegt wurde (die einzige Sprache, der die Introseite zugewiesen wird), wählen Sie die Option "Deutsch" aus der Sprachliste und klicken Sie auf Hauptsprache.

§Mit Hilfe der Schaltflächen Nach obenund Nach unten können Sie die Sprachen wie gewünscht ordnen.

Nachdem die Flaggensymbole für die Sprachen eingefügt wurden, müssen nun die entsprechenden Verknüpfungen erstellt werden. Wird für jede Sprache eine eigene Website erstellt und veröffentlicht, kann die Verknüpfung zu einer URL eingefügt werden:

§Wählen Sie in der Sprachliste den Eintrag "English" und klicken Sie auf Bearbeiten..., um das Fenster Spracheinstellungen zu öffnen.

§Klicken Sie auf [image] unter Link für diese Sprache (z.B. Website in dieser Sprache anzeigen), wählen Sie im Fenster Link die Aktion Datei oder URL und geben Sie die URL der englischen Version Ihrer Website ein, zum Beispiel http://www.meinewebsite.de/en/index.html, wenn die englische Version im Unterverzeichnis "en" des Hauptverzeichnisses auf dem Server veröffentlicht werden soll.

§Wiederholen Sie die Schritte analog für die portugiesische Version, indem Sie auch hier die entsprechende URL verknüpfen, zum Beispiel http://www.meinewebsite.de/pt/index.html, wenn die portugiesische Version im Unterverzeichnis "pt" des Hauptverzeichnisses auf dem Server veröffentlicht werden soll.

Nun ist die Website für die Sprachauswahl vorbereitet, aber es fehlen noch die Inhalte für die englische und die portugiesische Version.

§Für eine schnelle Realisierung der englischen Sprachversion erstellen Sie zunächst eine Kopie der deutschen: Wählen Sie im Startfenster Projektauswahl das Projekt in deutscher Sprache und klicken Sie auf Duplizieren. Klicken Sie auf Umbenennen, um dem neuen Projekt einen angemessenen Namen zu geben.

§Öffnen Sie das Projekt und stellen Sie unter Allgemeine Einstellungen | Allgemein "EN - English" als Sprache der Website ein. Lokalisieren Sie dann alle Texte und sonstigen, eventuell sprachabhängigen Elemente.

§Öffnen Sie in Schritt 4 - Erweiterte Einstellungen das Fenster Introseite und deaktivieren Sie die Option Introseite anzeigen.

§Gehen Sie nach Fertigstellung der englischen Sprachversion analog vor, um auch das Projekt in portugiesischer Sprache zu erstellen.

Zur Veröffentlichung der Websites auf dem Server gehen Sie bitte wie folgt vor:

§Veröffentlichung der deutschen Sprachversion: Der deutschen Sprachversion der Website wurde die Introseite zugewiesen und sie wurde als "Standard" definiert. Bei der Veröffentlichung wird von der Introseite eine Datei index.html erstellt und im Verzeichnis für die Veröffentlichung gespeichert. Für die URL der Websites in englischer und portugiesischer Sprache müssen auf dem Server entsprechende Unterverzeichnisse "en" und "pt" erstellt werden.

Nach diesem Schritt ist die deutsche Version der Website online und auf der Introseite sehen Sie die aktiven Schaltflächen für die Sprachversionen, jedoch noch ohne die entsprechenden Verlinkungen.

§Veröffentlichung der englischen Sprachversion: Damit der Sprachlink auf der Introseite funktioniert, muss das entsprechende Projekt in dem erstellten Unterverzeichnis "en" veröffentlicht werden.

§Veröffentlichung der portugiesischen Sprachversion: Damit der Sprachlink zur portugiesischen Version auf der Introseite funktioniert, muss analog das entsprechende Projekt in dem erstellten Unterverzeichnis "pt" veröffentlicht werden.

Nachdem alle drei Websites in den entsprechenden Unterverzeichnissen veröffentlicht wurden, funktionieren die Schaltflächen auf der Introseite korrekt und die Besucher können die Inhalte in der bevorzugten Sprache anzeigen.

Mit der Option Link für diese Sprache (z.B. Website in dieser Sprache anzeigen) im Fenster Spracheinstellungen können für die Bilder, die den einzelnen Sprachen zugeordnet wurden (in den meisten Fällen Flaggen) beliebige Aktionen festgelegt werden. Dies bedeutet, Sie können anstelle der Verlinkung einer kompletten Website, wie im Beispiel dargestellt, eine einfache interne Seite oder eine Meldung verlinken, um darauf hinzuweisen, dass sich die Website in einer bestimmten Sprache noch im Aufbau befindet. Alternativ können Sie auch zu einer PDF-Datei verlinken, die alle Informationen bezüglich einer Sprache enthält, oder nach Bedarf sonstige Lösungen umsetzen.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Erstellen einer mehrsprachigen Website mit Hilfe der Schaltflächen für den Header des Templates

Nehmen wir noch einmal an, Sie möchten eine Website erstellen, die in deutscher, englischer und portugiesischer Sprache verfügbar ist. Alternativ oder ergänzend zur Verlinkung der Introseite können Sie die Schaltflächen für die Sprachauswahl auch in den Header Ihres Templates einfügen. Diese Methode hat den Vorteil, dass die Besucher die Sprache jederzeit und auf jeder beliebigen Seite der Website umschalten können.

§Erstellen Sie zunächst die Website in deutscher Sprache, definieren Sie die Struktur und die Inhalte und stellen Sie unter Allgemeine Einstellungen | Allgemein "DE - Deutsch" als Sprache der Website ein.

§Öffnen Sie das Fenster Gestaltung des Templates, um den Header zu bearbeiten und die Schaltflächen für die Sprachauswahl einzufügen.

§Über die Schaltfläche [image] Bild einfügen das gewünschte Bild, beispielsweise die deutsche Flagge, importieren: Soll die Schaltfläche mit Mouse-Over-Effekt erstellt werden, können Sie mit der Option Bild bei Mauskontakt ein zweites Bild importieren, das vom ersten leicht abweicht.

§Wiederholen Sie diesen Vorgang für die weiteren Schaltflächen mit Bildern der englischen und der portugiesischen Flagge.

§Markieren Sie die Schaltfläche mit der englischen Flagge und klicken Sie auf [image] Link zuweisen: Es öffnet sich das Fenster Link. Wählen Sie dort die Aktion Datei oder URL, aktivieren Sie URL oder Datei im Internet und geben Sie die URL ein, unter der die englische Sprachversion der Website abgelegt werden soll (zum Beispiel http://www.meinewebsite.de/en/index.html).

§Wiederholen Sie die Schritte analog für die portugiesische Version, indem Sie auch hier die entsprechende URL verknüpfen (zum Beispiel http://www.meinewebsite.de/pt/index.html).

Da Sie für das Projekt die deutsche Sprache als Standard definiert haben, müssen Sie natürlich die Schaltfläche mit der deutschen Flagge nicht verlinken.

§Für eine schnelle Realisierung der englischen Sprachversion erstellen Sie zunächst eine Kopie der deutschen: Wählen Sie im Startfenster Projektauswahl das Projekt in deutscher Sprache und klicken Sie auf Duplizieren. Klicken Sie dann auf Umbenennen, um dem neuen Projekt einen angemessenen Namen zu geben.

§Öffnen Sie das Projekt und stellen Sie unter Allgemeine Einstellungen | Allgemein "EN - English" als Sprache der Website ein. Lokalisieren Sie dann alle Texte und sonstigen, eventuell sprachabhängigen Elemente.

§Öffnen Sie das Fenster Gestaltung des Templates und ordnen Sie die Verlinkungen den einzelnen Flaggensymbolen zu: Verlinken Sie die Schaltfläche für Deutsch mit der entsprechenden URL (zum Beispiel: http://http://www.meinewebsite.de/index.html) und entfernen Sie die Verlinkung von der englischen Flagge.

§Gehen Sie nach Fertigstellung der englischen Sprachversion analog vor, um auch das Projekt in portugiesischer Sprache zu erstellen. In diesem Fall müssen die Verlinkungen der Schaltflächen für die deutsche und englische Sprache eingestellt und von der portugiesischen entfernt werden.

Damit die so erstellten Schaltflächen korrekt funktionieren, müssen die Websites in den 3 Sprachen über die vorgesehenen Pfade auf dem Server veröffentlicht werden.

§Erstellen Sie hierzu im Server-Verzeichnis für die Veröffentlichung zwei Unterverzeichnisse und nennen Sie diese "en" und "pt".

§Veröffentlichen Sie das Projekt in deutscher Sprache (hier als Hauptprojekt angenommen) in dem Hauptverzeichnis sowie die Websites in englischer und portugiesischer Sprache in den jeweiligen Unterverzeichnissen "en" und "pt".

Praktische Anwendung:

-

Sprachverwaltung für automatisch eingefügten Text


Management der Blog- und Gästebuch-Kommentare im Control Panel

Praktische Anwendung > Schritt 4 - Erweiterte Einstellungen >

Management der Blog- und Gästebuch-Kommentare im Control Panel

 Return to chapter overview
Versteckten Text zeigen/verstecken

Ein Blog ist eine Art Web-Tagebuch, in dem Sie Artikel unterschiedlicher Natur veröffentlichen und Ihren Lesern die Möglichkeit geben, Kommentare abzugeben. Wenn die Lesercommunity durch die Qualität der Posts angeregt wird, können sich aus diesem Dialog interessante Diskussionen zum Thema entwickeln.

Klicken Sie um zu erweitern/minimieren Vorgehensweise: Wie die Kommentarverwaltung in WebSite X5 einsgestellt werden kann

Um den Lesern die Möglichkeit zu geben, die veröffentlichten Posts zu kommentieren, muss der Blog zunächst in Blog | Kommentare entsprechend konfiguriert werden. Im Einzelnen:

§Aktivieren Sie die Option Kommentare zum Blog zulassen.

§Geben Sie den Pfad zum Verzeichnis mit Schreibzugriff an, also dem Verzeichnis, in dem der PHP-Code Schreibzugriff auf die Dateien zulässt.

§Entscheiden Sie, ob Sie sen Antispam-Filter "Captcha" aktivieren wollen.

§Geben Sie die E-Mail-Adresse für Kommentarbenachrichtigung an. An diese E-Mail-Adresse werden Sie automatisch informiert, wenn ein neuer Kommentar abgegeben wurde.

§Legen Sie fest, ob die Kommentare sofort veröffentlicht werden sollen oder ob sie erst genehmigt werden müssen.

Anschließend können Sie beginnen, Artikel einzugeben und den Blog veröffentlichen. Unter den Blog-Posts wird automatisch ein Formular eingefügt, in das die Leser ihre Kommentare eingeben und dann senden können. In dieses Formular müssen folgende Informationen eingegeben werden: Name, E-Mail, Website und die Nachricht. Mit Ausnahme der Angabe der Website müssen alle Felder ausgefüllt werden.
Klicken Sie um zu erweitern/minimieren Vorgehensweise: Wie im Control Panel die Kommentare verwaltet werden können

Sobald ein Leser einen Kommentar abgegeben hat, wird automatisch eine E-Mail erstellt, die an die angegebene E-mail-Adresse gesendet wird. Wenn die Option Anzeigen von Kommentaren nach Admin-Zustimmung aktiviert wurde, muss der Kommentar, damit er online unter dem betreffenden Post erscheint, erst im Control Panel von WebSite X5 mit dem entsprechenden Befehl bestätigt werden.

Das Control Panel finden Sie unter der URL http://www.meinewebsite.de/admin, wobei http://www.meinewebsite.de er URL der Website entspricht, mit der der Blog verknüpft ist. Zugang zum Control Panel haben alle Benutzer, die unter Zugangsverwaltung in Schritt 4 - Erweiterte Einstellungen in der Gruppe Administratoren registriert sind.

Im Bereich Blog des Control Panels finden Sie zwei Dropdown-Menüs mit den Kategorien sowie den mit diesen verknüpften Artikellisten. In diesen Menüs können Sie die Posts auswählen, deren Kommentare Sie anzeigen möchten. Nach der Auswahl wird die Liste der Kommentare angezeigt. Von jedem Kommentar werden der Autor, dessen E-Mail-Adresse, der Kommentartext sowie das Datum und die Uhrzeit des Versands angezeigt. Sofern diese Information verfügbar ist

So verwalten Sie die Kommentare:

§Öffnen Sie das Control Panel, loggen Sie sich ein und öffnen Sie den Bereich Blog.

§Wählen Sie den Artikel, dessen Kommentare Sie einsehen möchten, aus den Dropdown-Menüs mit den Kategorien und jeweiligen Blog-Posts.

§In der Liste der Kommentare zum ausgewählten Post können Sie diese nun mit folgenden Befehlen verwalten:

-Entfernen: Der ausgewählte Kommentar wird entfernt, das heißt, er wird nicht im Blog veröffentlicht und auch aus der Kommentarliste im Control Panel gelöscht.

-Genehmigen/Ablehnen: Mit diesem Befehl können Sie einen Kommentar genehmigen, also seine Anzeige im Blog bestätigen, oder ablehnen, das heißt, ihn aus den Kommentaren im Blog entfernen. Ein abgelehnter Kommentar wird nicht aus den Listen des Control Panels gelöscht.

Es ist von fundamentaler Bedeutung, die Veröffentlichung von Kommentaren im Blog steuern zu können, um sich vor Spam zu schützen und die Diskussion zu moderieren, indem Sie Beiträge löschen, die Sie als beiligend, für das jeweilige Thema irrelevant oder inkompatibel mit dem gewünschten Stil erachten.


Inhalt der E-Mail zur Bestellbestätigung

Praktische Anwendung > Schritt 4 - Erweiterte Einstellungen > Warenkorb für E-Commerce >

Inhalt der E-Mail zur Bestellbestätigung

 Return to chapter overview

Nachdem eine Bestellung eingegangen ist, muss der Kunde eine E-Mail erhalten, in der bestätigt wird, dass die Bestellung korrekt aufgegeben wurde und in der die erforderlichen Zahlungshinweise mitgeteilt werden.

WebSite X5 erstellt die E-Mail zur Bestellbestätigung automatisch und verwendet hierzu nur die benötigten individuellen Daten, die der Kunde bei Aufgabe seiner Bestellung angegeben hat.

Im Einzelnen setzt sich die Bestätigungs-Mail wie folgt zusammen:

Header-Text:
Beschreibung: | Dies ist die Einleitung. Sie sollte einen Satz enthalten, mit dem Sie sich für den Einkauf bedanken, sowie die nachstehend enthaltenen Informationen ankündigen.
Beispiel: | Sehr geehrter Kunde, Vielen Dank für Ihren Einkauf. Hiermit erhalten Sie eine Zusammenfassung Ihrer Bestellung. Nachstehend finden Sie die Liste der bestellten Produkte, die Rechnungsinformationen sowie Hinweise zu der von Ihnen gewählten Versand- und Zahlungsart.
Wo einstellen: | In Warenkorb für E-Commerce | Bestellung senden, im Feld Einführungstext.
Kundendetails
Beschreibung: | In diesem Bereich werden die Daten für die Rechnungsausstellung und den Versand angezeigt, die der Kunde in das Bestellformular eingegeben hat.
Wo einstellen: | Das Bestellformular kann in Warenkorb für E-Commerce | Kundendetails definiert werden.
Zusammenfassung der Bestellung
Beschreibung: | Dies ist eine Tabelle, in der die bestellten Produkte aufgelistet sind. Die Tabelle enthält die bestellte Menge, den Einzelpreis pro Produkt sowie den Gesamtbestellwert.
Wo einstellen: | Hierfür muss keine besondere Einstellung vorgenommen werden. Die Tabelle wird auf der Grundlage der eingegangenen Bestellung automatisch generiert.
Zahlungsart
Beschreibung: | Je nach Auswahl des Kunden aus den angebotenen Zahlungsarten muss er Informationen und Hinweise erhalten, die er benötigt, um die Zahlung vorzunehmen.
Beispiel: | Zahlung per Banküberweisung: Nachstehend finden Sie die Informationen, die für die Zahlung per Banküberweisung benötigt werden: XXX YYY ZZZ Bitte beachten Sie, dass Sie nach Abschluss der Zahlung eine Kopie der Überweisungsbestätigung gemeinsam mit der Bestellnummer senden müssen.
Wo einstellen: | Im Tab E-Mail-Nachricht im Dialogfenster Zahlungsart.
Versandart
Beschreibung: | Es empfiehlt sich, dem Kunden zu wiederholen, welche Versandart er gewählt hat, sowie ihm neben allen sonstigen Daten, falls möglich, Informationen über die Fristen und Modalitäten der Lieferung bereitzustellen.
Beispiel: | Versand per Expresslieferung: Versand per Expresslieferung. Die Ware wird in 1-2 Werktagen geliefert.
Wo einstellen: | NeIm Tab E-Mail-Nachricht im Dialogfenster Versandart.
Fußzeilentext
Beschreibung: | Geben Sie hier einen Schlusssatz ein, in dem Sie Ihre Verfügbarkeit versichern, grüßen und unterschreiben.
Beispiel: | Für weitere Informationen stehen wir Ihnen gern zur Verfügung. Mit freundlichen Grüßen, Ihr Vertriebs-Team.
Wo einstellen: | Im Tab Warenkorb für E-Commerce | Bestellung senden, im Bereich Fußzeilentext.

Wie auf alle automatisch vom Programm generierten und versendeten E-Mails, wird auch auf die E-Mail zur Bestellbestätigung der grafische Stil angewendet, der in Stile und Modelle | E-Mail festgelegt wurde.

Die E-Mail zur Bestellbestätigung wird auch im Textformat versendet.

Praktische Anwendung:

-

Export / Import von Produkten aus dem / in den Warenkorb


Export / Import von Produkten aus dem / in den Warenkorb

Praktische Anwendung > Schritt 4 - Erweiterte Einstellungen > Warenkorb für E-Commerce >

Export / Import von Produkten aus dem / in den Warenkorb

 Return to chapter overview

Nachdem ein Warenkorb für den E-Commerce erstellt wurde, könnte es nützlich sein, den Produktkatalog exportieren zu können, beispielsweise um ihn in ein anderes Projekt einzufügen oder in einer anderen Software - z.B. für die Rechnungsverwaltung - zu nutzen. Umgekehrt kann es sich als ebenso nützlich erweisen, einen existierenden Produktkatalog zu importieren, um ihn nicht neu erstellen zu müssen.

WebSite X5 ermöglicht einen solchen Import bzw. Export mit Hilfe der entsprechenden Befehle in der Werkzeugleiste des Dialogfensters Warenkorb für E-Commerce | Produkte. Beim Export des Produktkatalogs wird eine Datei im Format .TXT oder .CSV generiert, die mit einem herkömmlichen Text-Editor (z.B. im Windows-Editor) oder Microsoft Excel geöffnet und bearbeitet werden kann.

Um die Export-Datei eines Produktkatalogs manuell zu bearbeiten oder eine Datei für den Import zu erstellen, beachten Sie bitte folgende Regeln:

§Die erste Zeile muss die Spaltenüberschriften, also folgende Einträge enthalten:

ID;Category;Name/Code;Description;Price;Enable VAT;VAT Value;Weight;Options;Enable Discounts;Discounts

§Wird eine Spaltenüberschrift entfernt, geht der Wert für alle Produkte verloren. Die Pflichtfelder Category, Name/Code, Description und Price können nicht gelöscht werden.

§Jede Zeile unter den Spaltenüberschriften muss einem Produkt entsprechen.

§Alle Parameter müssen mit einem ";" (Semikolon) voneinander getrennt werden.

§Für jedes Produkt müssen angegeben werden: Kategorie, Produktname, Produktbeschreibung und der Preis des Produkts. Alle anderen Felder sind optional und können ausgelassen werden (für das jeweilige Feld zwischen den Semikolons ";" nichts eingeben).

§Die Produkt-ID wird vom Programm und nicht manuell generiert: Lassen Sie das Feld der Produkt-ID daher leer, wenn Sie ein neues Produkt eingeben.

§Eventuell eingegebene, überflüssige Leerzeichen werden beim Import automatisch gelöscht.

Die in der .TXT- oder .CSV-Datei enthaltenen Parameter sind im Einzelnen:

Parameter: ID

Obligatorisch

Nen

Beschreibung

Dies ist ein eindeutiger Identifizierungs-Code für das Produkt.

Wert

Er wird automatisch vom Programm generiert und dem Produkt zugeordnet.

Soll eine zuvor exportierte .TXT- oder .CSV-Datei aktualisiert werden, ändern Sie die dort bereits zugewiesenen Produkt-IDs nicht und lassen Sie das Feld für neu hinzugefügte Produkte frei. Auch, wenn eine .TXT- oder .CSV-Datei von Grund auf neu erstellt wird, um sie anschließend zu importieren, müssen die Produkt-IDs nicht manuell erstellt werden. In der Importphase vergleicht das Programm die IDs, um Zweifacheinträge zu vermeiden, und generiert fehlende automatisch.

Parameter: Category

Obligatorisch

Ja

Beschreibung

Kategorie, der das Produkt zugeordnet wurde.

Wert

Mit Hilfe des Zeichens ">" kann der Pfad der Kategorien und Unterkategorien wiedergegeben werden.

Ist das Produkt zum Beispiel ein T-Shirt, das im Katalog der Unterkategorie "Casual" der Kategorie "Herrenbekleidung" zugeordnet wurde, kann dieser Pfad in der .TXT- oder .CSV-Datei folgendermaßen angegeben werden:

... ; Herrenbekleidung > Casual ; ...

Auf diese Weise können alle benötigten Unterkategorien definiert werden.

Parameter: Name/Code

Obligatorisch

Ja

Beschreibung

Dem Produkt zugewiesener Name oder Code.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter dem Feld Produktbezeichnung/Code des Dialogfensters Produkteinstellungen | Allgemein entnommen.

Parameter: Description

Obligatorisch

Ja

Beschreibung

Beschreibung des Produkts.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter dem Feld Beschreibung des Dialogfensters Produkteinstellungen | Allgemein entnommen.

Parameter: Price

Obligatorisch

Ja

Beschreibung

Preis des Produkts.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter dem Feld Preis des Dialogfenster Produkteinstellungen | Allgemein entnommen.

Parameter: Enable VAT

Obligatorisch

Nein

Beschreibung

Hier wird angegeben, ob für das Produkt ein besonderer Umsatzsteuersatz vorgesehen ist.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter aus dem Feld MwSt. (%) des Dialogfensters Produkteinstellungen | Allgemein. Diese Option ist nur dann verfügbar, wenn unter Warenkorb für E-Commerce | Verfügbarkeit die Option Typ ingeschlossen aktiviert wurde für die Angabe der MwSt. und dient dem Zweck, auf das Produkt einen speziellen Mehrwertsteuersatz anzuwenden, der von dem der anderen Produkte im Katalog verschieden ist. In diesem Fall wird der Preis ohne Mehrwertsteuer angegeben.

Der Parameter kann nur die zwei Werte 0 oder 1 haben, je nachdem, ob die vorstehend genannte Option MwSt. (%) aktiviert wurde oder nicht.

Parameter: VAT Value

Obligatorisch

Nein

Beschreibung

Höhe der Umsatzsteuer für den Fall, dass die Anwendung eines speziellen Umsatzsteuersatzes auf den Produktpreis vorgesehen ist.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter dem Feld MwSt. (%) des Dialogfensters Produkteinstellungen | Allgemein as, ebenso wie bei dem zuvor genannten Parameter, nur dann verfügbar ist, wenn im Fenster Warenkorb für E-Commerce | Verfügbarkeit die Option Typ "MwSt. Inkl" per le Angabe der MwSt..

Wenn Die Option MwSt. (%) im Fenster Produkteinstellungen | Allgemein aktiviert wurde aber keinen Wert festgelegt wurde wird den Wert Standardwert (%) der für jedes Produkt im Tab Produkteinstellungen | Verfügbarkeit festgelegt wurde, benutzt.

Parameter: Weight

Obligatorisch

Nein

Beschreibung

Gewicht des Produkts.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter dem Feld Gewicht des Dialogfensters Produkteinstellungen | Allgemein entnommen.

Parameter: Options

Obligatorisch

Nein

Beschreibung

Liste eventuell verfügbarer Produktvarianten.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter dem Feld Liste der Hauptvarianten des Dialogfensters Produkteinstellungen | Optionen.

Bei der Erstellung einer zu importierenden .TXT- oder .CSV-Datei hingegen kann die Liste der Hauptvarianten mit Hilfe des Zeichens "|" folgendermaßen erstellt werden:

... ; Variante1 |Variante2 | Variante3 ; ....

Auf diese Weise können alle benötigten Produktvarianten definiert werden.

Parameter: Enable Discounts

Obligatorisch

Nein

Beschreibung

Hier wird angegeben, ob, für das Produkt ein Mengenrabatt vorgesehen ist.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter dem Feld Mengenrabatt aktivieren des Dialogfensters Produkteinstellungen | Rabatt.

Der Parameter kann nur die zwei Werte 0 oder 1 haben, je nachdem, ob die vorstehend genannte Option Mengenrabatt aktivieren aktiviert wurde oder nicht.

Parameter: Discounts

Obligatorisch

Nein

Beschreibung

Liste der auf das Produkt anzuwendenden Mengenrabatte, sofern vorgesehen.

Wert

Beim Export des Katalogs in eine .TXT- oder .CSV-Datei wird dieser Parameter wie der zuvor genannte dem Feld Mengenrabatt aktivieren des Dialogfensters Produkteinstellungen | Rabatt entnommen.

Bei der Erstellung einer zu importierenden .TXT- oder .CSV-Datei hingegen muss die Liste der Produktvarianten folgendermaßen erstellt werden:

... ; Menge : Rabatt | Menge : Rabatt ; ...

Ist zum Beispiel für eine Bestellung von mehr als 20 Stück ein Rabatt von 10% und für Bestellmengen über 50 Stück ein Rabatt von 15% vorgesehen, geben Sie folgende Sequenz ein:

... ; 20 : 10 | 50 : 15 ; ...

Mit dem Zeichen "|" können alle benötigten Rabatte und Mengen definiert werden.

Beim Import einer zuvor exportierten oder manuell erstellten .TXT- oder .CSV-Datei wird diese sehr wahrscheinlich vom Programm aktualisiert, beispielsweise durch Einfügen fehlender Produkt-IDs. Ist eine aktuelle Kopie der .TXT- oder .CSV-Datei gewünscht, muss daher der Produktkatalog erneut exportiert werden.

Praktische Anwendung:

-

Inhalt der E-Mail zur Bestellbestätigung


Die Web-Browser und der interne Browser von WebSite X5

Zusatzinformationen >

Die Web-Browser und der interne Browser von WebSite X5

 Return to chapter overview
Versteckten Text zeigen/verstecken

Ein Browser ist eine Software-Anwendung, mit der der Benutzer auf Websites befindliche Informationen (Texte, Bilder usw.) anzeigen und mit diesen interagieren kann. Es gibt diverse Browser, die bekanntesten sind Microsoft Explorer®, Firefox®, Safari® und Google Chrome®.

Für die Anzeige von Web-Inhalten nutzen Browser Rendering-Engines, also Software, die nach dem Download der Inhalte (z. B. einer HTML-Seite) die jeweiligen Informationen (z.B die verknüpften CSS) formatiert und auf dem Bildschirm anzeigt. Untersschiedliche Browser nutzen verschiedene Rendering-Engines, die sich in der Qualität des Renderings im Verhältnis zum Standard sowie in der Geschwindigkeit des Renderings voneinander unterscheiden. Hieraus folgt, dass ein und dieselbe Website je nach verwendetem Browser unterschiedlich dargestellt werden kann. Da eine Website keine gedruckte Seite ist, ist eine gewisse Toletanz akzeptabel, solange der Nutzerkomfort nicht beeinträchtigt wird.

Die beste Methode für die Erstellung von Websites, die mit den wichtigsten Browsern in ihren verschiedenen Versionen kompatibel sind, ist die Realisierung eines Codes, der möglichst sauber geschrieben und konform mit den Standards ist.

WebSite X5 generiert automatisch den Code HTML5 mit CSS 2.1 oder 3 und garantiert volle Kompatibilität mit allen gängigen Browsern sowie Mobilgeräten wie Mobiltelefonen, Smartphones und PDAs.

Klicken Sie um zu erweitern/minimieren Der interne Browser von WebSite X5

Bei der Umsetzung eines Projekts muss es möglich sein, das Endergebnis und die Darstellung der fertigen, online gestellten Website zu testen. Dafür stellt Ihnen WebSite X5 über die in allen Phasen verfügbare Schaltfläche Vorschau (siehe Arbeitsumgebung) eine lokale Ansicht der Website zur Verfügung, die kontinuierlich aktualisiert wird (siehe Vorschau automatisch aktualisieren im Dialogfenster Einstellungen).

Für die Anzeige der Vorschau verwendet WebSite X5 einen internen Browser, der auf Chromium basiert (http://www.chromium.org/), den Open-Source Browser der zur herstellung von Google Chrome™ benutzt wurde. Der interne Browser bietet folgende Funktionen:

Eine Seite zurück

Rückkehr zur vorher angezeigten Seite.

Eine Seite vor

Erneutes Öffnen der nächsten Seite nach Rückkehr

Homepage

Rückkehr zur Homepage der Website.

Adressleiste

Hier wird der Pfad der angezeigten Seite angezeigt oder es kann der Pfad zu der Seite eingegeben werden, die angezeigt werden soll.

Gehe zu

Lädt die Seite, deren Pfad in die Adressleiste eingegeben wurde. Alternativ kann die eingegebene Adresse mit der Eingabetaste bestätigt werden.

Diese Seite bearbeiten

Mit diesem Befehl kehren Sie zum Programm zurück und es öffnet sich die angesehene Seiteder Vorschau im Erstellen der Seiten Fenster, wo Sie die gewünschten Änderungen vornehmen können. Werden in der Vorschau Seiten aus dem Blog, dem Geschützen Bereich oder Warenkorb für E-Commerce angezeigt, kehren Sie mit Klick auf diese Schaltfläche zur entsprechenden Seite in Schritt 4 - Erweiterte Einstellungen zurück.

Bitte berücksichtigen Sie, dass nach dem Öffnen des Browsers zur Anzeige der lokalen Vorschau des aktiven Projekts sich die dargestellte Seite automatisch der gerade bearbeiteten Seite anpasst. Dies bedeutet, wenn Sie zur Bearbeitung einer anderen Seite übergehen, wird diese auch in der Vorschau des Browsers angezeigt.

Der Einsatz eines internen Browsers zur Anzeige einer Vorschau der im Aufbau befindlichen Webseite bietet folgende Vorteile:

§Die Vorschau ersetzt nicht die Ansicht im eventuell geöffneten Standard-Browser;

§Die Vorschau der im Aufbau befindlichen Website wird im internen Browser aktualisiert und öffnet keine zusätzlichen Tabs oder Fenster im Standard-Browser.


Funktionsprinzip der internen Suchmaschine von WebSite X5

Zusatzinformationen >

Funktionsprinzip der internen Suchmaschine von WebSite X5

 Return to chapter overview
Versteckten Text zeigen/verstecken

Mit WebSite X5 können Sie im Header / Fußzeile des Template (siehe Gestaltung des Templates | Suchfeld einfügen) ein Suchfeld einfügen. Die Suchergebnisse, geordnet nach Relevanz, werden auf automatisch vom Programm generierten Seiten angezeigt.

Klicken Sie um zu erweitern/minimieren Was von der Suchmaschine in Betracht genommen wird

Um die interne Suchmaschine von WebSite X5 optimal zu nutzen, sollten Sie Folgendes wissen:

§Seiten

Die Suchmaschine erkennt folgende Seitenelemente: Titel, Beschreibung, Keywords (siehe Dialogfenster Eigenschaften der Seite |Allgemein) und natürlich die Textinhalte. In Titeln gefundene Übereinstimmungen haben hohe Relevanz und werden daher vor der Addition zu den anderen Übereinstimmungen automatisch mit einem Korrekturfaktor multipliziert. Auf der Grundlage der Anzahl der so errechneten Übereinstimmungen wird die Relevanz und somit die Position bestimmt, in der das Suchergebnis auf der Seite der Suchergebnisse angezeigt wird.

§Bilder / Video

Die Suchmaschine berücksichtigt nur Bilder und Videos, die mit Hilfe der entsprechenden Option in die Sitemap eingefügt wurden (siehe Bildobjekt | Sitemap oder Video-/Audio-Objekt | Sitemap) und analysiert alle zu diesem Zweck eingefügten Informationen: Titel, Kurzbeschreibung und Geografische Lage (z.B. Adresse, Stadt etc.) Bei Bildern; Titel, Kurzbeschreibung, Kategorie, Keywords e Veröffentlichungsdatum bei Videos.

§Produkte im Warenkorb für E-Commerce

Die interne Suchmaschine erfasst alle in den Warenkorb für E-Commerce eingestellten Produkte mit ihrem Produktbezeichnung/Code und ihrer Beschreibung (siehe Fenster Produkteinstellungen | Allgemein).

§Blog

In die Suche werden auch alle Blogseiten einbezogen, im Einzelnen werden analysiert: Titel, Autor, Kategorie, Tag, Kurzbeschreibung und Inhalt aller Posts.

§Geschützter Bereich

Geschützte Seiten, auf die erst nach Eingabe eines Benutzernamens und eines Passworts zugegriffen werden kAnn (innerhalb eines Geschützten Bereichs) werden von der internen Suchmaschine nur dann berücksichtigt, wenn sich der Benutzer eingeloggt hat.

§Unsichtbare Seiten

Seiten, die als nicht sichtbar im Menü eingestellt sind, werden von der internen Suchmaschine berücksichtigt.

§Ausschluss einer Seite aus der Suche

wenn eine Seite von der internen Suchmaschine nicht berücksichtigt werden soll, wählen Sie diese Seite in der Sitemap aus, öffnen Sie das Dialogfenster Eigenschaften der Seite und deaktivieren Sie im Tab Erweitert die Option Diese Seite in die Sitemap einbinden.

§Groß- und Kleinbuchstaben

Die Suchmaschine ist nicht case-sensitive: Dies bedeutet, dass zwischen Groß- und Kleinbuchstaben nicht unterschieden wird.

Die verschiedenen, von der Suchmaschine berücksichtigten Parameter haben unterschiedliche Relevanz: Treffer in Seitenüberschriften haben beispielsweise hohe Priorität. Treffer für bestimmte Parameter werden daher vor der Einordnung in die anderen Übereinstimmungen automatisch mit einem Gewichtungsfaktor multipliziert.

Auf der Grundlage der Anzahl der so errechneten Übereinstimmungen wird die Relevanz und somit die Position bestimmt, in der das Suchergebniss auf der Seite der Suchergebnisse angezeigt wird.
Klicken Sie um zu erweitern/minimieren Seiten mit Suchergebnissen

Die Seiten mit den Suchergebnissen werden vom Programm automatisch erstellt und enthalten:

§das Suchfeld, wie es auch im Header oder in der Fußzeile des jeweiligen Templates angezeigt wird;

§ein Seitenmenü, in dem die Suchergebnisse in den verschiedenen Bereichen wie Seiten, Blog, Online-Shop, Bildern oder Videos ausgewählt werden können. Neben jedem Eintrag in diesem Menü wird in Klammern die jeweilig erzielte Trefferzahl angegeben. Liegen für eine Kategorie keine Suchergebnisse vor, wird dieser Eintrag im Seitenmenü nicht angezeigt.

§die Liste der Suchergebnisse, in der wie beschrieben ermittelten Rangordnung.

Bei Suchergebnissen in Bildern und Videos können Sie das jeweilige Bild / Video anklicken, um es direkt auf der Seite zu öffnen, in die es eingefügt wurde.

Ganz besonders nützlich erweist sich die interne Suchmaschine für Websites mit großen Produktkatalogen: Die Seiten mit den Suchergebnissen enthalten nicht nur die kompletten Produktbeschreibungen, sondern auch direkt die Schaltfläche Kaufen, über die der Kunde sofort seine Bestellung aufgeben kann.

Die Seiten mit den Suchergebnissen werden vom Programm automatisch erstellt: Die grafische Gestaltung dieser Seiten entspricht den Einstellungen, die Sie in Schritt 4 - Erweiterte Einstellungen, im Bereich Stile und Modelle z.B. für das Seitenmenü im Bereich Stil des Seitenmenüs vorgenommen haben.


Das Box-Model in WebSite X5

Zusatzinformationen >

Das Box-Model in WebSite X5

 Return to chapter overview

In WebSite X5 werden die Seiten in einem Raster erstellt und das Layout kann im Dialogfenster Zellenrand angepasst werden dank der Außenrand und Innenabstand Optionen, die sich im Zellenstil | Stil Fenster befinden.

Um den Begriff Rand besser zu verstehen und das Layout der Inhalte präzise umzusetzen, müssen Sie mit dem verwendeten Box-Modell vertraut sein.

Beim Schreiben des Codes einer Website wird jedes HTML-Element als Block (Box) bezeichnet, während die Gesamtheit der Regeln, die die grafischen Merkmale dieser Block-Elemente Box-Modell genannt wird. Jede Box enthält eine bestimmte Anzahl Basiskomponenten, die mit Hilfe der CSS-Eigenschaften wie Außenabstand, Rahmen, Innenabstand und Inhalt geändert werden können.

Die nachstehende Abbildung veranschaulicht die Bestandteile des Box-Modells:

Das Layout-Schema in WebSite X5 besteht aus Zellen, in die verschiedene Inhalte eingefügt werden können. Auf jede dieser Zellen wird das dargestellte Box-Modell angewendet.

Die Elemente sind die Folgenden:

§Inhalt (grüner Bereich): Inhalt, der durch Ziehen eines der verfügbaren Objekte wird.

§Innenabstand (rosa Bereich): Abstand zwischen eingefügtem Inhalt und Rahmen.

§Rahmen: Rahmen, der um den Inhalt gezeichnet ist. Das Aussehen dieses Rahmens kann mit den Optionen im Dialogfenster Zellenstil definiert werden.

§Außenabstand (gelber Bereich): Abstand zwischen dem Rahmen und den Begrenzungslinien des Layout-Schemas.

Ausgehend von diesen Definitionen ist der Raum zwischen zwei Objekten (horizontal oder vertikal) die Summe der Außenabstände, die für die jeweiligen Zellen festgelegt wurden.


Control Panel online

Zusatzinformationen >

Control Panel online

 Return to chapter overview

Für jede realisierte Website stellt WebSite X5 automatisch ein Control Panel online zur Verfügung, in dem der Administrator verschiedene Funktionen nutzen kann. Er kann die die Blog-Kommentare oder Gästebucheinträge seiner Leser verwalten sowie Diagnoseinformationen und Daten zur Optimierung für Suchmaschinen abrufen.

Zugriff auf das Control Panel haben alle Benutzer, die im Bereich Zugangsverwaltung in Schritt 4 - Erweiterte Einstellungen in die Gruppe Administratoren aufgenommen wurden.

Zugang zum Control Panel:

§Öffnen Sie die Webseite http://www.meinewebsite.de/admin wobei http://www.meinewebsite.de die URL Ihrer Website ist.

§Loggen Sie sich mit Ihren Zugangsdaten ein (Benutzername und Passwort).

Nach dem Login wird das Control Panel geöffnet, das in folgende Bereiche gegliedert ist:

§Blog: Hier können Sie die Kommentare verwalten, die Leser in dem mit Ihrer Website verknüpften Blog hinterlassen haben. (siehe Management der Blog-Kommentare im Control Panel online)

§Guestbook: Hier können Sie die Einträge in Ihrem Gästebuch verwalten, das Sie mit des Gästebuch-Objekt in Ihre Website aufgenommen haben.

§WebSite Test: Hier finden Sie einige Diagnosedaten Ihrer Website und des Servers, auf dem diese veröffentlicht wurde. Im Einzelnen werden folgende Parameter überprüft:

-Installierte PHP-Version - Für die korrekte Funktion des E-Mail-Versands, den Sie mit dem Objekt E-Mail-Formular konfiguriert haben, des Warenkorb für E-Commerce und des Zugriffs auf Geschützte Seiten über das entsprechende Login muss der Server PHP unterstützen. Es wird geprüft, ob der Server diese Unterstützung bietet und wenn ja, wird ermittelt, welche Version unterstützt wird.

-Unterstützung von Sitzungen - Neben PHP muss der Server auch Sitzungen unterstützen, damit der Zugriff auf die Geschützten Seiten erst nach Eingabe der korrekten Zugangsdaten gewährt wird.

-Verzeichnis mit Schreibzugriff - Um die Kommentare der Blog-Posts und vom Gästebuch-Objekt archivieren und speichern zu können muss ein Verzeichnis auf dem Server angegeben werden, das bei Aktivierung der enstprechenden Optionen den Schreibzugriff ermöglicht. Hierbei wird zuerst überprüft, ob das angegebene Verzeichnis mit Schreibzugriff existiert und wenn ja, ob dieses Verzeichnis effektiv Schreibzugriff gewährt

-MySQL-Unterstützung und Datenbankeinstellungen - Bei der Konfiguration des Objekt E-Mail-Formular kann als Versandmethode "Datenversand an eine Datenbank" ausgewählt werden (siehe Objekt E-Mail-Formular | Senden): In diesem Fall müssen die Parameter angegeben werden, die den Verbindungsaufbau mit der Datenbank auf dem Server ermöglichen. Mit dem Test wird überprüft, ob der Server MySQL unterstützt und wenn ja, ob die eingegebenen Parameter effektiv den Zugriff auf die Datenbank ermöglichen.


Informationen und Support

Informationen und Support

ist ein Produkt von Incomedia

www.websitex5.com

www.incomedia.eu

Copyright 2013 Incomedia. Alle Rechte vorbehalten.

WebSite X5 arbeitet mit DotNetZip unter der Ms-PL Lizenz (Microsoft Public License)

WebSite X5 arbeitet mit Cef unter der BSD 3 Lizenz.

WebSite X5 arbeitet mit Cef Sharp unter der BSD 2 Lizenz.

Weitere Informationen und technischen Support erhalten Sie auf der Webseite: www.websitex5.com/help


License BSD 3

License BSD 3

Copyright (c) 2008-2012 Marshall A. Greenblatt. Portions Copyright (c)

2006-2009 Google Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without

modification, are permitted provided that the following conditions are

met:

* Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above

copyright notice, this list of conditions and the following disclaimer

in the documentation and/or other materials provided with the

distribution.

* Neither the name of Google Inc. nor the name Chromium Embedded

Framework nor the names of its contributors may be used to endorse

or promote products derived from this software without specific prior

written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR

A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT

OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT

LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,

DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE

OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


License BSD 2

License BSD 2

Copyright (c) 2012, Anthony Taranto.

Redistribution and use in source and binary forms, with or without

modification, are permitted provided that the following conditions are

met:

* Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above

copyright notice, this list of conditions and the following disclaimer

in the documentation and/or other materials provided with the

distribution.

* Neither the name of Google Inc. nor the name Chromium Embedded

Framework nor the name CefSharp nor the names of its contributors

may be used to endorse or promote products derived from this software

without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR

A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT

OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT

LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,

DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE

OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Microsoft Public License (Ms-PL)

Microsoft Public License (Ms-PL)

 Return to chapter overview

This license governs use of the accompanying software. If you use the software, you accept this license. If you do not accept the license, do not use the software.

1. Definitions

The terms "reproduce," "reproduction," "derivative works," and "distribution" have the same meaning here as under U.S. copyright law.

A "contribution" is the original software, or any additions or changes to the software.

A "contributor" is any person that distributes its contribution under this license.

"Licensed patents" are a contributor's patent claims that read directly on its contribution.

2. Grant of Rights

(A) Copyright Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free copyright license to reproduce its contribution, prepare derivative works of its contribution, and distribute its contribution or any derivative works that you create.

(B) Patent Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free license under its licensed patents to make, have made, use, sell, offer for sale, import, and/or otherwise dispose of its contribution in the software or derivative works of the contribution in the software.

3. Conditions and Limitations

(A) No Trademark License- This license does not grant you rights to use any contributors' name, logo, or trademarks.

(B) If you bring a patent claim against any contributor over patents that you claim are infringed by the software, your patent license from such contributor to the software ends automatically.

(C) If you distribute any portion of the software, you must retain all copyright, patent, trademark, and attribution notices that are present in the software.

(D) If you distribute any portion of the software in source code form, you may do so only under this license by including a complete copy of this license with your distribution. If you distribute any portion of the software in compiled or object code form, you may only do so under a license that complies with this license.

(E) The software is licensed "as-is." You bear the risk of using it. The contributors give no express warranties, guarantees or conditions. You may have additional consumer rights under your local laws which this license cannot change. To the extent permitted under your local laws, the contributors exclude the implied warranties of merchantability, fitness for a particular purpose and non-infringement.


print_copyright

print_copyright

© Copyright 2013 Incomedia. All rights reserved.

Le informazioni contenute in questo manuale possono essere soggette a modifiche senza alcun preavviso. Nessuna parte di questo manuale può essere riprodotta o trasmessa in qualsiasi forma o con qualsiasi mezzo, elettronico o meccanico, per qualsiasi scopo, senza l'espresso consenso scritto di Incomedia.

Si ricorda che filmati, suoni o immagini che si desidera utilizzare nei progetti possono essere soggetti a diritto d'autore. L'inserimento non autorizzato di tali materiali potrebbe, dunque, rappresentare una violazione dei diritti di autore ed è bene accertarsi di poterne fare uso liberamente o ottenere i permessi necessari dai rispettivi autori o dagli enti preposti.

Incomedia, WebSite X5, WebSite X5 Evolution sono marchi registrati di Incomedia s.r.l. Altri marchi o nomi di prodotti citati nel presente documento sono marchi o marchi registrati dei rispettivi proprietari.

Scritto e impaginato da Incomedia s.r.l.